automatic version update by autodist [release 2.79a-1mamba;Sun Mar 11 2018]
This commit is contained in:
parent
cfc7ffe6f1
commit
07a9f1a5ad
9
blender-2.79a-freetype-link.patch
Normal file
9
blender-2.79a-freetype-link.patch
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
--- blender-2.79a/source/blender/blentranslation/msgfmt/CMakeLists.txt.orig 2018-03-11 21:41:59.164492990 +0100
|
||||||
|
+++ blender-2.79a/source/blender/blentranslation/msgfmt/CMakeLists.txt 2018-03-11 21:39:01.994550654 +0100
|
||||||
|
@@ -48,3 +48,6 @@
|
||||||
|
|
||||||
|
target_link_libraries(msgfmt ${ZLIB_LIBRARIES})
|
||||||
|
target_link_libraries(msgfmt ${PLATFORM_LINKLIBS})
|
||||||
|
+target_link_libraries(msgfmt extern_wcwidth)
|
||||||
|
+target_link_libraries(msgfmt bf_intern_eigen)
|
||||||
|
+target_link_libraries(msgfmt "-lfreetype")
|
32
blender.spec
32
blender.spec
@ -1,6 +1,6 @@
|
|||||||
%define majver %(echo %version | sed "s|[a-z]*$||")
|
%define majver %(echo %version | sed "s|[a-z]*$||")
|
||||||
Name: blender
|
Name: blender
|
||||||
Version: 2.70a
|
Version: 2.79a
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: 3D modeling, animation, rendering and post-production
|
Summary: 3D modeling, animation, rendering and post-production
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
@ -16,6 +16,7 @@ Patch0: %{name}-2.46-xvidcore_configure.patch
|
|||||||
Patch1: %{name}-2.48a-ffmpeg.patch
|
Patch1: %{name}-2.48a-ffmpeg.patch
|
||||||
Patch2: %{name}-2.48a-ffmpeg-includes.patch
|
Patch2: %{name}-2.48a-ffmpeg-includes.patch
|
||||||
Patch3: blender-2.68a-freestyle-build.patch
|
Patch3: blender-2.68a-freestyle-build.patch
|
||||||
|
Patch4: blender-2.79a-freetype-link.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -60,6 +61,7 @@ BuildRequires: libspnav-devel
|
|||||||
BuildRequires: python-numpy-py3
|
BuildRequires: python-numpy-py3
|
||||||
BuildRequires: libopenexr-devel >= 2.0.1-3mamba
|
BuildRequires: libopenexr-devel >= 2.0.1-3mamba
|
||||||
BuildRequires: libilmbase-devel >= 2.0.1-2mamba
|
BuildRequires: libilmbase-devel >= 2.0.1-2mamba
|
||||||
|
BuildRequires: libopencolorio-devel
|
||||||
#Requires: yafray
|
#Requires: yafray
|
||||||
%py_requires
|
%py_requires
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root/
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root/
|
||||||
@ -74,10 +76,11 @@ Blender is the essential software solution you need for 3D, from modeling, anima
|
|||||||
Professionals and novices can easily and inexpensively publish stand-alone, secure, multi-platform content to the web, CD-ROMs, and other media, whether they are users of Windows, Linux, Irix, Sun Solaris, FreeBSD or OSX.
|
Professionals and novices can easily and inexpensively publish stand-alone, secure, multi-platform content to the web, CD-ROMs, and other media, whether they are users of Windows, Linux, Irix, Sun Solaris, FreeBSD or OSX.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-v%{version}
|
%setup -q -n %{name}-%{version}
|
||||||
#-D -T
|
#-D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
%patch3 -p1
|
#%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
@ -85,18 +88,20 @@ Professionals and novices can easily and inexpensively publish stand-alone, secu
|
|||||||
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
|
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
|
||||||
-DCMAKE_SKIP_RPATH=ON \
|
-DCMAKE_SKIP_RPATH=ON \
|
||||||
-DWITH_INSTALL_PORTABLE=OFF \
|
-DWITH_INSTALL_PORTABLE=OFF \
|
||||||
-DOPENJPEG_INCLUDE_DIR=%{_includedir}/openjpeg-1.5 \
|
-DBOOST_ROOT=1 \
|
||||||
-DWITH_CYCLES=0 \
|
-DWITH_CYCLES=OFF \
|
||||||
-DBOOST_ROOT=1
|
-DWITH_CYCLES_PTEX=OFF \
|
||||||
|
-DFTGL_LIBPATH=%{_libdir} \
|
||||||
|
-DWITH_FREESTYLE=ON \
|
||||||
|
-DWITH_SYSTEM_OPENJPEG=ON \
|
||||||
|
-DPYTHON_VERSION=3.6 \
|
||||||
|
-DPYTHON_LIBPATH=%{_libdir} \
|
||||||
|
-DPYTHON_LIBRARY=python3.6m \
|
||||||
|
-DPYTHON_INCLUDE_DIRS=%{_includedir}/python3.6m
|
||||||
|
|
||||||
export LD_LIBRARY_PATH=`pwd`/lib
|
export LD_LIBRARY_PATH=`pwd`/lib
|
||||||
%make
|
%make
|
||||||
|
|
||||||
#sed -i "s/use_openal =.*/use_openal = 'true'/g" SConstruct
|
|
||||||
##sed -i "s/release_flags = .*/release_flags = \"%{optflags}\"/" SConstruct
|
|
||||||
#
|
|
||||||
#scons clean || :
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != "/" ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != "/" ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall -C build
|
%makeinstall -C build
|
||||||
@ -158,9 +163,12 @@ fi
|
|||||||
%{_datadir}/icons/hicolor/scalable/apps/blender.svg
|
%{_datadir}/icons/hicolor/scalable/apps/blender.svg
|
||||||
%dir %{_datadir}/doc/blender
|
%dir %{_datadir}/doc/blender
|
||||||
%{_datadir}/doc/blender/*
|
%{_datadir}/doc/blender/*
|
||||||
%{_mandir}/man1/blender.1.gz
|
#%{_mandir}/man1/blender.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Mar 11 2018 Automatic Build System <autodist@mambasoft.it> 2.79a-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sun Apr 13 2014 Automatic Build System <autodist@mambasoft.it> 2.70a-1mamba
|
* Sun Apr 13 2014 Automatic Build System <autodist@mambasoft.it> 2.70a-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user