renamed from avidemux2; fixes [release 2.7.8-2mamba;Thu Dec 23 2021]
This commit is contained in:
parent
6e64ef39b5
commit
5b0eeaf45e
@ -1,2 +1,6 @@
|
||||
# avidemux
|
||||
|
||||
Avidemux2 is a graphical tool to edit AVI. It allows you to multiplex and demultiplex audio to/from video.
|
||||
It is able to cut video, import BMP, MJPEG and MPEG video, and encode them.
|
||||
You can also process video with included filters. It requires a DivX compatible encoder and the Gimp Toolkit (GTK) libraries.
|
||||
|
||||
|
40
avidemux-2.4.3-x264.patch
Normal file
40
avidemux-2.4.3-x264.patch
Normal file
@ -0,0 +1,40 @@
|
||||
diff -ur avidemux_2.4.3.orig/avidemux/ADM_codecs/ADM_x264.cpp avidemux_2.4.3/avidemux/ADM_codecs/ADM_x264.cpp
|
||||
--- avidemux_2.4.3.orig/avidemux/ADM_codecs/ADM_x264.cpp 2008-10-09 01:45:06.048940024 -0700
|
||||
+++ avidemux_2.4.3/avidemux/ADM_codecs/ADM_x264.cpp 2008-10-09 01:49:07.606940126 -0700
|
||||
@@ -109,8 +109,14 @@
|
||||
MKPARAM(i_bframe,MaxBFrame);
|
||||
MKPARAM(i_bframe_bias,Bias);
|
||||
MKPARAM( b_bframe_pyramid,BasReference );
|
||||
+#if X264_BUILD < 65
|
||||
MKPARAM(analyse. b_bidir_me,BidirME );
|
||||
+#endif
|
||||
+#if X264_BUILD >= 63
|
||||
+ MKPARAM( i_bframe_adaptive, Adaptative);
|
||||
+#else
|
||||
MKPARAM( b_bframe_adaptive, Adaptative);
|
||||
+#endif
|
||||
MKPARAM( analyse.b_weighted_bipred, Weighted);
|
||||
MKPARAM( b_cabac , CABAC);
|
||||
MKPARAM( analyse.i_trellis, Trellis);
|
||||
@@ -118,12 +124,16 @@
|
||||
#define MIN_RDO 6
|
||||
if(zparam->PartitionDecision+1>=MIN_RDO)
|
||||
{
|
||||
- int rank,parity;
|
||||
- rank=((zparam->PartitionDecision+1-MIN_RDO)>>1)+MIN_RDO;
|
||||
- parity=(zparam->PartitionDecision+1-MIN_RDO)&1;
|
||||
+#if X264_BUILD >= 65
|
||||
+ param.analyse.i_subpel_refine = zparam->PartitionDecision + 1;
|
||||
+#else
|
||||
+ int rank,parity;
|
||||
+ rank=((zparam->PartitionDecision+1-MIN_RDO)>>1)+MIN_RDO;
|
||||
+ parity=(zparam->PartitionDecision+1-MIN_RDO)&1;
|
||||
|
||||
- param.analyse.i_subpel_refine=rank;
|
||||
- param.analyse.b_bframe_rdo=parity;
|
||||
+ param.analyse.i_subpel_refine=rank;
|
||||
+ param.analyse.b_bframe_rdo=parity;
|
||||
+#endif
|
||||
}
|
||||
MKPARAM(analyse.b_chroma_me,ChromaME);
|
||||
MKPARAM(b_deblocking_filter,DeblockingFilter);
|
170
avidemux-2.5.0-gcc-4.4.patch
Normal file
170
avidemux-2.5.0-gcc-4.4.patch
Normal file
@ -0,0 +1,170 @@
|
||||
--- avidemux_2.5.0/avidemux/ADM_core/include/ADM_misc.h.ark 2009-06-21 16:50:12.412942889 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_core/include/ADM_misc.h 2009-06-21 16:50:18.760943176 +0200
|
||||
@@ -10,7 +10,7 @@
|
||||
#define ADM_MISC_H
|
||||
|
||||
#include "ADM_coreConfig.h"
|
||||
-
|
||||
+#include <stdint.h>
|
||||
|
||||
typedef struct
|
||||
{
|
||||
--- avidemux_2.5.0/avidemux/ADM_core/src/ADM_fileio.cpp.ark 2009-06-21 16:35:38.140135807 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_core/src/ADM_fileio.cpp 2009-06-21 16:35:51.867969517 +0200
|
||||
@@ -681,7 +681,7 @@ void ADM_PathStripName(char *str)
|
||||
*/
|
||||
const char *ADM_GetFileName(const char *str)
|
||||
{
|
||||
- char *filename;
|
||||
+ const char *filename;
|
||||
char *filename2;
|
||||
|
||||
#ifndef __WIN32
|
||||
--- avidemux_2.5.0/avidemux/ADM_coreUI/include/DIA_coreToolkit.h.ark 2009-06-21 16:57:14.895092062 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_coreUI/include/DIA_coreToolkit.h 2009-06-21 16:57:23.752111783 +0200
|
||||
@@ -19,6 +19,8 @@
|
||||
#ifndef ADM_COREUI_TOOLKIT__
|
||||
#define ADM_COREUI_TOOLKIT__
|
||||
|
||||
+#include <stdint.h>
|
||||
+
|
||||
typedef enum
|
||||
{
|
||||
ADM_LOG_NONE=0,
|
||||
--- avidemux_2.5.0/avidemux/ADM_coreUI/include/DIA_enter.h.ark 2009-06-21 16:55:46.188973629 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_coreUI/include/DIA_enter.h 2009-06-21 16:55:53.465409726 +0200
|
||||
@@ -15,6 +15,7 @@
|
||||
***************************************************************************/
|
||||
#ifndef DIA_ENTER_H
|
||||
#define DIA_ENTER_H
|
||||
+#include <stdint.h>
|
||||
|
||||
// Get a float value
|
||||
uint8_t DIA_GetFloatValue(float *value, float min, float max, const char *title, const char *legend);
|
||||
--- avidemux_2.5.0/avidemux/ADM_coreUI/include/DIA_fileSel.h.ark 2009-06-21 16:55:31.471073751 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_coreUI/include/DIA_fileSel.h 2009-06-21 16:55:39.379067926 +0200
|
||||
@@ -15,6 +15,7 @@
|
||||
|
||||
#ifndef DIA_FILESEL_H
|
||||
#define DIA_FILESEL_H
|
||||
+#include <stdint.h>
|
||||
typedef void SELFILE_CB(const char *);
|
||||
|
||||
// Associated functions type
|
||||
--- avidemux_2.5.0/avidemux/ADM_inputs/ADM_mpegdemuxer/dmx_io.cpp.ark 2009-06-21 16:40:22.066196323 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_inputs/ADM_mpegdemuxer/dmx_io.cpp 2009-06-21 16:40:29.289001011 +0200
|
||||
@@ -71,7 +71,7 @@ fileParser::~fileParser()
|
||||
*/
|
||||
uint8_t fileParser::open( const char *filename,FP_TYPE *multi )
|
||||
{
|
||||
- char *dot = NULL; // pointer to the last dot in filename
|
||||
+ const char *dot = NULL; // pointer to the last dot in filename
|
||||
uint8_t decimals = 0; // number of decimals
|
||||
char *left = NULL, *number = NULL, *right = NULL; // parts of filename (after splitting)
|
||||
|
||||
--- avidemux_2.5.0/avidemux/ADM_libraries/ADM_libmpeg2enc/yuv4mpeg_ratio.cc.ark 2009-06-21 16:42:15.574312778 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_libraries/ADM_libmpeg2enc/yuv4mpeg_ratio.cc 2009-06-21 16:42:18.926951396 +0200
|
||||
@@ -104,7 +104,7 @@ void y4m_ratio_reduce(y4m_ratio_t *r)
|
||||
|
||||
int y4m_parse_ratio(y4m_ratio_t *r, const char *s)
|
||||
{
|
||||
- char *t = strchr(s, ':');
|
||||
+ const char *t = strchr(s, ':');
|
||||
if (t == NULL) return Y4M_ERR_RANGE;
|
||||
r->n = atoi(s);
|
||||
r->d = atoi(t+1);
|
||||
--- avidemux_2.5.0/avidemux/ADM_libraries/ADM_mplex/lpcmstrm_in.cpp.ark 2009-06-21 16:43:15.988362511 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_libraries/ADM_mplex/lpcmstrm_in.cpp 2009-06-21 16:43:19.560943520 +0200
|
||||
@@ -53,7 +53,7 @@ LPCMStream::LPCMStream(IBitStream &ibs,
|
||||
|
||||
bool LPCMStream::Probe(IBitStream &bs )
|
||||
{
|
||||
- char *last_dot = strrchr( bs.StreamName(), '.' );
|
||||
+ const char *last_dot = strrchr( bs.StreamName(), '.' );
|
||||
return
|
||||
last_dot != NULL
|
||||
&& strcmp( last_dot+1, "lpcm") == 0;
|
||||
--- avidemux_2.5.0/avidemux/ADM_UIs/ADM_QT4/src/T_threadCount.h.ark 2009-06-21 16:48:26.935280369 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_UIs/ADM_QT4/src/T_threadCount.h 2009-06-21 16:48:38.041943420 +0200
|
||||
@@ -7,6 +7,7 @@
|
||||
#include <QtGui/QRadioButton>
|
||||
#include <QtGui/QSpinBox>
|
||||
#include <QtGui/QWidget>
|
||||
+#include <stdint.h>
|
||||
|
||||
namespace ADM_qt4Factory
|
||||
{
|
||||
--- avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_commonUI/ADM_tray.h.ark 2009-06-21 17:06:07.032249029 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_commonUI/ADM_tray.h 2009-06-21 17:06:13.612069717 +0200
|
||||
@@ -17,6 +17,7 @@
|
||||
|
||||
#ifndef ADM_TRAY_H
|
||||
#define ADM_TRAY_H
|
||||
+#include <stdint.h>
|
||||
|
||||
class ADM_tray
|
||||
{
|
||||
--- avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_dialog/DIA_color.cpp.ark 2009-06-21 17:00:29.869950030 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_dialog/DIA_color.cpp 2009-06-21 17:00:36.084898982 +0200
|
||||
@@ -1,4 +1,5 @@
|
||||
#include <QtGui/QColorDialog>
|
||||
+#include <stdint.h>
|
||||
|
||||
#include "ADM_toolkitQt.h"
|
||||
|
||||
@@ -17,4 +18,4 @@ int DIA_colorSel(uint8_t *r, uint8_t *g,
|
||||
}
|
||||
|
||||
return 0;
|
||||
-}
|
||||
\ No newline at end of file
|
||||
+}
|
||||
--- avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_dialog/Q_jobs.cpp.ark 2009-06-21 16:54:38.555192979 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_dialog/Q_jobs.cpp 2009-06-21 16:54:44.176068089 +0200
|
||||
@@ -6,6 +6,7 @@
|
||||
#include "Q_jobs.h"
|
||||
#include "DIA_coreToolkit.h"
|
||||
#include "ADM_toolkitQt.h"
|
||||
+#include <cstdio>
|
||||
|
||||
static void updateStatus(void);
|
||||
extern bool parseECMAScript(const char *name);
|
||||
--- avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_dialog/Q_license.cpp.ark 2009-06-21 16:53:15.590997514 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_dialog/Q_license.cpp 2009-06-21 16:53:23.719993769 +0200
|
||||
@@ -17,6 +17,7 @@
|
||||
|
||||
#include "Q_license.h"
|
||||
#include "ADM_toolkitQt.h"
|
||||
+#include <stdint.h>
|
||||
|
||||
Ui_licenseWindow::Ui_licenseWindow(QWidget *parent) : QDialog(parent)
|
||||
{
|
||||
--- avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_gui/ADM_qslider.cpp.ark 2009-06-21 17:04:44.617943090 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_gui/ADM_qslider.cpp 2009-06-21 17:04:50.589943463 +0200
|
||||
@@ -14,6 +14,7 @@ Custom slider
|
||||
|
||||
#include <QtGui/QPainter>
|
||||
#include <QtGui/QSlider>
|
||||
+#include <cstdio>
|
||||
|
||||
#include "ADM_qslider.h"
|
||||
|
||||
--- avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_gui/ADM_qslider.h.ark 2009-06-21 17:01:19.298477728 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_gui/ADM_qslider.h 2009-06-21 17:01:25.233500616 +0200
|
||||
@@ -1,5 +1,6 @@
|
||||
#ifndef ADM_Q_SLIDER_H
|
||||
#define ADM_Q_SLIDER_H
|
||||
+#include <stdint.h>
|
||||
|
||||
class ADM_QSlider : public QSlider
|
||||
{
|
||||
--- avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_gui/gui_none.cpp.ark 2009-06-21 17:04:07.237197461 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_gui/gui_none.cpp 2009-06-21 17:04:14.105432535 +0200
|
||||
@@ -9,6 +9,7 @@
|
||||
//
|
||||
|
||||
#include "config.h"
|
||||
+#include <stdint.h>
|
||||
|
||||
#include <QtGui/QApplication>
|
||||
#include <QtGui/QDesktopWidget>
|
333
avidemux.spec
Normal file
333
avidemux.spec
Normal file
@ -0,0 +1,333 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: avidemux
|
||||
Version: 2.7.8
|
||||
Release: 2mamba
|
||||
Summary: Graphical video editing tool
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://fixounet.free.fr/avidemux/
|
||||
Source: http://downloads.sourceforge.net/project/avidemux/avidemux/%{version}/avidemux_%{version}.tar.gz
|
||||
Patch0: avidemux-2.4.3-x264.patch
|
||||
Patch1: avidemux-2.5.0-gcc-4.4.patch
|
||||
Patch2: avidemux2-2.6.11-x86-fix-impossible-asm-constraints.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXv-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libdca-devel
|
||||
BuildRequires: libesound-devel
|
||||
BuildRequires: libfaac-devel
|
||||
BuildRequires: libfaad2-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libfribidi-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libjack-devel
|
||||
BuildRequires: liblame-devel
|
||||
BuildRequires: libopencore-amr-devel
|
||||
BuildRequires: libopus-devel
|
||||
BuildRequires: libpulseaudio-devel
|
||||
BuildRequires: libsqlite-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtwolame-devel
|
||||
BuildRequires: libva-devel
|
||||
BuildRequires: libvdpau-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libvpx-devel
|
||||
BuildRequires: libx264-devel
|
||||
BuildRequires: libx265-devel
|
||||
BuildRequires: libxvidcore-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: automake
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: gcc
|
||||
BuildRequires: liba52dec-devel
|
||||
BuildRequires: libid3tag-devel
|
||||
BuildRequires: libmad-devel
|
||||
BuildRequires: libslang-devel
|
||||
BuildRequires: mjpegtools-devel
|
||||
BuildRequires: nasm
|
||||
BuildRequires: spidermonkey
|
||||
Provides: avidemux2
|
||||
Obsoletes: avidemux2 <= 2.7.8-1mamba
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description
|
||||
Avidemux2 is a graphical tool to edit AVI. It allows you to multiplex and demultiplex audio to/from video.
|
||||
It is able to cut video, import BMP, MJPEG and MPEG video, and encode them.
|
||||
You can also process video with included filters. It requires a DivX compatible encoder and the Gimp Toolkit (GTK) libraries.
|
||||
|
||||
%package qt5
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Summary: GUI frontend for avidemux
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: %{name}-gtk
|
||||
Obsoletes: %{name}-gtk < 2.7.8
|
||||
Provides: %{name}-qt4
|
||||
Obsoletes: %{name}-qt4 < 2.7.8
|
||||
Provides: avidemux2-qt5
|
||||
Obsoletes: avidemux2-qt5 <= 2.7.8-1mamba
|
||||
|
||||
%description qt5
|
||||
Avidemux2 is a graphical tool to edit AVI. It allows you to multiplex and demultiplex audio to/from video.
|
||||
It is able to cut video, import BMP, MJPEG and MPEG video, and encode them.
|
||||
You can also process video with included filters. It requires a DivX compatible encoder and the Gimp Toolkit (GTK) libraries.
|
||||
This package contains the Qt frontend.
|
||||
|
||||
%package -n lib%{name}
|
||||
Summary: Libraries provided by %{name}
|
||||
Group: System/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: libavidemux2
|
||||
Obsoletes: libavidemux2 <= 2.7.8-1mamba
|
||||
|
||||
%description -n lib%{name}
|
||||
Libraries provided by %{name}.
|
||||
|
||||
%package -n lib%{name}-devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: avidemux2-devel
|
||||
Obsoletes: avidemux2-devel < 2.7.8
|
||||
Provides: libavidemux2-devel
|
||||
Obsoletes: libavidemux2-devel <= 2.7.8-1mamba
|
||||
|
||||
%description -n lib%{name}-devel
|
||||
Avidemux2 is a graphical tool to edit AVI. It allows you to multiplex and demultiplex audio to/from video.
|
||||
It is able to cut video, import BMP, MJPEG and MPEG video, and encode them.
|
||||
You can also process video with included filters. It requires a DivX compatible encoder and the Gimp Toolkit (GTK) libraries.
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n avidemux_%{version}
|
||||
#%ifarch %{ix86}
|
||||
#%patch2 -p1
|
||||
#%endif
|
||||
|
||||
%build
|
||||
sh ./bootStrap.bash --with-cli --with-plugins
|
||||
|
||||
for f in build*; do
|
||||
%make -C $f
|
||||
done
|
||||
|
||||
# --with-gtk # doesn't build, use qt interface
|
||||
|
||||
#%c make -d build ../avidemux_core
|
||||
|
||||
#%{__make} -f Makefile.dist
|
||||
#%{__perl} -pi.orig -e 's|/usr/X11R6/lib|\$x_libraries|g' configure
|
||||
#%{__perl} -pi.orig -e 's|/usr/X11R6/lib|%{_prefix}/X11R6/%{_lib}|g' Makefile.in */Makefile.in */*/Makefile.in
|
||||
#export CFLAGS="${CFLAGS:-%optflags}"
|
||||
#export CXXFLAGS="${CXXFLAGS:-%optflags}"
|
||||
#% configure \
|
||||
# --x-libraries="%{_prefix}/X11R6/%{_lib}" \
|
||||
# --with-qt-dir=%{_qt4_prefix} \
|
||||
# --with-qt-include=%{_qt4_headerdir} \
|
||||
# --with-qt-lib=%{_qt4_libdir} \
|
||||
# --without-arts
|
||||
#
|
||||
#% make -j1
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
for f in build*; do
|
||||
%makeinstall -C $f
|
||||
done
|
||||
|
||||
install -D -m644 avidemux_icon.png \
|
||||
%{buildroot}%{_datadir}/pixmaps/avidemux.png
|
||||
|
||||
# Create the system menu entry
|
||||
mkdir -p %{buildroot}%{_datadir}/applications
|
||||
cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
|
||||
[Desktop Entry]
|
||||
Name=Avidemux Video Editor
|
||||
Comment=Edit your videos in real-time
|
||||
Icon=%{_datadir}/pixmaps/avidemux.png
|
||||
MimeType=video/mpeg;video/quicktime;video/x-msvideo;video/x-anim;audio/x-mp3;audio/x-mp2;
|
||||
Exec=avidemux3
|
||||
Terminal=false
|
||||
Type=Application
|
||||
Categories=Application;AudioVideo
|
||||
EOF
|
||||
|
||||
ln -s avidemux3_qt5 %{buildroot}%{_bindir}/avidemux3
|
||||
ln -s avidemux3_qt5 %{buildroot}%{_bindir}/avidemux
|
||||
|
||||
#%find_lang avidemux -f avidemux.lang
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/avidemux3_cli
|
||||
%dir %{_datadir}/ADM6_addons
|
||||
%dir %{_datadir}/ADM6_addons/avsfilter
|
||||
%{_datadir}/ADM6_addons/avsfilter/avsload.exe
|
||||
%{_datadir}/ADM6_addons/avsfilter/pipe_source.dll
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files qt5
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/avidemux3_qt5
|
||||
%{_bindir}/avidemux3_jobs_qt5
|
||||
%{_bindir}/avidemux
|
||||
%{_bindir}/avidemux3
|
||||
#%{_libdir}/libADM_render6_qt5.so
|
||||
#%dir %{_datadir}/avidemux6
|
||||
#%dir %{_datadir}/avidemux6/help
|
||||
#%dir %{_datadir}/avidemux6/help/QtScriptQT4
|
||||
#%{_datadir}/avidemux6/help/QtScriptQT4/*
|
||||
#%dir %{_datadir}/avidemux6/qt4
|
||||
#%dir %{_datadir}/avidemux6/qt4/i18n
|
||||
%{_datadir}/avidemux6/qt5/i18n/avidemux_*.qm
|
||||
%{_datadir}/avidemux6/qt5/i18n/qtbase_*.qm
|
||||
%{_datadir}/applications/%{name}.desktop
|
||||
%{_datadir}/applications/org.avidemux.Avidemux.desktop
|
||||
%{_datadir}/icons/hicolor/128x128/apps/org.avidemux.Avidemux.png
|
||||
%{_datadir}/metainfo/org.avidemux.Avidemux.appdata.xml
|
||||
%{_datadir}/pixmaps/avidemux.png
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libADM6avcodec.so.*
|
||||
%{_libdir}/libADM6avformat.so.*
|
||||
%{_libdir}/libADM6avutil.so.*
|
||||
%{_libdir}/libADM6postproc.so.*
|
||||
%{_libdir}/libADM6swscale.so.*
|
||||
#%dir %{_libdir}/ADM_glade
|
||||
#%{_libdir}/ADM_glade/*
|
||||
%dir %{_libdir}/ADM_plugins6
|
||||
%{_libdir}/ADM_plugins6/*
|
||||
%{_libdir}/libADM_*.so
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/avidemux
|
||||
%dir %{_includedir}/avidemux/%{majver}
|
||||
%{_includedir}/avidemux/%{majver}/*
|
||||
#%doc README
|
||||
|
||||
%changelog
|
||||
* Thu Dec 23 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.7.8-2mamba
|
||||
- renamed from avidemux2; fixes
|
||||
|
||||
* Tue Jun 29 2021 Automatic Build System <autodist@mambasoft.it> 2.7.8-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Jul 06 2020 Automatic Build System <autodist@mambasoft.it> 2.7.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Aug 15 2019 Automatic Build System <autodist@mambasoft.it> 2.7.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Mar 21 2019 Automatic Build System <autodist@mambasoft.it> 2.7.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Mar 13 2019 Automatic Build System <autodist@mambasoft.it> 2.7.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jun 04 2018 Automatic Build System <autodist@mambasoft.it> 2.7.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jan 06 2018 Automatic Build System <autodist@mambasoft.it> 2.7.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Nov 22 2016 Automatic Build System <autodist@mambasoft.it> 2.6.15-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Sep 18 2016 Automatic Build System <autodist@mambasoft.it> 2.6.14-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Aug 20 2016 Automatic Build System <autodist@mambasoft.it> 2.6.13-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Mar 05 2016 Automatic Build System <autodist@mambasoft.it> 2.6.12-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Jan 29 2016 Automatic Build System <autodist@mambasoft.it> 2.6.11-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jul 25 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.10-1mamba
|
||||
- update to 2.6.10
|
||||
|
||||
* Sat Mar 15 2014 Automatic Build System <autodist@mambasoft.it> 2.6.8-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Dec 08 2013 Automatic Build System <autodist@mambasoft.it> 2.6.7-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Sep 28 2013 Automatic Build System <autodist@mambasoft.it> 2.6.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Aug 29 2013 Automatic Build System <autodist@mambasoft.it> 2.6.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Jul 16 2013 Automatic Build System <autodist@mambasoft.it> 2.6.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Mar 26 2013 Automatic Build System <autodist@mambasoft.it> 2.6.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Mar 20 2013 Automatic Build System <autodist@mambasoft.it> 2.6.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Dec 20 2012 Automatic Build System <autodist@mambasoft.it> 2.6.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Oct 06 2012 Automatic Build System <autodist@mambasoft.it> 2.6.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Apr 10 2012 Automatic Build System <autodist@mambasoft.it> 2.5.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jun 16 2011 Automatic Build System <autodist@mambasoft.it> 2.5.5-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Oct 25 2010 Automatic Build System <autodist@mambasoft.it> 2.5.4-1mamba
|
||||
- automatic update to 2.5.4 by autodist
|
||||
|
||||
* Sat May 08 2010 Automatic Build System <autodist@mambasoft.it> 2.5.3-1mamba
|
||||
- automatic update to 2.5.3 by autodist
|
||||
|
||||
* Mon Dec 21 2009 Automatic Build System <autodist@mambasoft.it> 2.5.2-1mamba
|
||||
- automatic update to 2.5.2 by autodist
|
||||
|
||||
* Thu Aug 20 2009 Automatic Build System <autodist@mambasoft.it> 2.5.1-1mamba
|
||||
- automatic update to 2.5.1 by autodist
|
||||
|
||||
* Thu Jul 02 2009 Automatic Build System <autodist@mambasoft.it> 2.5.0-1mamba
|
||||
- automatic update to 2.5.0 by autodist
|
||||
|
||||
* Fri Mar 06 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.4-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Dec 12 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.3-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Mon Nov 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.3-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat Jun 14 2008 gil <puntogil@libero.it> 2.4.1-1mamba
|
||||
- update to 2.4.1
|
||||
|
||||
* Mon Jun 27 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 2.0.42-2qilnx
|
||||
- new version
|
||||
|
||||
* Tue Sep 14 2004 Matteo Bernasconi <voyagernm@virgilio.it> 2.028-1qilnx
|
||||
- First Build
|
11
avidemux2-2.6.11-x86-fix-impossible-asm-constraints.patch
Normal file
11
avidemux2-2.6.11-x86-fix-impossible-asm-constraints.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- avidemux_2.6.11/cmake/admFFmpegBuild.cmake.orig 2016-02-02 11:05:13.698634486 +0100
|
||||
+++ avidemux_2.6.11/cmake/admFFmpegBuild.cmake 2016-02-02 11:06:17.123634605 +0100
|
||||
@@ -29,7 +29,7 @@
|
||||
set(FFMPEG_PARSERS ac3 h263 h264 hevc mpeg4video)
|
||||
set(FFMPEG_PROTOCOLS file)
|
||||
set(FFMPEG_BSFS h264_mp4toannexb aac_adtstoasc)
|
||||
-xadd("--enable-shared --disable-static --disable-everything --disable-avfilter --enable-hwaccels --enable-postproc --enable-gpl")
|
||||
+xadd("--disable-optimizations --enable-shared --disable-static --disable-everything --disable-avfilter --enable-hwaccels --enable-postproc --enable-gpl")
|
||||
xadd("--enable-runtime-cpudetect --disable-network ")
|
||||
xadd("--enable-swscale --disable-swresample")
|
||||
xadd("--disable-doc --disable-programs")
|
Loading…
Reference in New Issue
Block a user