automatic version update by autodist [release 2.5.2-1mamba;Fri Jan 19 2024]
This commit is contained in:
parent
09aa332011
commit
c0fb4557d3
@ -1,38 +0,0 @@
|
||||
diff -ru attr-2.4.46/include/builddefs.in attr-2.4.46-build/include/builddefs.in
|
||||
--- attr-2.4.46/include/builddefs.in 2010-01-22 23:55:11.000000000 +0100
|
||||
+++ attr-2.4.46-build/include/builddefs.in 2012-01-29 22:57:50.000000000 +0100
|
||||
@@ -40,14 +40,14 @@
|
||||
PKG_VERSION = @pkg_version@
|
||||
PKG_PLATFORM = @pkg_platform@
|
||||
PKG_DISTRIBUTION= @pkg_distribution@
|
||||
-PKG_BIN_DIR = @bindir@
|
||||
-PKG_SBIN_DIR = @sbindir@
|
||||
-PKG_LIB_DIR = @libdir@@libdirsuffix@
|
||||
-PKG_DEVLIB_DIR = @libexecdir@@libdirsuffix@
|
||||
-PKG_INC_DIR = @includedir@/attr
|
||||
-PKG_MAN_DIR = @mandir@
|
||||
-PKG_DOC_DIR = @datadir@/doc/@pkg_name@
|
||||
-PKG_LOCALE_DIR = @datadir@/locale
|
||||
+PKG_BIN_DIR = $(DESTDIR)@bindir@
|
||||
+PKG_SBIN_DIR = $(DESTDIR)@sbindir@
|
||||
+PKG_LIB_DIR = $(DESTDIR)@libdir@@libdirsuffix@
|
||||
+PKG_DEVLIB_DIR = $(DESTDIR)@libexecdir@@libdirsuffix@
|
||||
+PKG_INC_DIR = $(DESTDIR)@includedir@/attr
|
||||
+PKG_MAN_DIR = $(DESTDIR)@mandir@
|
||||
+PKG_DOC_DIR = $(DESTDIR)@datadir@/doc/@pkg_name@
|
||||
+PKG_LOCALE_DIR = $(DESTDIR)@datadir@/locale
|
||||
|
||||
CC = @cc@
|
||||
AWK = @awk@
|
||||
diff -ru attr-2.4.46/include/buildmacros attr-2.4.46-build/include/buildmacros
|
||||
--- attr-2.4.46/include/buildmacros 2010-01-22 23:55:11.000000000 +0100
|
||||
+++ attr-2.4.46-build/include/buildmacros 2012-01-29 22:56:01.000000000 +0100
|
||||
@@ -40,7 +40,7 @@
|
||||
$(LFILES:.l=.o) \
|
||||
$(YFILES:%.y=%.tab.o)
|
||||
|
||||
-INSTALL = $(TOPDIR)/include/install-sh -o $(PKG_USER) -g $(PKG_GROUP)
|
||||
+INSTALL = $(TOPDIR)/include/install-sh
|
||||
|
||||
SHELL = /bin/sh
|
||||
IMAGES_DIR = $(TOPDIR)/all-images
|
55
attr.spec
55
attr.spec
@ -1,26 +1,19 @@
|
||||
Name: attr
|
||||
Version: 2.5.1
|
||||
Version: 2.5.2
|
||||
Release: 1mamba
|
||||
Summary: Commands for Manipulating Filesystem Extended Attributes
|
||||
Group: System/Kernel and Hardware
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://savannah.nongnu.org/projects/attr
|
||||
Source: http://download-mirror.savannah.gnu.org/releases/attr/attr-%{version}.tar.gz
|
||||
Patch0: %{name}-2.4.46-build.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
%ifarch x86_64_disabled
|
||||
BuildRequires: gcc-multilib
|
||||
BuildRequires: glibc-multilib-devel
|
||||
%endif
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%debug_package
|
||||
|
||||
%description
|
||||
Commands for Manipulating Filesystem Extended Attributes.
|
||||
|
||||
@ -55,9 +48,10 @@ Requires: lib%{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
%description -n lib32-lib%{name}-devel
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -70,8 +64,6 @@ This package contains static libraries and header files needed for development.
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
#% makeinstall install-dev
|
||||
#% makeinstall install-lib
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
@ -80,25 +72,6 @@ rm -fr %{buildroot}%{_datadir}/doc/attr
|
||||
# already provided by manpages
|
||||
rm -f %{buildroot}%{_mandir}/man2/*attr.2*
|
||||
|
||||
%ifarch x86_64_disabled
|
||||
# x86_64 lib32 support
|
||||
make clean
|
||||
|
||||
./configure \
|
||||
--prefix=%{_prefix} \
|
||||
--libdir=/lib \
|
||||
--libexecdir=/lib \
|
||||
CC="%{_target_platform}-gcc -m32"
|
||||
|
||||
make
|
||||
|
||||
make install DESTDIR=`pwd`/lib32
|
||||
make install DESTDIR=`pwd`/lib32 install-dev
|
||||
make install DESTDIR=`pwd`/lib32 install-lib
|
||||
|
||||
cp -a lib32/lib %{buildroot}/
|
||||
%endif
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
@ -114,37 +87,25 @@ cp -a lib32/lib %{buildroot}/
|
||||
%{_mandir}/man1/%{name}.*
|
||||
%{_mandir}/man1/getfattr.*
|
||||
%{_mandir}/man1/setfattr.*
|
||||
#%{_mandir}/man5/attr.*
|
||||
%doc doc/COPYING
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/lib%{name}.so.*
|
||||
%doc doc/COPYING
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/%{name}
|
||||
%{_libdir}/lib%{name}.a
|
||||
%{_libdir}/lib%{name}.la
|
||||
%{_libdir}/lib%{name}.so
|
||||
%{_libdir}/pkgconfig/libattr.pc
|
||||
%{_mandir}/man3/attr_*
|
||||
%doc README
|
||||
|
||||
%ifarch x86_64_disabled
|
||||
%files -n lib32-lib%{name}
|
||||
%defattr(-,root,root)
|
||||
/lib/lib%{name}.so.*
|
||||
%doc doc/COPYING
|
||||
|
||||
%files -n lib32-lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
/lib/lib%{name}.a
|
||||
/lib/lib%{name}.la
|
||||
/lib/lib%{name}.so
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Jan 19 2024 Automatic Build System <autodist@openmamba.org> 2.5.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Mar 17 2021 Automatic Build System <autodist@mambasoft.it> 2.5.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user