rebuilt with ghostscript 10 [release 3.0.5-2mamba;Mon Sep 04 2023]

This commit is contained in:
Silvan Calarco 2024-01-05 20:08:03 +01:00
parent 95b2155492
commit e042fa9b4e
1 changed files with 11 additions and 50 deletions

View File

@ -2,14 +2,14 @@
Name: abiword
Version: 3.0.5
Release: 1mamba
Release: 2mamba
Summary: A free word processing program
Group: Graphical Desktop/Applications/Office
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.abisource.com/
Source0: http://www.abisource.com/downloads/abiword/%{version}/source/%{name}-%{version}.tar.gz
URL: https://www.abisource.com
Source0: https://www.abisource.com/downloads/abiword/%{version}/source/%{name}-%{version}.tar.gz
Source4: abiword.mime
Patch0: abiword-extras-2.6.0-build_datadir.patch
Patch1: abiword-2.8.6-gcc-4.7.patch
@ -25,38 +25,27 @@ License: GPL
BuildRequires: clutter-gtk-devel
BuildRequires: glibc-devel
BuildRequires: libX11-devel
BuildRequires: libXau-devel
BuildRequires: libXcomposite-devel
BuildRequires: libXdamage-devel
BuildRequires: libXdmcp-devel
BuildRequires: libXext-devel
BuildRequires: libXfixes-devel
BuildRequires: libXi-devel
BuildRequires: libXrandr-devel
BuildRequires: libXrender-devel
BuildRequires: libaiksaurus-devel
BuildRequires: libatk-devel
BuildRequires: libblkid-devel
BuildRequires: libat-spi2-core-devel
BuildRequires: libbrotli-devel
BuildRequires: libbsd-devel
BuildRequires: libbzip2-devel
BuildRequires: libcairo-devel
BuildRequires: libcap-devel
BuildRequires: libcares-devel
BuildRequires: libchamplain-devel
BuildRequires: libclutter-devel
BuildRequires: libcogl-devel
BuildRequires: libcurl-devel
BuildRequires: libdb53-devel
BuildRequires: libdbus-devel
BuildRequires: libdbus-glib-devel
BuildRequires: libdrm-devel
BuildRequires: libdw-devel
BuildRequires: libe2fs-devel
BuildRequires: libenchant1-devel
BuildRequires: libevdev-devel
BuildRequires: libexpat-devel
BuildRequires: libffi-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libfribidi-devel
@ -66,47 +55,27 @@ BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel
BuildRequires: libglvnd-devel
BuildRequires: libgmp-devel
BuildRequires: libgnutls-devel
BuildRequires: libgoffice-devel
BuildRequires: libgpg-error-devel
BuildRequires: libgraphite2-devel
BuildRequires: libgsasl-devel
BuildRequires: libgsf-devel
BuildRequires: libgss-devel
BuildRequires: libgtk3-devel
BuildRequires: libgudev-devel
BuildRequires: libharfbuzz-devel
BuildRequires: libhunspell-devel
BuildRequires: libical-devel
BuildRequires: libicu-devel
BuildRequires: libidn-devel
BuildRequires: libidn2-devel
BuildRequires: libinput-devel
BuildRequires: libjpeg-devel
BuildRequires: libjson-glib-devel
BuildRequires: libkrb5-devel
BuildRequires: liblink-grammar-devel
BuildRequires: libloudmouth-devel
BuildRequires: libltdl-devel
BuildRequires: liblzma-devel
BuildRequires: libmesa-devel
BuildRequires: libmhash-devel
BuildRequires: libmount-devel
BuildRequires: libmpfr-devel
BuildRequires: libmtdev-devel
BuildRequires: libncurses-devel
BuildRequires: libnettle-devel
BuildRequires: libnghttp2-devel
BuildRequires: libnsl-devel
BuildRequires: libntlm-devel
BuildRequires: libopenldap-devel
BuildRequires: libopenssl-devel
BuildRequires: libp11-kit-devel
BuildRequires: libpango-devel
BuildRequires: libpcre-devel
BuildRequires: libpcre2-devel
BuildRequires: libpng-devel
BuildRequires: libpsl-devel
BuildRequires: libraptor2-devel
BuildRequires: librasqal-devel
BuildRequires: librdf-devel
@ -115,29 +84,18 @@ BuildRequires: librsvg-devel
BuildRequires: librtmp-devel
BuildRequires: libsasl2-devel
BuildRequires: libselinux-devel
BuildRequires: libsepol-devel
BuildRequires: libspectre-devel
BuildRequires: libsqlite-devel
BuildRequires: libssh2-devel
BuildRequires: libstdc++6-devel
BuildRequires: libsystemd-devel
BuildRequires: libtasn1-devel
BuildRequires: libthai-devel
BuildRequires: libudev-devel
BuildRequires: libunistring-devel
BuildRequires: libuuid-devel
BuildRequires: libwacom-devel
BuildRequires: libwayland-devel
BuildRequires: libwayland-egl-devel
BuildRequires: libwmf-devel
BuildRequires: libwv-devel
BuildRequires: libxcb-devel
BuildRequires: libxkbcommon-devel
BuildRequires: libxml2-devel
BuildRequires: libxslt-devel
BuildRequires: libyajl-devel
BuildRequires: libz-devel
BuildRequires: libzstd-devel
BuildRequires: telepathy-glib-devel
## AUTOBUILDREQ-END
BuildRequires: liblink-grammar-devel >= 5.8.0
@ -145,6 +103,7 @@ BuildRequires: aspell-devel >= 0.60.2
BuildRequires: desktop-file-utils >= 0.10
BuildRequires: libots >= 0.4.2
BuildRequires: libaiksaurus >= 1.2.1
BuildRequires: libgs >= 10.01.2
BuildRequires: valgrind-devel
BuildRequires: ImageMagick
BuildRequires: libboost-devel
@ -168,9 +127,11 @@ This package provides files needed for development.
%prep
%setup -q %{name}-%{version}
#-D -T
autoreconf --force --install
%build
autoreconf --force --install
#:<< _EOF
%configure \
--with-libxml2 \
--enable-printing \
@ -214,7 +175,6 @@ install -D -m644 %{S:4} \
%{_libdir}/libAiksaurusGtk3--export-dynamic.so
%{_libdir}/libAiksaurusGtk3.so
%{_libdir}/abiword-%{majversion}/plugins/*.so
%{_libdir}/abiword-%{majversion}/plugins/*.la
%{_mandir}/man1/abiword.1*
%files devel
@ -224,11 +184,12 @@ install -D -m644 %{S:4} \
%{_includedir}/abiword-%{majversion}/xap_UnixTableWidget.h
#%{_libdir}/abiword-%{majversion}/plugins/opendocument.a
#%{_libdir}/libabiword-%{majversion}.a
%{_libdir}/libabiword-%{majversion}.la
%{_libdir}/libAiksaurusGtk3.la
%{_libdir}/pkgconfig/abiword-%{majversion}.pc
%changelog
* Mon Sep 04 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.5-2mamba
- rebuilt with ghostscript 10
* Sun Jul 04 2021 Automatic Build System <autodist@mambasoft.it> 3.0.5-1mamba
- automatic version update by autodist