update to 1.2.0 [release 1.2.0-1mamba;Fri Aug 14 2020]

This commit is contained in:
Silvan Calarco 2024-01-05 17:51:43 +01:00
parent f1ddc37146
commit 516a5fb66f
3 changed files with 87 additions and 244 deletions

View File

@ -1,95 +0,0 @@
diff -Nru PackageKit-1.1.13.orig/backends/dnf/Makefile.am PackageKit-1.1.13/backends/dnf/Makefile.am
--- PackageKit-1.1.13.orig/backends/dnf/Makefile.am 2020-01-08 14:56:23.000000000 +0100
+++ PackageKit-1.1.13/backends/dnf/Makefile.am 2020-01-08 16:43:25.929000000 +0100
@@ -4,6 +4,7 @@
dnf-backend-vendor-fedora.c \
dnf-backend-vendor-mageia.c \
dnf-backend-vendor-openmandriva.c \
+ dnf-backend-vendor-openmamba.c \
dnf-backend-vendor-rosa.c
libpk_backend_dnf_la_SOURCES = \
dnf-backend-vendor.h \
diff -Nru PackageKit-1.1.13.orig/backends/dnf/Makefile.in PackageKit-1.1.13/backends/dnf/Makefile.in
--- PackageKit-1.1.13.orig/backends/dnf/Makefile.in 2020-01-08 15:01:27.000000000 +0100
+++ PackageKit-1.1.13/backends/dnf/Makefile.in 2020-01-08 16:43:50.249000000 +0100
@@ -489,6 +489,7 @@
dnf-backend-vendor-fedora.c \
dnf-backend-vendor-mageia.c \
dnf-backend-vendor-openmandriva.c \
+ dnf-backend-vendor-openmamba.c \
dnf-backend-vendor-rosa.c
libpk_backend_dnf_la_SOURCES = \
diff -Nru PackageKit-1.1.13.orig/backends/dnf/dnf-backend-vendor-openmamba.c PackageKit-1.1.13/backends/dnf/dnf-backend-vendor-openmamba.c
--- PackageKit-1.1.13.orig/backends/dnf/dnf-backend-vendor-openmamba.c 1970-01-01 01:00:00.000000000 +0100
+++ PackageKit-1.1.13/backends/dnf/dnf-backend-vendor-openmamba.c 2020-01-08 16:42:42.017000000 +0100
@@ -0,0 +1,43 @@
+/* -*- Mode: C; tab-width: 8; indent-tabs-mode: t; c-basic-offset: 8 -*-
+ *
+ * Copyright (C) 2016 Neal Gompa <ngompa13@gmail.com>
+ * Copyright (C) 2018 Kalev Lember <klember@redhat.com>
+ *
+ * Licensed under the GNU Lesser General Public License Version 2.1
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+ */
+
+#include "dnf-backend-vendor.h"
+
+gboolean
+dnf_validate_supported_repo (const gchar *id)
+{
+ const gchar *default_repos[] = { "rolling",
+ "rolling-games",
+ "rolling-i586",
+ "rolling-games-i586",
+ "unstable-makedist",
+ "unstable-makedist-i586",
+ NULL };
+
+ /* core repos that users shouldn't play with */
+ for (guint i = 0; default_repos[i] != NULL; i++) {
+ if (g_strcmp0 (id, default_repos[i]) == 0)
+ return TRUE;
+ }
+
+ return FALSE;
+}
diff -Nru PackageKit-1.1.13.orig/configure PackageKit-1.1.13/configure
--- PackageKit-1.1.13.orig/configure 2020-01-08 15:01:26.000000000 +0100
+++ PackageKit-1.1.13/configure 2020-01-08 16:44:25.417000000 +0100
@@ -1799,7 +1799,7 @@
where D-BUS system-services directory is
--with-dnf-vendor=<vendor>
select a vendor configuration (fedora, mageia,
- openmandriva, rosa; default is fedora)
+ openmandriva, openmamba, rosa; default is fedora)
Some influential environment variables:
PKG_CONFIG path to pkg-config utility
diff -Nru PackageKit-1.1.13.orig/configure.ac PackageKit-1.1.13/configure.ac
--- PackageKit-1.1.13.orig/configure.ac 2020-01-08 14:56:23.000000000 +0100
+++ PackageKit-1.1.13/configure.ac 2020-01-08 16:45:25.496000000 +0100
@@ -426,8 +426,8 @@
if test x$enable_dnf = xyes; then
PKG_CHECK_MODULES(DNF, appstream-glib libdnf >= 0.22.0 rpm)
AC_ARG_WITH(dnf-vendor,
- [AS_HELP_STRING([--with-dnf-vendor=<vendor>],[select a vendor configuration (fedora, mageia, openmandriva, rosa; default is fedora)])])
- if test "$with_dnf_vendor" = "fedora" -o "$with_dnf_vendor" = "mageia" -o "$with_dnf_vendor" = "openmandriva" -o "$with_dnf_vendor" = "rosa"; then
+ [AS_HELP_STRING([--with-dnf-vendor=<vendor>],[select a vendor configuration (fedora, mageia, openmandriva, openmamba, rosa; default is fedora)])])
+ if test "$with_dnf_vendor" = "fedora" -o "$with_dnf_vendor" = "mageia" -o "$with_dnf_vendor" = "openmandriva" -o "$with_dnf_vendor" = "openmamba" -o "$with_dnf_vendor" = "rosa"; then
with_dnf_vendor="$with_dnf_vendor"
else
with_dnf_vendor="fedora"

View File

@ -0,0 +1,47 @@
diff -Nru PackageKit-1.1.13.orig/backends/dnf/dnf-backend-vendor-openmamba.c PackageKit-1.1.13/backends/dnf/dnf-backend-vendor-openmamba.c
--- PackageKit-1.1.13.orig/backends/dnf/dnf-backend-vendor-openmamba.c 1970-01-01 01:00:00.000000000 +0100
+++ PackageKit-1.1.13/backends/dnf/dnf-backend-vendor-openmamba.c 2020-01-08 16:42:42.017000000 +0100
@@ -0,0 +1,43 @@
+/* -*- Mode: C; tab-width: 8; indent-tabs-mode: t; c-basic-offset: 8 -*-
+ *
+ * Copyright (C) 2016 Neal Gompa <ngompa13@gmail.com>
+ * Copyright (C) 2018 Kalev Lember <klember@redhat.com>
+ *
+ * Licensed under the GNU Lesser General Public License Version 2.1
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+ */
+
+#include "dnf-backend-vendor.h"
+
+gboolean
+dnf_validate_supported_repo (const gchar *id)
+{
+ const gchar *default_repos[] = { "rolling",
+ "rolling-games",
+ "rolling-i586",
+ "rolling-games-i586",
+ "unstable-makedist",
+ "unstable-makedist-i586",
+ NULL };
+
+ /* core repos that users shouldn't play with */
+ for (guint i = 0; default_repos[i] != NULL; i++) {
+ if (g_strcmp0 (id, default_repos[i]) == 0)
+ return TRUE;
+ }
+
+ return FALSE;
+}

View File

@ -1,5 +1,5 @@
Name: PackageKit Name: PackageKit
Version: 1.1.13 Version: 1.2.0
Release: 1mamba Release: 1mamba
Summary: A system designed to make installing and updating software on your computer easier Summary: A system designed to make installing and updating software on your computer easier
Group: System/Management Group: System/Management
@ -23,69 +23,32 @@ Patch11: PackageKit-0.6.22-display_smart_errors_as_html.patch
Patch12: PackageKit-0.8.11-smartBackend-fix-remove-packages.patch Patch12: PackageKit-0.8.11-smartBackend-fix-remove-packages.patch
Patch13: PackageKit-0.9.5-smartBackend-correctly-raise-exceptions.patch Patch13: PackageKit-0.9.5-smartBackend-correctly-raise-exceptions.patch
Patch14: PackageKit-1.1.6-yumBackend-override_sigchecks.patch Patch14: PackageKit-1.1.6-yumBackend-override_sigchecks.patch
Patch15: PackageKit-1.1.13-dnf-openmamba.patch Patch15: PackageKit-1.2.0-dnf-openmamba.patch
Patch16: PackageKit-1.1.12-dnf-repos-dir.patch Patch16: PackageKit-1.1.12-dnf-repos-dir.patch
Patch17: PackageKit-1.1.12-dnf-disable-trusted-packages-check.patch Patch17: PackageKit-1.1.12-dnf-disable-trusted-packages-check.patch
Patch18: PackageKit-1.1.12-upstream-dnf-invalidate-the-sack-cache-after-downloading-new-metadata.patch Patch18: PackageKit-1.1.12-upstream-dnf-invalidate-the-sack-cache-after-downloading-new-metadata.patch
License: GPL License: GPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
BuildRequires: ldconfig
BuildRequires: libappstream-glib-devel BuildRequires: libappstream-glib-devel
BuildRequires: libatk-devel
BuildRequires: libbeecrypt-devel
BuildRequires: libblkid-devel
BuildRequires: libbzip2-devel
BuildRequires: libcairo-devel
%ifnarch arm
BuildRequires: libcpuinfo-devel
%endif
BuildRequires: libdnf-devel BuildRequires: libdnf-devel
BuildRequires: libdw-devel
BuildRequires: libe2fs-devel
BuildRequires: libelf-devel
BuildRequires: libexpat-devel
BuildRequires: libffi-devel
BuildRequires: libfontconfig-devel BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libfribidi-devel
BuildRequires: libgcc
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel BuildRequires: libglib-devel
BuildRequires: libgraphite2-devel
BuildRequires: libgstreamer-devel BuildRequires: libgstreamer-devel
BuildRequires: libgtk-devel
BuildRequires: libgtk2-devel
BuildRequires: libharfbuzz-devel
BuildRequires: libkrb5-devel
BuildRequires: liblzma-devel
BuildRequires: libmagic-devel
BuildRequires: libmount-devel
BuildRequires: libneon-devel
BuildRequires: libopenssl-devel
BuildRequires: libpango-devel BuildRequires: libpango-devel
BuildRequires: libpcre-devel
BuildRequires: libpng-devel
BuildRequires: libpolkit-devel BuildRequires: libpolkit-devel
BuildRequires: libpopt-devel BuildRequires: libpython-devel
BuildRequires: libproxy-devel BuildRequires: librpm-devel
BuildRequires: librepo-devel
BuildRequires: libselinux-devel
BuildRequires: libsepol-devel
BuildRequires: libsqlite-devel BuildRequires: libsqlite-devel
BuildRequires: libstdc++6-devel
BuildRequires: libsyck-devel
BuildRequires: libsystemd-devel BuildRequires: libsystemd-devel
BuildRequires: libthai-devel
BuildRequires: libunwind-devel
BuildRequires: libuuid-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
BuildRequires: librpm-devel >= 1:4.14.2.1 BuildRequires: librpm-devel >= 1:4.14.3
BuildRequires: gobject-introspection-devel BuildRequires: gobject-introspection-devel
BuildRequires: pm-utils-devel BuildRequires: pm-utils-devel
BuildRequires: libcppunit-devel BuildRequires: libcppunit-devel
BuildRequires: libdnf >= 0.31.0 BuildRequires: libdnf >= 0.48.0
BuildRequires: librepo >= 1.10.3 BuildRequires: librepo >= 1.11.2
Requires: dnf Requires: dnf
%systemd_requires %systemd_requires
BuildRoot: %{_tmppath}/%{name}-%{version}-root BuildRoot: %{_tmppath}/%{name}-%{version}-root
@ -129,101 +92,49 @@ Summary: Gtk interface library for %{name}
Group: System/Libraries Group: System/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release} Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-glib = %{?epoch:%epoch:}%{version}-%{release} Requires: %{name}-glib = %{?epoch:%epoch:}%{version}-%{release}
Provides: PackageKit-gtk2
Obsoletes: PackageKit-gtk2
%description gtk %description gtk
PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less. PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
This package contains the Gtk interface library for %{name}. This package contains the Gtk interface library for %{name}.
%package gtk2
Summary: Gtk 2 interface library for %{name}
Group: System/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-glib = %{?epoch:%epoch:}%{version}-%{release}
%description gtk2
PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
This package contains the Gtk 2 interface library for %{name}.
%package mozilla
Summary: Mozilla plugin for %{name}
Group: System/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description mozilla
PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
This package contains the Mozilla plugin for %{name}.
%package qt2
Summary: New QT interface library for %{name}
Group: System/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Obsoletes: %{name}-qt
%description qt2
PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
This package contains the new QT interface library for %{name}.
%package qt2-devel
Summary: Devel package for %{name}-qt2
Group: Development/Libraries
Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-qt2 = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-gtk = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name}-gtk2 = %{?epoch:%epoch:}%{version}-%{release}
Obsoletes: %{name}-qt-devel
%description qt2-devel
PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
This package contains static libraries and header files need for development.
%debug_package %debug_package
%prep %prep
%setup -q %setup -q
#%patch0 -p1
%patch1 -p1 %patch1 -p1
#%patch2 -p1 #%patch14 -p1
##%patch3 -p1
##%patch4 -p1
##%patch5 -p1
###%patch6 -p1
###%patch7 -p1
##%patch8 -p1
###%patch9 -p1
###%patch10 -p1
###%patch11 -p1
##%patch12 -p1
##%patch13 -p1
#sed -i "s|/usr/bin/python$|/usr/bin/python%{python27_version}|" backends/smart/smartBackend.py
%patch14 -p1
%patch15 -p1 %patch15 -p1
%patch16 -p1 #%patch16 -p1
%patch17 -p1 %patch17 -p1
#%patch18 -p1 #%patch18 -p1
%build sed -i "s|openmandriva|openmamba|" meson_options.txt
%configure \
--enable-dnf \
--enable-pm-utils \
--with-default-backend=dnf \
--with-dnf-vendor=openmamba \
--enable-introspection \
--enable-networkmanager \
PYTHON=%{__python}
%make %build
%meson \
-Dpackaging_backend=dnf \
-Ddnf_vendor=openmamba \
-Dgtk_doc=true \
-Dpythonpackagedir=%{python3_sitearch}
# --enable-pm-utils \
# --enable-introspection \
# --enable-networkmanager \
# PYTHON=%{__python}
%meson_build
%install %install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}" [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall %meson_install
rm -f %{buildroot}/var/lib/PackageKit/transactions.db rm -f %{buildroot}/var/lib/PackageKit/transactions.db
install -d -m0755 %{buildroot}/var/cache/PackageKit
%find_lang %{name} %find_lang %{name}
%clean %clean
@ -244,7 +155,7 @@ rm -f %{buildroot}/var/lib/PackageKit/transactions.db
%{_libdir}/packagekit-backend/libpk_backend_* %{_libdir}/packagekit-backend/libpk_backend_*
%{_unitdir}/packagekit.service %{_unitdir}/packagekit.service
%{_unitdir}/packagekit-offline-update.service %{_unitdir}/packagekit-offline-update.service
%{_unitdir}/system-update.target.wants/packagekit-offline-update.service #%{_unitdir}/system-update.target.wants/packagekit-offline-update.service
%{_libexecdir}/packagekit-direct %{_libexecdir}/packagekit-direct
%{_libexecdir}/pk-offline-update %{_libexecdir}/pk-offline-update
%{_libexecdir}/packagekitd %{_libexecdir}/packagekitd
@ -256,14 +167,14 @@ rm -f %{buildroot}/var/lib/PackageKit/transactions.db
%{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service %{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
%{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy %{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
%{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules %{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
%{_datadir}/PackageKit/helpers #%{_datadir}/PackageKit/helpers
%{_datadir}/PackageKit/pk-upgrade-distro.sh %{_datadir}/PackageKit/pk-upgrade-distro.sh
#%dir %{python_sitelib}/packagekit %dir %{python3_sitearch}/packagekit
#%{python_sitelib}/packagekit/* %{python3_sitearch}/packagekit/*
%dir /var/lib/PackageKit %dir /var/lib/PackageKit
%dir /var/cache/PackageKit %dir /var/cache/PackageKit
%dir /var/cache/PackageKit/downloads #%dir /var/cache/PackageKit/downloads
%dir /var/cache/PackageKit/metadata #%dir /var/cache/PackageKit/metadata
%{_mandir}/man1/pkcon.1* %{_mandir}/man1/pkcon.1*
%{_mandir}/man1/pkmon.1* %{_mandir}/man1/pkmon.1*
%doc AUTHORS COPYING %doc AUTHORS COPYING
@ -273,18 +184,6 @@ rm -f %{buildroot}/var/lib/PackageKit/transactions.db
%{_libdir}/gtk-3.0/modules/libpk-gtk-module.* %{_libdir}/gtk-3.0/modules/libpk-gtk-module.*
%{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop %{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
%files gtk2
%defattr(-,root,root)
%{_libdir}/gtk-2.0/modules/libpk-gtk-module.*
#%if "%{stage1}" != "1"
#%ifnarch arm
#%files mozilla
#%defattr(-,root,root)
#%{_libdir}/mozilla/plugins/packagekit-plugin.*
#%endif
#%endif
%files glib %files glib
%defattr(-,root,root) %defattr(-,root,root)
%{_libdir}/libpackagekit-glib2.so.* %{_libdir}/libpackagekit-glib2.so.*
@ -293,25 +192,17 @@ rm -f %{buildroot}/var/lib/PackageKit/transactions.db
%files glib-devel %files glib-devel
%defattr(-,root,root) %defattr(-,root,root)
%{_includedir}/PackageKit/packagekit-glib2/*.h %{_includedir}/PackageKit/packagekit-glib2/*.h
%{_libdir}/libpackagekit-glib2.a
%{_libdir}/libpackagekit-glib2.la
%{_libdir}/libpackagekit-glib2.so %{_libdir}/libpackagekit-glib2.so
%{_datadir}/gir-1.0/PackageKitGlib-1.0.gir %{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
%{_datadir}/vala/vapi/packagekit-glib2.vapi %{_datadir}/vala/vapi/packagekit-glib2.*
%{_libdir}/pkgconfig/packagekit-glib2.pc %{_libdir}/pkgconfig/packagekit-glib2.pc
%{_datadir}/gtk-doc/html/PackageKit %{_datadir}/gtk-doc/html/PackageKit
%doc ChangeLog NEWS README %doc NEWS README
#%files devel
#%defattr(-,root,root)
#%dir %{_includedir}/PackageKit/backend
#%{_includedir}/PackageKit/backend/*.h
#%dir %{_includedir}/PackageKit/plugin
#%{_includedir}/PackageKit/plugin/*.h
#%{_datadir}/gir-1.0/PackageKitPlugin-1.0.gir
#%{_libdir}/pkgconfig/packagekit-plugin.pc
%changelog %changelog
* Fri Aug 14 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.0-1mamba
- update to 1.2.0
* Wed Jan 08 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.13-1mamba * Wed Jan 08 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.13-1mamba
- update to 1.1.13 - update to 1.1.13