PackageKit/PackageKit-1.1.13-dnf-openmamba.patch

96 lines
4.7 KiB
Diff

diff -Nru PackageKit-1.1.13.orig/backends/dnf/Makefile.am PackageKit-1.1.13/backends/dnf/Makefile.am
--- PackageKit-1.1.13.orig/backends/dnf/Makefile.am 2020-01-08 14:56:23.000000000 +0100
+++ PackageKit-1.1.13/backends/dnf/Makefile.am 2020-01-08 16:43:25.929000000 +0100
@@ -4,6 +4,7 @@
dnf-backend-vendor-fedora.c \
dnf-backend-vendor-mageia.c \
dnf-backend-vendor-openmandriva.c \
+ dnf-backend-vendor-openmamba.c \
dnf-backend-vendor-rosa.c
libpk_backend_dnf_la_SOURCES = \
dnf-backend-vendor.h \
diff -Nru PackageKit-1.1.13.orig/backends/dnf/Makefile.in PackageKit-1.1.13/backends/dnf/Makefile.in
--- PackageKit-1.1.13.orig/backends/dnf/Makefile.in 2020-01-08 15:01:27.000000000 +0100
+++ PackageKit-1.1.13/backends/dnf/Makefile.in 2020-01-08 16:43:50.249000000 +0100
@@ -489,6 +489,7 @@
dnf-backend-vendor-fedora.c \
dnf-backend-vendor-mageia.c \
dnf-backend-vendor-openmandriva.c \
+ dnf-backend-vendor-openmamba.c \
dnf-backend-vendor-rosa.c
libpk_backend_dnf_la_SOURCES = \
diff -Nru PackageKit-1.1.13.orig/backends/dnf/dnf-backend-vendor-openmamba.c PackageKit-1.1.13/backends/dnf/dnf-backend-vendor-openmamba.c
--- PackageKit-1.1.13.orig/backends/dnf/dnf-backend-vendor-openmamba.c 1970-01-01 01:00:00.000000000 +0100
+++ PackageKit-1.1.13/backends/dnf/dnf-backend-vendor-openmamba.c 2020-01-08 16:42:42.017000000 +0100
@@ -0,0 +1,43 @@
+/* -*- Mode: C; tab-width: 8; indent-tabs-mode: t; c-basic-offset: 8 -*-
+ *
+ * Copyright (C) 2016 Neal Gompa <ngompa13@gmail.com>
+ * Copyright (C) 2018 Kalev Lember <klember@redhat.com>
+ *
+ * Licensed under the GNU Lesser General Public License Version 2.1
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+ */
+
+#include "dnf-backend-vendor.h"
+
+gboolean
+dnf_validate_supported_repo (const gchar *id)
+{
+ const gchar *default_repos[] = { "rolling",
+ "rolling-games",
+ "rolling-i586",
+ "rolling-games-i586",
+ "unstable-makedist",
+ "unstable-makedist-i586",
+ NULL };
+
+ /* core repos that users shouldn't play with */
+ for (guint i = 0; default_repos[i] != NULL; i++) {
+ if (g_strcmp0 (id, default_repos[i]) == 0)
+ return TRUE;
+ }
+
+ return FALSE;
+}
diff -Nru PackageKit-1.1.13.orig/configure PackageKit-1.1.13/configure
--- PackageKit-1.1.13.orig/configure 2020-01-08 15:01:26.000000000 +0100
+++ PackageKit-1.1.13/configure 2020-01-08 16:44:25.417000000 +0100
@@ -1799,7 +1799,7 @@
where D-BUS system-services directory is
--with-dnf-vendor=<vendor>
select a vendor configuration (fedora, mageia,
- openmandriva, rosa; default is fedora)
+ openmandriva, openmamba, rosa; default is fedora)
Some influential environment variables:
PKG_CONFIG path to pkg-config utility
diff -Nru PackageKit-1.1.13.orig/configure.ac PackageKit-1.1.13/configure.ac
--- PackageKit-1.1.13.orig/configure.ac 2020-01-08 14:56:23.000000000 +0100
+++ PackageKit-1.1.13/configure.ac 2020-01-08 16:45:25.496000000 +0100
@@ -426,8 +426,8 @@
if test x$enable_dnf = xyes; then
PKG_CHECK_MODULES(DNF, appstream-glib libdnf >= 0.22.0 rpm)
AC_ARG_WITH(dnf-vendor,
- [AS_HELP_STRING([--with-dnf-vendor=<vendor>],[select a vendor configuration (fedora, mageia, openmandriva, rosa; default is fedora)])])
- if test "$with_dnf_vendor" = "fedora" -o "$with_dnf_vendor" = "mageia" -o "$with_dnf_vendor" = "openmandriva" -o "$with_dnf_vendor" = "rosa"; then
+ [AS_HELP_STRING([--with-dnf-vendor=<vendor>],[select a vendor configuration (fedora, mageia, openmandriva, openmamba, rosa; default is fedora)])])
+ if test "$with_dnf_vendor" = "fedora" -o "$with_dnf_vendor" = "mageia" -o "$with_dnf_vendor" = "openmandriva" -o "$with_dnf_vendor" = "openmamba" -o "$with_dnf_vendor" = "rosa"; then
with_dnf_vendor="$with_dnf_vendor"
else
with_dnf_vendor="fedora"