rebuild with patch against libpng 1.5 and glibc 2.17 [release 0.2.33-3mamba;Tue Feb 12 2013]

This commit is contained in:
Silvan Calarco 2024-01-05 20:05:38 +01:00
parent 92a071080c
commit 4ac4454fa8
4 changed files with 193 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# zvbi
The Zapping VBI (zvbi) library provides routines to read from raw Vertical Blanking Interval capture devices, to demodulate raw to sliced VBI data, and to interpret the data of several popular services. Basically, it offers all the functionality needed by a VBI application except for the UI.
ZVBI provides routines to read from raw Vertical Blanking interval capture devices.

View File

@ -0,0 +1,34 @@
diff -Nru zvbi-0.2.33.orig/contrib/ntsc-cc.c zvbi-0.2.33/contrib/ntsc-cc.c
--- zvbi-0.2.33.orig/contrib/ntsc-cc.c 2007-11-27 18:39:34.000000000 +0100
+++ zvbi-0.2.33/contrib/ntsc-cc.c 2013-02-12 22:53:52.953635085 +0100
@@ -34,6 +34,7 @@
#include <locale.h>
#include <sys/ioctl.h>
#include <sys/types.h>
+#include <sys/stat.h>
#include <sys/time.h>
#ifdef HAVE_GETOPT_LONG
# include <getopt.h>
diff -Nru zvbi-0.2.33.orig/src/io-dvb.c zvbi-0.2.33/src/io-dvb.c
--- zvbi-0.2.33.orig/src/io-dvb.c 2008-02-24 15:18:21.000000000 +0100
+++ zvbi-0.2.33/src/io-dvb.c 2013-02-12 22:53:04.136118717 +0100
@@ -29,6 +29,8 @@
#include <errno.h>
#include <sys/select.h>
#include <sys/ioctl.h>
+#include <sys/types.h>
+#include <sys/stat.h>
#ifndef HAVE_S64_U64
/* Linux 2.6.x asm/types.h defines __s64 and __u64 only
diff -Nru zvbi-0.2.33.orig/src/io-v4l.c zvbi-0.2.33/src/io-v4l.c
--- zvbi-0.2.33.orig/src/io-v4l.c 2008-02-24 15:17:28.000000000 +0100
+++ zvbi-0.2.33/src/io-v4l.c 2013-02-12 22:53:29.141870986 +0100
@@ -42,6 +42,7 @@
#include <assert.h>
#include <sys/time.h> /* timeval */
#include <sys/types.h> /* fd_set, uid_t */
+#include <sys/stat.h>
#include <sys/ioctl.h> /* for (_)videodev.h */
#include <pthread.h>

View File

@ -0,0 +1,38 @@
Support build with libpng version 1.5.x.
--- zvbi-0.2.33-orig/src/exp-gfx.c 2012-02-18 03:20:39.668146729 +0100
+++ zvbi-0.2.33/src/exp-gfx.c 2012-02-18 03:08:29.578283492 +0100
@@ -1637,6 +1637,19 @@ VBI_AUTOREG_EXPORT_MODULE(vbi_export_cla
#include "png.h"
#include "setjmp.h"
+/* starting from libpng version 1.5 it is not possible
+ * to access inside the PNG struct directly
+ */
+#ifdef PNG_SETJMP
+#undef PNG_SETJMP
+#endif
+
+#if (defined(PNG_LIBPNG_VER) && PNG_LIBPNG_VER >= 10500)
+#define PNG_SETJMP(ptr) setjmp(png_jmpbuf(ptr))
+#else
+#define PNG_SETJMP(ptr) setjmp(ptr->jmpbuf)
+#endif
+
static void
write_data (png_structp png_ptr,
png_bytep data,
@@ -1672,11 +1685,11 @@ write_png (gfx_instance * gfx,
char title[80];
unsigned int i;
- if (setjmp (png_ptr->jmpbuf))
+ if (PNG_SETJMP(png_ptr))
return FALSE;
png_set_write_fn (png_ptr,
- (voidp) gfx,
+ (png_voidp) gfx,
write_data,
flush_data);

118
zvbi.spec Normal file
View File

@ -0,0 +1,118 @@
Name: zvbi
Version: 0.2.33
Release: 3mamba
Summary: ZVBI provides routines to read from raw Vertical Blanking interval capture devices
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Tiziana Ferro <tiziana.ferro@email.it>
URL: http://freshmeat.net/projects/libzvbi
Source0: http://switch.dl.sourceforge.net/sourceforge/zapping/zvbi-%{version}.tar.bz2
Patch0: zvbi-0.2.33-libpng-1.5.patch
Patch1: zvbi-0.2.33-glibc-2.17.patch
License: GPL
BuildRoot: %{_tmppath}/%{name}-%{version}-root
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libpng-devel
BuildRequires: libpthread-stubs-devel
BuildRequires: libX11-devel
BuildRequires: libXau-devel
BuildRequires: libxcb-devel
BuildRequires: libXdmcp-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
Requires: pam
%description
The Zapping VBI (zvbi) library provides routines to read from raw Vertical Blanking Interval capture devices, to demodulate raw to sliced VBI data, and to interpret the data of several popular services. Basically, it offers all the functionality needed by a VBI application except for the UI.
ZVBI provides routines to read from raw Vertical Blanking interval capture devices.
%package -n libzvbi
Group: Development/Libraries
Summary: ZVBI provides routines to read from raw Vertical Blanking interval capture devices
%description -n libzvbi
ZVBI library provides routines to read from raw Vertical Blanking interval capture devices.
%package -n libzvbi-devel
Group: Development/Libraries
Summary: Static libraries and headers for lib%{name}
Requires: libzvbi = %{version}-%{release}
%description -n libzvbi-devel
ZVBI library provides routines to read from raw Vertical Blanking interval capture devices.
This package contains static libraries and header files need for development.
%prep
%setup -q -n zvbi-%{version}
%patch0 -p1
%patch1 -p1
%build
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall
%{find_lang} %{name}
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/zvbi-atsc-cc
%{_bindir}/zvbi-chains
%{_bindir}/zvbi-ntsc-cc
%{_sbindir}/zvbid
%{_mandir}/man1/zvbi-atsc-cc.1.*
%{_mandir}/man1/zvbi-chains.1.*
%{_mandir}/man1/zvbid.1.*
%{_mandir}/man1/zvbi-ntsc-cc.1.*
%files -n libzvbi -f %{name}.lang
%defattr(-,root,root)
%{_libdir}/libzvbi.so.*
%{_libdir}/libzvbi-chains.so.*
%doc AUTHORS COPYING
%files -n libzvbi-devel
%defattr(-,root,root)
%{_includedir}/*.h
%{_libdir}/libzvbi.a
%{_libdir}/libzvbi.la
%{_libdir}/libzvbi.so
%{_libdir}/libzvbi-chains.a
%{_libdir}/libzvbi-chains.la
%{_libdir}/libzvbi-chains.so
%{_libdir}/pkgconfig/*.pc
%doc BUGS ChangeLog INSTALL NEWS README TODO
%changelog
* Tue Feb 12 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.33-3mamba
- rebuild with patch against libpng 1.5 and glibc 2.17
* Fri May 08 2009 Automatic Build System <autodist@mambasoft.it> 0.2.33-2mamba
- automatic rebuild by autodist
* Tue Jan 20 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.33-1mamba
- automatic update by autodist
* Fri Jul 25 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.30-2mamba
- libzvbi: remove requirement for zvbi
- zvbi: remove static requirement for libzvbi
- removed devfs support
* Wed Jul 02 2008 Tiziana Ferro <tiziana.ferro@email.it> 0.2.30-1mamba
- update to 0.2.30
* Wed May 18 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.2.15-1qilnx
- package created by autospec