90 lines
2.9 KiB
RPMSpec
90 lines
2.9 KiB
RPMSpec
%define gittag %(echo %version | cut -d+ -f2 | cut -d. -f2)
|
|
Name: zig
|
|
Version: 0.13.0+20241005git.73de620
|
|
Release: 1mamba
|
|
Summary: A general-purpose programming language and toolchain for maintaining robust, optimal and reusable software
|
|
Group: Applications/Development
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://ziglang.org/
|
|
Source: https://github.com/ziglang/zig.git/master@%{gittag}/zig-%{version}.tar.bz2
|
|
License: MIT
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libclang-devel
|
|
BuildRequires: liblld-devel
|
|
BuildRequires: libllvm-devel
|
|
BuildRequires: libstdc++6-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: liblld-devel >= 19.1.1
|
|
BuildRequires: libclang-devel >= 19.1.1
|
|
BuildRequires: cmake
|
|
|
|
%description
|
|
Zig is a general-purpose programming language and toolchain for maintaining robust, optimal and reusable software.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
#-D -T
|
|
#:<< __EOF
|
|
|
|
%build
|
|
#:<< _EOF
|
|
# FIXME: PKG_CONFIG_PATH as set by rpm script causes the build to fail
|
|
export PKG_CONFIG_PATH=""
|
|
%cmake -d build \
|
|
-DCMAKE_BUILD_TYPE=Debug \
|
|
-DZIG_SHARED_LLVM=ON
|
|
|
|
# FIXME: prevent segfault due to mixing with libLLVM-16.so
|
|
LD_PRELOAD=%{_libdir}/libLLVM-17.so make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
# FIXME: PKG_CONFIG_PATH as set by rpm script causes the build to fail
|
|
export PKG_CONFIG_PATH=""
|
|
%makeinstall -C build
|
|
|
|
rm -rf %{buildroot}/usr/doc
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/zig
|
|
%dir %{_prefix}/lib/zig
|
|
%{_prefix}/lib/zig/*
|
|
%doc LICENSE
|
|
|
|
%changelog
|
|
* Sat Oct 05 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 0.13.0+20241005git.73de620-1mamba
|
|
- update to 0.13.0+20241005git.73de620
|
|
|
|
* Sun Jul 28 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 0.13.0-1mamba
|
|
- update to 0.13.0
|
|
|
|
* Sat Nov 04 2023 Automatic Build System <autodist@mambasoft.it> 0.11.0.20231028git.256ab6-2mamba
|
|
- rebuilt by autoport with build requirements: liblld-devel>=17.0.4-1mamba
|
|
|
|
* Sat Oct 28 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.11.0.20231028git.256ab6-1mamba
|
|
- update to 0.11.0.20231028git.256ab6
|
|
|
|
* Sat Oct 28 2023 Automatic Build System <autodist@mambasoft.it> 0.11.0-2mamba
|
|
- rebuilt by autoport with build requirements: libclang-devel>=17.0.3-1mamba
|
|
|
|
* Sat Aug 05 2023 Automatic Build System <autodist@mambasoft.it> 0.11.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 25 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.1.20230525git.230ea41-1mamba
|
|
- update to 0.10.1.20230525git.230ea41
|
|
|
|
* Thu May 25 2023 Sdk Build System <sdk@mambasoft.it> 0.10.1-2mamba
|
|
- rebuilt by autoport with build requirements: libclang-devel>=0:16.0.4-1mamba
|
|
|
|
* Sat Mar 18 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.1-1mamba
|
|
- package created using the webbuild interface
|