package created using the webbuild interface [release 0.10.1-1mamba;Sat Mar 18 2023]

This commit is contained in:
Silvan Calarco 2024-01-05 20:04:33 +01:00
parent 81a50b9ae3
commit fe8a199bdf
4 changed files with 85 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# zig
Zig is a general-purpose programming language and toolchain for maintaining robust, optimal and reusable software.

View File

@ -0,0 +1,11 @@
--- zig-0.10.1/lib/std/build.zig.orig 2023-03-18 13:15:44.162105708 +0100
+++ zig-0.10.1/lib/std/build.zig 2023-03-18 13:15:48.812081417 +0100
@@ -1181,7 +1181,7 @@
if (!std.process.can_spawn)
return error.ExecNotSupported;
- const max_output_size = 400 * 1024;
+ const max_output_size = 1000 * 1024;
var child = std.ChildProcess.init(argv, self.allocator);
child.stdin_behavior = .Ignore;
child.stdout_behavior = .Pipe;

11
zig-0.10.1-llvm-15.patch Normal file
View File

@ -0,0 +1,11 @@
--- zig-0.10.1/CMakeLists.txt.orig 2023-03-18 10:33:29.545883623 +0100
+++ zig-0.10.1/CMakeLists.txt 2023-03-18 10:33:43.992805754 +0100
@@ -889,7 +889,7 @@
if(MSVC)
set(EXE_CFLAGS "${EXE_CFLAGS} /w")
else()
- set(EXE_CFLAGS "${EXE_CFLAGS} -Werror -Wall")
+ set(EXE_CFLAGS "${EXE_CFLAGS} -Werror -Wall -Wno-error=maybe-uninitialized")
# fallthrough support was added in GCC 7.0
if(NOT CMAKE_CXX_COMPILER_ID STREQUAL "GNU" OR CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 7.0)
set(EXE_CFLAGS "${EXE_CFLAGS} -Werror=implicit-fallthrough")

61
zig.spec Normal file
View File

@ -0,0 +1,61 @@
Name: zig
Version: 0.10.1
Release: 1mamba
Summary: A general-purpose programming language and toolchain for maintaining robust, optimal and reusable software
Group: Applications/Development
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://ziglang.org/
Source: https://ziglang.org/download/%{version}/zig-%{version}.tar.xz
Patch0: zig-0.10.1-llvm-15.patch
Patch1: zig-0.10.1-build-increase-max_output-size.patch
License: MIT
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libclang-devel
BuildRequires: liblld-devel
BuildRequires: libllvm-devel
BuildRequires: libstdc++6-devel
## AUTOBUILDREQ-END
BuildRequires: cmake
%description
Zig is a general-purpose programming language and toolchain for maintaining robust, optimal and reusable software.
%debug_package
%prep
%setup -q
#-D -T
#:<< __EOF
%patch 0 -p1
%patch 1 -p1
%build
#:<< _EOF
%cmake -d build \
\
%ifarch %{ix86}
-DCMAKE_BUILD_TYPE=None
%endif
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C build
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/zig
%dir %{_prefix}/lib/zig
%{_prefix}/lib/zig/*
%doc LICENSE
%changelog
* Sat Mar 18 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.1-1mamba
- package created using the webbuild interface