update to 0.13.0 [release 0.13.0-1mamba;Sun Jul 28 2024]
This commit is contained in:
parent
487d93baf4
commit
6cad9c21f1
@ -1,11 +0,0 @@
|
||||
--- zig-0.10.1/lib/std/build.zig.orig 2023-03-18 13:15:44.162105708 +0100
|
||||
+++ zig-0.10.1/lib/std/build.zig 2023-03-18 13:15:48.812081417 +0100
|
||||
@@ -1181,7 +1181,7 @@
|
||||
if (!std.process.can_spawn)
|
||||
return error.ExecNotSupported;
|
||||
|
||||
- const max_output_size = 400 * 1024;
|
||||
+ const max_output_size = 1000 * 1024;
|
||||
var child = std.ChildProcess.init(argv, self.allocator);
|
||||
child.stdin_behavior = .Ignore;
|
||||
child.stdout_behavior = .Pipe;
|
@ -1,11 +0,0 @@
|
||||
--- zig-0.10.1/CMakeLists.txt.orig 2023-03-18 10:33:29.545883623 +0100
|
||||
+++ zig-0.10.1/CMakeLists.txt 2023-03-18 10:33:43.992805754 +0100
|
||||
@@ -889,7 +889,7 @@
|
||||
if(MSVC)
|
||||
set(EXE_CFLAGS "${EXE_CFLAGS} /w")
|
||||
else()
|
||||
- set(EXE_CFLAGS "${EXE_CFLAGS} -Werror -Wall")
|
||||
+ set(EXE_CFLAGS "${EXE_CFLAGS} -Werror -Wall -Wno-error=maybe-uninitialized")
|
||||
# fallthrough support was added in GCC 7.0
|
||||
if(NOT CMAKE_CXX_COMPILER_ID STREQUAL "GNU" OR CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 7.0)
|
||||
set(EXE_CFLAGS "${EXE_CFLAGS} -Werror=implicit-fallthrough")
|
15
zig.spec
15
zig.spec
@ -1,16 +1,14 @@
|
||||
%define gittag %(echo %version | cut -d. -f5)
|
||||
#% define gittag %(echo %version | cut -d. -f5)
|
||||
Name: zig
|
||||
Version: 0.11.0.20231028git.256ab6
|
||||
Release: 2mamba
|
||||
Version: 0.13.0
|
||||
Release: 1mamba
|
||||
Summary: A general-purpose programming language and toolchain for maintaining robust, optimal and reusable software
|
||||
Group: Applications/Development
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://ziglang.org/
|
||||
Source: https://github.com/ziglang/zig.git/master@%{gittag}/zig-%{version}.tar.bz2
|
||||
Patch0: zig-0.10.1-llvm-15.patch
|
||||
Patch1: zig-0.10.1-build-increase-max_output-size.patch
|
||||
Source: https://github.com/ziglang/zig.git/%{version}/zig-%{version}.tar.bz2
|
||||
License: MIT
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -32,8 +30,6 @@ Zig is a general-purpose programming language and toolchain for maintaining robu
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< __EOF
|
||||
#%patch 0 -p1
|
||||
#%patch 1 -p1
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
@ -65,6 +61,9 @@ rm -rf %{buildroot}/usr/doc
|
||||
%doc LICENSE
|
||||
|
||||
%changelog
|
||||
* Sun Jul 28 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 0.13.0-1mamba
|
||||
- update to 0.13.0
|
||||
|
||||
* Sat Nov 04 2023 Automatic Build System <autodist@mambasoft.it> 0.11.0.20231028git.256ab6-2mamba
|
||||
- rebuilt by autoport with build requirements: liblld-devel>=17.0.4-1mamba
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user