242 lines
7.7 KiB
RPMSpec
242 lines
7.7 KiB
RPMSpec
%define MAJver %(echo %version | cut -d. -f1)
|
|
Name: yelp
|
|
Version: 42.2
|
|
Release: 1mamba
|
|
Summary: Gnome help viewer
|
|
Group: Graphical Desktop/Applications/Utilities
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://wiki.gnome.org/action/show/Apps/Yelp?action=show
|
|
Source0: https://download.gnome.org/sources/yelp/%{MAJver}/yelp-%{version}.tar.xz
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libat-spi2-core-devel
|
|
BuildRequires: libbzip2-devel
|
|
BuildRequires: libcairo-devel
|
|
BuildRequires: libgcrypt-devel
|
|
BuildRequires: libgdk-pixbuf-devel
|
|
BuildRequires: libglib-devel
|
|
BuildRequires: libgtk3-devel
|
|
BuildRequires: libhandy-devel
|
|
BuildRequires: libharfbuzz-devel
|
|
BuildRequires: liblzma-devel
|
|
BuildRequires: libpango-devel
|
|
BuildRequires: libsoup-devel
|
|
BuildRequires: libsqlite-devel
|
|
BuildRequires: libwebkit2gtk-4.1-devel
|
|
BuildRequires: libxml2-devel
|
|
BuildRequires: libxslt-devel
|
|
BuildRequires: libz-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: intltool
|
|
BuildRequires: perl-XML-Parser
|
|
BuildRequires: yelp-xsl-devel
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: gnome-doc-utils
|
|
Requires: yelp-xsl
|
|
Requires: man
|
|
|
|
%description
|
|
Yelp is the help viewer in Gnome.
|
|
Together with gnome-doc-utils, Yelp serves as a DocBook viewer, a man page viewer, and an info page viewer.
|
|
This page serves as a development workspace for Yelp and gnome-doc-utils.
|
|
For the content that goes into Yelp, see the GNOME DocumentationProject.
|
|
|
|
%package -n lib%{name}
|
|
Summary: Shared libraries for %{name}
|
|
Group: System/Libraries
|
|
|
|
%description -n lib%{name}
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-devel
|
|
Summary: Development files for lib%{name}
|
|
Group: Development/Libraries
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use lib%{name}.
|
|
|
|
%package -n lib%{name}-apidocs
|
|
Summary: lib%{name} API documentation
|
|
Group: Documentation
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: gtk-doc
|
|
|
|
%description -n lib%{name}-apidocs
|
|
This package includes the lib%{name} API documentation.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%configure \
|
|
--disable-static
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall
|
|
|
|
find %{buildroot}%{_libdir} -name '*.la' -type f -delete
|
|
|
|
install -d %{buildroot}%{_datadir}/gnome/help
|
|
|
|
%find_lang %{name}
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%postun
|
|
if [ $1 -eq 0 ]; then
|
|
glib-compile-schemas %{_datadir}/glib-2.0/schemas >/dev/null 2>&1 ||:
|
|
fi
|
|
|
|
%posttrans
|
|
glib-compile-schemas %{_datadir}/glib-2.0/schemas >/dev/null 2>&1 ||:
|
|
|
|
%post -n lib%{name} -p /sbin/ldconfig
|
|
%postun -n lib%{name} -p /sbin/ldconfig
|
|
|
|
%files -f %{name}.lang
|
|
%defattr(-,root,root)
|
|
%{_bindir}/gnome-help
|
|
%{_bindir}/yelp
|
|
%{_datadir}/yelp
|
|
%dir %{_datadir}/gnome/help
|
|
%{_datadir}/glib-*/schemas/org.gnome.yelp.gschema.xml
|
|
%{_datadir}/applications/yelp.desktop
|
|
%{_datadir}/icons/hicolor/scalable/apps/org.gnome.Yelp.svg
|
|
%{_datadir}/icons/hicolor/symbolic/apps/org.gnome.Yelp-symbolic.svg
|
|
%{_datadir}/metainfo/yelp.appdata.xml
|
|
%{_datadir}/yelp-xsl/xslt/common/domains/yelp.xml
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libyelp.so.*
|
|
%dir %{_libdir}/yelp
|
|
#%{_libdir}/yelp/libyelpcommon.so
|
|
%dir %{_libdir}/yelp/web-extensions
|
|
%{_libdir}/yelp/web-extensions/libyelpwebextension.so
|
|
%doc AUTHORS COPYING
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libyelp.so
|
|
%{_includedir}/libyelp
|
|
%doc NEWS README.md ChangeLog
|
|
|
|
#%files -n lib%{name}-apidocs
|
|
#%defattr(-,root,root)
|
|
#%{_datadir}/gtk-doc/html/libyelp
|
|
|
|
%changelog
|
|
* Mon Nov 21 2022 Automatic Build System <autodist@mambasoft.it> 42.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jul 25 2021 Automatic Build System <autodist@mambasoft.it> 40.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 27 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 40.0-1mamba
|
|
- update to 40.0
|
|
|
|
* Thu Feb 25 2021 Automatic Build System <autodist@mambasoft.it> 3.38.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 22 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.38.2-2mamba
|
|
- rebuilt with debug package
|
|
|
|
* Sun Nov 22 2020 Automatic Build System <autodist@mambasoft.it> 3.38.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Oct 04 2020 Automatic Build System <autodist@mambasoft.it> 3.38.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Sep 27 2020 Automatic Build System <autodist@mambasoft.it> 3.38.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 08 2020 Automatic Build System <autodist@mambasoft.it> 3.36.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 13 2019 Automatic Build System <autodist@mambasoft.it> 3.34.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed May 08 2019 Automatic Build System <autodist@mambasoft.it> 3.32.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Apr 09 2019 Automatic Build System <autodist@mambasoft.it> 3.32.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Apr 01 2019 Automatic Build System <autodist@mambasoft.it> 3.32.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Sep 18 2018 Automatic Build System <autodist@mambasoft.it> 3.30.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Sep 11 2018 Automatic Build System <autodist@mambasoft.it> 3.28.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 13 2017 Automatic Build System <autodist@mambasoft.it> 3.26.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Oct 15 2016 Automatic Build System <autodist@mambasoft.it> 3.22.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri May 20 2016 Automatic Build System <autodist@mambasoft.it> 3.20.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Oct 27 2015 Automatic Build System <autodist@mambasoft.it> 3.18.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 12 2015 Automatic Build System <autodist@mambasoft.it> 3.18.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed May 13 2015 Automatic Build System <autodist@mambasoft.it> 3.16.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 09 2015 Automatic Build System <autodist@mambasoft.it> 3.16.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 16 2014 Automatic Build System <autodist@mambasoft.it> 3.14.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 03 2014 Automatic Build System <autodist@mambasoft.it> 3.14.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Mar 26 2014 Automatic Build System <autodist@mambasoft.it> 3.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 04 2014 Automatic Build System <autodist@mambasoft.it> 3.10.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 28 2013 Automatic Build System <autodist@mambasoft.it> 3.10.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue May 14 2013 Automatic Build System <autodist@mambasoft.it> 3.8.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Mar 28 2013 Automatic Build System <autodist@mambasoft.it> 3.8.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Nov 12 2012 Automatic Build System <autodist@mambasoft.it> 3.6.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 15 2012 Automatic Build System <autodist@mambasoft.it> 3.6.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 11 2012 Automatic Build System <autodist@mambasoft.it> 3.6.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jul 03 2012 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 3.4.2-1mamba
|
|
- update to 3.4.2
|
|
- added library, devel and apidocs packages
|
|
- spec cleaned
|
|
|
|
* Mon Jan 12 2009 gil <puntogil@libero.it> 2.24.0-1mamba
|
|
- package created by autospec
|