81 lines
2.3 KiB
RPMSpec
81 lines
2.3 KiB
RPMSpec
Name: yaml-cpp
|
|
Version: 0.5.1
|
|
Release: 1mamba
|
|
Summary: A YAML parser and emitter in C++ matching the YAML 1.2 spec
|
|
Group: Development/Tools
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://code.google.com/p/yaml-cpp/
|
|
Source: https://yaml-cpp.googlecode.com/files/yaml-cpp-%{version}.tar.gz
|
|
License: MIT
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libstdc++6-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
yaml-cpp is a YAML parser and emitter in C++ matching the YAML 1.2 spec.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: A YAML parser and emitter in C++ matching the YAML 1.2 spec
|
|
|
|
%description -n lib%{name}
|
|
yaml-cpp is a YAML parser and emitter in C++ matching the YAML 1.2 spec.
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: pkg-config
|
|
|
|
%description -n lib%{name}-devel
|
|
yaml-cpp is a YAML parser and emitter in C++ matching the YAML 1.2 spec.
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%cmake -d build
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -n lib%{name} -p /sbin/ldconfig
|
|
%postun -n lib%{name} -p /sbin/ldconfig
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libyaml-cpp.so.*
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/yaml-cpp
|
|
%{_includedir}/yaml-cpp/*.h
|
|
%dir %{_includedir}/yaml-cpp/contrib
|
|
%{_includedir}/yaml-cpp/contrib/*.h
|
|
%dir %{_includedir}/yaml-cpp/node
|
|
%{_includedir}/yaml-cpp/node/*.h
|
|
%dir %{_includedir}/yaml-cpp/node/detail
|
|
%{_includedir}/yaml-cpp/node/detail/*.h
|
|
%{_libdir}/libyaml-cpp.so
|
|
%{_libdir}/pkgconfig/yaml-cpp.pc
|
|
|
|
%changelog
|
|
* Tue Feb 03 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-1mamba
|
|
- package created using the webbuild interface
|