automatic version update by autodist [release 1.3.17-1mamba;Wed Feb 06 2013]

This commit is contained in:
Automatic Build System 2024-01-05 19:59:09 +01:00
parent 8905d1b866
commit 406ddaa7c1
5 changed files with 184 additions and 0 deletions

View File

@ -1,2 +1,6 @@
# yaboot
Yaboot is an OpenFirmware bootloader for Open Firmware based machines. It is known to work on "NewWorld" class PowerMacs (iMac and all machines released after it), RS/6000, and possibly other OF based CHRP machines. "OldWorld" PowerMacs (with the built-in MacOS ROM) are not supported.
Ybin is the GNU/Linux utility to install the yaboot boot loader onto a bootstrap partition. It will not run from MacOS.
Ybin (YaBoot INstaller) was created so that there could be a lilo/quik style bootloader installer for yaboot. With a properly configured system one can simply type ybin, and the bootloader will be installed/updated on the bootstrap partition without any further user intervention. Ybin is required to install yaboot.

View File

@ -0,0 +1,67 @@
diff -Nru yaboot-1.3.13.orig/Makefile yaboot-1.3.13/Makefile
--- yaboot-1.3.13.orig/Makefile 2005-08-21 11:49:49.000000000 +0200
+++ yaboot-1.3.13/Makefile 2005-08-21 12:01:19.000000000 +0200
@@ -172,38 +172,38 @@
release: docs bindist clean
strip: all
- strip second/yaboot
- strip --remove-section=.comment second/yaboot
- strip util/addnote
- strip --remove-section=.comment --remove-section=.note util/addnote
+ $(CROSS)strip second/yaboot
+ $(CROSS)strip --remove-section=.comment second/yaboot
+ $(CROSS)strip util/addnote
+ $(CROSS)strip --remove-section=.comment --remove-section=.note util/addnote
install: all strip
- install -d -o root -g root -m 0755 ${ROOT}/etc/
- install -d -o root -g root -m 0755 ${ROOT}/${PREFIX}/sbin/
- install -d -o root -g root -m 0755 ${ROOT}/${PREFIX}/lib
- install -d -o root -g root -m 0755 ${ROOT}/${PREFIX}/lib/yaboot
- install -d -o root -g root -m 0755 ${ROOT}/${PREFIX}/${MANDIR}/man5/
- install -d -o root -g root -m 0755 ${ROOT}/${PREFIX}/${MANDIR}/man8/
- install -o root -g root -m 0644 second/yaboot ${ROOT}/$(PREFIX)/lib/yaboot
- install -o root -g root -m 0755 util/addnote ${ROOT}/${PREFIX}/lib/yaboot/addnote
- install -o root -g root -m 0644 first/ofboot ${ROOT}/${PREFIX}/lib/yaboot/ofboot
- install -o root -g root -m 0755 ybin/ofpath ${ROOT}/${PREFIX}/sbin/ofpath
- install -o root -g root -m 0755 ybin/ybin ${ROOT}/${PREFIX}/sbin/ybin
- install -o root -g root -m 0755 ybin/yabootconfig ${ROOT}/${PREFIX}/sbin/yabootconfig
+ install -d -m 0755 ${ROOT}/etc/
+ install -d -m 0755 ${ROOT}/${PREFIX}/sbin/
+ install -d -m 0755 ${ROOT}/${PREFIX}/lib
+ install -d -m 0755 ${ROOT}/${PREFIX}/lib/yaboot
+ install -d -m 0755 ${ROOT}/${PREFIX}/${MANDIR}/man5/
+ install -d -m 0755 ${ROOT}/${PREFIX}/${MANDIR}/man8/
+ install -m 0644 second/yaboot ${ROOT}/$(PREFIX)/lib/yaboot
+ install -m 0755 util/addnote ${ROOT}/${PREFIX}/lib/yaboot/addnote
+ install -m 0644 first/ofboot ${ROOT}/${PREFIX}/lib/yaboot/ofboot
+ install -m 0755 ybin/ofpath ${ROOT}/${PREFIX}/sbin/ofpath
+ install -m 0755 ybin/ybin ${ROOT}/${PREFIX}/sbin/ybin
+ install -m 0755 ybin/yabootconfig ${ROOT}/${PREFIX}/sbin/yabootconfig
rm -f ${ROOT}/${PREFIX}/sbin/mkofboot
ln -s ybin ${ROOT}/${PREFIX}/sbin/mkofboot
@gzip -9 man/*.[58]
- install -o root -g root -m 0644 man/bootstrap.8.gz ${ROOT}/${PREFIX}/${MANDIR}/man8/bootstrap.8.gz
- install -o root -g root -m 0644 man/mkofboot.8.gz ${ROOT}/${PREFIX}/${MANDIR}/man8/mkofboot.8.gz
- install -o root -g root -m 0644 man/ofpath.8.gz ${ROOT}/${PREFIX}/${MANDIR}/man8/ofpath.8.gz
- install -o root -g root -m 0644 man/yaboot.8.gz ${ROOT}/${PREFIX}/${MANDIR}/man8/yaboot.8.gz
- install -o root -g root -m 0644 man/yabootconfig.8.gz ${ROOT}/${PREFIX}/${MANDIR}/man8/yabootconfig.8.gz
- install -o root -g root -m 0644 man/ybin.8.gz ${ROOT}/${PREFIX}/${MANDIR}/man8/ybin.8.gz
- install -o root -g root -m 0644 man/yaboot.conf.5.gz ${ROOT}/${PREFIX}/${MANDIR}/man5/yaboot.conf.5.gz
+ install -m 0644 man/bootstrap.8.gz ${ROOT}/${PREFIX}/${MANDIR}/man8/bootstrap.8.gz
+ install -m 0644 man/mkofboot.8.gz ${ROOT}/${PREFIX}/${MANDIR}/man8/mkofboot.8.gz
+ install -m 0644 man/ofpath.8.gz ${ROOT}/${PREFIX}/${MANDIR}/man8/ofpath.8.gz
+ install -m 0644 man/yaboot.8.gz ${ROOT}/${PREFIX}/${MANDIR}/man8/yaboot.8.gz
+ install -m 0644 man/yabootconfig.8.gz ${ROOT}/${PREFIX}/${MANDIR}/man8/yabootconfig.8.gz
+ install -m 0644 man/ybin.8.gz ${ROOT}/${PREFIX}/${MANDIR}/man8/ybin.8.gz
+ install -m 0644 man/yaboot.conf.5.gz ${ROOT}/${PREFIX}/${MANDIR}/man5/yaboot.conf.5.gz
@gunzip man/*.gz
@if [ ! -e ${ROOT}/etc/yaboot.conf ] ; then \
- echo "install -o root -g root -m 0644 etc/yaboot.conf ${ROOT}/etc/yaboot.conf"; \
- install -o root -g root -m 0644 etc/yaboot.conf ${ROOT}/etc/yaboot.conf; \
+ echo "install -m 0644 etc/yaboot.conf ${ROOT}/etc/yaboot.conf"; \
+ install -m 0644 etc/yaboot.conf ${ROOT}/etc/yaboot.conf; \
else \
echo "/etc/yaboot.conf already exists, leaving it alone"; \
fi

12
yaboot-1.3.13-gcc34.patch Normal file
View File

@ -0,0 +1,12 @@
diff -Nru yaboot-1.3.13.orig/lib/strstr.c yaboot-1.3.13/lib/strstr.c
--- yaboot-1.3.13.orig/lib/strstr.c 2005-08-21 11:49:49.000000000 +0200
+++ yaboot-1.3.13/lib/strstr.c 2005-08-21 11:49:59.000000000 +0200
@@ -76,7 +76,7 @@
a = *++haystack;
if (a == '\0')
goto ret0;
-shloop: }
+shloop: ; }
while (a != b);
jin: a = *++haystack;

12
yaboot-1.3.13-gcc4.patch Normal file
View File

@ -0,0 +1,12 @@
diff -Nru yaboot-1.3.13.orig/lib/strstr.c yaboot-1.3.13/lib/strstr.c
--- yaboot-1.3.13.orig/lib/strstr.c 2001-09-20 15:15:31.000000000 +0200
+++ yaboot-1.3.13/lib/strstr.c 2008-11-28 05:13:24.000000000 +0100
@@ -76,7 +76,7 @@
a = *++haystack;
if (a == '\0')
goto ret0;
-shloop: }
+shloop: ; }
while (a != b);
jin: a = *++haystack;

89
yaboot.spec Normal file
View File

@ -0,0 +1,89 @@
Name: yaboot
Version: 1.3.17
Release: 1mamba
Summary: An OpenFirmware bootloader for Open Firmware based machine
Group: System/Kernel and Hardware
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://yaboot.ozlabs.org/
Source: http://yaboot.ozlabs.org/releases/yaboot-%{version}.tar.gz
Patch0: yaboot-1.3.13-gcc34.patch
Patch1: yaboot-1.3.13-Makefile.patch
Patch2: yaboot-1.3.13-gcc4.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgcc
## AUTOBUILDREQ-END
%ifarch ppc
Provides: bootloader
%endif
Requires: hfsutils
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Yaboot is an OpenFirmware bootloader for Open Firmware based machines. It is known to work on "NewWorld" class PowerMacs (iMac and all machines released after it), RS/6000, and possibly other OF based CHRP machines. "OldWorld" PowerMacs (with the built-in MacOS ROM) are not supported.
Ybin is the GNU/Linux utility to install the yaboot boot loader onto a bootstrap partition. It will not run from MacOS.
Ybin (YaBoot INstaller) was created so that there could be a lilo/quik style bootloader installer for yaboot. With a properly configured system one can simply type ybin, and the bootloader will be installed/updated on the bootstrap partition without any further user intervention. Ybin is required to install yaboot.
%prep
%setup -q
#%patch0 -p1
%patch1 -p1
#%patch2 -p1
sed -i "s|/usr/local|/usr|" etc/yaboot.conf
sed -i -e "s/-Werror//" Makefile
%build
make \
PREFIX=%{_prefix} \
MANDIR=%{_mandir} \
CROSS=ppc-openmamba-linux-gnu-
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
make install \
PREFIX=%{_prefix} \
MANDIR=share/man \
CROSS=ppc-openmamba-linux-gnu- \
ROOT=%{buildroot}
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%files
%defattr(-,root,root)
%config(noreplace) %{_sysconfdir}/yaboot.conf
%dir %{_libdir}/yaboot
%{_libdir}/yaboot/*
%{_sbindir}/*
%{_mandir}/man5/yaboot.conf.5.gz
%{_mandir}/man8/bootstrap.8.gz
%{_mandir}/man8/mkofboot.8.gz
%{_mandir}/man8/ofpath.8.gz
%{_mandir}/man8/yaboot.8.gz
%{_mandir}/man8/yabootconfig.8.gz
%{_mandir}/man8/ybin.8.gz
%doc COPYING ChangeLog
#BUGS INSTALL README README.man.patch THANKS TODO
%changelog
* Wed Feb 06 2013 Automatic Build System <autodist@mambasoft.it> 1.3.17-1mamba
- automatic version update by autodist
* Fri Sep 10 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.16-2mamba
- added requirement for hfsutils
* Mon Aug 09 2010 Automatic Build System <autodist@mambasoft.it> 1.3.16-1mamba
- update to 1.3.16
* Sun Mar 21 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.13-3mamba
- don't build as noarch
* Fri Nov 28 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.13-2mamba
- specfile fixes
- not updated to 1.3.14 because it requires libe2fs in ppc cross build environment
* Sun Aug 21 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.13-1qilnx
- package created by autospec