update to 2.2.0 [release 2.2.0-1mamba;Sun Aug 23 2015]
This commit is contained in:
parent
7820532d88
commit
6cf4a3b3f7
35
xsupplicant-2.2.0-force-release.patch
Normal file
35
xsupplicant-2.2.0-force-release.patch
Normal file
@ -0,0 +1,35 @@
|
||||
diff -up xsupplicant-src-2.1.9.709/xsupplicant-ui/xsupptray/XSupplicantUI-unix.pro.BAD xsupplicant-src-2.1.9.709/xsupplicant-ui/xsupptray/XSupplicantUI-unix.pro
|
||||
--- xsupplicant-src-2.1.9.709/xsupplicant-ui/xsupptray/XSupplicantUI-unix.pro.BAD 2010-01-13 11:50:15.939273096 -0500
|
||||
+++ xsupplicant-src-2.1.9.709/xsupplicant-ui/xsupptray/XSupplicantUI-unix.pro 2010-01-13 11:50:53.312370639 -0500
|
||||
@@ -5,9 +5,9 @@
|
||||
|
||||
TEMPLATE = app
|
||||
TARGET = XSupplicantUI
|
||||
-DESTDIR = ../build-debug
|
||||
+DESTDIR = ../build-release
|
||||
QT += xml
|
||||
-CONFIG += debug
|
||||
+CONFIG += release
|
||||
INCLUDEPATH += ./../../xsupplicant/src/eap_types/tnc \
|
||||
./../../xsupplicant/lib \
|
||||
./../../xsupplicant/lib/libsupdetect \
|
||||
@@ -18,7 +18,7 @@ INCLUDEPATH += ./../../xsupplicant/src/e
|
||||
/usr/include/libxml2 \
|
||||
/usr/local/include \
|
||||
. \
|
||||
- ./debug \
|
||||
+ ./release \
|
||||
./GeneratedFiles
|
||||
LIBS += -L"./../../xsupplicant/lib/libsupdetect" \
|
||||
-L"./../../xsupplicant/lib/libxsupconfig" \
|
||||
@@ -36,8 +36,8 @@ LIBS += -L"./../../xsupplicant/lib/libsu
|
||||
-lxsupconfcheck \
|
||||
-lsupdetect
|
||||
DEPENDPATH += .
|
||||
-MOC_DIR += debug
|
||||
-OBJECTS_DIR += debug
|
||||
+MOC_DIR += release
|
||||
+OBJECTS_DIR += release
|
||||
UI_DIR += ./GeneratedFiles
|
||||
RCC_DIR += ./release
|
||||
|
12
xsupplicant-2.2.0-gcc47.patch
Normal file
12
xsupplicant-2.2.0-gcc47.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up XSupplicant-2.2.0-src/xsupplicant-ui/xsupptray/main.cpp.gcc47 XSupplicant-2.2.0-src/xsupplicant-ui/xsupptray/main.cpp
|
||||
--- XSupplicant-2.2.0-src/xsupplicant-ui/xsupptray/main.cpp.gcc47 2012-01-05 15:45:39.227669265 -0500
|
||||
+++ XSupplicant-2.2.0-src/xsupplicant-ui/xsupptray/main.cpp 2012-01-05 15:45:47.510593833 -0500
|
||||
@@ -30,6 +30,8 @@
|
||||
* Nortel Networks for an OEM Commercial License.
|
||||
**/
|
||||
|
||||
+#include <unistd.h>
|
||||
+
|
||||
#include "stdafx.h"
|
||||
|
||||
extern "C" {
|
105
xsupplicant-2.2.0-implicit-DSO.patch
Normal file
105
xsupplicant-2.2.0-implicit-DSO.patch
Normal file
@ -0,0 +1,105 @@
|
||||
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
|
||||
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
|
||||
<html xmlns='http://www.w3.org/1999/xhtml' xml:lang='en' lang='en'>
|
||||
<head>
|
||||
<title>xsupplicant.git - xsupplicant</title>
|
||||
<meta name='generator' content='cgit v0.10.2'/>
|
||||
<meta name='robots' content='index, nofollow'/>
|
||||
<link rel='stylesheet' type='text/css' href='/cgit-data/cgit.css'/>
|
||||
<link rel='shortcut icon' href='/favicon.ico'/>
|
||||
<link rel='alternate' title='Atom feed' href='http://pkgs.fedoraproject.org/cgit/xsupplicant.git/atom/xsupplicant-2.2.0-implicit-DSO.patch?h=master' type='application/atom+xml'/>
|
||||
</head>
|
||||
<body>
|
||||
<script src="https://apps.fedoraproject.org/fedmenu/js/jquery-1.11.2.min.js"></script>
|
||||
<script src="https://apps.fedoraproject.org/fedmenu/js/fedmenu.js"></script>
|
||||
|
||||
<script>
|
||||
var base = 'https://apps.fedoraproject.org/';
|
||||
var tokens = window.location.href.split('/');
|
||||
var repo = null;
|
||||
if (tokens.length > 4 && tokens[4] != '') {
|
||||
repo = tokens[4].split('.')[0];
|
||||
}
|
||||
fedmenu({
|
||||
'url': base + 'js/data.js',
|
||||
'mimeType': 'application/javascript',
|
||||
'position': 'bottom-right',
|
||||
'package': repo,
|
||||
});
|
||||
</script>
|
||||
<div id='cgit'><table id='header'>
|
||||
<tr>
|
||||
<td class='logo' rowspan='2'><a href='/cgit/'><img src='/cgit-data/cgit.png' alt='cgit logo'/></a></td>
|
||||
<td class='main'><a href='/cgit/'>index</a> : <a title='xsupplicant.git' href='/cgit/xsupplicant.git/'>xsupplicant.git</a></td><td class='form'><form method='get' action=''>
|
||||
<select name='h' onchange='this.form.submit();'>
|
||||
<option value='el4'>el4</option>
|
||||
<option value='el5'>el5</option>
|
||||
<option value='el6'>el6</option>
|
||||
<option value='f10'>f10</option>
|
||||
<option value='f11'>f11</option>
|
||||
<option value='f12'>f12</option>
|
||||
<option value='f13'>f13</option>
|
||||
<option value='f14'>f14</option>
|
||||
<option value='f15'>f15</option>
|
||||
<option value='f16'>f16</option>
|
||||
<option value='f17'>f17</option>
|
||||
<option value='f18'>f18</option>
|
||||
<option value='f19'>f19</option>
|
||||
<option value='f20'>f20</option>
|
||||
<option value='f21'>f21</option>
|
||||
<option value='f22'>f22</option>
|
||||
<option value='f23'>f23</option>
|
||||
<option value='f7'>f7</option>
|
||||
<option value='f8'>f8</option>
|
||||
<option value='f9'>f9</option>
|
||||
<option value='fc6'>fc6</option>
|
||||
<option value='master' selected='selected'>master</option>
|
||||
</select> <input type='submit' name='' value='switch'/></form></td></tr>
|
||||
<tr><td class='sub'>xsupplicant</td><td class='sub right'>Jesse Keating</td></tr></table>
|
||||
<table class='tabs'><tr><td>
|
||||
<a href='/cgit/xsupplicant.git/'>summary</a><a href='/cgit/xsupplicant.git/refs/'>refs</a><a href='/cgit/xsupplicant.git/log/xsupplicant-2.2.0-implicit-DSO.patch'>log</a><a class='active' href='/cgit/xsupplicant.git/tree/xsupplicant-2.2.0-implicit-DSO.patch'>tree</a><a href='/cgit/xsupplicant.git/commit/xsupplicant-2.2.0-implicit-DSO.patch'>commit</a><a href='/cgit/xsupplicant.git/diff/xsupplicant-2.2.0-implicit-DSO.patch'>diff</a><a href='/cgit/xsupplicant.git/stats/xsupplicant-2.2.0-implicit-DSO.patch'>stats</a></td><td class='form'><form class='right' method='get' action='/cgit/xsupplicant.git/log/xsupplicant-2.2.0-implicit-DSO.patch'>
|
||||
<select name='qt'>
|
||||
<option value='grep'>log msg</option>
|
||||
<option value='author'>author</option>
|
||||
<option value='committer'>committer</option>
|
||||
<option value='range'>range</option>
|
||||
</select>
|
||||
<input class='txt' type='text' size='10' name='q' value=''/>
|
||||
<input type='submit' value='search'/>
|
||||
</form>
|
||||
</td></tr></table>
|
||||
<div class='path'>path: <a href='/cgit/xsupplicant.git/tree/'>root</a>/<a href='/cgit/xsupplicant.git/tree/xsupplicant-2.2.0-implicit-DSO.patch'>xsupplicant-2.2.0-implicit-DSO.patch</a></div><div class='content'>blob: 6c6328f5c2e376d4e4edf601c51d59eb55c6d864 (<a href='/cgit/xsupplicant.git/plain/xsupplicant-2.2.0-implicit-DSO.patch'>plain</a>)
|
||||
<table summary='blob content' class='blob'>
|
||||
<tr><td class='linenumbers'><pre><a id='n1' href='#n1'>1</a>
|
||||
<a id='n2' href='#n2'>2</a>
|
||||
<a id='n3' href='#n3'>3</a>
|
||||
<a id='n4' href='#n4'>4</a>
|
||||
<a id='n5' href='#n5'>5</a>
|
||||
<a id='n6' href='#n6'>6</a>
|
||||
<a id='n7' href='#n7'>7</a>
|
||||
<a id='n8' href='#n8'>8</a>
|
||||
<a id='n9' href='#n9'>9</a>
|
||||
<a id='n10' href='#n10'>10</a>
|
||||
<a id='n11' href='#n11'>11</a>
|
||||
<a id='n12' href='#n12'>12</a>
|
||||
<a id='n13' href='#n13'>13</a>
|
||||
</pre></td>
|
||||
<td class='lines'><pre><code>diff -up XSupplicant-2.2.0-src/xsupplicant/configure.ac.DSO XSupplicant-2.2.0-src/xsupplicant/configure.ac
|
||||
--- XSupplicant-2.2.0-src/xsupplicant/configure.ac.DSO 2009-06-18 13:20:09.000000000 -0400
|
||||
+++ XSupplicant-2.2.0-src/xsupplicant/configure.ac 2010-02-10 16:05:30.374641077 -0500
|
||||
@@ -361,6 +361,9 @@ case "$host_os" in
|
||||
AC_CHECK_HEADER(sys/socket.h, [], [AC_MSG_ERROR([header file \
|
||||
<sys/socket.h> is required for Xsupplicant.])])
|
||||
|
||||
+ AC_CHECK_LIB(dl, dladdr)
|
||||
+ AC_CHECK_LIB(z, deflate)
|
||||
+
|
||||
AS_IF([test "$enable_static_iwlib" != yes],
|
||||
[AC_CHECK_HEADER([iwlib.h],
|
||||
[MORELIBS="${MORELIBS} -liw"], [AC_MSG_ERROR([header file <iwlib.h> is required for XSupplicant.])])],
|
||||
</code></pre></td></tr></table>
|
||||
</div> <!-- class=content -->
|
||||
<div class='footer'>generated by cgit v0.10.2 at 2015-08-23 17:53:22 (GMT)</div>
|
||||
</div> <!-- id=cgit -->
|
||||
</body>
|
||||
</html>
|
11
xsupplicant-2.2.0-linux_if.patch
Normal file
11
xsupplicant-2.2.0-linux_if.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- XSupplicant-2.2.0-src/xsupplicant/src/platform/linux/cardif_linux_rtnetlink.c.orig 2015-08-23 19:59:38.635741118 +0200
|
||||
+++ XSupplicant-2.2.0-src/xsupplicant/src/platform/linux/cardif_linux_rtnetlink.c 2015-08-23 19:59:44.018735343 +0200
|
||||
@@ -13,7 +13,7 @@
|
||||
#include <sys/ioctl.h>
|
||||
#include "netlink.h"
|
||||
#include "rtnetlink.h"
|
||||
-#include <net/if.h>
|
||||
+#include <linux/if.h>
|
||||
#include <linux/if_packet.h>
|
||||
#include <math.h>
|
||||
#include <arpa/inet.h>
|
114
xsupplicant.spec
114
xsupplicant.spec
@ -1,70 +1,148 @@
|
||||
Name: xsupplicant
|
||||
Version: 1.2.8
|
||||
Release: 3mamba
|
||||
Version: 2.2.0
|
||||
Release: 1mamba
|
||||
Summary: A free, open source 802.1X/WPA/WPA2/IEEE802.11i implementation
|
||||
Group: Network/Security
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://open1x.sourceforge.net/
|
||||
Source: http://ovh.dl.sourceforge.net/sourceforge/open1x/xsupplicant-%{version}.tar.gz
|
||||
Source: http://downloads.sourceforge.net/project/open1x/Open1X/XSupplicant%20%{version}/XSupplicant-%{version}-src.tar.gz
|
||||
Patch0: %{name}-1.2.8-configure.patch
|
||||
Patch1: %{name}-1.2.8-kernel-2.6.19.patch
|
||||
Patch2: xsupplicant-2.2.0-gcc47.patch
|
||||
Patch3: xsupplicant-2.2.0-implicit-DSO.patch
|
||||
Patch4: xsupplicant-2.2.0-linux_if.patch
|
||||
Patch5: xsupplicant-2.2.0-force-release.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libiw-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpcsclite-devel
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtnc-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libiw-devel >= 30.pre9-1mamba
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The Open1X project is dedicated to bringing a free, open source 802.1X/WPA/WPA2/IEEE802.11i implementation to as many target platforms as possible.
|
||||
|
||||
%package devel
|
||||
%package -n lib%{name}
|
||||
Summary: A free, open source 802.1X/WPA/WPA2/IEEE802.11i implementation
|
||||
Group: System/Libraries
|
||||
|
||||
%description -n lib%{name}
|
||||
The Open1X project is dedicated to bringing a free, open source 802.1X/WPA/WPA2/IEEE802.11i implementation to as many target platforms as possible.
|
||||
|
||||
%package -n lib%{name}-devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: xsupplicant-devel
|
||||
Obsoletes: xsupplicant-devel
|
||||
|
||||
%description devel
|
||||
%description -n lib%{name}-devel
|
||||
The Open1X project is dedicated to bringing a free, open source 802.1X/WPA/WPA2/IEEE802.11i implementation to as many target platforms as possible.
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package ui
|
||||
Summary: Graphical interface for xsupplicant
|
||||
Group: Graphical Desktop/Applications/Networking
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description ui
|
||||
The Open1X project is dedicated to bringing a free, open source 802.1X/WPA/WPA2/IEEE802.11i implementation to as many target platforms as possible.
|
||||
This package provides a graphical interface for xsupplicant.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%setup -q -n XSupplicant-2.2.0-src
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
%make MOREDEFS="-DNEW_IWLIB"
|
||||
cd xsupplicant
|
||||
./autoregen.sh
|
||||
%configure --enable-tnc --enable-eap-fast --enable-eap-sim
|
||||
%make
|
||||
|
||||
cd ../xsupplicant-ui/xsupptray
|
||||
qmake-qt4 XSupplicantUI-unix.pro
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
%makeinstall -C xsupplicant
|
||||
|
||||
cd xsupplicant-ui
|
||||
mkdir -p %{buildroot}%{_datadir}/%{name}/
|
||||
cp -a Skins %{buildroot}%{_datadir}/%{name}/
|
||||
install -p build-release/XSupplicantUI %{buildroot}%{_bindir}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/connect-tool
|
||||
%{_bindir}/ipcevents
|
||||
%{_bindir}/ipctest
|
||||
%{_bindir}/config-parser
|
||||
%{_bindir}/xsup_get_state
|
||||
%{_bindir}/xsup_monitor
|
||||
%{_bindir}/xsup_ntpwdhash
|
||||
%{_bindir}/xsup_set_pwd
|
||||
%{_sbindir}/xsupplicant
|
||||
%doc AUTHORS COPYING LICENSE README TODO
|
||||
|
||||
%files devel
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libbirddog.so.*
|
||||
%{_libdir}/libsoftsim2g.so.*
|
||||
%{_libdir}/libsoftsim3g.so.*
|
||||
%doc xsupplicant/AUTHORS xsupplicant/COPYING xsupplicant/LICENSE
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libxsupconfcheck.a
|
||||
%{_libdir}/libxsupconfig.a
|
||||
%{_libdir}/libxsupconfwrite.a
|
||||
%{_libdir}/libbirddog.a
|
||||
%{_libdir}/libbirddog.la
|
||||
%{_libdir}/libbirddog.so
|
||||
%{_libdir}/libsoftsim2g.a
|
||||
%{_libdir}/libsoftsim2g.la
|
||||
%{_libdir}/libsoftsim2g.so
|
||||
%{_libdir}/libsoftsim3g.a
|
||||
%{_libdir}/libsoftsim3g.la
|
||||
%{_libdir}/libsoftsim3g.so
|
||||
%{_libdir}/libxsupgui.a
|
||||
%{_includedir}/*.h
|
||||
%doc xsupplicant/README xsupplicant/TODO
|
||||
|
||||
%files ui
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/XSupplicantUI
|
||||
%dir %{_datadir}/xsupplicant
|
||||
%dir %{_datadir}/xsupplicant/Skins
|
||||
%dir %{_datadir}/xsupplicant/Skins/Default
|
||||
%{_datadir}/xsupplicant/Skins/Default/*
|
||||
%doc xsupplicant-ui/LICENSE
|
||||
|
||||
%changelog
|
||||
* Sun Aug 23 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.0-1mamba
|
||||
- update to 2.2.0
|
||||
|
||||
* Sun Aug 23 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.8-4mamba
|
||||
- rebuilt by autoport with build requirements: libiw-devel>=30.pre9-1mamba
|
||||
|
||||
* Fri Oct 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.8-3mamba
|
||||
- rebuilt against libopenssl 0.9.8
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user