automatic update by autodist [release 0.999-1mamba;Tue Aug 06 2013]
This commit is contained in:
parent
b9bd00866c
commit
b3931f7df5
@ -1,2 +1,5 @@
|
||||
# xsane
|
||||
|
||||
XSane is an X based interface for the SANE (Scanner Access Now Easy) library, which provides access to scanners, digital cameras, and other capture devices. XSane is written in GTK+ and provides control for performing the scan and then manipulating the captured image.
|
||||
This package also includes THE GIMP plug-in
|
||||
|
||||
|
20
xsane-0.999-libpng-1.5.patch
Normal file
20
xsane-0.999-libpng-1.5.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- xsane-0.998/src/xsane-save.c.org 2012-02-10 12:31:29.768614682 +0100
|
||||
+++ xsane-0.998/src/xsane-save.c 2012-02-10 12:31:31.511986798 +0100
|
||||
@@ -4910,7 +4910,7 @@
|
||||
return -1; /* error */
|
||||
}
|
||||
|
||||
- if (setjmp(png_ptr->jmpbuf))
|
||||
+ if (setjmp(png_jmpbuf(png_ptr)))
|
||||
{
|
||||
snprintf(buf, sizeof(buf), "%s %s", ERR_DURING_SAVE, ERR_LIBPNG);
|
||||
xsane_back_gtk_error(buf, TRUE);
|
||||
@@ -5100,7 +5100,7 @@
|
||||
return -1; /* error */
|
||||
}
|
||||
|
||||
- if (setjmp(png_ptr->jmpbuf))
|
||||
+ if (setjmp(png_jmpbuf(png_ptr)))
|
||||
{
|
||||
snprintf(buf, sizeof(buf), "%s %s", ERR_DURING_SAVE, ERR_LIBPNG);
|
||||
xsane_back_gtk_error(buf, TRUE);
|
125
xsane.spec
Normal file
125
xsane.spec
Normal file
@ -0,0 +1,125 @@
|
||||
Summary: An X Window System front-end for the SANE scanner interface.
|
||||
Name: xsane
|
||||
Version: 0.999
|
||||
Release: 1mamba
|
||||
Group: Graphical Desktop/Applications/Graphics
|
||||
Distribution: openmamba
|
||||
Vendor: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.xsane.org/
|
||||
Source0: http://www.xsane.org/download/%{name}-%{version}.tar.gz
|
||||
Patch0: xsane-0.999-libpng-1.5.patch
|
||||
License: GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libavahi-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libexif-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgphoto-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: liblcms-devel
|
||||
BuildRequires: libnetsnmp-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libsane-backends-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: libusb0-devel
|
||||
BuildRequires: libv4l-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
|
||||
%description
|
||||
XSane is an X based interface for the SANE (Scanner Access Now Easy) library, which provides access to scanners, digital cameras, and other capture devices. XSane is written in GTK+ and provides control for performing the scan and then manipulating the captured image.
|
||||
This package also includes THE GIMP plug-in
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
|
||||
uname -a | grep -qi SMP && make -j 2 || make
|
||||
|
||||
install -D -m0755 src/xsane %{buildroot}%{_libdir}/gimp/2.0/plug-ins/xsane
|
||||
|
||||
make clean
|
||||
CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix} --disable-gimp
|
||||
uname -a | grep -qi SMP && make -j 2 || make
|
||||
|
||||
%install
|
||||
mkdir -p %{buildroot}%{_prefix}
|
||||
make prefix=%{buildroot}%{_prefix} install
|
||||
strip %{buildroot}%{_prefix}/bin/* || :
|
||||
|
||||
install -D -m644 src/xsane-16x16.png %{buildroot}%{_datadir}/pixmaps/xsane.png
|
||||
|
||||
# Create the system menu entry
|
||||
mkdir -p %{buildroot}%{_datadir}/applications/
|
||||
cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
|
||||
[Desktop Entry]
|
||||
Name=XSane
|
||||
Comment=Sane FrontEnd
|
||||
GenericName=Scanner Utility
|
||||
GenericName[it]=Programma per lo Scanner
|
||||
Exec=xsane
|
||||
Icon=xsane
|
||||
Terminal=0
|
||||
Type=Application
|
||||
Categories=Graphics
|
||||
EOF
|
||||
|
||||
chmod 755 %{buildroot}%{_datadir}/applications/%{name}.desktop
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/xsane
|
||||
%{_datadir}/applications/xsane.desktop
|
||||
%{_datadir}/pixmaps/xsane.png
|
||||
%{_datadir}/pixmaps/xsane.xpm
|
||||
%dir %{_datadir}/sane/xsane
|
||||
%{_datadir}/sane/xsane/*-logo.xpm
|
||||
%{_datadir}/sane/xsane/xsane-*.txt
|
||||
%{_datadir}/sane/xsane/xsane-*.pnm
|
||||
%{_datadir}/sane/xsane/xsane-*.rc
|
||||
%dir %{_datadir}/sane/xsane/doc
|
||||
%{_datadir}/sane/xsane/doc/*
|
||||
%{_mandir}/man1/xsane.1*
|
||||
#%doc xsane*
|
||||
|
||||
%changelog
|
||||
* Tue Aug 06 2013 Automatic Build System <autodist@mambasoft.it> 0.999-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Nov 02 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.998-2mamba
|
||||
- rebuild with latest libsane-backends to remove dependency on libresmgr
|
||||
|
||||
* Fri Feb 11 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.998-1mamba
|
||||
- update to 0.998
|
||||
|
||||
* Tue Dec 02 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.996-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Apr 28 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.995-1mamba
|
||||
- update to 0.995
|
||||
|
||||
* Sat Aug 18 2007 Tiziana Ferro <tiziana.ferro@email.it> 0.994-1mamba
|
||||
- update to 0.994
|
||||
|
||||
* Thu Jun 09 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.97-2qilnx
|
||||
- rebuild and moved from devel-contrib repository to devel repository
|
||||
|
||||
* Wed Jun 8 2005 Matteo Bernasconi <voyagernm@virgilio.it> 0.97-1qilnx
|
||||
- first build
|
Loading…
Reference in New Issue
Block a user