rebuilt with many configure enable options
configuration changes for openmamba [release 0.9.15-2mamba;Thu Feb 11 2021]
This commit is contained in:
parent
a3de7173b6
commit
13b9f0ff3b
@ -1,2 +1,5 @@
|
||||
# xrdp
|
||||
|
||||
xrdp provides a graphical login to remote machines using Microsoft Remote Desktop Protocol (RDP). xrdp accepts connections from a variety of RDP clients: FreeRDP, rdesktop, NeutrinoRDP and Microsoft Remote Desktop Client (for Windows, Mac OS, iOS and Android).
|
||||
RDP transport is encrypted using TLS by default.
|
||||
|
||||
|
28
xrdp-0.9.15-startwm-openmamba.patch
Normal file
28
xrdp-0.9.15-startwm-openmamba.patch
Normal file
@ -0,0 +1,28 @@
|
||||
--- xrdp-0.9.15/sesman/startwm.sh.orig 2021-02-11 21:26:27.821827145 +0100
|
||||
+++ xrdp-0.9.15/sesman/startwm.sh 2021-02-11 21:26:32.541910223 +0100
|
||||
@@ -58,11 +58,23 @@
|
||||
#start the window manager
|
||||
wm_start()
|
||||
{
|
||||
- if [ -r /etc/default/locale ]; then
|
||||
- . /etc/default/locale
|
||||
+ if [ -r /etc/locale.conf ]; then
|
||||
+ . /etc/locale.conf
|
||||
export LANG LANGUAGE
|
||||
fi
|
||||
|
||||
+ # openmamba user
|
||||
+ if [ -r ~/.xinitrc ]; then
|
||||
+ . ~/.xinitrc
|
||||
+ exit 0
|
||||
+ fi
|
||||
+
|
||||
+ # openmamba xinit
|
||||
+ if [ -r /etc/X11/xinit/xinitrc ]; then
|
||||
+ . /etc/X11/xinit/xinitrc
|
||||
+ exit 0
|
||||
+ fi
|
||||
+
|
||||
# debian
|
||||
if [ -r /etc/X11/Xsession ]; then
|
||||
pre_start
|
200
xrdp.spec
Normal file
200
xrdp.spec
Normal file
@ -0,0 +1,200 @@
|
||||
Name: xrdp
|
||||
Version: 0.9.15
|
||||
Release: 2mamba
|
||||
Summary: Provides a graphical login to remote machines using Microsoft Remote Desktop Protocol (RDP)
|
||||
Group: System/Servers
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://github.com/neutrinolabs/xrdp
|
||||
Source: https://github.com/neutrinolabs/xrdp.git/v%{version}/xrdp-%{version}.tar.bz2
|
||||
Patch0: xrdp-0.9.15-startwm-openmamba.patch
|
||||
License: Apache License 2.0
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libaudit-devel
|
||||
BuildRequires: libbsd-devel
|
||||
BuildRequires: libcap-ng-devel
|
||||
BuildRequires: libfuse-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: liblame-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libopus-devel
|
||||
BuildRequires: libpam-devel
|
||||
BuildRequires: libpixman-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libxcb-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: xorgxrdp
|
||||
Requires: xinit >= 1.4.1-2mamba
|
||||
Requires: xorg-server
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
xrdp provides a graphical login to remote machines using Microsoft Remote Desktop Protocol (RDP). xrdp accepts connections from a variety of RDP clients: FreeRDP, rdesktop, NeutrinoRDP and Microsoft Remote Desktop Client (for Windows, Mac OS, iOS and Android).
|
||||
RDP transport is encrypted using TLS by default.
|
||||
|
||||
%package -n lib%{name}
|
||||
Group: System/Libraries
|
||||
Summary: Shared libraries for %{name}
|
||||
|
||||
%description -n lib%{name}
|
||||
This package contains shared libraries for %{name}.
|
||||
|
||||
%package -n lib%{name}-devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: pkg-config
|
||||
|
||||
%description -n lib%{name}-devel
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
./bootstrap
|
||||
|
||||
sed -i "s|param=Xorg|param=%{_libexecdir}/Xorg|" sesman/sesman.ini.in
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-jpeg \
|
||||
--enable-tjpeg \
|
||||
--enable-fuse \
|
||||
--enable-opus \
|
||||
--enable-rfxcodec \
|
||||
--enable-mp3lame \
|
||||
--enable-pixman \
|
||||
--enable-painter \
|
||||
--enable-vsock
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
rm -f %{buildroot}%{_sysconfdir}/xrdp/rsakeys.ini
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
%systemd_post xrdp
|
||||
%systemd_post xrdp-sesman
|
||||
if [ $1 -ge 1 ]; then
|
||||
[ -e %{sysconfdir}/xrdp/rsakeys.ini ] || xrdp-keygen xrdp %{_sysconfdir}/xrdp/rsakeys.ini
|
||||
fi
|
||||
:
|
||||
|
||||
%preun
|
||||
%systemd_preun xrdp
|
||||
%systemd_preun xrdp-sesman
|
||||
:
|
||||
|
||||
%postun
|
||||
%systemd_postun xrdp
|
||||
%systemd_postun xrdp-sesman
|
||||
:
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/pam.d/xrdp-sesman
|
||||
%{_sysconfdir}/xrdp/cert.pem
|
||||
%{_sysconfdir}/xrdp/key.pem
|
||||
%{_sysconfdir}/xrdp/km-*.ini
|
||||
%{_sysconfdir}/xrdp/pulse/default.pa
|
||||
%{_sysconfdir}/xrdp/reconnectwm.sh
|
||||
%config(noreplace) %{_sysconfdir}/xrdp/sesman.ini
|
||||
%{_sysconfdir}/xrdp/startwm.sh
|
||||
%config(noreplace) %{_sysconfdir}/xrdp/xrdp.ini
|
||||
%config(noreplace) %{_sysconfdir}/xrdp/xrdp_keyboard.ini
|
||||
%{_bindir}/xrdp-dis
|
||||
%{_bindir}/xrdp-genkeymap
|
||||
%{_bindir}/xrdp-keygen
|
||||
%{_bindir}/xrdp-sesadmin
|
||||
%{_bindir}/xrdp-sesrun
|
||||
%{_sbindir}/xrdp
|
||||
%{_sbindir}/xrdp-chansrv
|
||||
%{_sbindir}/xrdp-sesman
|
||||
%{_unitdir}/xrdp-sesman.service
|
||||
%{_unitdir}/xrdp.service
|
||||
%dir %{_datadir}/xrdp
|
||||
%{_datadir}/xrdp/*
|
||||
%{_mandir}/man1/xrdp-dis.1*
|
||||
%{_mandir}/man5/sesman.ini.5*
|
||||
%{_mandir}/man5/xrdp.ini.5*
|
||||
%{_mandir}/man8/xrdp*.8*
|
||||
%doc COPYING
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libpainter.so.*
|
||||
%{_libdir}/librfxencode.so.*
|
||||
%dir %{_libdir}/xrdp
|
||||
%{_libdir}/xrdp/libcommon.so.*
|
||||
%{_libdir}/xrdp/libscp.so.*
|
||||
%{_libdir}/xrdp/libxrdp.so.*
|
||||
%{_libdir}/xrdp/libxrdpapi.so.*
|
||||
%{_libdir}/xrdp/libmc.a
|
||||
%{_libdir}/xrdp/libmc.la
|
||||
%{_libdir}/xrdp/libmc.so
|
||||
%{_libdir}/xrdp/libvnc.a
|
||||
%{_libdir}/xrdp/libvnc.la
|
||||
%{_libdir}/xrdp/libvnc.so
|
||||
%{_libdir}/xrdp/libxrdpapi.a
|
||||
%{_libdir}/xrdp/libxrdpapi.la
|
||||
%{_libdir}/xrdp/libxrdpapi.so
|
||||
%{_libdir}/xrdp/libxup.a
|
||||
%{_libdir}/xrdp/libxup.la
|
||||
%{_libdir}/xrdp/libxup.so
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/*.h
|
||||
%{_libdir}/libpainter.a
|
||||
%{_libdir}/libpainter.la
|
||||
%{_libdir}/libpainter.so
|
||||
%{_libdir}/librfxencode.a
|
||||
%{_libdir}/librfxencode.la
|
||||
%{_libdir}/librfxencode.so
|
||||
%{_libdir}/xrdp/libcommon.a
|
||||
%{_libdir}/xrdp/libcommon.la
|
||||
%{_libdir}/xrdp/libcommon.so
|
||||
%{_libdir}/xrdp/libscp.a
|
||||
%{_libdir}/xrdp/libscp.la
|
||||
%{_libdir}/xrdp/libscp.so
|
||||
%{_libdir}/xrdp/libxrdp.a
|
||||
%{_libdir}/xrdp/libxrdp.la
|
||||
%{_libdir}/xrdp/libxrdp.so
|
||||
%{_libdir}/pkgconfig/libpainter.pc
|
||||
%{_libdir}/pkgconfig/rfxcodec.pc
|
||||
%{_libdir}/pkgconfig/xrdp.pc
|
||||
%doc README.md
|
||||
|
||||
%changelog
|
||||
* Thu Feb 11 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.15-2mamba
|
||||
- rebuilt with many configure enable options
|
||||
- configuration changes for openmamba
|
||||
|
||||
* Thu Feb 11 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.15-1mamba
|
||||
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user