update to 4.4.5 [release 4.4.5-1mamba;Thu Jun 08 2023]
This commit is contained in:
parent
7e5e6f1ba9
commit
3c8588b69a
21
xpra-4.4.5-add_missing_fake_function.patch
Normal file
21
xpra-4.4.5-add_missing_fake_function.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
From a5bccfca2cae9b64528b140e90568d2fa899fd97 Mon Sep 17 00:00:00 2001
|
||||||
|
From: totaam <antoine@xpra.org>
|
||||||
|
Date: Wed, 24 May 2023 12:38:44 +0700
|
||||||
|
Subject: [PATCH] #3860 add missing fake function
|
||||||
|
|
||||||
|
---
|
||||||
|
xpra/client/gl/window_backend.py | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/xpra/client/gl/window_backend.py b/xpra/client/gl/window_backend.py
|
||||||
|
index 53b27a0516..d766ca925c 100755
|
||||||
|
--- a/xpra/client/gl/window_backend.py
|
||||||
|
+++ b/xpra/client/gl/window_backend.py
|
||||||
|
@@ -69,6 +69,7 @@ def noop(*_args):
|
||||||
|
self.server_readonly = False
|
||||||
|
self.server_pointer = False
|
||||||
|
self.update_focus = noop
|
||||||
|
+ self.has_focus = noop
|
||||||
|
self.handle_key_action = noop
|
||||||
|
self.window_ungrab = noop
|
||||||
|
self.idle_add = no_idle_add
|
53
xpra.spec
53
xpra.spec
@ -1,6 +1,6 @@
|
|||||||
Name: xpra
|
Name: xpra
|
||||||
Version: 4.4.2
|
Version: 4.4.5
|
||||||
Release: 2mamba
|
Release: 1mamba
|
||||||
Summary: A tool like screen for X allowing to direct X programs display to another X host
|
Summary: A tool like screen for X allowing to direct X programs display to another X host
|
||||||
Group: Graphical Desktop/Applications/Utilities
|
Group: Graphical Desktop/Applications/Utilities
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -9,6 +9,7 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|||||||
URL: https://xpra.org/
|
URL: https://xpra.org/
|
||||||
Source: http://xpra.org/src/xpra-%{version}.tar.xz
|
Source: http://xpra.org/src/xpra-%{version}.tar.xz
|
||||||
Patch0: xpra-4.4.2-upstream_clamp_clock_values_to_unsigned_long.patch
|
Patch0: xpra-4.4.2-upstream_clamp_clock_values_to_unsigned_long.patch
|
||||||
|
Patch1: xpra-4.4.5-add_missing_fake_function.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -22,7 +23,10 @@ BuildRequires: libXrandr-devel
|
|||||||
BuildRequires: libXres-devel
|
BuildRequires: libXres-devel
|
||||||
BuildRequires: libXtst-devel
|
BuildRequires: libXtst-devel
|
||||||
BuildRequires: libat-spi2-core-devel
|
BuildRequires: libat-spi2-core-devel
|
||||||
|
BuildRequires: libavcodec-ffmpeg-devel
|
||||||
|
BuildRequires: libavformat-ffmpeg-devel
|
||||||
BuildRequires: libavif-devel
|
BuildRequires: libavif-devel
|
||||||
|
BuildRequires: libavutil-ffmpeg-devel
|
||||||
BuildRequires: libbrotli-devel
|
BuildRequires: libbrotli-devel
|
||||||
BuildRequires: libcairo-devel
|
BuildRequires: libcairo-devel
|
||||||
BuildRequires: libdrm-devel
|
BuildRequires: libdrm-devel
|
||||||
@ -35,40 +39,58 @@ BuildRequires: liblz4-devel
|
|||||||
BuildRequires: libpam-devel
|
BuildRequires: libpam-devel
|
||||||
BuildRequires: libpango-devel
|
BuildRequires: libpango-devel
|
||||||
BuildRequires: libprocps-devel
|
BuildRequires: libprocps-devel
|
||||||
BuildRequires: libpython3-devel
|
BuildRequires: libpython310-devel
|
||||||
BuildRequires: libqrencode-devel
|
BuildRequires: libqrencode-devel
|
||||||
|
BuildRequires: libswscale-ffmpeg-devel
|
||||||
BuildRequires: libsystemd-devel
|
BuildRequires: libsystemd-devel
|
||||||
BuildRequires: libvpx6-devel
|
BuildRequires: libvpx-devel
|
||||||
BuildRequires: libwebp-devel
|
BuildRequires: libwebp-devel
|
||||||
BuildRequires: libx264-devel
|
BuildRequires: libx264-devel
|
||||||
BuildRequires: libxkbfile-devel
|
BuildRequires: libxkbfile-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: python3
|
Requires: xf86-video-dummy
|
||||||
|
Requires: xorg-server
|
||||||
|
Requires: pygobject-py310
|
||||||
|
Requires: python-cryptography-py310
|
||||||
|
Requires: python-cups-py310
|
||||||
|
Requires: python-Pillow-py310
|
||||||
|
Requires: python-netifaces-py310
|
||||||
|
Requires: python-numpy-py310
|
||||||
|
Requires: python-paramiko-py310
|
||||||
|
Requires: python-opengl-py310
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Xpra is 'screen for X' -- it allows you to run X programs, usually on a remote host, direct their display to your local machine, and then to disconnect from these programs and reconnect from the same or another machine, without losing any state.
|
Xpra is 'screen for X' -- it allows you to run X programs, usually on a remote host, direct their display to your local machine, and then to disconnect from these programs and reconnect from the same or another machine, without losing any state.
|
||||||
|
|
||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
|
# Don't clean build at the end
|
||||||
|
%global __spec_rmbuild_cmd /bin/true
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .upstream_clamp_clock_values_to_unsigned_long
|
#-D -T
|
||||||
|
#:<< _EOF
|
||||||
|
#%patch 0 -p1 -b .upstream_clamp_clock_values_to_unsigned_long
|
||||||
|
%patch 1 -p1 -b .add_missing_fake_function
|
||||||
|
|
||||||
sed -i "s|systemd_dir = .*|systemd_dir = \"%{_unitdir}\"|" setup.py
|
sed -i "s|systemd_dir = .*|systemd_dir = \"%{_unitdir}\"|" setup.py
|
||||||
|
|
||||||
%build
|
%build
|
||||||
CFLAGS="%{optflags}" %{__python3} setup.py build
|
CFLAGS="%{optflags}" %{__python310} setup.py build
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%{__python3} setup.py install \
|
%{__python310} setup.py install \
|
||||||
-O1 --skip-build \
|
-O1 --skip-build \
|
||||||
--root="%{buildroot}" \
|
--root="%{buildroot}" \
|
||||||
--install-headers=%{python3_inc} \
|
--install-headers=%{python310_inc} \
|
||||||
--install-lib=%{python3_sitearch} \
|
--install-lib=%{python310_sitearch} \
|
||||||
--without-docs \
|
--without-docs \
|
||||||
--record=%{name}.filelist
|
--record=%{name}.filelist
|
||||||
|
|
||||||
|
sed -i "s|%{buildroot}||" %{buildroot}%{_sysconfdir}/xpra/conf.d/55_server_x11.conf
|
||||||
|
|
||||||
sed -i "s,.*/man/.*,&.gz," %{name}.filelist
|
sed -i "s,.*/man/.*,&.gz," %{name}.filelist
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -76,6 +98,9 @@ sed -i "s,.*/man/.*,&.gz," %{name}.filelist
|
|||||||
|
|
||||||
%post
|
%post
|
||||||
%systemd_post xpra.socket
|
%systemd_post xpra.socket
|
||||||
|
if [ $1 -ge 1 ]; then
|
||||||
|
echo "allowed_users = anybody" > %{_sysconfdir}/X11/Xwrapper.config
|
||||||
|
fi
|
||||||
:
|
:
|
||||||
|
|
||||||
%preun
|
%preun
|
||||||
@ -93,7 +118,7 @@ sed -i "s,.*/man/.*,&.gz," %{name}.filelist
|
|||||||
%config(noreplace) %{_sysconfdir}/xpra/xorg-uinput.conf
|
%config(noreplace) %{_sysconfdir}/xpra/xorg-uinput.conf
|
||||||
%config(noreplace) %{_sysconfdir}/xpra/xorg.conf
|
%config(noreplace) %{_sysconfdir}/xpra/xorg.conf
|
||||||
%dir %{_sysconfdir}/xpra/conf.d
|
%dir %{_sysconfdir}/xpra/conf.d
|
||||||
%{_sysconfdir}/xpra/conf.d/*.conf
|
%config(noreplace) %{_sysconfdir}/xpra/conf.d/*.conf
|
||||||
%dir %{_sysconfdir}/xpra/content-categories
|
%dir %{_sysconfdir}/xpra/content-categories
|
||||||
%{_sysconfdir}/xpra/content-categories/10_default.conf
|
%{_sysconfdir}/xpra/content-categories/10_default.conf
|
||||||
%dir %{_sysconfdir}/xpra/content-parent
|
%dir %{_sysconfdir}/xpra/content-parent
|
||||||
@ -114,6 +139,12 @@ sed -i "s,.*/man/.*,&.gz," %{name}.filelist
|
|||||||
%doc COPYING
|
%doc COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 08 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4.5-1mamba
|
||||||
|
- update to 4.4.5
|
||||||
|
|
||||||
|
* Tue Apr 11 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4.4-1mamba
|
||||||
|
- update to 4.4.4
|
||||||
|
|
||||||
* Mon Nov 21 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4.2-2mamba
|
* Mon Nov 21 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4.2-2mamba
|
||||||
- added upstream patch to fix build on 32bit platforms
|
- added upstream patch to fix build on 32bit platforms
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user