update to 1.3.1 [release 1.3.1-1mamba;Fri May 21 2021]
This commit is contained in:
parent
c13dff36b1
commit
adb1520811
157
xplanet-1.3.1-gcc-11.1.0.patch
Normal file
157
xplanet-1.3.1-gcc-11.1.0.patch
Normal file
@ -0,0 +1,157 @@
|
|||||||
|
Index: src/libannotate/addArcs.cpp
|
||||||
|
===================================================================
|
||||||
|
diff --git a/src/libannotate/addArcs.cpp b/src/libannotate/addArcs.cpp
|
||||||
|
--- a/src/libannotate/addArcs.cpp (revision 206)
|
||||||
|
+++ b/src/libannotate/addArcs.cpp (revision 207)
|
||||||
|
@@ -258,7 +258,7 @@
|
||||||
|
{
|
||||||
|
ifstream inFile(arcFile.c_str());
|
||||||
|
char *line = new char[MAX_LINE_LENGTH];
|
||||||
|
- while (inFile.getline (line, MAX_LINE_LENGTH, '\n') != NULL)
|
||||||
|
+ while (inFile.getline (line, MAX_LINE_LENGTH, '\n'))
|
||||||
|
readArcFile(line, planet, view, projection,
|
||||||
|
planetProperties, annotationMap);
|
||||||
|
|
||||||
|
@@ -292,7 +292,7 @@
|
||||||
|
{
|
||||||
|
ifstream inFile(arcFile.c_str());
|
||||||
|
char *line = new char[256];
|
||||||
|
- while (inFile.getline (line, 256, '\n') != NULL)
|
||||||
|
+ while (inFile.getline (line, 256, '\n'))
|
||||||
|
readArcFile(line, NULL, view, NULL, NULL, annotationMap);
|
||||||
|
|
||||||
|
inFile.close();
|
||||||
|
Index: src/libannotate/addMarkers.cpp
|
||||||
|
===================================================================
|
||||||
|
diff --git a/src/libannotate/addMarkers.cpp b/src/libannotate/addMarkers.cpp
|
||||||
|
--- a/src/libannotate/addMarkers.cpp (revision 206)
|
||||||
|
+++ b/src/libannotate/addMarkers.cpp (revision 207)
|
||||||
|
@@ -429,7 +429,7 @@
|
||||||
|
{
|
||||||
|
ifstream inFile(markerFile.c_str());
|
||||||
|
char *line = new char[MAX_LINE_LENGTH];
|
||||||
|
- while (inFile.getline (line, MAX_LINE_LENGTH, '\n') != NULL)
|
||||||
|
+ while (inFile.getline (line, MAX_LINE_LENGTH, '\n'))
|
||||||
|
{
|
||||||
|
unsigned char color[3];
|
||||||
|
memcpy(color, planetProperties->MarkerColor(), 3);
|
||||||
|
@@ -475,7 +475,7 @@
|
||||||
|
{
|
||||||
|
ifstream inFile(markerFile.c_str());
|
||||||
|
char *line = new char[MAX_LINE_LENGTH];
|
||||||
|
- while (inFile.getline (line, MAX_LINE_LENGTH, '\n') != NULL)
|
||||||
|
+ while (inFile.getline (line, MAX_LINE_LENGTH, '\n'))
|
||||||
|
{
|
||||||
|
unsigned char color[3];
|
||||||
|
memcpy(color, options->Color(), 3);
|
||||||
|
Index: src/libannotate/addSatellites.cpp
|
||||||
|
===================================================================
|
||||||
|
diff --git a/src/libannotate/addSatellites.cpp b/src/libannotate/addSatellites.cpp
|
||||||
|
--- a/src/libannotate/addSatellites.cpp (revision 206)
|
||||||
|
+++ b/src/libannotate/addSatellites.cpp (revision 207)
|
||||||
|
@@ -488,10 +488,10 @@
|
||||||
|
{
|
||||||
|
ifstream inFile(tleFile.c_str());
|
||||||
|
char lines[3][80];
|
||||||
|
- while (inFile.getline(lines[0], 80) != NULL)
|
||||||
|
+ while (inFile.getline(lines[0], 80))
|
||||||
|
{
|
||||||
|
- if ((inFile.getline(lines[1], 80) == NULL)
|
||||||
|
- || (inFile.getline(lines[2], 80) == NULL))
|
||||||
|
+ if ((!inFile.getline(lines[1], 80))
|
||||||
|
+ || (!inFile.getline(lines[2], 80)))
|
||||||
|
{
|
||||||
|
ostringstream errStr;
|
||||||
|
errStr << "Malformed TLE file (" << tleFile << ")?\n";
|
||||||
|
@@ -542,7 +542,7 @@
|
||||||
|
{
|
||||||
|
ifstream inFile(satFile.c_str());
|
||||||
|
char *line = new char[MAX_LINE_LENGTH];
|
||||||
|
- while (inFile.getline (line, MAX_LINE_LENGTH, '\n') != NULL)
|
||||||
|
+ while (inFile.getline (line, MAX_LINE_LENGTH, '\n'))
|
||||||
|
readSatelliteFile(line, planet, view, projection,
|
||||||
|
planetProperties, annotationMap);
|
||||||
|
|
||||||
|
Index: src/libannotate/addSpiceObjects.cpp
|
||||||
|
===================================================================
|
||||||
|
diff --git a/src/libannotate/addSpiceObjects.cpp b/src/libannotate/addSpiceObjects.cpp
|
||||||
|
--- a/src/libannotate/addSpiceObjects.cpp (revision 206)
|
||||||
|
+++ b/src/libannotate/addSpiceObjects.cpp (revision 207)
|
||||||
|
@@ -524,7 +524,7 @@
|
||||||
|
{
|
||||||
|
ifstream inFile(kernelFile.c_str());
|
||||||
|
char *line = new char[MAX_LINE_LENGTH];
|
||||||
|
- while (inFile.getline(line, MAX_LINE_LENGTH, '\n') != NULL)
|
||||||
|
+ while (inFile.getline(line, MAX_LINE_LENGTH, '\n'))
|
||||||
|
{
|
||||||
|
int ii = 0;
|
||||||
|
while (isDelimiter(line[ii]))
|
||||||
|
@@ -576,7 +576,7 @@
|
||||||
|
{
|
||||||
|
ifstream inFile(spiceFile.c_str());
|
||||||
|
char *line = new char[MAX_LINE_LENGTH];
|
||||||
|
- while (inFile.getline(line, MAX_LINE_LENGTH, '\n') != NULL)
|
||||||
|
+ while (inFile.getline(line, MAX_LINE_LENGTH, '\n'))
|
||||||
|
readSpiceFile(line, planetsFromSunMap, view, projection,
|
||||||
|
annotationMap);
|
||||||
|
inFile.close();
|
||||||
|
Index: src/libmultiple/RayleighScattering.cpp
|
||||||
|
===================================================================
|
||||||
|
diff --git a/src/libmultiple/RayleighScattering.cpp b/src/libmultiple/RayleighScattering.cpp
|
||||||
|
--- a/src/libmultiple/RayleighScattering.cpp (revision 206)
|
||||||
|
+++ b/src/libmultiple/RayleighScattering.cpp (revision 207)
|
||||||
|
@@ -369,7 +369,7 @@
|
||||||
|
|
||||||
|
diskTemplate_.clear();
|
||||||
|
limbTemplate_.clear();
|
||||||
|
- while (inFile.getline(line, MAX_LINE_LENGTH, '\n') != NULL)
|
||||||
|
+ while (inFile.getline(line, MAX_LINE_LENGTH, '\n'))
|
||||||
|
{
|
||||||
|
int i = 0;
|
||||||
|
while (isDelimiter(line[i]))
|
||||||
|
@@ -439,7 +439,7 @@
|
||||||
|
values.clear();
|
||||||
|
|
||||||
|
char line[MAX_LINE_LENGTH];
|
||||||
|
- while (inFile.getline(line, MAX_LINE_LENGTH, '\n') != NULL)
|
||||||
|
+ while (inFile.getline(line, MAX_LINE_LENGTH, '\n'))
|
||||||
|
{
|
||||||
|
int i = 0;
|
||||||
|
while (isDelimiter(line[i]))
|
||||||
|
@@ -470,7 +470,7 @@
|
||||||
|
double &value)
|
||||||
|
{
|
||||||
|
char line[MAX_LINE_LENGTH];
|
||||||
|
- while (inFile.getline(line, MAX_LINE_LENGTH, '\n') != NULL)
|
||||||
|
+ while (inFile.getline(line, MAX_LINE_LENGTH, '\n'))
|
||||||
|
{
|
||||||
|
int i = 0;
|
||||||
|
while (isDelimiter(line[i]))
|
||||||
|
Index: src/libmultiple/drawStars.cpp
|
||||||
|
===================================================================
|
||||||
|
diff --git a/src/libmultiple/drawStars.cpp b/src/libmultiple/drawStars.cpp
|
||||||
|
--- a/src/libmultiple/drawStars.cpp (revision 206)
|
||||||
|
+++ b/src/libmultiple/drawStars.cpp (revision 207)
|
||||||
|
@@ -41,7 +41,7 @@
|
||||||
|
ifstream inFile(starMap.c_str());
|
||||||
|
|
||||||
|
char line[MAX_LINE_LENGTH];
|
||||||
|
- while (inFile.getline(line, MAX_LINE_LENGTH, '\n') != NULL)
|
||||||
|
+ while (inFile.getline(line, MAX_LINE_LENGTH, '\n'))
|
||||||
|
{
|
||||||
|
if (line[0] == '#') continue;
|
||||||
|
|
||||||
|
Index: src/readConfig.cpp
|
||||||
|
===================================================================
|
||||||
|
diff --git a/src/readConfig.cpp b/src/readConfig.cpp
|
||||||
|
--- a/src/readConfig.cpp (revision 206)
|
||||||
|
+++ b/src/readConfig.cpp (revision 207)
|
||||||
|
@@ -550,7 +550,7 @@
|
||||||
|
|
||||||
|
ifstream inFile(configFile.c_str());
|
||||||
|
char *line = new char[256];
|
||||||
|
- while (inFile.getline(line, 256, '\n') != NULL)
|
||||||
|
+ while (inFile.getline(line, 256, '\n'))
|
||||||
|
readConfig(line, planetProperties);
|
||||||
|
|
||||||
|
// This condition will only be true if [default] is the only
|
30
xplanet-1.3.1-libgif-5.2.1.patch
Normal file
30
xplanet-1.3.1-libgif-5.2.1.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
diff -wbBur xplanet-1.3.1/src/libimage/gif.c xplanet-1.3.1.q/src/libimage/gif.c
|
||||||
|
--- xplanet-1.3.1/src/libimage/gif.c 2013-02-16 23:37:47.000000000 +0400
|
||||||
|
+++ xplanet-1.3.1.q/src/libimage/gif.c 2016-03-14 17:41:14.244144734 +0300
|
||||||
|
@@ -179,7 +179,7 @@
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
- if (DGifCloseFile(GifFile) == GIF_ERROR) {
|
||||||
|
+ if (DGifCloseFile(GifFile, NULL) == GIF_ERROR) {
|
||||||
|
return(0);
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -493,7 +493,7 @@
|
||||||
|
static void QuitGifError(GifFileType *GifFile)
|
||||||
|
{
|
||||||
|
fprintf(stderr, "Error writing GIF file\n");
|
||||||
|
- if (GifFile != NULL) EGifCloseFile(GifFile);
|
||||||
|
+ if (GifFile != NULL) EGifCloseFile(GifFile, NULL);
|
||||||
|
}
|
||||||
|
|
||||||
|
int
|
||||||
|
@@ -589,7 +589,7 @@
|
||||||
|
Ptr += width;
|
||||||
|
}
|
||||||
|
|
||||||
|
- if (EGifCloseFile(GifFile) == GIF_ERROR)
|
||||||
|
+ if (EGifCloseFile(GifFile, NULL) == GIF_ERROR)
|
||||||
|
|
||||||
|
{
|
||||||
|
QuitGifError(GifFile);
|
31
xplanet.spec
31
xplanet.spec
@ -1,43 +1,47 @@
|
|||||||
Name: xplanet
|
Name: xplanet
|
||||||
Version: 1.3.0
|
Version: 1.3.1
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Render a planetary image into an X window
|
Summary: Render a planetary image into an X window
|
||||||
Group: Graphical Desktop/Applications/Scientific
|
Group: Graphical Desktop/Applications/Scientific
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://xplanet.sourceforge.net/
|
URL: http://xplanet.sourceforge.net/
|
||||||
Source: http://prdownloads.sourceforge.net/xplanet/xplanet-%{version}.tar.gz
|
Source: https://downloads.sourceforge.net/project/xplanet/xplanet/%{version}/xplanet-%{version}.tar.gz
|
||||||
Patch: %{name}-1.2.1-g++44.patch
|
Patch0: xplanet-1.2.1-g++44.patch
|
||||||
|
Patch1: xplanet-1.3.1-libgif-5.2.1.patch
|
||||||
|
Patch2: xplanet-1.3.1-gcc-11.1.0.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXScrnSaver-devel
|
||||||
|
BuildRequires: libXext-devel
|
||||||
BuildRequires: libfontconfig-devel
|
BuildRequires: libfontconfig-devel
|
||||||
BuildRequires: libfreetype-devel
|
BuildRequires: libfreetype-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libgif-devel
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libharfbuzz-devel
|
||||||
BuildRequires: libjpeg-devel
|
BuildRequires: libjpeg-devel
|
||||||
BuildRequires: libpango-devel
|
BuildRequires: libpango-devel
|
||||||
BuildRequires: libpng-devel
|
BuildRequires: libpng-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libtiff-devel
|
BuildRequires: libtiff-devel
|
||||||
BuildRequires: libungif-devel
|
|
||||||
BuildRequires: libX11-devel
|
|
||||||
BuildRequires: libXext-devel
|
|
||||||
BuildRequires: libXScrnSaver-devel
|
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: perl-devel
|
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Xplanet was inspired by Xearth, which renders an image of the earth into the X root window.
|
Xplanet was inspired by Xearth, which renders an image of the earth into the X root window.
|
||||||
All of the major planets and most satellites can be drawn, similar to the Solar System Simulator.
|
All of the major planets and most satellites can be drawn, similar to the Solar System Simulator.
|
||||||
A number of different map projections are also supported, including azimuthal, Lambert, Mercator, Mollweide, orthographic, and rectangular.
|
A number of different map projections are also supported, including azimuthal, Lambert, Mercator, Mollweide, orthographic, and rectangular.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -56,9 +60,12 @@ A number of different map projections are also supported, including azimuthal, L
|
|||||||
%dir %{_datadir}/xplanet
|
%dir %{_datadir}/xplanet
|
||||||
%{_datadir}/xplanet/*
|
%{_datadir}/xplanet/*
|
||||||
%{_mandir}/man1/xplanet.*
|
%{_mandir}/man1/xplanet.*
|
||||||
%doc AUTHORS COPYING ChangeLog NEWS README TODO
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 21 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.1-1mamba
|
||||||
|
- update to 1.3.1
|
||||||
|
|
||||||
* Tue Dec 18 2012 Automatic Build System <autodist@mambasoft.it> 1.3.0-1mamba
|
* Tue Dec 18 2012 Automatic Build System <autodist@mambasoft.it> 1.3.0-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user