arm: rebuilt to fix 'symbol lookup error: X: undefined symbol: __aeabi_ui2d' [release 1.12.4-5mamba;Sat Jul 27 2013]
This commit is contained in:
parent
d43f808918
commit
a7fefdbd61
@ -1,2 +1,7 @@
|
||||
# xorg-server
|
||||
|
||||
The X Window System provides the base technology for developing graphical user interfaces.
|
||||
Simply stated, X draws the elements of the GUI on the user's screen and builds methods for sending user interactions back to the application.
|
||||
X also supports remote application deployment--running an application on another computer while viewing the input/output on your machine.
|
||||
X is a powerful environment which supports many different applications, such as games, programming tools, graphics programs, text editors, etc.
|
||||
|
||||
|
1
XFree86-skel-.xinitrc
Normal file
1
XFree86-skel-.xinitrc
Normal file
@ -0,0 +1 @@
|
||||
startkde
|
25
xorg-server-1.12.1-Xorg_configure.patch
Normal file
25
xorg-server-1.12.1-Xorg_configure.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff -Nru xorg-server-1.12.1.orig/hw/xfree86/common/xf86Config.c xorg-server-1.12.1/hw/xfree86/common/xf86Config.c
|
||||
--- xorg-server-1.12.1.orig/hw/xfree86/common/xf86Config.c 2012-03-30 04:57:26.000000000 +0200
|
||||
+++ xorg-server-1.12.1/hw/xfree86/common/xf86Config.c 2012-04-24 12:24:57.966283561 +0200
|
||||
@@ -514,7 +514,7 @@
|
||||
static void
|
||||
fixup_video_driver_list(char **drivers)
|
||||
{
|
||||
- static const char *fallback[4] = { "vesa", "fbdev", "wsfb", NULL };
|
||||
+ static const char *fallback[6] = { "fglrx", "fbdev", "vesa", "wsfb", "nv", NULL };
|
||||
char **end, **drv;
|
||||
char *x;
|
||||
int i;
|
||||
@@ -528,9 +528,11 @@
|
||||
* swap it with the last available non-fallback driver.
|
||||
*/
|
||||
for (i = 0; fallback[i]; i++) {
|
||||
- for (drv = drivers; drv != end; drv++) {
|
||||
+ for (drv = drivers; drv <= end; drv++) {
|
||||
if (strstr(*drv, fallback[i])) {
|
||||
x = *drv;
|
||||
+ /* disable the faulty probe of fglrx driver */
|
||||
+ if (i == 0) *end = NULL;
|
||||
*drv = *end;
|
||||
*end = x;
|
||||
end--;
|
12
xorg-server-1.3.0.0-hsync_higher_default.patch
Normal file
12
xorg-server-1.3.0.0-hsync_higher_default.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru xorg-server-1.3.0.0.orig/hw/xfree86/common/xf86Mode.c xorg-server-1.3.0.0/hw/xfree86/common/xf86Mode.c
|
||||
--- xorg-server-1.3.0.0.orig/hw/xfree86/common/xf86Mode.c 2006-11-16 19:01:24.000000000 +0100
|
||||
+++ xorg-server-1.3.0.0/hw/xfree86/common/xf86Mode.c 2007-08-26 19:31:55.000000000 +0200
|
||||
@@ -1361,7 +1361,7 @@
|
||||
}
|
||||
} else {
|
||||
scrp->monitor->hsync[0].lo = 31.5;
|
||||
- scrp->monitor->hsync[0].hi = 37.9;
|
||||
+ scrp->monitor->hsync[0].hi = 49.9;
|
||||
scrp->monitor->nHsync = 1;
|
||||
}
|
||||
type = "default ";
|
140
xorg-server-1.6.4-fix_DGA_removal.patch
Normal file
140
xorg-server-1.6.4-fix_DGA_removal.patch
Normal file
@ -0,0 +1,140 @@
|
||||
diff --git a/hw/xfree86/common/xf86DGA.c b/hw/xfree86/common/xf86DGA.c
|
||||
index 42b7c58..804fd37 100644
|
||||
--- a/hw/xfree86/common/xf86DGA.c
|
||||
+++ b/hw/xfree86/common/xf86DGA.c
|
||||
@@ -120,8 +120,22 @@ DGAInit(
|
||||
|
||||
DGAScreenKey = &DGAScreenKeyIndex;
|
||||
|
||||
- if(!(pScreenPriv = (DGAScreenPtr)xalloc(sizeof(DGAScreenRec))))
|
||||
- return FALSE;
|
||||
+ pScreenPriv = DGA_GET_SCREEN_PRIV(pScreen);
|
||||
+
|
||||
+ if (!pScreenPriv)
|
||||
+ {
|
||||
+ if(!(pScreenPriv = (DGAScreenPtr)xalloc(sizeof(DGAScreenRec))))
|
||||
+ return FALSE;
|
||||
+ dixSetPrivate(&pScreen->devPrivates, DGAScreenKey, pScreenPriv);
|
||||
+ pScreenPriv->CloseScreen = pScreen->CloseScreen;
|
||||
+ pScreen->CloseScreen = DGACloseScreen;
|
||||
+ pScreenPriv->DestroyColormap = pScreen->DestroyColormap;
|
||||
+ pScreen->DestroyColormap = DGADestroyColormap;
|
||||
+ pScreenPriv->InstallColormap = pScreen->InstallColormap;
|
||||
+ pScreen->InstallColormap = DGAInstallColormap;
|
||||
+ pScreenPriv->UninstallColormap = pScreen->UninstallColormap;
|
||||
+ pScreen->UninstallColormap = DGAUninstallColormap;
|
||||
+ }
|
||||
|
||||
pScreenPriv->pScrn = pScrn;
|
||||
pScreenPriv->numModes = num;
|
||||
@@ -146,17 +160,6 @@ DGAInit(
|
||||
modes[i].flags &= ~DGA_PIXMAP_AVAILABLE;
|
||||
#endif
|
||||
|
||||
- dixSetPrivate(&pScreen->devPrivates, DGAScreenKey, pScreenPriv);
|
||||
- pScreenPriv->CloseScreen = pScreen->CloseScreen;
|
||||
- pScreen->CloseScreen = DGACloseScreen;
|
||||
- pScreenPriv->DestroyColormap = pScreen->DestroyColormap;
|
||||
- pScreen->DestroyColormap = DGADestroyColormap;
|
||||
- pScreenPriv->InstallColormap = pScreen->InstallColormap;
|
||||
- pScreen->InstallColormap = DGAInstallColormap;
|
||||
- pScreenPriv->UninstallColormap = pScreen->UninstallColormap;
|
||||
- pScreen->UninstallColormap = DGAUninstallColormap;
|
||||
-
|
||||
-
|
||||
return TRUE;
|
||||
}
|
||||
|
||||
diff --git a/hw/xfree86/modes/xf86Crtc.c b/hw/xfree86/modes/xf86Crtc.c
|
||||
index c1e31e0..f274725 100644
|
||||
--- a/hw/xfree86/modes/xf86Crtc.c
|
||||
+++ b/hw/xfree86/modes/xf86Crtc.c
|
||||
@@ -806,7 +806,7 @@ xf86CrtcScreenInit (ScreenPtr screen)
|
||||
screen->CloseScreen = xf86CrtcCloseScreen;
|
||||
|
||||
#ifdef XFreeXDGA
|
||||
- xf86DiDGAInit(screen, 0);
|
||||
+ _xf86_di_dga_init_for_reals(screen);
|
||||
#endif
|
||||
#ifdef RANDR_13_INTERFACE
|
||||
return RANDR_INTERFACE_VERSION;
|
||||
@@ -1928,7 +1928,7 @@ xf86SetScrnInfoModes (ScrnInfoPtr scrn)
|
||||
scrn->currentMode = scrn->modes;
|
||||
#ifdef XFreeXDGA
|
||||
if (scrn->pScreen)
|
||||
- xf86DiDGAReInit(scrn->pScreen);
|
||||
+ _xf86_di_dga_reinit_for_reals(scrn->pScreen);
|
||||
#endif
|
||||
}
|
||||
|
||||
diff --git a/hw/xfree86/modes/xf86Crtc.h b/hw/xfree86/modes/xf86Crtc.h
|
||||
index 69afaa5..edf84d8 100644
|
||||
--- a/hw/xfree86/modes/xf86Crtc.h
|
||||
+++ b/hw/xfree86/modes/xf86Crtc.h
|
||||
@@ -833,6 +833,10 @@ xf86OutputGetEDID (xf86OutputPtr output, I2CBusPtr pDDCBus);
|
||||
extern _X_EXPORT Bool
|
||||
xf86DiDGAInit (ScreenPtr pScreen, unsigned long dga_address);
|
||||
|
||||
+/* this is the real function, used only internally */
|
||||
+_X_INTERNAL Bool
|
||||
+_xf86_di_dga_init_for_reals (ScreenPtr pScreen);
|
||||
+
|
||||
/**
|
||||
* Re-initialize dga for this screen (as when the set of modes changes)
|
||||
*/
|
||||
@@ -841,6 +845,10 @@ extern _X_EXPORT Bool
|
||||
xf86DiDGAReInit (ScreenPtr pScreen);
|
||||
#endif
|
||||
|
||||
+/* This is the real function, used only internally */
|
||||
+_X_INTERNAL Bool
|
||||
+_xf86_di_dga_reinit_for_reals (ScreenPtr pScreen);
|
||||
+
|
||||
/*
|
||||
* Set the subpixel order reported for the screen using
|
||||
* the information from the outputs
|
||||
diff --git a/hw/xfree86/modes/xf86DiDGA.c b/hw/xfree86/modes/xf86DiDGA.c
|
||||
index 0f7b834..3df3754 100644
|
||||
--- a/hw/xfree86/modes/xf86DiDGA.c
|
||||
+++ b/hw/xfree86/modes/xf86DiDGA.c
|
||||
@@ -175,6 +175,12 @@ static DGAFunctionRec xf86_dga_funcs = {
|
||||
Bool
|
||||
xf86DiDGAReInit (ScreenPtr pScreen)
|
||||
{
|
||||
+ return TRUE;
|
||||
+}
|
||||
+
|
||||
+_X_INTERNAL Bool
|
||||
+_xf86_di_dga_reinit_for_reals (ScreenPtr pScreen)
|
||||
+{
|
||||
ScrnInfoPtr scrn = xf86Screens[pScreen->myNum];
|
||||
xf86CrtcConfigPtr xf86_config = XF86_CRTC_CONFIG_PTR(scrn);
|
||||
|
||||
@@ -190,12 +196,15 @@ xf86DiDGAReInit (ScreenPtr pScreen)
|
||||
Bool
|
||||
xf86DiDGAInit (ScreenPtr pScreen, unsigned long dga_address)
|
||||
{
|
||||
+ return TRUE;
|
||||
+}
|
||||
+
|
||||
+_X_INTERNAL Bool
|
||||
+_xf86_di_dga_init_for_reals (ScreenPtr pScreen)
|
||||
+{
|
||||
ScrnInfoPtr scrn = xf86Screens[pScreen->myNum];
|
||||
xf86CrtcConfigPtr xf86_config = XF86_CRTC_CONFIG_PTR(scrn);
|
||||
|
||||
- if (DGAAvailable(pScreen->myNum))
|
||||
- return TRUE;
|
||||
-
|
||||
xf86_config->dga_flags = 0;
|
||||
xf86_config->dga_address = 0;
|
||||
xf86_config->dga_width = 0;
|
||||
ScrnInfoPtr scrn = xf86Screens[pScreen->myNum];
|
||||
xf86CrtcConfigPtr xf86_config = XF86_CRTC_CONFIG_PTR(scrn);
|
||||
|
||||
- if (DGAAvailable(pScreen->myNum))
|
||||
- return TRUE;
|
||||
-
|
||||
xf86_config->dga_flags = 0;
|
||||
xf86_config->dga_address = 0;
|
||||
xf86_config->dga_width = 0;
|
8
xorg-server-xprofile
Normal file
8
xorg-server-xprofile
Normal file
@ -0,0 +1,8 @@
|
||||
#
|
||||
# xprofile Default Xorg profile configuration
|
||||
#
|
||||
|
||||
|
||||
for f in /etc/xprofile.d/*.sh ; do
|
||||
[ -x $f ] && . $f
|
||||
done
|
528
xorg-server.spec
Normal file
528
xorg-server.spec
Normal file
@ -0,0 +1,528 @@
|
||||
Name: xorg-server
|
||||
Version: 1.12.4
|
||||
Release: 5mamba
|
||||
Summary: The core of the X.Org Foundation implementation of the X Window system
|
||||
Group: System/X11
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.x.org
|
||||
Source: ftp://x.org/pub/individual/xserver/xorg-server-%{version}.tar.bz2
|
||||
Source10: XFree86-skel-.xinitrc
|
||||
Source11: xorg-server-xprofile
|
||||
Patch0: %{name}-1.12.1-Xorg_configure.patch
|
||||
Patch1: %{name}-1.3.0.0-hsync_higher_default.patch
|
||||
Patch2: %{name}-1.6.4-fix_DGA_removal.patch
|
||||
License: MIT
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libdmx-devel
|
||||
BuildRequires: libdrm-devel
|
||||
BuildRequires: libfontenc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libncurses-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libXaw-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libXfont-devel
|
||||
BuildRequires: libXi-devel
|
||||
BuildRequires: libxkbfile-devel
|
||||
BuildRequires: libxkbui-devel
|
||||
BuildRequires: libXmu-devel
|
||||
BuildRequires: libXpm-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: libXxf86misc-devel
|
||||
BuildRequires: libXxf86vm-devel
|
||||
BuildRequires: xorg-apps-base
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: glproto-devel
|
||||
BuildRequires: xproto-devel
|
||||
BuildRequires: dri2proto-devel
|
||||
BuildRequires: xorg-xtrans-devel >= 1.0.0
|
||||
BuildRequires: libXRes-devel >= 1.0.1
|
||||
BuildRequires: libGL-devel >= 6.5.2
|
||||
BuildRequires: perl-devel >= 5.8.8
|
||||
BuildRequires: libpciaccess-devel
|
||||
%ifarch %{ix86} x86_64
|
||||
BuildRequires: libsmbios-devel
|
||||
%endif
|
||||
Requires: xorgdrvinput
|
||||
Requires: xorgdrvvideo
|
||||
Requires: xorg-fonts-base
|
||||
Requires: xorg-apps-base
|
||||
Requires: xkeyboard-config
|
||||
Requires: xorglibGL
|
||||
Requires: xorglibglx
|
||||
Obsoletes: Xorg
|
||||
Provides: Xorg
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The X Window System provides the base technology for developing graphical user interfaces.
|
||||
Simply stated, X draws the elements of the GUI on the user's screen and builds methods for sending user interactions back to the application.
|
||||
X also supports remote application deployment--running an application on another computer while viewing the input/output on your machine.
|
||||
X is a powerful environment which supports many different applications, such as games, programming tools, graphics programs, text editors, etc.
|
||||
|
||||
%package devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
The X Window System provides the base technology for developing graphical user interfaces.
|
||||
Simply stated, X draws the elements of the GUI on the user's screen and builds methods for sending user interactions back to the application.
|
||||
X also supports remote application deployment--running an application on another computer while viewing the input/output on your machine.
|
||||
X is a powerful environment which supports many different applications, such as games, programming tools, graphics programs, text editors, etc.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package dmx
|
||||
Summary: X.Org dmx server
|
||||
Group: System/X11
|
||||
|
||||
%description dmx
|
||||
X.Org dmx server.
|
||||
|
||||
%package -n xorg-ext-libglx
|
||||
Summary: X.Org glx extension
|
||||
Group: System/X11
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Obsoletes: libglx
|
||||
Provides: xorglibglx
|
||||
|
||||
%description -n xorg-ext-libglx
|
||||
X.Org glx extension.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
ld -v | grep gold && {
|
||||
echo "ERROR: building with gold produces failing binaries; aborting."
|
||||
exit 1
|
||||
}
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
#%patch2 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-glx \
|
||||
--enable-dri \
|
||||
--enable-xdmcp \
|
||||
--enable-dmx \
|
||||
--enable-xdm-auth-1 \
|
||||
--with-xkb-output=%{_sysconfdir}/X11/xkb/compiled \
|
||||
--with-os-name="Linux" \
|
||||
--with-os-vendor="openmamba" \
|
||||
--enable-aiglx \
|
||||
--with-fop=no
|
||||
|
||||
# --with-mesa-source=`pwd`/Mesa-%{mesa_ver} \
|
||||
# --enable-xgl \
|
||||
# --enable-xglx
|
||||
# --enable-xegl
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
install -d %{buildroot}%{_sysconfdir}/skel %{buildroot}%{_sysconfdir}/xprofile.d
|
||||
install -d -m0755 %{buildroot}%{_sysconfdir}/X11/xorg.conf.d
|
||||
|
||||
cp %{SOURCE10} %{buildroot}%{_sysconfdir}/skel/.xinitrc
|
||||
install -m 755 %{SOURCE11} %{buildroot}%{_sysconfdir}/xprofile
|
||||
|
||||
install hw/xfree86/parser/xf86Parser.h %{buildroot}%{_includedir}/xorg/
|
||||
install hw/xfree86/parser/xf86Optrec.h %{buildroot}%{_includedir}/xorg/
|
||||
|
||||
mv %{buildroot}%{_libdir}/xorg/modules/extensions/libglx.so \
|
||||
%{buildroot}%{_libdir}/xorg/modules/extensions/libglx_dri_so
|
||||
|
||||
mv %{buildroot}%{_libdir}/xorg/modules/extensions/libdri.so \
|
||||
%{buildroot}%{_libdir}/xorg/modules/extensions/libdri_so
|
||||
|
||||
mkdir -p %{buildroot}%{_sbindir}
|
||||
cat > %{buildroot}%{_sbindir}/update-alternatives-set-dri << _EOF
|
||||
#!/bin/bash
|
||||
update-alternatives \
|
||||
--set libglx.so %{_libdir}/xorg/modules/extensions/libglx_dri_so
|
||||
|
||||
update-alternatives \
|
||||
--set libdri.so %{_libdir}/xorg/modules/extensions/libdri_so
|
||||
|
||||
update-alternatives \
|
||||
--set libGL.so.1 %{_libdir}/libGL_so.1.2
|
||||
|
||||
_EOF
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
if [ $1 -eq 1 ]; then
|
||||
[ -e %{_sysconfdir}/X11/xorg.conf ] && {
|
||||
sed -i "s|/usr/X11R6/lib/X11/rgb|/usr/lib/xorg/rgb|" %{_sysconfdir}/X11/xorg.conf
|
||||
sed -i "s|/usr/X11R6/lib/modules|/usr/lib/xorg/modules|" %{_sysconfdir}/X11/xorg.conf
|
||||
sed -i "s|/usr/X11R6/lib/X11/fonts|/usr/lib/X11/fonts|" %{_sysconfdir}/X11/xorg.conf
|
||||
# remove wrong CID font configuration line if present
|
||||
sed -i "/fonts\/CID/d" %{_sysconfdir}/X11/xorg.conf
|
||||
}
|
||||
[ -e %{_datadir}/config/kdm/kdmrc ] &&
|
||||
sed -i "s|/usr/X11R6/bin|/usr/bin|" %{_datadir}/config/kdm/kdmrc
|
||||
|
||||
grep -q '/usr/X11R6/lib' /etc/ld.so.conf &&
|
||||
sed -i "/\usr\/X11R6\/lib/d" /etc/ld.so.conf
|
||||
ldconfig
|
||||
install -m 1777 -o root -g root -d /tmp/.ICE-unix
|
||||
fc-cache
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%post -n xorg-ext-libglx
|
||||
/usr/sbin/update-alternatives \
|
||||
--remove libglx.so %{_libdir}/xorg/modules/extensions/libglx_dri.so 2>/dev/null
|
||||
|
||||
/usr/sbin/update-alternatives \
|
||||
--install %{_libdir}/xorg/modules/extensions/libglx.so libglx.so \
|
||||
%{_libdir}/xorg/modules/extensions/libglx_dri_so 50
|
||||
|
||||
/usr/sbin/update-alternatives \
|
||||
--install %{_libdir}/xorg/modules/extensions/libdri.so libdri.so \
|
||||
%{_libdir}/xorg/modules/extensions/libdri_so 50
|
||||
|
||||
[ -e `readlink /etc/alternatives/libglx.so` ] || {
|
||||
update-alternatives-set-dri
|
||||
}
|
||||
exit 0
|
||||
|
||||
%preun -n xorg-ext-libglx
|
||||
if [ $1 -eq 0 ]; then
|
||||
/usr/sbin/update-alternatives --remove libglx.so \
|
||||
%{_libdir}/xorg/modules/extensions/libglx_dri_so
|
||||
/usr/sbin/update-alternatives --remove libdri.so \
|
||||
%{_libdir}/xorg/modules/extensions/libdri_so
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%attr(0755,root,root) %{_sysconfdir}/skel/.xinitrc
|
||||
%dir %{_sysconfdir}/X11
|
||||
%dir %{_sysconfdir}/X11/xorg.conf.d
|
||||
%{_sysconfdir}/X11/xkb/compiled/README.compiled
|
||||
#%{_sysconfdir}/X11/Xsession.d/92xprint-xpserverlist
|
||||
%dir %{_sysconfdir}/xprofile.d
|
||||
%{_sysconfdir}/xprofile
|
||||
%{_bindir}/X
|
||||
%{_bindir}/Xnest
|
||||
%attr(4755, root, root) %{_bindir}/Xorg
|
||||
#%{_bindir}/Xprt
|
||||
%{_bindir}/Xvfb
|
||||
%{_bindir}/cvt
|
||||
%{_bindir}/gtf
|
||||
#%{_bindir}/inb
|
||||
#%{_bindir}/inl
|
||||
#%{_bindir}/inw
|
||||
#%{_bindir}/ioport
|
||||
#%{_bindir}/outb
|
||||
#%{_bindir}/outl
|
||||
#%{_bindir}/outw
|
||||
#%{_bindir}/pcitweak
|
||||
#%{_bindir}/scanpci
|
||||
#%{_bindir}/xorgcfg
|
||||
#%{_bindir}/xorgconfig
|
||||
%attr(0755,root,root) %{_sbindir}/update-alternatives-set-dri
|
||||
#%{_libdir}/X11/Cards
|
||||
#%{_libdir}/X11/Options
|
||||
#%{_libdir}/X11/xserver/*
|
||||
%{_libdir}/xorg/modules/extensions/libdbe.la
|
||||
%{_libdir}/xorg/modules/extensions/libdbe.so
|
||||
%{_libdir}/xorg/modules/extensions/libdri.la
|
||||
%{_libdir}/xorg/modules/extensions/libdri_so
|
||||
%{_libdir}/xorg/modules/extensions/libdri2.la
|
||||
%{_libdir}/xorg/modules/extensions/libdri2.so
|
||||
%{_libdir}/xorg/modules/extensions/libextmod.la
|
||||
%{_libdir}/xorg/modules/extensions/libextmod.so
|
||||
%{_libdir}/xorg/modules/extensions/librecord.la
|
||||
%{_libdir}/xorg/modules/extensions/librecord.so
|
||||
#%{_libdir}/xorg/modules/extensions/libGLcore.la
|
||||
#%{_libdir}/xorg/modules/extensions/libGLcore.so
|
||||
#%{_libdir}/xorg/modules/extensions/libxtrap.la
|
||||
#%{_libdir}/xorg/modules/extensions/libxtrap.so
|
||||
#%{_libdir}/xorg/modules/extensions/librecord.la
|
||||
#%{_libdir}/xorg/modules/extensions/librecord.so
|
||||
#%{_libdir}/xorg/modules/fonts/*
|
||||
%{_libdir}/xorg/modules/lib*.la
|
||||
%{_libdir}/xorg/modules/lib*.so
|
||||
#%{_libdir}/xorg/modules/linux/*
|
||||
%{_libdir}/xorg/modules/multimedia/*
|
||||
%{_libdir}/xorg/protocol.txt
|
||||
#%{_libdir}/xserver/SecurityPolicy
|
||||
%{_datadir}/X11/xorg.conf.d/10-evdev.conf
|
||||
%{_mandir}/man1/Xnest.*
|
||||
%{_mandir}/man1/Xorg.*
|
||||
#%{_mandir}/man1/Xprt.*
|
||||
%{_mandir}/man1/Xserver.*
|
||||
%{_mandir}/man1/Xvfb.*
|
||||
%{_mandir}/man1/gtf.*
|
||||
#%{_mandir}/man1/pcitweak.*
|
||||
#%{_mandir}/man1/scanpci.*
|
||||
#%{_mandir}/man1/xorgcfg.*
|
||||
#%{_mandir}/man1/xorgconfig.*
|
||||
%{_mandir}/man4/exa.*
|
||||
%{_mandir}/man4/fbdevhw.*
|
||||
%{_mandir}/man5/xorg.conf.*
|
||||
%{_mandir}/man5/xorg.conf.d.*
|
||||
#%{_mandir}/man5/SecurityPolicy.*
|
||||
%{_mandir}/man1/cvt.*
|
||||
%doc COPYING
|
||||
|
||||
%files dmx
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/Xdmx
|
||||
%{_bindir}/dmxaddinput
|
||||
%{_bindir}/dmxaddscreen
|
||||
%{_bindir}/dmxinfo
|
||||
%{_bindir}/dmxreconfig
|
||||
%{_bindir}/dmxresize
|
||||
%{_bindir}/dmxrminput
|
||||
%{_bindir}/dmxrmscreen
|
||||
%{_bindir}/dmxtodmx
|
||||
%{_bindir}/dmxwininfo
|
||||
%{_bindir}/vdltodmx
|
||||
%{_bindir}/xdmxconfig
|
||||
%{_mandir}/man1/Xdmx.*
|
||||
%{_mandir}/man1/dmxtodmx.*
|
||||
%{_mandir}/man1/vdltodmx.*
|
||||
%{_mandir}/man1/xdmxconfig.*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
#%{_includedir}/X11/bitmaps/*
|
||||
#%{_includedir}/X11/pixmaps/*
|
||||
%{_includedir}/xorg/*.h
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%{_datadir}/aclocal/xorg-server.m4
|
||||
%{_docdir}/xorg-server/Xserver-DTrace*
|
||||
|
||||
%files -n xorg-ext-libglx
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/xorg/modules/extensions/libglx.la
|
||||
%{_libdir}/xorg/modules/extensions/libglx_dri_so
|
||||
|
||||
%changelog
|
||||
* Sat Jul 27 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12.4-5mamba
|
||||
- arm: rebuilt to fix 'symbol lookup error: X: undefined symbol: __aeabi_ui2d'
|
||||
|
||||
* Wed Jun 26 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12.4-4mamba
|
||||
- rebuild using ld.bfd (add check and exit if ld is gold)
|
||||
|
||||
* Tue Jun 25 2013 openmamba WebBuild System <webbuild@openmamba.org> 1.12.4-3mamba
|
||||
- really install Xorg mode 4755
|
||||
|
||||
* Tue Jun 18 2013 openmamba WebBuild System <webbuild@openmamba.org> 1.12.4-2mamba
|
||||
- install Xorg mode 4755 to run X as non-root user
|
||||
|
||||
* Tue Mar 05 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12.4-1mamba
|
||||
- update to 1.12.4
|
||||
|
||||
* Wed Jul 11 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12.3-2mamba
|
||||
- really remove xorg -configure patch
|
||||
|
||||
* Mon Jul 09 2012 Automatic Build System <autodist@mambasoft.it> 1.12.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jul 08 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12.2-2mamba
|
||||
- drop xorg-configure patch for now as it causes a segfault when running X -configure
|
||||
|
||||
* Wed May 30 2012 Automatic Build System <autodist@mambasoft.it> 1.12.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Apr 24 2012 Automatic Build System <autodist@mambasoft.it> 1.12.1-1mamba
|
||||
- update to 1.12.1
|
||||
|
||||
* Sat Jan 28 2012 Automatic Build System <autodist@mambasoft.it> 1.11.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Dec 17 2011 Automatic Build System <autodist@mambasoft.it> 1.11.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Nov 05 2011 Automatic Build System <autodist@mambasoft.it> 1.11.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Sep 24 2011 Automatic Build System <autodist@mambasoft.it> 1.11.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Aug 29 2011 Automatic Build System <autodist@mambasoft.it> 1.11.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Aug 25 2011 Automatic Build System <autodist@mambasoft.it> 1.10.4-1mamba
|
||||
- automatic version update by autodist
|
||||
- removed internal Mesa sources
|
||||
|
||||
* Sat Aug 13 2011 Automatic Build System <autodist@mambasoft.it> 1.10.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Apr 16 2011 Automatic Build System <autodist@mambasoft.it> 1.10.1-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Apr 06 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.0-2mamba
|
||||
- removed requirement for postplug-xorg
|
||||
|
||||
* Mon Mar 07 2011 Automatic Build System <autodist@mambasoft.it> 1.10.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat Feb 05 2011 Automatic Build System <autodist@mambasoft.it> 1.9.4-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Dec 14 2010 Automatic Build System <autodist@mambasoft.it> 1.9.3-1mamba
|
||||
- automatic update to 1.9.3 by autodist
|
||||
|
||||
* Sun Nov 21 2010 Automatic Build System <autodist@mambasoft.it> 1.9.2.901-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Nov 01 2010 Automatic Build System <autodist@mambasoft.it> 1.9.2-1mamba
|
||||
- automatic update to 1.9.2 by autodist
|
||||
|
||||
* Thu Oct 28 2010 Automatic Build System <autodist@mambasoft.it> 1.9.1-1mamba
|
||||
- automatic update to 1.9.1 by autodist
|
||||
|
||||
* Wed Jul 14 2010 Automatic Build System <autodist@mambasoft.it> 1.8.2-1mamba
|
||||
- automatic update to 1.8.2 by autodist
|
||||
|
||||
* Tue Jul 13 2010 Automatic Build System <autodist@mambasoft.it> 1.8.1-1mamba
|
||||
- automatic update to 1.8.1 by autodist
|
||||
|
||||
* Wed Mar 17 2010 Automatic Build System <autodist@mambasoft.it> 1.7.6-1mamba
|
||||
- automatic update to 1.7.6 by autodist
|
||||
|
||||
* Fri Feb 19 2010 Automatic Build System <autodist@mambasoft.it> 1.7.5-1mamba
|
||||
- automatic update to 1.7.5 by autodist
|
||||
|
||||
* Fri Jan 08 2010 Automatic Build System <autodist@mambasoft.it> 1.7.4-1mamba
|
||||
- automatic update to 1.7.4 by autodist
|
||||
|
||||
* Sun Dec 06 2009 Automatic Build System <autodist@mambasoft.it> 1.7.3-1mamba
|
||||
- automatic update to 1.7.3 by autodist
|
||||
|
||||
* Fri Nov 27 2009 Automatic Build System <autodist@mambasoft.it> 1.7.2-1mamba
|
||||
- automatic update to 1.7.2 by autodist
|
||||
|
||||
* Sat Nov 21 2009 Automatic Build System <autodist@mambasoft.it> 1.7.1-1mamba
|
||||
- automatic update to 1.7.1 by autodist
|
||||
|
||||
* Thu Oct 15 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.4-2mamba
|
||||
- added fix_DGA_removal patch; fixes crash with radeon and possibly other drivers
|
||||
|
||||
* Mon Sep 28 2009 Automatic Build System <autodist@mambasoft.it> 1.6.4-1mamba
|
||||
- automatic update to 1.6.4 by autodist
|
||||
|
||||
* Tue Sep 08 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.3-2mamba
|
||||
- install libdri.so as libdri_so and create libdri.so as an alternative to support fglrx alternative library
|
||||
|
||||
* Sat Aug 01 2009 Automatic Build System <autodist@mambasoft.it> 1.6.3-1mamba
|
||||
- automatic update to 1.6.3 by autodist
|
||||
|
||||
* Mon Jul 27 2009 Automatic Build System <autodist@mambasoft.it> 1.6.2.901-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat Jul 18 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.2-2mamba
|
||||
- install Xf86Parser.h and Xf86Optrec.h missing hedaers required by video drivers
|
||||
|
||||
* Thu Jul 09 2009 Automatic Build System <autodist@mambasoft.it> 1.6.2-1mamba
|
||||
- automatic update to 1.6.2 by autodist
|
||||
|
||||
* Sun Jul 05 2009 Automatic Build System <autodist@mambasoft.it> 1.6.1.902-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Jun 25 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.1-3mamba
|
||||
- rebuilt with libsmbios 2.2.16
|
||||
|
||||
* Tue Jun 23 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.1-2mamba
|
||||
- removed requirement and default for crystalcursors
|
||||
|
||||
* Fri Apr 17 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.1-1mamba
|
||||
- automatic update to 1.6.1 by autodist
|
||||
|
||||
* Sat Feb 07 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.2-1mamba
|
||||
- update to 1.4.2
|
||||
|
||||
* Tue May 20 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0.0-9mamba
|
||||
- obsolete Xorg legacy package
|
||||
|
||||
* Mon Sep 10 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0.0-8mamba
|
||||
- remove .so from libglx to avoid a conflict between alternatives and ldconfig
|
||||
|
||||
* Wed Sep 05 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0.0-7mamba
|
||||
- fix for the previous patch: add nv to the end of fallback vector
|
||||
|
||||
* Tue Sep 04 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0.0-6mamba
|
||||
- configure patch: added nv as fallback to privilege detect of nvidia driver
|
||||
|
||||
* Sun Aug 26 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0.0-5mamba
|
||||
- added patch to raise hsync default from 37.9 to 49.9 khz
|
||||
|
||||
* Wed Aug 01 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0.0-4mamba
|
||||
- added "Xorg -configure" patch for ensuring vesa and fglrx are at the end
|
||||
of probed drivers list
|
||||
|
||||
* Tue Jul 31 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0.0-3mamba
|
||||
- set xkb-output to /etc/X11/xkb/compiled (default was in %{_datadir})
|
||||
|
||||
* Sun Jul 22 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0.0-1mamba
|
||||
- update-alternatives-set-dri: also set libGL alternative to mesa (libGL.so.1.2)
|
||||
|
||||
* Tue Jul 17 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0.0-1mamba
|
||||
- update to 1.3.0.0
|
||||
|
||||
* Sat May 26 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.0-5mamba
|
||||
- xorg-ext-libglx: rename libglx.so to libglx.so.%{version} and set as the
|
||||
default alternative
|
||||
- change requirement for xorgdrvinput to xorg-drv-input-base
|
||||
|
||||
* Tue Mar 06 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.0-4qilnx
|
||||
- added default xprofile and xprofile.d support
|
||||
|
||||
* Tue Feb 20 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.0-3qilnx
|
||||
- added requirement for xorglibglx
|
||||
|
||||
* Mon Feb 19 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.0-2qilnx
|
||||
- fix a post script error
|
||||
|
||||
* Wed Feb 07 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.0-1qilnx
|
||||
- update to version 1.2.0 by autospec
|
||||
|
||||
* Wed Jan 03 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.1-3qilnx
|
||||
- move %{_datadir}/X11/compiled from xorg-server-devel to xorg-server
|
||||
|
||||
* Wed Jan 03 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.1-2qilnx
|
||||
- add requirement for xorg-xkbdata
|
||||
|
||||
* Tue Jan 02 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.1-1qilnx
|
||||
- update to version 1.1.1 by autospec
|
||||
- post script: generate font cache on upgrade
|
||||
|
||||
* Thu Dec 28 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.0-5qilnx
|
||||
- rebuilt with aiglx support
|
||||
|
||||
* Wed Dec 27 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.0-4qilnx
|
||||
- add support for crystalcursors
|
||||
- configure xinit to launch startkde
|
||||
- do not obsolete old Xorg packages
|
||||
- put libglx extension into xorg-ext-libglx and obsolete libglx
|
||||
|
||||
* Thu Dec 21 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.0-3qilnx
|
||||
- fix Xorg configuration file on post script
|
||||
|
||||
* Wed Dec 20 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.0-2qilnx
|
||||
- rebuilt obsoleting monolitic Xorg packages
|
||||
|
||||
* Mon Dec 18 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.0-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user