automatic update by autodist [release 7.3.0-1mamba;Sun Feb 23 2014]
This commit is contained in:
parent
b829d956e3
commit
1c3eef58a7
@ -1,2 +1,4 @@
|
|||||||
# xorg-drv-video-ati
|
# xorg-drv-video-ati
|
||||||
|
|
||||||
|
ATI video driver for X.Org.
|
||||||
|
|
||||||
|
25
xorg-drv-video-ati-6.13.2-xorg-server-1.10.patch
Normal file
25
xorg-drv-video-ati-6.13.2-xorg-server-1.10.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
diff --git a/src/drmmode_display.c b/src/drmmode_display.c
|
||||||
|
index a6038b2..5586970 100644
|
||||||
|
--- a/src/drmmode_display.c
|
||||||
|
+++ b/src/drmmode_display.c
|
||||||
|
@@ -1145,7 +1145,7 @@ drmmode_xf86crtc_resize (ScrnInfoPtr scrn, int width, int height)
|
||||||
|
width, height, -1, -1, pitch * cpp,
|
||||||
|
info->fb_shadow);
|
||||||
|
}
|
||||||
|
- scrn->pixmapPrivate.ptr = ppix->devPrivate.ptr;
|
||||||
|
+// scrn->pixmapPrivate.ptr = ppix->devPrivate.ptr;
|
||||||
|
|
||||||
|
// xf86DrvMsg(scrn->scrnIndex, X_INFO, "New front buffer at 0x%lx\n",
|
||||||
|
// info->front_bo-);
|
||||||
|
@@ -1442,10 +1442,7 @@ void drmmode_uevent_init(ScrnInfoPtr scrn, drmmode_ptr drmmode)
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
|
||||||
|
- if (udev_monitor_filter_add_match_subsystem_devtype(mon,
|
||||||
|
- "drm",
|
||||||
|
- "drm_minor") < 0 ||
|
||||||
|
- udev_monitor_enable_receiving(mon) < 0) {
|
||||||
|
+ if ( udev_monitor_enable_receiving(mon) < 0) {
|
||||||
|
udev_monitor_unref(mon);
|
||||||
|
udev_unref(u);
|
||||||
|
return;
|
134
xorg-drv-video-ati.spec
Normal file
134
xorg-drv-video-ati.spec
Normal file
@ -0,0 +1,134 @@
|
|||||||
|
%define xorg_ver %(pkg-config xorg-server --modversion|cut -d. -f 1-2)
|
||||||
|
Name: xorg-drv-video-ati
|
||||||
|
Version: 7.3.0
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: ATI video driver for X.Org
|
||||||
|
Group: System/X11
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://x.org
|
||||||
|
Source: ftp://x.org/pub/individual/driver/xf86-video-ati-%{version}.tar.bz2
|
||||||
|
Patch0: xorg-drv-video-ati-6.13.2-xorg-server-1.10.patch
|
||||||
|
License: MIT
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libdrm-devel
|
||||||
|
BuildRequires: libpciaccess-devel
|
||||||
|
BuildRequires: udev-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: xorg-server-devel >= 1.1.0
|
||||||
|
BuildRequires: xorg-proto-devel
|
||||||
|
BuildRequires: libXvMC-devel >= 1.0.2
|
||||||
|
BuildRequires: libXrender >= 0.9.1
|
||||||
|
BuildRequires: libXrandr >= 1.1.1
|
||||||
|
BuildRequires: libXv >= 1.0.1
|
||||||
|
BuildRequires: libdrm-devel >= 2.3.0
|
||||||
|
BuildRequires: libXinerama-devel >= 1.0.1
|
||||||
|
BuildRequires: libpthread-stubs-devel
|
||||||
|
BuildRequires: systemd-devel
|
||||||
|
BuildRequires: libglamor-egl-devel
|
||||||
|
Requires: xorg-drv-video-r128
|
||||||
|
Provides: xorgdrvvideo
|
||||||
|
Provides: xorg-drv-video-avivo
|
||||||
|
Obsoletes: xorg-drv-video-avivo
|
||||||
|
Requires: radeon-firmware
|
||||||
|
Requires: xorg-server >= %{xorg_ver}
|
||||||
|
Requires: xorg-server <= %{xorg_ver}.255
|
||||||
|
|
||||||
|
%description
|
||||||
|
ATI video driver for X.Org.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n xf86-video-ati-%{version}
|
||||||
|
#%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/xorg/modules/drivers/ati_drv.la
|
||||||
|
%{_libdir}/xorg/modules/drivers/ati_drv.so
|
||||||
|
%{_libdir}/xorg/modules/drivers/radeon_drv.la
|
||||||
|
%{_libdir}/xorg/modules/drivers/radeon_drv.so
|
||||||
|
#%{_libdir}/xorg/modules/multimedia/theatre200_drv.la
|
||||||
|
#%{_libdir}/xorg/modules/multimedia/theatre200_drv.so
|
||||||
|
#%{_libdir}/xorg/modules/multimedia/theatre_detect_drv.la
|
||||||
|
#%{_libdir}/xorg/modules/multimedia/theatre_detect_drv.so
|
||||||
|
#%{_libdir}/xorg/modules/multimedia/theatre_drv.la
|
||||||
|
#%{_libdir}/xorg/modules/multimedia/theatre_drv.so
|
||||||
|
%{_mandir}/man4/*.4.gz
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Feb 23 2014 Automatic Build System <autodist@mambasoft.it> 7.3.0-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sat Aug 10 2013 Automatic Build System <autodist@mambasoft.it> 7.2.0-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue Mar 05 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 7.1.0-2mamba
|
||||||
|
- X.org 1.12 rebuild
|
||||||
|
|
||||||
|
* Thu Feb 28 2013 Automatic Build System <autodist@mambasoft.it> 7.1.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Jan 14 2013 Automatic Build System <autodist@mambasoft.it> 7.0.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Nov 16 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 6.14.6-1mamba
|
||||||
|
- update to 6.14.6
|
||||||
|
|
||||||
|
* Thu Jun 07 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 6.14.4-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Feb 17 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 6.14.3-2mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Thu Jan 05 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 6.14.3-1mamba
|
||||||
|
- update to 6.14.3
|
||||||
|
|
||||||
|
* Sun Jun 26 2011 Automatic Build System <autodist@mambasoft.it> 6.14.2-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Thu Mar 10 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 6.13.2-3mamba
|
||||||
|
- rebuilt with xorg-server 1.10
|
||||||
|
|
||||||
|
* Sun Feb 06 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 6.13.2-2mamba
|
||||||
|
- rebuilt with xorg-server 1.9.4
|
||||||
|
|
||||||
|
* Thu Jan 20 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 6.13.2-1mamba
|
||||||
|
- update to 6.13.2
|
||||||
|
|
||||||
|
* Sun Aug 15 2010 Automatic Build System <autodist@mambasoft.it> 6.13.1-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sun Jul 04 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 6.13.0-2mamba
|
||||||
|
- added requirement for radeon-firmware
|
||||||
|
|
||||||
|
* Mon Jun 21 2010 Automatic Build System <autodist@mambasoft.it> 6.13.0-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Feb 26 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 6.12.4-2mamba
|
||||||
|
- rebuilt for xorg-server 1.7.5
|
||||||
|
|
||||||
|
* Thu Oct 01 2009 Automatic Build System <autodist@mambasoft.it> 6.12.4-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Thu Jul 23 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 6.12.2-2mamba
|
||||||
|
- added provide for xorgdrvvideo
|
||||||
|
|
||||||
|
* Mon Jun 08 2009 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 6.12.2-1mamba
|
||||||
|
- update to 6.12.2
|
||||||
|
|
||||||
|
* Sat Jun 06 2009 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 6.8.0-1mamba
|
||||||
|
- Package created
|
Loading…
Reference in New Issue
Block a user