update to 0.5.10 [release 0.5.10-1mamba;Sun Oct 20 2013]
This commit is contained in:
parent
3595c6ee1e
commit
aae33c3ad9
@ -1,2 +1,4 @@
|
|||||||
# xmoto
|
# xmoto
|
||||||
|
|
||||||
|
xmoto is a nice 2D motocross game, where phisics rules are very strong
|
||||||
|
|
||||||
|
11
xmoto-0.5.10-gcc-4.8.patch
Normal file
11
xmoto-0.5.10-gcc-4.8.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- src/helpers/System.cpp.orig 2011-10-12 00:18:14.000000000 +0400
|
||||||
|
+++ src/helpers/System.cpp 2013-09-13 22:36:38.029229232 +0400
|
||||||
|
@@ -25,6 +25,8 @@
|
||||||
|
#include "VExcept.h"
|
||||||
|
#include <sstream>
|
||||||
|
|
||||||
|
+#include <unistd.h> // for getpid()
|
||||||
|
+
|
||||||
|
std::vector<std::string>* System::getDisplayModes(int windowed) {
|
||||||
|
std::vector<std::string>* modes = new std::vector<std::string>;
|
||||||
|
SDL_Rect **sdl_modes;
|
12
xmoto-0.5.3-libpng14.patch
Normal file
12
xmoto-0.5.3-libpng14.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nru xmoto-0.5.3.orig//src/image/tim_png.cpp xmoto-0.5.3/src/image/tim_png.cpp
|
||||||
|
--- xmoto-0.5.3.orig//src/image/tim_png.cpp 2007-12-03 11:33:24.000000000 +0100
|
||||||
|
+++ xmoto-0.5.3/src/image/tim_png.cpp 2010-10-25 03:08:58.857513109 +0200
|
||||||
|
@@ -166,7 +166,7 @@
|
||||||
|
png_set_palette_to_rgb(PngPtr);
|
||||||
|
|
||||||
|
if(nColorType==PNG_COLOR_TYPE_GRAY && nBitDepth<8)
|
||||||
|
- png_set_gray_1_2_4_to_8(PngPtr);
|
||||||
|
+ png_set_expand_gray_1_2_4_to_8(PngPtr);
|
||||||
|
|
||||||
|
if(png_get_valid(PngPtr,InfoPtr,PNG_INFO_tRNS))
|
||||||
|
png_set_tRNS_to_alpha(PngPtr);
|
BIN
xmoto-icon.png
Normal file
BIN
xmoto-icon.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 26 KiB |
10
xmoto.desktop
Normal file
10
xmoto.desktop
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
[Desktop Entry]
|
||||||
|
Encoding=UTF-8
|
||||||
|
Categories=Application;Game;ArcadeGame
|
||||||
|
Name=xmoto
|
||||||
|
GenericName=2D motocross race game
|
||||||
|
GenericName[it]=Gioco 2D di corse di motocross
|
||||||
|
Exec=/usr/bin/xmoto
|
||||||
|
Terminal=0
|
||||||
|
Type=Application
|
||||||
|
Icon=/usr/share/pixmaps/xmoto.png
|
99
xmoto.spec
Normal file
99
xmoto.spec
Normal file
@ -0,0 +1,99 @@
|
|||||||
|
Name: xmoto
|
||||||
|
Version: 0.5.10
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A nice 2D motocross game
|
||||||
|
Group: Graphical Desktop/Applications/Games
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
|
||||||
|
URL: http://xmoto.tuxfamily.org/index.php?page=news
|
||||||
|
Source: http://download.tuxfamily.org/xmoto/xmoto/%{version}/xmoto-%{version}-src.tar.gz
|
||||||
|
Source2: xmoto.desktop
|
||||||
|
Source3: xmoto-icon.png
|
||||||
|
Patch0: xmoto-0.5.3-libpng14.patch
|
||||||
|
Patch1: xmoto-0.5.10-gcc-4.8.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libbzip2-devel
|
||||||
|
BuildRequires: libcurl-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libGL-devel
|
||||||
|
BuildRequires: libGLU-devel
|
||||||
|
BuildRequires: libjpeg-devel
|
||||||
|
BuildRequires: liblua-devel
|
||||||
|
BuildRequires: libode-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libSDL-devel
|
||||||
|
BuildRequires: libSDL_mixer-devel
|
||||||
|
BuildRequires: libSDL_net-devel
|
||||||
|
BuildRequires: libSDL_ttf-devel
|
||||||
|
BuildRequires: libsqlite-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libxdg-basedir-devel
|
||||||
|
BuildRequires: libxml2-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
|
||||||
|
%description
|
||||||
|
xmoto is a nice 2D motocross game, where phisics rules are very strong
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}-%{version}
|
||||||
|
#%patch0 -p1
|
||||||
|
%patch1 -p0
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --with-enable-zoom=1
|
||||||
|
# Workarounf
|
||||||
|
sed -i "s|llua|llua5.1|" Makefile src/Makefile
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
install -D %{SOURCE2} %{buildroot}%{_datadir}/applications/xmoto.desktop
|
||||||
|
install -D %{SOURCE3} %{buildroot}%{_datadir}/pixmaps/xmoto.png
|
||||||
|
%find_lang %{name}
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files -f %{name}.lang
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/xmoto
|
||||||
|
%{_datadir}/pixmaps/xmoto.png
|
||||||
|
%dir %{_datadir}/xmoto
|
||||||
|
%dir %{_datadir}/xmoto/Textures
|
||||||
|
%dir %{_datadir}/xmoto/Textures/Fonts
|
||||||
|
%{_datadir}/xmoto/Textures/Fonts/DejaVuSans.ttf
|
||||||
|
%{_datadir}/xmoto/Textures/Fonts/DejaVuSansMono.ttf
|
||||||
|
%dir %{_datadir}/xmoto/Textures/Musics
|
||||||
|
%{_datadir}/xmoto/Textures/Musics/*.ogg
|
||||||
|
%{_datadir}/xmoto/xmoto.bin
|
||||||
|
%{_datadir}/xmoto/xmoto_icone_x.ico
|
||||||
|
%{_datadir}/applications/xmoto.desktop
|
||||||
|
%{_mandir}/man6/xmoto.6*
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
#ChangeLog NEWS README TODO
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Oct 20 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.10-1mamba
|
||||||
|
- update to 0.5.10
|
||||||
|
|
||||||
|
* Fri Mar 18 2011 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.5.5-1mamba
|
||||||
|
- update to 0.5.5
|
||||||
|
|
||||||
|
* Mon Oct 25 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.3-1mamba
|
||||||
|
- update to 0.5.3
|
||||||
|
|
||||||
|
* Fri Nov 20 2009 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.5.2-1mamba
|
||||||
|
- update to 0.5.2
|
||||||
|
- added build requirements for libSDL_net-devel
|
||||||
|
|
||||||
|
* Mon Jul 07 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.2-2mamba
|
||||||
|
- added desktop menu icon
|
||||||
|
- move build requirements to correct position
|
||||||
|
|
||||||
|
* Sat Jul 05 2008 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.4.2-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user