update to 1.51.08
source renamed from libxmlrpc-c to xmlrpc-c removed dependency on libwww [release 1.51.08-1mamba;Thu Oct 19 2023]
This commit is contained in:
parent
7b9c0b3d58
commit
822291f41e
@ -1,2 +1,6 @@
|
||||
# xmlrpc-c
|
||||
|
||||
Programming library for writing an XML-RPC server or client in C or C++.
|
||||
XML-RPC is a standard network protocol to allow a client program to make a simple remote procedure call (RPC) type request of a server.
|
||||
Like SOAP or CORBA, but much simpler.
|
||||
|
||||
|
30
libxmlrpc-c-1.16.41-curl-7.25.0.patch
Normal file
30
libxmlrpc-c-1.16.41-curl-7.25.0.patch
Normal file
@ -0,0 +1,30 @@
|
||||
--- xmlrpc-c-1.16.33.orig/lib/curl_transport/curlmulti.c
|
||||
+++ xmlrpc-c-1.16.33/lib/curl_transport/curlmulti.c
|
||||
@@ -17,7 +17,6 @@
|
||||
#endif
|
||||
|
||||
#include <curl/curl.h>
|
||||
-#include <curl/types.h>
|
||||
#include <curl/easy.h>
|
||||
#include <curl/multi.h>
|
||||
|
||||
--- xmlrpc-c-1.16.33.orig/lib/curl_transport/curltransaction.c
|
||||
+++ xmlrpc-c-1.16.33/lib/curl_transport/curltransaction.c
|
||||
@@ -15,7 +15,6 @@
|
||||
#include "version.h"
|
||||
|
||||
#include <curl/curl.h>
|
||||
-#include <curl/types.h>
|
||||
#include <curl/easy.h>
|
||||
|
||||
#include "curlversion.h"
|
||||
--- xmlrpc-c-1.16.33.orig/lib/curl_transport/xmlrpc_curl_transport.c
|
||||
+++ xmlrpc-c-1.16.33/lib/curl_transport/xmlrpc_curl_transport.c
|
||||
@@ -83,7 +83,6 @@
|
||||
#include "xmlrpc-c/time_int.h"
|
||||
|
||||
#include <curl/curl.h>
|
||||
-#include <curl/types.h>
|
||||
#include <curl/easy.h>
|
||||
#include <curl/multi.h>
|
||||
|
181
xmlrpc-c.spec
Normal file
181
xmlrpc-c.spec
Normal file
@ -0,0 +1,181 @@
|
||||
Name: xmlrpc-c
|
||||
Version: 1.51.08
|
||||
Release: 1mamba
|
||||
Summary: Programming library for writing an XML-RPC server or client in C or C++
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://xmlrpc-c.sourceforge.io/
|
||||
Source: https://downloads.sourceforge.net/project/xmlrpc-c/Xmlrpc-c%20Super%20Stable/%{version}/xmlrpc-%{version}.tgz
|
||||
Patch0: libxmlrpc-c-1.16.41-curl-7.25.0.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires(post):%{__install_info}
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description
|
||||
Programming library for writing an XML-RPC server or client in C or C++.
|
||||
XML-RPC is a standard network protocol to allow a client program to make a simple remote procedure call (RPC) type request of a server.
|
||||
Like SOAP or CORBA, but much simpler.
|
||||
|
||||
%package -n lib%{name}
|
||||
Group: System/Libraries
|
||||
Summary: Programming library for writing an XML-RPC server or client in C or C++
|
||||
|
||||
%description -n lib%{name}
|
||||
Programming library for writing an XML-RPC server or client in C or C++.
|
||||
XML-RPC is a standard network protocol to allow a client program to make a simple remote procedure call (RPC) type request of a server.
|
||||
Like SOAP or CORBA, but much simpler.
|
||||
|
||||
%package -n lib%{name}-devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n lib%{name}-devel
|
||||
Programming library for writing an XML-RPC server or client in C or C++.
|
||||
XML-RPC is a standard network protocol to allow a client program to make a simple remote procedure call (RPC) type request of a server.
|
||||
Like SOAP or CORBA, but much simpler.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n xmlrpc-%{version}
|
||||
sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," config.sub
|
||||
# fix strange permissions
|
||||
chmod 644 README doc/*
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-shared \
|
||||
--enable-libxml2-backend \
|
||||
--disable-libwww-client \
|
||||
--disable-wininet-client \
|
||||
--enable-cplusplus
|
||||
|
||||
# --disable-cgi-server \
|
||||
|
||||
%make -j1 LIBINST_DIR=%{_libdir}
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall LIBINST_DIR=%{_libdir}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libxmlrpc.so.*
|
||||
%{_libdir}/libxmlrpc_abyss.so.*
|
||||
%{_libdir}/libxmlrpc_abyss++.so.*
|
||||
%{_libdir}/libxmlrpc_cpp.so.*
|
||||
%{_libdir}/libxmlrpc++.so.*
|
||||
%{_libdir}/libxmlrpc_client++.so.*
|
||||
%{_libdir}/libxmlrpc_server++.so.*
|
||||
%{_libdir}/libxmlrpc_server_abyss++.so.*
|
||||
%{_libdir}/libxmlrpc_client.so.*
|
||||
%{_libdir}/libxmlrpc_packetsocket.so.*
|
||||
%{_libdir}/libxmlrpc_server.so.*
|
||||
%{_libdir}/libxmlrpc_server_abyss.so.*
|
||||
%{_libdir}/libxmlrpc_server_cgi.so.*
|
||||
%{_libdir}/libxmlrpc_server_cgi++.so.*
|
||||
%{_libdir}/libxmlrpc_server_pstream++.so.*
|
||||
%{_libdir}/libxmlrpc_util.so.*
|
||||
%{_libdir}/libxmlrpc_util++.so.*
|
||||
%doc doc/COPYING doc/CREDITS
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/xmlrpc-c-config
|
||||
%{_includedir}/*.h
|
||||
%{_includedir}/xmlrpc-c
|
||||
%{_libdir}/libxmlrpc*.a
|
||||
#%{_libdir}/libxmlrpc*.la
|
||||
%{_libdir}/libxmlrpc*.so
|
||||
%{_libdir}/pkgconfig/xmlrpc*.pc
|
||||
%doc README
|
||||
%doc doc/DEVELOPING doc/HISTORY doc/SECURITY doc/TESTING doc/TODO
|
||||
|
||||
#%files tools
|
||||
#%defattr(-,root,root)
|
||||
#%{_bindir}/xmlrpc
|
||||
#%{_bindir}/xmlrpc_transport
|
||||
|
||||
%changelog
|
||||
* Thu Oct 19 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.51.08-1mamba
|
||||
- update to 1.51.08
|
||||
- source renamed from libxmlrpc-c to xmlrpc-c
|
||||
- removed dependency on libwww
|
||||
|
||||
* Wed Jun 16 2021 Automatic Build System <autodist@mambasoft.it> 1.51.07-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Apr 10 2020 Automatic Build System <autodist@mambasoft.it> 1.51.06-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Mar 17 2015 Automatic Build System <autodist@mambasoft.it> 1.33.17-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Jan 18 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.33.15-1mamba
|
||||
- update to 1.33.15
|
||||
|
||||
* Tue Nov 04 2014 Automatic Build System <autodist@mambasoft.it> 1.25.30-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat May 24 2014 Automatic Build System <autodist@mambasoft.it> 1.25.28-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Sep 30 2013 Automatic Build System <autodist@mambasoft.it> 1.25.26-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Aug 21 2013 Automatic Build System <autodist@mambasoft.it> 1.25.25-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Jun 20 2013 Automatic Build System <autodist@mambasoft.it> 1.25.24-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Mar 31 2013 Automatic Build System <autodist@mambasoft.it> 1.25.23-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Dec 08 2012 Automatic Build System <autodist@mambasoft.it> 1.16.44-1mamba
|
||||
- update to 1.16.44
|
||||
|
||||
* Mon Apr 23 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.16.41-1mamba
|
||||
- update to 1.16.41
|
||||
|
||||
* Wed Feb 23 2011 Automatic Build System <autodist@mambasoft.it> 1.06.42-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Jan 03 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.06.41-1mamba
|
||||
- update to 1.06.41
|
||||
|
||||
* Tue Jul 14 2009 Automatic Build System <autodist@mambasoft.it> 1.06.35-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Jan 12 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.06.32-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Aug 28 2008 Aleph0 <aleph0@openmamba.org> 1.06.30-2mamba
|
||||
- fix strange permissions in doc files
|
||||
|
||||
* Thu Aug 28 2008 Aleph0 <aleph0@openmamba.org> 1.06.30-1mamba
|
||||
- update to 1.06.30
|
||||
|
||||
* Fri Nov 16 2007 Aleph0 <aleph0@openmamba.org> 1.06.21-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user