automatic rebuild by autodist [release 0.106-3mamba;Thu Sep 05 2013]
This commit is contained in:
parent
cfbfad5626
commit
2efb2ffa2b
@ -1,2 +1,6 @@
|
||||
# xmame
|
||||
|
||||
Mame is an arcade machine emulator.
|
||||
Started in 1997 by Nicola Salmoria, mame started out as a series of emulators for individual games. This series of emulators was combined into a simgle multi-game emulator.
|
||||
This is the current form of mame; no longer a one-man show, there are over 100 contributors to the project.
|
||||
|
||||
|
23
xmame-0.106-Makefile.patch
Normal file
23
xmame-0.106-Makefile.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -Nru xmame-0.106/makefile.unix xmame-0.106.org/makefile.unix
|
||||
--- xmame-0.106/makefile.unix 2008-06-30 23:46:14.000000000 +0200
|
||||
+++ xmame-0.106.org/makefile.unix 2008-07-01 00:10:13.000000000 +0200
|
||||
@@ -108,8 +108,8 @@
|
||||
|
||||
# Compiler for host compilations in cross-compiling environments (used
|
||||
# in src/unix/unix.mak for m68k).
|
||||
-HOST_CC = $(CC)
|
||||
-# HOST_CC = @gcc
|
||||
+#HOST_CC = $(CC)
|
||||
+HOST_CC = @gcc
|
||||
|
||||
|
||||
###########################################################################
|
||||
@@ -758,7 +758,7 @@
|
||||
X11_MITSHM = 1
|
||||
|
||||
# Use Xv extension for hardware scaling.
|
||||
-X11_XV = 1
|
||||
+#X11_XV = 1
|
||||
|
||||
# Enable XFree86 DGA. This also causes "make install" to set the suid bit
|
||||
# on the executable.
|
14
xmame-0.106-libGLName.patch
Normal file
14
xmame-0.106-libGLName.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -Nru xmame-0.106.orig/src/unix/video-drivers/xgl.c xmame-0.106/src/unix/video-drivers/xgl.c
|
||||
--- xmame-0.106.orig/src/unix/video-drivers/xgl.c 2006-05-26 06:56:38.000000000 +0200
|
||||
+++ xmame-0.106/src/unix/video-drivers/xgl.c 2008-12-31 03:32:59.000000000 +0100
|
||||
@@ -78,8 +78,8 @@
|
||||
|
||||
int xgl_init(void)
|
||||
{
|
||||
- const char *libGLName = "libGL.so";
|
||||
- const char *libGLUName = "libGLU.so";
|
||||
+ const char *libGLName = "libGL.so.1";
|
||||
+ const char *libGLUName = "libGLU.so.1";
|
||||
|
||||
if (!loadGLLibrary(libGLName, libGLUName))
|
||||
{
|
125
xmame.spec
Normal file
125
xmame.spec
Normal file
@ -0,0 +1,125 @@
|
||||
Name: xmame
|
||||
Version: 0.106
|
||||
Release: 3mamba
|
||||
Summary: An arcade machine emulator
|
||||
Group: Graphical Desktop/Applications/Games
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://x.mame.net
|
||||
Source0: http://x.mame.net/download/xmame-%{version}.tar.bz2
|
||||
# see src/unix/doc/xmamerc.dist
|
||||
Source1: xmamerc.dist
|
||||
Source10: http://www.mame.net/roms/polyplay.zip
|
||||
Source11: http://www.mame.net/roms/robby.zip
|
||||
Source12: http://www.mame.net/roms/gridlee.zip
|
||||
Patch0: xmame-0.106-Makefile.patch
|
||||
Patch1: xmame-0.106-libGLName.patch
|
||||
License: MAME
|
||||
#BuildRequires: libXorg-devel >= 6.8.0
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libaudiofile-devel
|
||||
BuildRequires: libesound-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXinerama-devel
|
||||
BuildRequires: libXxf86dga-devel
|
||||
BuildRequires: libXxf86vm-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: lirc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Mame is an arcade machine emulator.
|
||||
Started in 1997 by Nicola Salmoria, mame started out as a series of emulators for individual games. This series of emulators was combined into a simgle multi-game emulator.
|
||||
This is the current form of mame; no longer a one-man show, there are over 100 contributors to the project.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%make \
|
||||
PREFIX=%{_prefix} \
|
||||
MANDIR=%{_mandir}/man6 \
|
||||
SYSCONFDIR=%{_sysconfdir}/mame \
|
||||
X11_XINERAMA=1 \
|
||||
X11_OPENGL=1 \
|
||||
SOUND_ALSA=1 \
|
||||
SOUND_SDL=1 \
|
||||
SOUND_ESOUND=1 \
|
||||
X11_DGA=1 \
|
||||
LIRC=1
|
||||
##
|
||||
##SOUND_WAVEOUT=1 ??
|
||||
##SOUND_ARTS_TEIRA=1 \
|
||||
##SOUND_ARTS_SMOTEK=1
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall \
|
||||
PREFIX=%{buildroot}%{_prefix} \
|
||||
MANDIR=%{buildroot}%{_mandir}/man6 \
|
||||
INSTALL_USER=$(id -un) \
|
||||
INSTALL_GROUP=$(id -gn)
|
||||
|
||||
chmod 755 %{buildroot}%{_bindir}/*
|
||||
ln -s xmame.x11 %{buildroot}%{_bindir}/xmame
|
||||
|
||||
install -d %{buildroot}%{_datadir}/mame/{roms,artwork,samples,snap}
|
||||
|
||||
install -d %{buildroot}%{_sysconfdir}/mame
|
||||
cp %{SOURCE1} %{buildroot}%{_sysconfdir}/mame/xmamerc
|
||||
|
||||
cp %{SOURCE10} %{buildroot}%{_datadir}/mame/roms
|
||||
cp %{SOURCE11} %{buildroot}%{_datadir}/mame/roms
|
||||
cp %{SOURCE12} %{buildroot}%{_datadir}/mame/roms
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/xmame
|
||||
%{_bindir}/xmame.x11
|
||||
%{_bindir}/chdman
|
||||
%{_bindir}/jedutil
|
||||
%{_bindir}/romcmp
|
||||
%{_bindir}/xml2info
|
||||
%dir %{_datadir}/mame/roms
|
||||
%{_datadir}/mame/roms/*
|
||||
%dir %{_datadir}/mame/artwork
|
||||
%dir %{_datadir}/mame/samples
|
||||
%dir %{_datadir}/mame/snap
|
||||
%dir %{_sysconfdir}/mame
|
||||
%{_sysconfdir}/mame/*
|
||||
%{_mandir}/man6/*
|
||||
|
||||
%changelog
|
||||
* Thu Sep 05 2013 Automatic Build System <autodist@mambasoft.it> 0.106-3mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Wed Dec 31 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.106-2mamba
|
||||
- added patch to load libGL.so.1 and libGLU.so.1 instead of libGL.so and libGLU.so
|
||||
|
||||
* Mon Jun 30 2008 gil <puntogil@libero.it> 0.106-1mamba
|
||||
- update to 0.106
|
||||
- added patch xmame-0.106-1make.patch ([xmame.obj/unix.x11/video-drivers/xv.o] Error 1)
|
||||
|
||||
* Mon Nov 21 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.101-1qilnx
|
||||
- update to version 0.101 by autospec
|
||||
- fixed package group
|
||||
|
||||
* Mon Mar 08 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.79.1-2qilnx
|
||||
- three distributable roms added
|
||||
|
||||
* Sun Mar 07 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.79.1-1qilnx
|
||||
- first build
|
203
xmamerc.dist
Normal file
203
xmamerc.dist
Normal file
@ -0,0 +1,203 @@
|
||||
### xmame running parameters ###
|
||||
|
||||
### Digital sound related ###
|
||||
# dsp-plugin <NULL> (not set)
|
||||
timer 0
|
||||
|
||||
### Sound mixer related ###
|
||||
# sound-mixer-plugin <NULL> (not set)
|
||||
|
||||
### Video Related ###
|
||||
video-mode 0
|
||||
heightscale 1
|
||||
widthscale 1
|
||||
autodouble 1
|
||||
artwork 1
|
||||
frameskipper 0
|
||||
throttle 1
|
||||
sleepidle 0
|
||||
autoframeskip 1
|
||||
maxautoframeskip 8
|
||||
frameskip 0
|
||||
brightness 1.000000
|
||||
gamma 1.000000
|
||||
|
||||
### Vector Games Related ###
|
||||
# vectorres <NULL> (not set)
|
||||
beam 1.000000
|
||||
flicker 0.000000
|
||||
antialias 1
|
||||
translucency 1
|
||||
|
||||
### X11-window Related ###
|
||||
cursor 1
|
||||
mitshm 1
|
||||
xsync 1
|
||||
#xil 1
|
||||
#mtxil 0
|
||||
run-in-root-window 0
|
||||
root_window_id 0
|
||||
#geometry 640x480
|
||||
|
||||
### XFree86 DGA Related ###
|
||||
|
||||
### Video Mode Selection Related ###
|
||||
keepaspect 1
|
||||
displayaspectratio 1.3333333333333
|
||||
|
||||
### X11-input related ###
|
||||
grabmouse 0
|
||||
winkeys 0
|
||||
|
||||
### Sound Related ###
|
||||
samples 1
|
||||
samplefreq 44100
|
||||
bufsize 3.000000
|
||||
volume -3
|
||||
# audiodevice <NULL> (not set)
|
||||
# mixerdevice <NULL> (not set)
|
||||
|
||||
### Input Related ###
|
||||
joytype 0
|
||||
analogstick 0
|
||||
|
||||
### Fileio Related ###
|
||||
rompath /usr/share/mame/roms
|
||||
snapshot_directory .
|
||||
cheat_file /usr/share/mame/cheat.dat
|
||||
hiscore_file /usr/share/mame/hiscore.dat
|
||||
|
||||
### Mame Related ###
|
||||
defaultgame robby
|
||||
language english
|
||||
fuzzycmp 1
|
||||
cheat 0
|
||||
# debug 0
|
||||
|
||||
### Frontend Related ###
|
||||
clones 1
|
||||
|
||||
### Internal verification list commands (only for developers) ###
|
||||
|
||||
### Rom Identification Related ###
|
||||
|
||||
### General Options ###
|
||||
|
||||
### X11 keymapping ###
|
||||
#
|
||||
# mapkey <Xcode>,<Scancode>
|
||||
#
|
||||
# Xcode means the HEX code of the key as appears in /usr/include/X11/keysymdef.h
|
||||
# Scancode means the hexadecimal code that represents the value used for Xmame
|
||||
# in keyboard inputs, as defined in src/unix/keyboard.h xmame source file
|
||||
# IMPORTANT:
|
||||
# 1- Due to some limitations, only LATIN-1 X-codes ( 0x0000-0x00ff ) and
|
||||
# Especial X-keycodes ( 0xff00-0xffff ) are supported
|
||||
# 2- Some keys are keyboard dependent: As Xmame works internally with
|
||||
# Standard US-AT keyboard codes, you must take care in remmaping some keys
|
||||
#
|
||||
|
||||
# An example: map space as "firebutton" (Mame predefines it as KEY_LCONTROL)
|
||||
# in symbolic Xlib/Mame notation it should be:
|
||||
#
|
||||
# mapkey XK_space,KEY_LCONTROL
|
||||
#
|
||||
# So, looking in X11/keysymdef.h and src/unix/keyboard.h, we'll write
|
||||
# mapkey 0x0020,0x001d
|
||||
#
|
||||
# (Other example). To use the F8 key to insert a coin, you should use
|
||||
# mapkey 0xffc5,0x0006
|
||||
|
||||
### Suggested German keymap mods by Peter Trauner.
|
||||
# <peter.trauner@jk.uni-linz.ac.at>
|
||||
#
|
||||
#mapkey 0xfe52,0x0029
|
||||
#mapkey 0x00df,0x000c
|
||||
#mapkey 0xfe51,0x000d
|
||||
#mapkey 0x00fc,0x001a
|
||||
#mapkey 0x002b,0x001b
|
||||
#mapkey 0x00f6,0x0027
|
||||
#mapkey 0x00e4,0x0028
|
||||
#mapkey 0x0023,0x002b
|
||||
#mapkey 0x0059,0x002c
|
||||
#mapkey 0x005a,0x0015
|
||||
#mapkey 0x002d,0x0035
|
||||
|
||||
### SDL keymapping ###
|
||||
#
|
||||
# sdlmapkey <SDLcode>,<Scancode>
|
||||
#
|
||||
# SDLcode means the HEX code of the key as it appears in
|
||||
# include/SDL/SDL_keysym.h
|
||||
# Scancode means the hexadecimal code that represents the value used for Xmame
|
||||
# in keyboard inputs, as defined in src/unix/keyboard.h xmame source file
|
||||
#
|
||||
|
||||
# An example: map space as "firebutton" (Mame predefines it as KEY_LCONTROL)
|
||||
# in symbolic SDL/Mame notation it should be:
|
||||
#
|
||||
# sdlmapkey SDLK_SPACE,KEY_LCONTROL
|
||||
#
|
||||
# So, looking in X11/keysymdef.h and src/unix/keyboard.h, we'll write
|
||||
# sdlmapkey 0x0020,0x001d
|
||||
#
|
||||
# (Other example). To use the F8 key to insert a coin, you should use
|
||||
# sdlmapkey 0x0121,0x0006
|
||||
|
||||
### Suggested French (azerty) SDL keymap mods by Luc Saillard.
|
||||
#
|
||||
# SDLK_WORLD_18 ² => KEY_TILDE
|
||||
#sdlmapkey 0x00b2,0x0029
|
||||
# SDLK_AMPERSAND => KEY_1
|
||||
#sdlmapkey 0x0026,0x0002
|
||||
# SDLK_WORLD_73 é => KEY_2
|
||||
#sdlmapkey 0x00e9,0x0003
|
||||
# SDLK_QUOTEDBL => KEY_3
|
||||
#sdlmapkey 0x0022,0x0004
|
||||
# SDLK_QUOTE => KEY_4
|
||||
#sdlmapkey 0x0027,0x0005
|
||||
# SDLK_LEFTPAREN => KEY_5
|
||||
#sdlmapkey 0x0028,0x0006
|
||||
# SDLK_MINUS => KEY_6
|
||||
#sdlmapkey 0x002d,0x0007
|
||||
# SDLK_WORLD_73 è => KEY_7
|
||||
#sdlmapkey 0x00e8,0x0008
|
||||
# SDLK_UNDERSCORE => KEY_8
|
||||
#sdlmapkey 0x005f,0x0009
|
||||
# SDLK_WORLD_71 ç => KEY_9
|
||||
#sdlmapkey 0x00e7,0x000a
|
||||
# SDLK_WORLD_64 à => KEY_10
|
||||
#sdlmapkey 0x00e0,0x000b
|
||||
# SDLK_RIGHTPAREN => KEY_11
|
||||
#sdlmapkey 0x0029,0x000c
|
||||
# SDLK_EQUALS => KEY_12
|
||||
#sdlmapkey 0x003d,0x000d
|
||||
|
||||
# SDLK_A => KEY_Q
|
||||
#sdlmapkey 0x0041,0x0010
|
||||
# SDLK_Z => KEY_W
|
||||
#sdlmapkey 0x005a,0x0011
|
||||
# SDLK_CARET => KEY_OPENBRACE
|
||||
#sdlmapkey 0x005e,0x001a
|
||||
# SDLK_DOLLAR => KEY_CLOSEBRACE
|
||||
#sdlmapkey 0x0024,0x001b
|
||||
|
||||
# SDLK_Q => KEY_A
|
||||
#sdlmapkey 0x0051,0x001e
|
||||
# SDLK_M => KEY_COLON
|
||||
#sdlmapkey 0x004d,0x0027
|
||||
# SDLK_WORLD_89 ù => KEY_QUOTE
|
||||
#sdlmapkey 0x00f9,0x0028
|
||||
# SDLK_ASTERISK => KEY_TILDE
|
||||
#sdlmapkey 0x002a,0x0029
|
||||
|
||||
# SDLK_W => KEY_Z
|
||||
#sdlmapkey 0x0057,0x002c
|
||||
# SDLK_COMMA => KEY_M
|
||||
#sdlmapkey 0x002c,0x0032
|
||||
# SDLK_SEMICOLON => KEY_COMMA
|
||||
#sdlmapkey 0x003b,0x0033
|
||||
# SDLK_COLON => KEY_STOP
|
||||
#sdlmapkey 0x003a,0x0034
|
||||
# SDLK_EXCLAIM => KEY_SLASH
|
||||
#sdlmapkey 0x0021,0x0035
|
Loading…
Reference in New Issue
Block a user