automatic version update by autodist [release 0.99.8-1mamba;Thu Mar 20 2014]
This commit is contained in:
parent
f4644857c8
commit
9c009ab585
@ -1,2 +1,9 @@
|
||||
# xine-ui
|
||||
|
||||
Xine is a free multimedia player.
|
||||
It plays back CDs, DVDs, and VCDs.
|
||||
It also decodes multimedia files like AVI, MOV, WMV, and MP3 from local disk drives, and displays multimedia streamed over the Internet.
|
||||
It interprets many of the most common multimedia formats available - and some of the most uncommon formats, too.
|
||||
|
||||
This package contains the GUI of the Xine multimedia player.
|
||||
|
||||
|
42
xine-ui-0.99.4-format_str.patch
Normal file
42
xine-ui-0.99.4-format_str.patch
Normal file
@ -0,0 +1,42 @@
|
||||
diff -pur xine-ui-0.99.5/src/xitk/main.c xine-ui-0.99.5-fix/src/xitk/main.c
|
||||
--- xine-ui-0.99.5/src/xitk/main.c 2005-07-24 04:40:37.000000000 +0200
|
||||
+++ xine-ui-0.99.5-fix/src/xitk/main.c 2006-04-28 14:42:58.000000000 +0200
|
||||
@@ -456,7 +456,7 @@ static void print_formatted(char *title,
|
||||
int len;
|
||||
char *blanks = " ";
|
||||
|
||||
- printf(title);
|
||||
+ printf("%s", title);
|
||||
|
||||
sprintf(buffer, "%s", blanks);
|
||||
plugin = *plugins++;
|
||||
@@ -469,7 +469,7 @@ static void print_formatted(char *title,
|
||||
sprintf(buffer, "%s%s%s", buffer, (strlen(buffer) == strlen(blanks)) ? "" : ", ", plugin);
|
||||
}
|
||||
else {
|
||||
- printf(buffer);
|
||||
+ printf("%s", buffer);
|
||||
printf(",\n");
|
||||
snprintf(buffer, sizeof(buffer), "%s%s", blanks, plugin);
|
||||
}
|
||||
@@ -478,7 +478,7 @@ static void print_formatted(char *title,
|
||||
}
|
||||
|
||||
if(strlen(buffer))
|
||||
- printf(buffer);
|
||||
+ printf("%s", buffer);
|
||||
|
||||
printf(".\n\n");
|
||||
}
|
||||
diff -pur xine-ui-0.99.5/src/xitk/xine-toolkit/xitk.c xine-ui-0.99.5-fix/src/xitk/xine-toolkit/xitk.c
|
||||
--- xine-ui-0.99.5/src/xitk/xine-toolkit/xitk.c 2005-05-21 00:02:05.000000000 +0200
|
||||
+++ xine-ui-0.99.5-fix/src/xitk/xine-toolkit/xitk.c 2006-04-28 14:43:25.000000000 +0200
|
||||
@@ -1877,7 +1877,7 @@ void xitk_init(Display *display, XColor
|
||||
sprintf(buffer, "%s%s", buffer, " ]-");
|
||||
|
||||
if(verbosity)
|
||||
- printf(buffer);
|
||||
+ printf("%s", buffer);
|
||||
|
||||
gXitk->wm_type = xitk_check_wm(display);
|
||||
|
50
xine-ui-0.99.5-mktemp.patch
Normal file
50
xine-ui-0.99.5-mktemp.patch
Normal file
@ -0,0 +1,50 @@
|
||||
diff -ru xine-ui-0.99.5/misc/xine-bugreport xine-ui-0.99.5-fix/misc/xine-bugreport
|
||||
--- xine-ui-0.99.5/misc/xine-bugreport 2005-07-26 18:38:34.000000000 +0000
|
||||
+++ xine-ui-0.99.5-fix/misc/xine-bugreport 2005-10-13 07:52:53.000000000 +0000
|
||||
@@ -14,18 +14,11 @@
|
||||
VERSION=0.9.12
|
||||
|
||||
COMMON_PLACES=/:/usr:/usr/local:/usr/local/xine:/usr/xine:/opt:/opt/xine:/usr/X11:/usr/X11R6
|
||||
-TMP_BASE=/tmp/xine-check.$$
|
||||
+TMP_BASE=`mktemp -d /tmp/xine-check.XXXXXXXX` ||
|
||||
+ { echo "Unable to create temp directory. Something is seriously wrong..." >&2
|
||||
+ exit 1; }
|
||||
|
||||
umask 077
|
||||
-i=1
|
||||
-while [ $i -lt 99 ] \
|
||||
- && tmpdir=$TMP_BASE.$i; mkdir $tmpdir; rc=$?; [ $rc != 0 ]; do
|
||||
- i=`expr $i + 1`
|
||||
-done
|
||||
-if [ $rc != 0 ]; then
|
||||
- echo "Unable to create temp directory. Something is seriously wrong..."
|
||||
- exit 1
|
||||
-fi
|
||||
|
||||
logfile=""
|
||||
bugreport=$tmpdir/xine-bugreport
|
||||
diff -ru xine-ui-0.99.5/misc/xine-check xine-ui-0.99.5-fix/misc/xine-check
|
||||
--- xine-ui-0.99.5/misc/xine-check 2005-07-26 18:38:34.000000000 +0000
|
||||
+++ xine-ui-0.99.5-fix/misc/xine-check 2005-10-13 07:53:00.000000000 +0000
|
||||
@@ -14,18 +14,11 @@
|
||||
VERSION=0.9.12
|
||||
|
||||
COMMON_PLACES=/:/usr:/usr/local:/usr/local/xine:/usr/xine:/opt:/opt/xine:/usr/X11:/usr/X11R6
|
||||
-TMP_BASE=/tmp/xine-check.$$
|
||||
+TMP_BASE=`mktemp -d /tmp/xine-check.XXXXXXXX` ||
|
||||
+ { echo "Unable to create temp directory. Something is seriously wrong..." >&2
|
||||
+ exit 1; }
|
||||
|
||||
umask 077
|
||||
-i=1
|
||||
-while [ $i -lt 99 ] \
|
||||
- && tmpdir=$TMP_BASE.$i; mkdir $tmpdir; rc=$?; [ $rc != 0 ]; do
|
||||
- i=`expr $i + 1`
|
||||
-done
|
||||
-if [ $rc != 0 ]; then
|
||||
- echo "Unable to create temp directory. Something is seriously wrong..."
|
||||
- exit 1
|
||||
-fi
|
||||
|
||||
logfile=""
|
||||
bugreport=$tmpdir/xine-bugreport
|
161
xine-ui.spec
Normal file
161
xine-ui.spec
Normal file
@ -0,0 +1,161 @@
|
||||
Name: xine-ui
|
||||
Version: 0.99.8
|
||||
Release: 1mamba
|
||||
Summary: Free multimedia player
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://xinehq.de/
|
||||
Source0: http://downloads.sourceforge.net/project/xine/xine-ui/%{version}/xine-ui-%{version}.tar.xz
|
||||
#Source0: http://dl.sf.net/xine/%{name}-%{version}.tar.gz
|
||||
Source1: xine-ui_desktopfile
|
||||
Patch0: %{name}-0.99.5-mktemp.patch
|
||||
Patch1: %{name}-0.99.4-format_str.patch
|
||||
License: GPL
|
||||
BuildRequires: gettext-devel >= 0.14.0
|
||||
#BuildRequires: Xorg-devel >= 6.8.0
|
||||
BuildRequires: libaa-devel >= 1.2
|
||||
BuildRequires: pkgconfig
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libcaca-devel >= 0.3
|
||||
BuildRequires: libcurl-devel >= 7.10.0
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libncurses-devel >= 5.4
|
||||
BuildRequires: libpng-devel >= 1.2.8
|
||||
BuildRequires: libreadline-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXft-devel
|
||||
BuildRequires: libxine1-devel >= 1.0.0
|
||||
BuildRequires: libXinerama-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libXxf86vm-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: lirc-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
|
||||
|
||||
# FIXME :
|
||||
# checking for nvtvsimple... *** nvtvsimple support will be disabled ***
|
||||
#Enable TV-Out on Linux for NVidia cards
|
||||
#URL: http://sourceforge.net/projects/nv-tv-out/
|
||||
%description
|
||||
Xine is a free multimedia player.
|
||||
It plays back CDs, DVDs, and VCDs.
|
||||
It also decodes multimedia files like AVI, MOV, WMV, and MP3 from local disk drives, and displays multimedia streamed over the Internet.
|
||||
It interprets many of the most common multimedia formats available - and some of the most uncommon formats, too.
|
||||
|
||||
This package contains the GUI of the Xine multimedia player.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1 -b .mktemp
|
||||
#%patch1 -p1 -b .format_str
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--x-libraries="%{_prefix}/X11R6/%{_lib}" \
|
||||
--program-prefix=""
|
||||
# --disable-lirc
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ %{buildroot} != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
install -D -m644 %{SOURCE1} %{buildroot}%{_datadir}/applications/%{name}.desktop
|
||||
|
||||
# move the docs back into place
|
||||
rm -fr rpm_xine-ui-doc
|
||||
mv %{buildroot}%{_docdir}/xine-ui rpm_xine-ui-doc
|
||||
mv %{buildroot}%{_datadir}/doc/xitk/README rpm_xine-ui-doc/README.xitk
|
||||
mkdir -p {buildroot}%{_datadir}
|
||||
%find_lang %{name}
|
||||
%find_lang xitk
|
||||
cat xitk.lang >> %{name}.lang
|
||||
|
||||
# remove unpackaged files
|
||||
rm -f %{buildroot}%{_datadir}/xine/desktop/xine.desktop
|
||||
|
||||
%clean
|
||||
[ %{buildroot} != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-, root, root)
|
||||
%{_bindir}/aaxine
|
||||
%{_bindir}/cacaxine
|
||||
%{_bindir}/fbxine
|
||||
%{_bindir}/xine
|
||||
%{_bindir}/xine-bugreport
|
||||
%{_bindir}/xine-check
|
||||
%{_bindir}/xine-remote
|
||||
%{_datadir}/applications/xine.desktop
|
||||
%{_datadir}/applications/%{name}.desktop
|
||||
%{_datadir}/mime/packages/xine-ui.xml
|
||||
%{_datadir}/icons/hicolor/*/apps/xine.png
|
||||
%{_datadir}/pixmaps/*
|
||||
%dir %{_datadir}/xine/
|
||||
%{_datadir}/xine/*
|
||||
%{_mandir}/man1/*
|
||||
%lang(de)%{_mandir}/de/man1/*
|
||||
%lang(es)%{_mandir}/es/man1/*
|
||||
%lang(fr)%{_mandir}/fr/man1/*
|
||||
%lang(pl)%{_mandir}/pl/man1/*
|
||||
%doc AUTHORS COPYING
|
||||
#ChangeLog NEWS README
|
||||
|
||||
%changelog
|
||||
* Thu Mar 20 2014 Automatic Build System <autodist@mambasoft.it> 0.99.8-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Feb 05 2013 Automatic Build System <autodist@mambasoft.it> 0.99.7-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jan 21 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.99.5-4mamba
|
||||
- rebuilt with recent glibc to fix missing strlcat symbol error
|
||||
|
||||
* Fri Jan 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.99.5-3mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Mon Oct 20 2008 gil <puntogil@libero.it> 0.99.5-2mamba
|
||||
- edit xine-ui_desktopfile (Icon=xine)
|
||||
|
||||
* Mon Jun 30 2008 gil <puntogil@libero.it> 0.99.5-1mamba
|
||||
- update to 0.99.5
|
||||
- removed xine-ui-0.99.4-format_str.patch, buildrequires Xorg-devel
|
||||
- edit xine-ui-0.99.5-mktemp.patch
|
||||
|
||||
* Thu May 18 2006 Davide Madrisan <davide.madrisan@qilinux.it> 0.99.4-3qilnx
|
||||
- rebuilt to replace the version uploaded in the devel-contrib repository
|
||||
|
||||
* Fri Apr 28 2006 Davide Madrisan <davide.madrisan@qilinux.it> 0.99.4-2qilnx
|
||||
- new desktop file (stolen from kappfinder)
|
||||
- use %%find_lang macro
|
||||
- fixed some format string vulnerabilities (CVE-2006-1905, qibug#159)
|
||||
|
||||
* Thu Oct 13 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.99.4-1qilnx
|
||||
- update to version 0.99.4 by autospec
|
||||
- fixed package group
|
||||
- use rpm macros
|
||||
- desktop file modified
|
||||
- fixed insecure creation of temporary files (xine-check, xine-bugreport)
|
||||
|
||||
* Mon Dec 20 2004 Davide Madrisan <davide.madrisan@qilinux.it> 0.99.3-1qilnx
|
||||
- update to version 0.99.3 by autospec
|
||||
- modified package group
|
||||
- conditionally remove buildroot directory
|
||||
- set program prefix to "" when running configure
|
||||
- added locales and related build requirement
|
||||
- own `%{_datadir}/xine/' directory
|
||||
- added basic documentation (COPYING, ...)
|
||||
- specfile cleanups
|
||||
|
||||
* Tue Oct 19 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.99.2-2qilnx
|
||||
- rebuilt and moved from devel-contrib to devel
|
||||
|
||||
* Wed Sep 22 2004 Matteo Bernasconi <voyagernm@virgilio.it> 0.99.2-1qilnx
|
||||
- first build
|
90
xine-ui_desktopfile
Normal file
90
xine-ui_desktopfile
Normal file
@ -0,0 +1,90 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
GenericName=Video Player
|
||||
GenericName[af]=Video Speler
|
||||
GenericName[ar]=مشغل ملفات فيديو
|
||||
GenericName[az]=Video Çalğıcısı
|
||||
GenericName[be]=Прайгравальнік відэа
|
||||
GenericName[bg]=Видео плеър
|
||||
GenericName[bn]=ভিডিও প্রদর্শক
|
||||
GenericName[br]=Ur soner Video
|
||||
GenericName[bs]=Video preglednik
|
||||
GenericName[ca]=Reproductor de vídeo
|
||||
GenericName[cs]=Přehrávač videa
|
||||
GenericName[cy]=Chwaraewr Fideo
|
||||
GenericName[da]=Videoafspiller
|
||||
GenericName[de]=Ein Abspielprogramm für Videos
|
||||
GenericName[el]=Αναπαραγωγέας βίντεο
|
||||
GenericName[eo]=Ludilo por videofilmoj
|
||||
GenericName[es]=Reproductor de vídeo
|
||||
GenericName[et]=Videofailide mängimine
|
||||
GenericName[eu]=Bideo erreproduzigailua
|
||||
GenericName[fa]=پخشکنندهی ویدیو
|
||||
GenericName[fi]=Videosoitin
|
||||
GenericName[fr]=Lecteur vidéo
|
||||
GenericName[fy]=Fideospiler
|
||||
GenericName[ga]=Fístaispeántóir
|
||||
GenericName[gl]=Reprodutor de Vídeo
|
||||
GenericName[he]=נגן וידאו
|
||||
GenericName[hi]=वीडियो प्लेयर
|
||||
GenericName[hu]=Videólejátszó
|
||||
GenericName[id]=Player Video
|
||||
GenericName[is]=Forrit til að spila kvikmyndir
|
||||
GenericName[it]=Lettore di video
|
||||
GenericName[ja]=ビデオプレーヤー
|
||||
GenericName[km]=កម្មវិធីចាក់វីដេអូ
|
||||
GenericName[ko]=비디오 연주기
|
||||
GenericName[lo]=ເຄືອ່ງຫລິ້ນວີດີໂອ
|
||||
GenericName[lt]=Vaizdo grotuvas
|
||||
GenericName[lv]=Video Atskaņotājs
|
||||
GenericName[mk]=Видео пуштач
|
||||
GenericName[mn]=Видео тоглуулагч
|
||||
GenericName[ms]=Pemain Video
|
||||
GenericName[mt]=Plejer tal-Video
|
||||
GenericName[nb]=Videospiller
|
||||
GenericName[nds]=Video-Afspeler
|
||||
GenericName[nl]=Videospeler
|
||||
GenericName[nn]=Videospelar
|
||||
GenericName[nso]=Sebapadi sa Video
|
||||
GenericName[oc]=Reproductor de video
|
||||
GenericName[pa]=ਵੀਡਿਓ ਪਲੇਅਰ
|
||||
GenericName[pl]=Odtwarzacz Video
|
||||
GenericName[pt]=Reprodutor de Vídeo
|
||||
GenericName[pt_BR]=Reprodutor de vídeos
|
||||
GenericName[ro]=Program de redare video
|
||||
GenericName[ru]=Видео плейер
|
||||
GenericName[rw]=Igikina Videwo
|
||||
GenericName[se]=Videočuojan
|
||||
GenericName[sk]=Video prehrávač
|
||||
GenericName[sl]=Predvajalnik videov
|
||||
GenericName[sr]=Видео приказивач
|
||||
GenericName[sr@Latn]=Video prikazivač
|
||||
GenericName[ss]=Sidlali mafilimu
|
||||
GenericName[sv]=Filmspelare
|
||||
GenericName[ta]=ஒளி-ஒலி சாதனம்
|
||||
GenericName[tg]=Плейери видео
|
||||
GenericName[th]=โปรแกรมเล่นภาพยนตร์
|
||||
GenericName[tr]=Görüntü Yürütücüsü
|
||||
GenericName[tt]=Video Uynatqıç
|
||||
GenericName[uk]=Програвач відео-файлів
|
||||
GenericName[uz]=Видео плейер
|
||||
GenericName[ven]=Tshitambisa Vidio
|
||||
GenericName[vi]=Trình xem Video
|
||||
GenericName[wa]=Djouweu di fitchîs videyo
|
||||
GenericName[xh]=Umdlali we Video
|
||||
GenericName[zh_CN]=视频播放器
|
||||
GenericName[zh_TW]=視像檔播放程式
|
||||
GenericName[zu]=Umdlali we-Vidiyo
|
||||
Exec=xine %f
|
||||
Icon=xine
|
||||
MimeType=video/mpeg;video/quicktime;video/x-flic;video/x-msvideo;video/x-ogm;video/x-theora;video/mp4
|
||||
Name=Xine
|
||||
Name[ar]=زاين
|
||||
Name[fa]=زاین
|
||||
Name[hi]=एक्साइन
|
||||
Name[lo]=ສຸວັນທອງ
|
||||
Name[vi]=Xine
|
||||
ServiceTypes=
|
||||
Type=Application
|
||||
Categories=Application;AudioVideo;Player;
|
||||
|
Loading…
Reference in New Issue
Block a user