rebuilt with same libxen majver to fix deps on older version [release 4.17.2-2mamba;Sun Oct 15 2023]

This commit is contained in:
Silvan Calarco 2024-01-05 19:36:43 +01:00
parent 9d110e229b
commit 72005411de
2 changed files with 39 additions and 11 deletions

View File

@ -0,0 +1,9 @@
--- xen-4.17.2/tools/qemu-xen/pc-bios/keymaps/meson.build.orig 2023-09-15 23:49:33.793961304 +0200
+++ xen-4.17.2/tools/qemu-xen/pc-bios/keymaps/meson.build 2023-09-15 23:49:46.415988646 +0200
@@ -1,5 +1,5 @@
keymaps = {
- 'ar': '-l ar',
+ 'ar': '-l ara',
'bepo': '-l fr -v dvorak',
'cz': '-l cz',
'da': '-l dk',

View File

@ -1,7 +1,7 @@
%define bigver %(echo %version | cut -d. -f1)
%define majver %(echo %version | cut -d. -f1-2)
Name: xen
Version: 4.16.2
Version: 4.17.2
Release: 2mamba
Summary: An high performing server virtualization software
Group: Applications/Emulators
@ -19,12 +19,14 @@ Patch4: xen-4.2.2-qemu-configure.patch
Patch5: xen-4.2.2-gcc-4.7.patch
Patch6: xen-4.2.2-qemu-remove-CFLAGS.patch
Patch7: xen-4.7.0-gcc-6.1.0.patch
Patch8: xen-4.17.2-xkeyboard-config-2.39.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libSDL2-devel
BuildRequires: libX11-devel
BuildRequires: libaio-devel
BuildRequires: libalsa-devel
BuildRequires: libbrltty-devel
BuildRequires: libbzip2-devel
BuildRequires: libcacard-devel
@ -33,12 +35,14 @@ BuildRequires: libcap-ng-devel
BuildRequires: libcurl-devel
BuildRequires: libe2fs-devel
BuildRequires: libepoxy-devel
BuildRequires: libfdt-devel
BuildRequires: libfuse3-devel
BuildRequires: libgcc
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel
BuildRequires: libgnutls-devel
BuildRequires: libgtk3-devel
BuildRequires: libjack-devel
BuildRequires: libjpeg-devel
BuildRequires: liblzma-devel
BuildRequires: liblzo-devel
@ -57,6 +61,7 @@ BuildRequires: libpython3-devel
BuildRequires: libsasl2-devel
BuildRequires: libsdl2_image-devel
BuildRequires: libseccomp-devel
BuildRequires: libselinux-devel
BuildRequires: libsnappy-devel
BuildRequires: libspice-devel
BuildRequires: libssh-devel
@ -71,11 +76,12 @@ BuildRequires: libyajl-devel
BuildRequires: libz-devel
BuildRequires: libzstd-devel
## AUTOBUILDREQ-END
BuildRequires: libxen >= %{majver}
BuildRequires: libmultipath-tools-devel >= 0:0.9.4-1mamba
BuildRequires: ocaml-findlib
Requires: bridge-utils
Requires: python
Requires: libxen = %{version}-%{release}
Requires: libxen = %{?epoch:%epoch:}%{version}-%{release}
%description
With Xen virtualization, a thin software layer known as the Xen hypervisor is inserted between the servers hardware and the operating system. This provides an abstraction layer that allows each physical server to run one or more “virtual servers,” effectively decoupling the operating system and its applications from the underlying physical server.
@ -92,7 +98,7 @@ This package contains the dynamic libraries used by Xen.
%package -n libxen-devel
Summary: Static libraries and header files for Xen
Requires: libxen = %{version}-%{release}
Requires: libxen = %{?epoch:%epoch:}%{version}-%{release}
Group: Development/Libraries
Provides: xen-devel
Obsoletes: xen-devel < 4.16.0
@ -111,10 +117,11 @@ With Xen virtualization, a thin software layer known as the Xen hypervisor is in
Once a virtual server image has been created it can run on any server, at any time, and multiple virtual servers can simultaneously share a single server, increasing its utilization while receiving a resource guarantee that ensures that application layer performance criteria are met.
This package contains the python bindings.
%debug_package
%prep
%setup -q
#-D -T
#:<< _EOF
%setup -q -D -T
:<< _EOF
#%patch1 -p1
#%patch2 -p1
#%patch3 -p1
@ -122,22 +129,22 @@ This package contains the python bindings.
#%patch5 -p1
#%patch6 -p1
#%patch7 -p1
%patch 8 -p1
%build
#:<< _EOF
:<< _EOF
ld -v | grep gold && {
echo "ERROR: gold linker detected, this package requires standard ld; aborting."
exit 1
}
export CFLAGS_FIX="$(echo %optflags | sed 's|-m64||g;s|-mtune=generic||g')"
#export CFLAGS_FIX="$(echo %optflags | sed 's|-m64||g;s|-mtune=generic||g')"
%ifarch x86_64
make %{_smp_mflags} xen
%else
XEN_TARGET_ARCH=x86_64 make %{_smp_mflags} CROSS_COMPILE=x86_64-openmamba-linux-gnu- xen
%endif
#_EOF
%configure \
--disable-ocamltools \
@ -146,7 +153,10 @@ export CFLAGS_FIX="$(echo %optflags | sed 's|-m64||g;s|-mtune=generic||g')"
--disable-golang
%endif
%make tools docs -j1
_EOF
# FIXME: sad but true as of 4.17.2
make tools docs || make tools docs
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
@ -237,7 +247,7 @@ rm -f %{buildroot}%{_datadir}/qemu-xen/qemu/hppa-firmware.img
%{_sbindir}/xl
%{_prefix}/lib/modules-load.d/xen.conf
%{_unitdir}/proc-xen.mount
%{_unitdir}/var-lib-xenstored.mount
#%{_unitdir}/var-lib-xenstored.mount
%{_unitdir}/xen-init-dom0.service
%{_unitdir}/xen-qemu-dom0-disk-backend.service
%{_unitdir}/xen-watchdog.service
@ -301,6 +311,15 @@ rm -f %{buildroot}%{_datadir}/qemu-xen/qemu/hppa-firmware.img
%{python3_sitearch}/pygrub-*.egg-info
%changelog
* Sun Oct 15 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 4.17.2-2mamba
- rebuilt with same libxen majver to fix deps on older version
* Sun Sep 03 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 4.17.2-1mamba
- update to 4.17.2
* Thu Dec 29 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 4.17.0-1mamba
- update to 4.17.0
* Mon Dec 26 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 4.16.2-2mamba
- rebuilt by autoport with build requirements: libmultipath-tools-devel>=0:0.9.4-1mamba