automatic version update by autodist [release 4.18.0-1mamba;Thu Mar 14 2024]

This commit is contained in:
Automatic Build System 2024-03-23 11:17:21 +01:00
parent 72005411de
commit 10a68e03f4
10 changed files with 21 additions and 246 deletions

View File

@ -1,20 +0,0 @@
diff -Nru xen-3.1.0-src.orig/tools/libxc/xc_core.c xen-3.1.0-src/tools/libxc/xc_core.c
--- xen-3.1.0-src.orig/tools/libxc/xc_core.c 2007-05-18 16:45:21.000000000 +0200
+++ xen-3.1.0-src/tools/libxc/xc_core.c 2007-06-22 18:47:13.000000000 +0200
@@ -192,12 +192,14 @@
if ( sheaders->num == sheaders->num_max )
{
Elf64_Shdr *shdrs;
- if ( sheaders->num_max + SHDR_INC < sheaders->num_max )
+
+ sheaders->num_max += SHDR_INC;
+ if ( sheaders->num_max < SHDR_INC )
{
errno = E2BIG;
return NULL;
}
- sheaders->num_max += SHDR_INC;
+
shdrs = realloc(sheaders->shdrs,
sizeof(sheaders->shdrs[0]) * sheaders->num_max);
if ( shdrs == NULL )

View File

@ -1,33 +0,0 @@
--- xen-4.1.2/tools/libxc/xc_dom_boot.c.orig 2013-05-29 17:56:31.336771949 +0200
+++ xen-4.1.2/tools/libxc/xc_dom_boot.c 2013-05-29 17:54:38.353087947 +0200
@@ -265,7 +265,7 @@
return rc;
/* let the vm run */
- memset(ctxt, 0, sizeof(ctxt));
+ memset(ctxt, 0, sizeof(*ctxt));
if ( (rc = dom->arch_hooks->vcpu(dom, ctxt)) != 0 )
return rc;
xc_dom_unmap_all(dom);
--- xen-4.1.2/tools/blktap2/drivers/md5.c.orig 2013-05-29 18:12:16.545606480 +0200
+++ xen-4.1.2/tools/blktap2/drivers/md5.c 2013-05-29 18:11:29.410164715 +0200
@@ -174,7 +174,7 @@
MD5Transform(ctx->buf, (uint32_t *) ctx->in);
byteReverse((unsigned char *) ctx->buf, 4);
memcpy(digest, ctx->buf, 16);
- memset(ctx, 0, sizeof(ctx)); /* In case it's sensitive */
+ memset(ctx, 0, sizeof(*ctx)); /* In case it's sensitive */
}
/* The four core functions - F1 is optimized somewhat */
--- xen-4.1.2/tools/xenstat/libxenstat/src/xenstat_linux.c.orig 2013-05-29 18:13:04.107043178 +0200
+++ xen-4.1.2/tools/xenstat/libxenstat/src/xenstat_linux.c 2013-05-29 18:07:34.835942468 +0200
@@ -113,7 +113,7 @@
/* Initialize all variables called has passed as non-NULL to zeros */
if (iface != NULL)
- memset(iface, 0, sizeof(iface));
+ memset(iface, 0, sizeof(*iface));
if (rxBytes != NULL)
*rxBytes = 0;
if (rxPackets != NULL)

View File

@ -1,31 +0,0 @@
gcc 4.8 gives the following error when building xen/common/compat/memory.c
memory.c: In function 'compat_memory_op':
/builddir/build/BUILD/xen-4.2.1/xen/include/public/arch-x86/xen.h:35:33: error: typedef '__guest_handle_const_compat_memory_exchange_t' locally defined but not used [-Werror=unused-local-typedefs]
typedef struct { type *p; } __guest_handle_ ## name
^
/builddir/build/BUILD/xen-4.2.1/xen/include/public/arch-x86/xen.h:43:5: note: in expansion of macro '___DEFINE_XEN_GUEST_HANDLE'
___DEFINE_XEN_GUEST_HANDLE(const_##name, const type)
^
/builddir/build/BUILD/xen-4.2.1/xen/include/public/arch-x86/xen.h:44:41: note: in expansion of macro '__DEFINE_XEN_GUEST_HANDLE'
#define DEFINE_XEN_GUEST_HANDLE(name) __DEFINE_XEN_GUEST_HANDLE(name, name)
^
memory.c:261:13: note: in expansion of macro 'DEFINE_XEN_GUEST_HANDLE'
DEFINE_XEN_GUEST_HANDLE(compat_memory_exchange_t);
^
The error is harmless in this case so turn the check off.
Signed-off-by: Michael Young <m.a.young@xxxxxxxxxxxx>
--- xen-4.2.1/Config.mk.orig 2013-02-07 21:11:51.603970255 +0000
+++ xen-4.2.1/Config.mk 2013-02-07 21:51:44.992048787 +0000
@@ -156,7 +156,7 @@
CFLAGS += -std=gnu99
-CFLAGS += -Wall -Wstrict-prototypes
+CFLAGS += -Wall -Wstrict-prototypes -Wno-unused-local-typedefs
# Clang complains about macros that expand to 'if ( ( foo == bar ) ) ...'
# and is over-zealous with the printf format lint

View File

@ -1,9 +0,0 @@
--- xen-4.17.2/tools/qemu-xen/pc-bios/keymaps/meson.build.orig 2023-09-15 23:49:33.793961304 +0200
+++ xen-4.17.2/tools/qemu-xen/pc-bios/keymaps/meson.build 2023-09-15 23:49:46.415988646 +0200
@@ -1,5 +1,5 @@
keymaps = {
- 'ar': '-l ar',
+ 'ar': '-l ara',
'bepo': '-l fr -v dvorak',
'cz': '-l cz',
'da': '-l dk',

View File

@ -1,30 +0,0 @@
# HG changeset patch
# User Olaf Hering <olaf@xxxxxxxxx>
# Date 1354786108 -3600
# Node ID 5dab922f04f4790b70d43d062114bddcc1bb7de6
# Parent 670b07e8d7382229639af0d1df30071e6c1ebb19
tools/gdbsx: fix build failure with glibc-2.17
[ 1029s] xg_main.c: In function '_domctl_hcall':
[ 1029s] xg_main.c:181:52: error: 'ulong' undeclared (first use in this
function)
[ 1029s] xg_main.c:181:52: note: each undeclared identifier is reported only
once for each function it appears in
[ 1029s] xg_main.c: In function '_check_hyp':
[ 1029s] xg_main.c:221:52: error: 'ulong' undeclared (first use in this
function)
[ 1029s] make[4]: *** [xg_main.o] Error 1
Signed-off-by: Olaf Hering <olaf@xxxxxxxxx>
diff -r 670b07e8d738 -r 5dab922f04f4 tools/debugger/gdbsx/xg/xg_main.c
--- a/tools/debugger/gdbsx/xg/xg_main.c
+++ b/tools/debugger/gdbsx/xg/xg_main.c
@@ -34,6 +34,7 @@
* XGTRC(): generic trace utility
*/
+#include <sys/types.h>
#include <stdio.h>
#include <stddef.h>
#include <stdarg.h>

View File

@ -1,32 +0,0 @@
diff --git xen-4.2.2/tools/qemu-xen/configure xen-4.2.2/tools/qemu-xen/configure
index 24778bf..947fa3f 100755
--- xen-4.2.2/tools/qemu-xen/configure.orig 2013-04-06 01:39:54.000000000 +0200
+++ xen-4.2.2/tools/qemu-xen/configure 2013-05-30 01:37:45.490314092 +0200
@@ -2463,11 +2463,14 @@
cat > $TMPC <<EOF
#include <signal.h>
#include <time.h>
-int main(void) { clockid_t id; return clock_gettime(id, NULL); }
+int main(void) {
+ timer_t timer; struct itimerspec timeout; timer_settime(timer, 0, &timeout, NULL);
+ clockid_t id; return clock_gettime(id, NULL);
+}
EOF
if compile_prog "" "" ; then
- :
+ LIBS="-lrt $LIBS"
elif compile_prog "" "-lrt" ; then
LIBS="-lrt $LIBS"
fi
--- xen-4.2.2/tools/qemu-xen-traditional/configure.orig 2013-05-30 01:57:46.182064602 +0200
+++ xen-4.2.2/tools/qemu-xen-traditional/configure 2013-05-30 01:58:20.425657638 +0200
@@ -1102,7 +1102,7 @@
rt=no
if $cc $ARCH_CFLAGS -o $TMPE $TMPC > /dev/null 2> /dev/null ; then
- :
+ rt=yes
elif $cc $ARCH_CFLAGS -o $TMPE $TMPC -lrt > /dev/null 2> /dev/null ; then
rt=yes
fi

View File

@ -1,10 +0,0 @@
--- xen-4.2.2/tools/Makefile.orig 2013-05-30 03:04:27.029917107 +0200
+++ xen-4.2.2/tools/Makefile 2013-05-30 03:04:53.093610079 +0200
@@ -187,6 +187,7 @@
source=.; \
fi; \
cd qemu-xen-dir; \
+ env -u CFLAGS \
$$source/configure --enable-xen --target-list=i386-softmmu \
--source-path=$$source \
--extra-cflags="-I$(XEN_ROOT)/tools/include \

View File

@ -1,28 +0,0 @@
--- xen-4.2.2/tools/qemu-xen/qemu-options.hx.orig 2013-05-08 15:18:06.824805369 +0200
+++ xen-4.2.2/tools/qemu-xen/qemu-options.hx 2013-05-08 15:19:01.540111255 +0200
@@ -1518,18 +1518,13 @@
devices.
Syntax for specifying a sheepdog device
-@table @list
-``sheepdog:<vdiname>''
-
-``sheepdog:<vdiname>:<snapid>''
-
-``sheepdog:<vdiname>:<tag>''
-
-``sheepdog:<host>:<port>:<vdiname>''
-
-``sheepdog:<host>:<port>:<vdiname>:<snapid>''
-
-``sheepdog:<host>:<port>:<vdiname>:<tag>''
+@table @code
+@item sheepdog:<vdiname>
+@item sheepdog:<vdiname>:<snapid>
+@item sheepdog:<vdiname>:<tag>
+@item sheepdog:<host>:<port>:<vdiname>
+@item sheepdog:<host>:<port>:<vdiname>:<snapid>
+@item sheepdog:<host>:<port>:<vdiname>:<tag>
@end table
Example

View File

@ -1,23 +0,0 @@
diff -Nru xen-4.7.0.orig/tools/firmware/etherboot/patches/series xen-4.7.0/tools/firmware/etherboot/patches/series
--- xen-4.7.0.orig/tools/firmware/etherboot/patches/series 2016-06-20 12:38:15.000000000 +0200
+++ xen-4.7.0/tools/firmware/etherboot/patches/series 2016-07-23 18:36:18.960739191 +0200
@@ -4,3 +4,4 @@
build_fix_3.patch
build-compare.patch
build_fix_4.patch
+xen-4.7.0-gcc-6.1.0.patch
diff -Nru xen-4.7.0.orig/tools/firmware/etherboot/patches/xen-4.7.0-gcc-6.1.0.patch xen-4.7.0/tools/firmware/etherboot/patches/xen-4.7.0-gcc-6.1.0.patch
--- xen-4.7.0.orig/tools/firmware/etherboot/patches/xen-4.7.0-gcc-6.1.0.patch 1970-01-01 01:00:00.000000000 +0100
+++ xen-4.7.0/tools/firmware/etherboot/patches/xen-4.7.0-gcc-6.1.0.patch 2016-07-23 18:23:50.625305190 +0200
@@ -0,0 +1,11 @@
+--- ipxe/src/Makefile.orig 2016-07-22 17:36:50.011196369 +0200
++++ ipxe/src/Makefile 2016-07-22 17:30:08.345532878 +0200
+@@ -165,7 +165,7 @@
+ CFLAGS += -DVERSION_MAJOR=$(VERSION_MAJOR) \
+ -DVERSION_MINOR=$(VERSION_MINOR) \
+ -DVERSION_PATCH=$(VERSION_PATCH) \
+- -DVERSION=\"$(VERSION)\"
++ -DVERSION=\"$(VERSION)\" -Wno-error=nonnull-compare -Wno-error=unused-const-variable -Wno-error=shift-negative-value -Wno-error=array-bounds -Wno-error=tautological-compare
+ IDENT = '$(@F) $(VERSION) (GPL) ipxe.org'
+ version :
+ @$(ECHO) $(VERSION)

View File

@ -1,8 +1,8 @@
%define bigver %(echo %version | cut -d. -f1) %define bigver %(echo %version | cut -d. -f1)
%define majver %(echo %version | cut -d. -f1-2) %define majver %(echo %version | cut -d. -f1-2)
Name: xen Name: xen
Version: 4.17.2 Version: 4.18.0
Release: 2mamba Release: 1mamba
Summary: An high performing server virtualization software Summary: An high performing server virtualization software
Group: Applications/Emulators Group: Applications/Emulators
Vendor: openmamba Vendor: openmamba
@ -11,15 +11,6 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://xenproject.org/ URL: https://xenproject.org/
Source: https://downloads.xenproject.org/release/xen/%{version}/xen-%{version}.tar.gz Source: https://downloads.xenproject.org/release/xen/%{version}/xen-%{version}.tar.gz
Source1: xen-grub-conf-07_xen Source1: xen-grub-conf-07_xen
Patch0: %{name}-3.1.0-gcc4.patch
Patch1: xen-4.1.2-gcc-4.8.patch
Patch2: xen-4.1.2-gcc-4.8-2.patch
Patch3: xen-4.2.2-qemu-texinfo-5.patch
Patch4: xen-4.2.2-qemu-configure.patch
Patch5: xen-4.2.2-gcc-4.7.patch
Patch6: xen-4.2.2-qemu-remove-CFLAGS.patch
Patch7: xen-4.7.0-gcc-6.1.0.patch
Patch8: xen-4.17.2-xkeyboard-config-2.39.patch
License: GPL License: GPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
@ -33,6 +24,7 @@ BuildRequires: libcacard-devel
BuildRequires: libcairo-devel BuildRequires: libcairo-devel
BuildRequires: libcap-ng-devel BuildRequires: libcap-ng-devel
BuildRequires: libcurl-devel BuildRequires: libcurl-devel
BuildRequires: libdw-devel
BuildRequires: libe2fs-devel BuildRequires: libe2fs-devel
BuildRequires: libepoxy-devel BuildRequires: libepoxy-devel
BuildRequires: libfdt-devel BuildRequires: libfdt-devel
@ -44,6 +36,7 @@ BuildRequires: libgnutls-devel
BuildRequires: libgtk3-devel BuildRequires: libgtk3-devel
BuildRequires: libjack-devel BuildRequires: libjack-devel
BuildRequires: libjpeg-devel BuildRequires: libjpeg-devel
BuildRequires: libkeyutils-devel
BuildRequires: liblzma-devel BuildRequires: liblzma-devel
BuildRequires: liblzo-devel BuildRequires: liblzo-devel
BuildRequires: libmesa-devel BuildRequires: libmesa-devel
@ -57,12 +50,13 @@ BuildRequires: libpam-devel
BuildRequires: libpixman-devel BuildRequires: libpixman-devel
BuildRequires: libpng-devel BuildRequires: libpng-devel
BuildRequires: libpulseaudio-devel BuildRequires: libpulseaudio-devel
BuildRequires: libpython3-devel BuildRequires: libpython311-devel
BuildRequires: libsasl2-devel BuildRequires: libsasl2-devel
BuildRequires: libsdl2_image-devel BuildRequires: libsdl2_image-devel
BuildRequires: libseccomp-devel BuildRequires: libseccomp-devel
BuildRequires: libselinux-devel BuildRequires: libselinux-devel
BuildRequires: libsnappy-devel BuildRequires: libsnappy-devel
BuildRequires: libsndio-devel
BuildRequires: libspice-devel BuildRequires: libspice-devel
BuildRequires: libssh-devel BuildRequires: libssh-devel
BuildRequires: libsystemd-devel BuildRequires: libsystemd-devel
@ -70,13 +64,14 @@ BuildRequires: libudev-devel
BuildRequires: libusb-devel BuildRequires: libusb-devel
BuildRequires: libusbredir-devel BuildRequires: libusbredir-devel
BuildRequires: libuuid-devel BuildRequires: libuuid-devel
BuildRequires: libvirglrenderer-devel
BuildRequires: libvte-devel BuildRequires: libvte-devel
BuildRequires: libxkbcommon-devel BuildRequires: libxkbcommon-devel
BuildRequires: libyajl-devel BuildRequires: libyajl-devel
BuildRequires: libz-devel BuildRequires: libz-devel
BuildRequires: libzstd-devel BuildRequires: libzstd-devel
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
BuildRequires: libxen >= %{majver} #BuildRequires: libxen >= %{majver}
BuildRequires: libmultipath-tools-devel >= 0:0.9.4-1mamba BuildRequires: libmultipath-tools-devel >= 0:0.9.4-1mamba
BuildRequires: ocaml-findlib BuildRequires: ocaml-findlib
Requires: bridge-utils Requires: bridge-utils
@ -120,19 +115,12 @@ This package contains the python bindings.
%debug_package %debug_package
%prep %prep
%setup -q -D -T %setup -q
:<< _EOF #-D -T
#%patch1 -p1 #:<< _EOF
#%patch2 -p1
#%patch3 -p1
#%patch4 -p1
#%patch5 -p1
#%patch6 -p1
#%patch7 -p1
%patch 8 -p1
%build %build
:<< _EOF #:<< _EOF
ld -v | grep gold && { ld -v | grep gold && {
echo "ERROR: gold linker detected, this package requires standard ld; aborting." echo "ERROR: gold linker detected, this package requires standard ld; aborting."
exit 1 exit 1
@ -153,10 +141,8 @@ ld -v | grep gold && {
--disable-golang --disable-golang
%endif %endif
_EOF # FIXME: compilation completes only when run from terminal
%make tools docs
# FIXME: sad but true as of 4.17.2
make tools docs || make tools docs
%install %install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}" [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
@ -190,6 +176,8 @@ rm -f %{buildroot}%{_datadir}/qemu-xen/qemu/opensbi-riscv*generic*.elf
rm -f %{buildroot}%{_datadir}/qemu-xen/qemu/palcode-clipper rm -f %{buildroot}%{_datadir}/qemu-xen/qemu/palcode-clipper
rm -f %{buildroot}%{_datadir}/qemu-xen/qemu/hppa-firmware.img rm -f %{buildroot}%{_datadir}/qemu-xen/qemu/hppa-firmware.img
%find_lang %{name} --all-name
%clean %clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}" [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
@ -204,7 +192,7 @@ rm -f %{buildroot}%{_datadir}/qemu-xen/qemu/hppa-firmware.img
%post -n libxen -p /sbin/ldconfig %post -n libxen -p /sbin/ldconfig
%postun -n libxen -p /sbin/ldconfig %postun -n libxen -p /sbin/ldconfig
%files %files -f %{name}.lang
%defattr(-,root,root) %defattr(-,root,root)
%config(noreplace) %{_sysconfdir}/sysconfig/xencommons %config(noreplace) %{_sysconfdir}/sysconfig/xencommons
%config(noreplace) %{_sysconfdir}/sysconfig/xendomains %config(noreplace) %{_sysconfdir}/sysconfig/xendomains
@ -223,7 +211,7 @@ rm -f %{buildroot}%{_datadir}/qemu-xen/qemu/hppa-firmware.img
%{_bindir}/xen-cpuid %{_bindir}/xen-cpuid
%{_bindir}/xen-detect %{_bindir}/xen-detect
%{_bindir}/xenalyze %{_bindir}/xenalyze
%{_bindir}/xencons #%{_bindir}/xencons
%{_bindir}/xencov_split %{_bindir}/xencov_split
%{_bindir}/xenstore %{_bindir}/xenstore
%{_bindir}/xenstore-chmod %{_bindir}/xenstore-chmod
@ -311,6 +299,9 @@ rm -f %{buildroot}%{_datadir}/qemu-xen/qemu/hppa-firmware.img
%{python3_sitearch}/pygrub-*.egg-info %{python3_sitearch}/pygrub-*.egg-info
%changelog %changelog
* Thu Mar 14 2024 Automatic Build System <autodist@openmamba.org> 4.18.0-1mamba
- automatic version update by autodist
* Sun Oct 15 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 4.17.2-2mamba * Sun Oct 15 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 4.17.2-2mamba
- rebuilt with same libxen majver to fix deps on older version - rebuilt with same libxen majver to fix deps on older version