xdg-utils-cxx/xdg-utils-cxx.spec

83 lines
2.4 KiB
RPMSpec

Name: xdg-utils-cxx
Version: 1.0.1
Release: 1mamba
Summary: Implementation of the FreeDesktop specifications to be used in c++ projects
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://github.com/azubieta/xdg-utils-cxx
Source: https://github.com/azubieta/xdg-utils-cxx.git/v%{version}/xdg-utils-cxx-%{version}.tar.bz2
Patch0: xdg-utils-cxx-1.0.1-fix_so_version.patch
Patch1: xdg-utils-cxx-1.0.1-fix_install_path.patch
License: MIT
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgcc
BuildRequires: libstdc++6-devel
## AUTOBUILDREQ-END
BuildRequires: cmake
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
%description
Implementation of the FreeDesktop specifications to be used in c++ projects.
%package -n lib%{name}
Group: System/Libraries
Summary: Shared libraries for %{name}
%description -n lib%{name}
Implementation of the FreeDesktop specifications to be used in c++ projects.
This package contains shared libraries for %{name}.
%package -n lib%{name}-devel
Group: Development/Libraries
Summary: Development files for %{name}
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n lib%{name}-devel
Implementation of the FreeDesktop specifications to be used in c++ projects.
This package contains libraries and header files for developing applications that use %{name}.
%debug_package
%prep
%setup -q
%patch 0 -p1 -b .fix_so_version
%patch 1 -p1 -b .fix_install_path
%build
%cmake \
-DXDG_UTILS_SHARED=ON
%cmake_build
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%cmake_install
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n lib%{name} -p /sbin/ldconfig
%postun -n lib%{name} -p /sbin/ldconfig
%files -n lib%{name}
%defattr(-,root,root)
%{_libdir}/libXdgUtilsBaseDir.so.*
%{_libdir}/libXdgUtilsDesktopEntry.so.*
%doc LICENSE
%files -n lib%{name}-devel
%defattr(-,root,root)
%dir %{_includedir}/XdgUtils
%{_includedir}/XdgUtils/*
%{_libdir}/libXdgUtilsBaseDir.so
%{_libdir}/libXdgUtilsDesktopEntry.so
%dir %{_libdir}/cmake/XdgUtils
%{_libdir}/cmake/XdgUtils/XdgUtils*.cmake
%doc README.md
%changelog
* Wed Aug 30 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.1-1mamba
- package created using the webbuild interface