automatic update to 2.8.8 by autodist [release 2.8.8-1mamba;Sun May 30 2010]
This commit is contained in:
parent
453ca49e0d
commit
5661a47648
@ -1,2 +1,4 @@
|
||||
# xchat
|
||||
|
||||
XChat is an IRC chat program for both Linux and Windows. It allows you to join multiple IRC channels (chat rooms) at the same time, talk publicly, private one-on-one conversations etc. Even file transfers are possible.
|
||||
|
||||
|
62
xchat-2.8.8-glib-2.31.patch
Normal file
62
xchat-2.8.8-glib-2.31.patch
Normal file
@ -0,0 +1,62 @@
|
||||
Author: Dominique Leuenberger <dimstar@opensuse.org>
|
||||
|
||||
http://sourceforge.net/tracker/?func=detail&aid=3446968&group_id=239&atid=100239
|
||||
|
||||
glib got stricter in checking includes. Only glib.h (and a few exceptions)
|
||||
are to be included directly.
|
||||
|
||||
Index: xchat-2.8.8/src/common/servlist.c
|
||||
===================================================================
|
||||
--- xchat-2.8.8.orig/src/common/servlist.c
|
||||
+++ xchat-2.8.8/src/common/servlist.c
|
||||
@@ -24,7 +24,7 @@
|
||||
#include <unistd.h>
|
||||
|
||||
#include "xchat.h"
|
||||
-#include <glib/ghash.h>
|
||||
+#include <glib.h>
|
||||
|
||||
#include "cfgfiles.h"
|
||||
#include "fe.h"
|
||||
Index: xchat-2.8.8/src/common/text.c
|
||||
===================================================================
|
||||
--- xchat-2.8.8.orig/src/common/text.c
|
||||
+++ xchat-2.8.8/src/common/text.c
|
||||
@@ -28,7 +28,7 @@
|
||||
#include <sys/mman.h>
|
||||
|
||||
#include "xchat.h"
|
||||
-#include <glib/ghash.h>
|
||||
+#include <glib.h>
|
||||
#include "cfgfiles.h"
|
||||
#include "chanopt.h"
|
||||
#include "plugin.h"
|
||||
Index: xchat-2.8.8/src/common/util.c
|
||||
===================================================================
|
||||
--- xchat-2.8.8.orig/src/common/util.c
|
||||
+++ xchat-2.8.8/src/common/util.c
|
||||
@@ -39,7 +39,7 @@
|
||||
#include <errno.h>
|
||||
#include "xchat.h"
|
||||
#include "xchatc.h"
|
||||
-#include <glib/gmarkup.h>
|
||||
+#include <glib.h>
|
||||
#include <ctype.h>
|
||||
#include "util.h"
|
||||
#include "../../config.h"
|
||||
Index: xchat-2.8.8/src/common/xchat.h
|
||||
===================================================================
|
||||
--- xchat-2.8.8.orig/src/common/xchat.h
|
||||
+++ xchat-2.8.8/src/common/xchat.h
|
||||
@@ -1,10 +1,6 @@
|
||||
#include "../../config.h"
|
||||
|
||||
-#include <glib/gslist.h>
|
||||
-#include <glib/glist.h>
|
||||
-#include <glib/gutils.h>
|
||||
-#include <glib/giochannel.h>
|
||||
-#include <glib/gstrfuncs.h>
|
||||
+#include <glib.h>
|
||||
#include <time.h> /* need time_t */
|
||||
|
||||
#ifndef XCHAT_H
|
101
xchat.spec
Normal file
101
xchat.spec
Normal file
@ -0,0 +1,101 @@
|
||||
%define xchatmajver %(echo %version | cut -d. -f 1-2)
|
||||
Name: xchat
|
||||
Version: 2.8.8
|
||||
Release: 1mamba
|
||||
Summary: An IRC chat program based on the GTK+ toolkit
|
||||
Group: Graphical Desktop/Applications/Internet
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.xchat.org/
|
||||
Source: http://www.xchat.org/files/source/%{xchatmajver}/xchat-%{version}.tar.bz2
|
||||
Patch0: xchat-2.8.8-glib-2.31.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libdbus-glib-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libglib-devel >= 2.8.6
|
||||
BuildRequires: libglitz-devel
|
||||
BuildRequires: libgtk-devel >= 2.8.17
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpixman-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libsexy-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libxcb-util-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: perl-devel >= 2:5.8.8
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libpython-devel >= 2.4.3
|
||||
BuildRequires: dbus >= 0.50
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
XChat is an IRC chat program for both Linux and Windows. It allows you to join multiple IRC channels (chat rooms) at the same time, talk publicly, private one-on-one conversations etc. Even file transfers are possible.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
# http://bbs.archlinux.org/viewtopic.php?id=58151
|
||||
sed -i 's/GtkType/GType/' src/fe-gtk/xtext.{c,h}
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-socks \
|
||||
--enable-ipv6
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/gconf/schemas/apps_xchat_url_handler.schemas
|
||||
%{_bindir}/xchat
|
||||
%dir %{_libdir}/xchat
|
||||
%dir %{_libdir}/xchat/plugins
|
||||
%{_libdir}/xchat/plugins/*
|
||||
%{_datadir}/dbus-1/services/org.xchat.service.service
|
||||
%{_datadir}/applications/xchat.desktop
|
||||
%{_datadir}/pixmaps/xchat.png
|
||||
%doc COPYING
|
||||
#ChangeLog README
|
||||
|
||||
%changelog
|
||||
* Sun May 30 2010 Automatic Build System <autodist@mambasoft.it> 2.8.8-1mamba
|
||||
- automatic update to 2.8.8 by autodist
|
||||
|
||||
* Wed Jun 03 2009 Automatic Build System <autodist@mambasoft.it> 2.8.6-3mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Wed Jun 03 2009 Automatic Build System <autodist@mambasoft.it> 2.8.6-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Tue Jun 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.6-1mamba
|
||||
- update to 2.8.6
|
||||
- enabled ipv6 and socks support
|
||||
|
||||
* Mon Jun 02 2008 gil <puntogil@libero.it> 2.8.4-1mamba
|
||||
- update to version 2.8.4
|
||||
|
||||
* Sun Jul 30 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.6-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user