update to 0.98alpha16 [release 0.98alpha16-1mamba;Sun Aug 25 2013]

This commit is contained in:
Automatic Build System 2024-01-05 19:33:41 +01:00
parent 8d1f41f836
commit e5d900dea1
4 changed files with 210 additions and 0 deletions

View File

@ -1,2 +1,6 @@
# xcdroast
X-CD-Roast provides a GUI interface for commands like cdrecord and mkisofs. X-CD-Roast includes a self-explanatory X11 user interface,
automatic SCSI and IDE hardware setup, support for mastering of new ISO9660 data CDs, support for production of new audio CDs, fast
copying of CDs without hard disk buffering, and a logfile option.

View File

@ -0,0 +1,20 @@
--- src/xtools.c 2003-11-06 11:19:10.000000000 +0100
+++ src/xtools.c 2004-01-04 14:48:09.000000000 +0100
@@ -3635,7 +3635,7 @@
return str;
#else
gchar *locstr;
-gint in, out;
+gsize in, out;
locstr = g_locale_from_utf8(str, strlen(str), &in, &out, NULL);
if (locstr) {
@@ -3655,7 +3655,7 @@
return str;
#else
gchar *locstr;
-gint in, out;
+gsize in, out;
/* ok, if your filesystem is already UTF8 we are not
allowed to change the filenames here. */

View File

@ -0,0 +1,95 @@
diff -u xcdroast-0.98alpha15/configure xcdroast-0.98alpha15.new/configure
--- xcdroast-0.98alpha15/configure 2003-10-26 00:51:45.000000000 +0200
+++ xcdroast-0.98alpha15.new/configure 2003-11-05 23:03:23.000000000 +0100
@@ -4361,55 +4361,6 @@
LIBS="$LIBS $PKGCONFIG_LIBS"
CFLAGS="$CFLAGS $PKGCONFIG_CFLAGS"
- # Extract the first word of "pcre-config", so it can be a program name with args.
-set dummy pcre-config; ac_word=$2
-echo "$as_me:$LINENO: checking for $ac_word" >&5
-echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
-if test "${ac_cv_path_PCRE_CONFIG+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
- case $PCRE_CONFIG in
- [\\/]* | ?:[\\/]*)
- ac_cv_path_PCRE_CONFIG="$PCRE_CONFIG" # Let the user override the test with a path.
- ;;
- *)
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
- ac_cv_path_PCRE_CONFIG="$as_dir/$ac_word$ac_exec_ext"
- echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
-done
-
- test -z "$ac_cv_path_PCRE_CONFIG" && ac_cv_path_PCRE_CONFIG="no"
- ;;
-esac
-fi
-PCRE_CONFIG=$ac_cv_path_PCRE_CONFIG
-
-if test -n "$PCRE_CONFIG"; then
- echo "$as_me:$LINENO: result: $PCRE_CONFIG" >&5
-echo "${ECHO_T}$PCRE_CONFIG" >&6
-else
- echo "$as_me:$LINENO: result: no" >&5
-echo "${ECHO_T}no" >&6
-fi
-
- if test "x$PCRE_CONFIG" = "xno" ; then
- { { echo "$as_me:$LINENO: error: pcre-config not found please install libpcre3-dev or similar" >&5
-echo "$as_me: error: pcre-config not found please install libpcre3-dev or similar" >&2;}
- { (exit 1); exit 1; }; }
- else
- LIBS="$LIBS `$PCRE_CONFIG --libs`"
- CFLAGS="$CFLAGS `$PCRE_CONFIG --cflags`"
- fi
-
else
@@ -9249,7 +9200,6 @@
s,@PKG_CONFIG@,$PKG_CONFIG,;t t
s,@PKGCONFIG_CFLAGS@,$PKGCONFIG_CFLAGS,;t t
s,@PKGCONFIG_LIBS@,$PKGCONFIG_LIBS,;t t
-s,@PCRE_CONFIG@,$PCRE_CONFIG,;t t
s,@GLIB_CONFIG@,$GLIB_CONFIG,;t t
s,@GLIB_CFLAGS@,$GLIB_CFLAGS,;t t
s,@GLIB_LIBS@,$GLIB_LIBS,;t t
diff -u xcdroast-0.98alpha15/configure.in xcdroast-0.98alpha15.new/configure.in
--- xcdroast-0.98alpha15/configure.in 2003-10-25 23:29:34.000000000 +0200
+++ xcdroast-0.98alpha15.new/configure.in 2003-11-05 23:02:25.000000000 +0100
@@ -105,14 +105,6 @@
LIBS="$LIBS $PKGCONFIG_LIBS"
CFLAGS="$CFLAGS $PKGCONFIG_CFLAGS"
- AC_PATH_PROG(PCRE_CONFIG, pcre-config, no)
- if test "x$PCRE_CONFIG" = "xno" ; then
- AC_MSG_ERROR(pcre-config not found please install libpcre3-dev or similar)
- else
- LIBS="$LIBS `$PCRE_CONFIG --libs`"
- CFLAGS="$CFLAGS `$PCRE_CONFIG --cflags`"
- fi
-
else
dnl pure plain GTK+-1.2.x support
Gemeinsame Unterverzeichnisse: xcdroast-0.98alpha15/contrib und xcdroast-0.98alpha15.new/contrib.
Gemeinsame Unterverzeichnisse: xcdroast-0.98alpha15/doc und xcdroast-0.98alpha15.new/doc.
Gemeinsame Unterverzeichnisse: xcdroast-0.98alpha15/extra und xcdroast-0.98alpha15.new/extra.
Gemeinsame Unterverzeichnisse: xcdroast-0.98alpha15/intl und xcdroast-0.98alpha15.new/intl.
Gemeinsame Unterverzeichnisse: xcdroast-0.98alpha15/lib und xcdroast-0.98alpha15.new/lib.
Gemeinsame Unterverzeichnisse: xcdroast-0.98alpha15/m4 und xcdroast-0.98alpha15.new/m4.
Gemeinsame Unterverzeichnisse: xcdroast-0.98alpha15/man und xcdroast-0.98alpha15.new/man.
Gemeinsame Unterverzeichnisse: xcdroast-0.98alpha15/po und xcdroast-0.98alpha15.new/po.
Gemeinsame Unterverzeichnisse: xcdroast-0.98alpha15/src und xcdroast-0.98alpha15.new/src.
Gemeinsame Unterverzeichnisse: xcdroast-0.98alpha15/xpms und xcdroast-0.98alpha15.new/xpms.

91
xcdroast.spec Normal file
View File

@ -0,0 +1,91 @@
Summary: An X Window System based tool for creating CDs
Name: xcdroast
Version: 0.98alpha16
Release: 1mamba
Group: Graphical Desktop/Applications/Multimedia
Vendor: openmamba
Distribution: openmamba
Packager: Fabio Giani <fabio.giani@gmail.com>
URL: http://www.xcdroast.org/
Source: http://downloads.sourceforge.net/project/xcdroast/xcdroast/%{version}/xcdroast-%{version}.tar.gz
Patch1: xcdroast-0.98alpha15-64bit_gsize.patch
Patch2: xcdroast-0.98alpha15-conf.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libatk-devel
BuildRequires: libcairo-devel
BuildRequires: libglib-devel
BuildRequires: libgtk-devel
BuildRequires: libpango-devel
## AUTOBUILDREQ-END
BuildRequires: libgdk-pixbuf-devel
BuildRoot: /var/tmp/%{name}-root
%description
X-CD-Roast provides a GUI interface for commands like cdrecord and mkisofs. X-CD-Roast includes a self-explanatory X11 user interface,
automatic SCSI and IDE hardware setup, support for mastering of new ISO9660 data CDs, support for production of new audio CDs, fast
copying of CDs without hard disk buffering, and a logfile option.
%prep
%setup -q
#%patch1 -p0 -b .64bit
#%patch2 -p1 -b .conf
%build
%configure --enable-gtk2
make PREFIX=%{_prefix} CC="gcc $RPM_OPT_FLAGS"
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
mkdir -p $RPM_BUILD_ROOT/{etc/{X11/applnk/Multimedia,pam.d,security/console.apps},usr/sbin}
%makeinstall
# Create the system menu entry
mkdir -p %{buildroot}%{_datadir}/applications
cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
[Desktop Entry]
Encoding=UTF-8
Name=CD Writer
GenericName=CD creation tool
Comment=CD creation tool
Exec=xcdroast
Icon=%{_libdir}/xcdroast-0.98/icons/xcdricon.png
Comment=Create a CD
Categories=Application;AudioVideo;
Type=Application
Terminal=false
EOF
%find_lang %name
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f %{name}.lang
%defattr(-,root,root)
%{_bindir}/*
%dir %{_libdir}/xcdroast-0.98
%{_libdir}/xcdroast-0.98/*
%{_mandir}/man?/xcdroast*
%{_datadir}/applications/%{name}.desktop
#%doc ChangeLog doc/DOCUMENTATION doc/FAQ doc/README* doc/TRANSLATION.HOWTO
%changelog
* Sun Aug 25 2013 Automatic Build System <autodist@mambasoft.it> 0.98alpha16-1mamba
- update to 0.98alpha16
* Sun Aug 25 2013 Automatic Build System <autodist@mambasoft.it> 0.9.8a16-1mamba
- update to 0.9.8a16
* Sun Aug 25 2013 Automatic Build System <autodist@mambasoft.it> 0.98a15-4mamba
- automatic rebuild by autodist
* Sun Jun 22 2008 Fabio Giani <fabio.giani@gmail.com> 0.98a15-3mamba
- update system menu, buildrequirements, Vendor, Distribution and Packager
* Tue Jun 21 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.98a15-2qilnx
- rebuild and moved from devel-contrib repository to devel repository
* Thu Sep 23 2004 Matteo Bernasconi <voyagernm@virgilio.it> 0.98a15-1qilnx
- First Build