update to 3.1.2 [release 3.1.2-1mamba;Sat Oct 21 2023]

This commit is contained in:
Silvan Calarco 2024-01-05 19:32:44 +01:00
parent 4d62354afa
commit 024a5d2907
11 changed files with 614 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# xbase
Xbase is a collection of specifications, programs, utilities and a C++ class library for manipulating Xbase type datafiles and indices.

20
xbase-2.0.0-ppc.patch Normal file
View File

@ -0,0 +1,20 @@
--- xbase-2.0.0/ltconfig.foo 2007-05-04 18:14:42.000000000 -0400
+++ xbase-2.0.0/ltconfig 2007-05-04 18:15:39.000000000 -0400
@@ -1664,16 +1664,7 @@ linux-gnu*)
shlibpath_var=LD_LIBRARY_PATH
check_shared_deplibs_method='file_magic ELF 32-bit LSB shared object'
sys_lib_search_path="/lib /usr/lib /usr/local/lib `echo $LD_LIBRARY_PATH | sed -e 's/:/ /g'`"
-
- if test -f /lib/ld.so.1; then
- dynamic_linker='GNU ld.so'
- else
- # Only the GNU ld.so supports shared libraries on MkLinux.
- case "$host_cpu" in
- powerpc*) dynamic_linker=no ;;
- *) dynamic_linker='Linux ld.so' ;;
- esac
- fi
+ dynamic_linker='GNU ld.so'
;;
netbsd* | openbsd*)

View File

@ -0,0 +1,12 @@
diff -up xbase64-3.1.2/configure.in.verfix xbase64-3.1.2/configure.in
--- xbase64-3.1.2/configure.in.verfix 2017-02-20 09:44:55.702420764 -0500
+++ xbase64-3.1.2/configure.in 2017-02-20 09:45:05.838144610 -0500
@@ -74,7 +74,7 @@ AC_SUBST(RHREL)
# get G++ version
if test "$GXX" = "yes"; then
- GXXVER=`${CXX} -v 2>&1 | grep version | cut -d " " -f 3 -`
+ GXXVER=`${CXX} -v 2>&1 | grep "gcc version" | cut -d " " -f 3 -`
GXXVER="gcc${GXXVER}"
else
GXXVER=""

View File

@ -0,0 +1,12 @@
diff -up xbase64-3.1.2/xbase64-config.in.BAD xbase64-3.1.2/xbase64-config.in
--- xbase64-3.1.2/xbase64-config.in.BAD 2009-08-19 22:58:42.081087534 -0400
+++ xbase64-3.1.2/xbase64-config.in 2009-08-19 22:58:45.604090002 -0400
@@ -5,7 +5,7 @@ exec_prefix=@exec_prefix@
exec_prefix_set=no
CC="@CC@"
CXX="@CXX@"
-LD="@SHARED_LD@"
+LD="@LD@"
usage="\
Usage: xbase-config [--prefix[=DIR]] [--exec-prefix[=DIR]] [--version] [--libs] [--cflags] [--cc] [--cxx] [--ld]"

24
xbase-3.1.2-gcc44.patch Normal file
View File

@ -0,0 +1,24 @@
diff -up xbase64-3.1.2/xbase64/xbase64.cpp.gcc44 xbase64-3.1.2/xbase64/xbase64.cpp
--- xbase64-3.1.2/xbase64/xbase64.cpp.gcc44 2006-07-17 12:54:42.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbase64.cpp 2009-08-19 23:08:14.724079392 -0400
@@ -66,6 +66,8 @@
#include <dos.h>
#endif
+#include <cerrno>
+
/*! \file xbase64.cpp
*/
diff -up xbase64-3.1.2/xbase64/xblock.cpp.gcc44 xbase64-3.1.2/xbase64/xblock.cpp
--- xbase64-3.1.2/xbase64/xblock.cpp.gcc44 2009-08-19 23:08:59.408186578 -0400
+++ xbase64-3.1.2/xbase64/xblock.cpp 2009-08-19 23:09:11.416184844 -0400
@@ -65,6 +65,8 @@
//#include <stdio.h>
//#include <stdlib.h>
+#include <cerrno>
+
/*! \file xblock.cpp
*/
#ifdef XB_LOCKING_ON

21
xbase-3.1.2-gcc47.patch Normal file
View File

@ -0,0 +1,21 @@
diff -up xbase64-3.1.2/bin/dumprecs.cpp.gcc47 xbase64-3.1.2/bin/dumprecs.cpp
--- xbase64-3.1.2/bin/dumprecs.cpp.gcc47 2012-01-05 15:36:00.377536998 -0500
+++ xbase64-3.1.2/bin/dumprecs.cpp 2012-01-05 15:36:15.198399295 -0500
@@ -70,7 +70,7 @@ int main(int ac,char** av)
return 1;
}
- for(int i=1; i<ac; ++i){
+ for(int i=1; i<ac; ++i){{
char* filename = av[i];
xbDbf MyFile( &x );
@@ -91,7 +91,7 @@ int main(int ac,char** av)
x.DisplayError( rc );
}
MyFile.CloseDatabase(); /* close database */
- }
+ }}
return 0;
}

49
xbase-3.1.2-gcc6.patch Normal file
View File

@ -0,0 +1,49 @@
diff -up xbase64-3.1.2/xbase64/xblock.cpp.gcc6 xbase64-3.1.2/xbase64/xblock.cpp
--- xbase64-3.1.2/xbase64/xblock.cpp.gcc6 2016-02-16 16:06:40.146864585 -0500
+++ xbase64-3.1.2/xbase64/xblock.cpp 2016-02-16 16:07:51.137342339 -0500
@@ -84,7 +84,7 @@ xbLock::xbLock(xbDbf * pdbf)
TableLockCnt = 0;
MemoLockCnt = 0;
IndexLockCnt = 0;
- std::cout << "xbLock constructor" << std::cout;
+ std::cout << "xbLock constructor";
}
/*************************************************************************/
xbLock::~xbLock()
@@ -169,7 +169,7 @@ else if( LockType == XB_LOCK || LockType
/*************************************************************************/
xbaseLock::xbaseLock( xbDbf * pdbf ) : xbLock( pdbf )
{
- std::cout << "xbaseLock constructor" << std::cout;
+ std::cout << "xbaseLock constructor";
}
/*************************************************************************/
xbShort xbaseLock::LockTableHeader( xbShort LockType )
@@ -336,7 +336,7 @@ xbShort xbaseLock::LockInit()
/*************************************************************************/
dbaseLock::dbaseLock( xbDbf * pdbf ) : xbLock( pdbf )
{
- std::cout << "dbaseLock constructor" << std::cout;
+ std::cout << "dbaseLock constructor";
}
/*************************************************************************/
xbShort dbaseLock::LockTableHeader( xbShort LockType )
@@ -460,7 +460,7 @@ xbShort dbaseLock::UnlockAll()
/*************************************************************************/
clipperLock::clipperLock( xbDbf * pdbf ) : xbLock( pdbf )
{
- std::cout << "clipperLock constructor" << std::cout;
+ std::cout << "clipperLock constructor";
}
/*************************************************************************/
xbShort clipperLock::LockTableHeader( xbShort LockType )
@@ -523,7 +523,7 @@ xbShort clipperLock::UnlockAll()
/*************************************************************************/
foxproLock::foxproLock( xbDbf * pdbf ) : xbLock( pdbf )
{
- std::cout << "foxproLock constructor" << std::cout;
+ std::cout << "foxproLock constructor";
}
/*************************************************************************/
xbShort foxproLock::LockTableHeader( xbShort LockType )
diff -up xbase64-3.1.2/xbase64/xblock.h.gcc6 xbase64-3.1.2/xbase64/xblock.h

34
xbase-3.1.2-gcc7.patch Normal file
View File

@ -0,0 +1,34 @@
diff -up xbase64-3.1.2/bin/dbfutil1.cpp.gcc7 xbase64-3.1.2/bin/dbfutil1.cpp
--- xbase64-3.1.2/bin/dbfutil1.cpp.gcc7 2017-02-20 09:59:36.135561103 -0500
+++ xbase64-3.1.2/bin/dbfutil1.cpp 2017-02-20 10:00:32.743218194 -0500
@@ -157,7 +157,8 @@ void MyClass::SetFilter()
memset( Expression, 0x00, 512 );
while( !strlen( Expression )){
std::cout << "Enter filter expression (like AMOUNT<5)" << std::endl;
- gets( Expression );
+ fgets( Expression, sizeof(Expression), stdin );
+ strtok( Expression, "\n" );
}
if( xbf )
delete xbf;
@@ -247,7 +248,8 @@ void MyClass::ProcessExpression()
while( !strstr( exprsn, "QUIT" ) && !strstr( exprsn, "quit" )){
std::cout << ">";
- gets( exprsn );
+ fgets( exprsn, sizeof(exprsn), stdin );
+ strtok( exprsn, "\n" );
if( strstr( exprsn, "HELP" ) || strstr( exprsn, "help" )){
std::cout << "** Command Help ***" << std::endl << std::endl;
diff -up xbase64-3.1.2/xbase64/xbase64.h.gcc7 xbase64-3.1.2/xbase64/xbase64.h
--- xbase64-3.1.2/xbase64/xbase64.h.gcc7 2017-02-20 09:49:07.063609482 -0500
+++ xbase64-3.1.2/xbase64/xbase64.h 2017-02-20 09:57:36.586618723 -0500
@@ -53,6 +53,7 @@
#endif
#include <string.h>
+#include <cstdio>
#if defined(__WIN32__)
#include "windows.h"

294
xbase-3.1.2-lesserg.patch Normal file
View File

@ -0,0 +1,294 @@
diff -up xbase64-3.1.2/xbase64/xbase64.cpp.lesserg xbase64-3.1.2/xbase64/xbase64.cpp
--- xbase64-3.1.2/xbase64/xbase64.cpp.lesserg 2012-01-05 15:31:01.695312436 -0500
+++ xbase64-3.1.2/xbase64/xbase64.cpp 2012-01-05 15:31:01.717312232 -0500
@@ -38,7 +38,7 @@
*/
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma implementation "xbase64.h"
#endif
diff -up xbase64-3.1.2/xbase64/xbase64.h.lesserg xbase64-3.1.2/xbase64/xbase64.h
--- xbase64-3.1.2/xbase64/xbase64.h.lesserg 2006-07-17 12:54:50.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbase64.h 2012-01-05 15:31:01.718312223 -0500
@@ -42,7 +42,7 @@
#ifndef __XB_XBASE_H__
#define __XB_XBASE_H__
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma interface
#endif
@@ -60,7 +60,7 @@
// ripped from wxWindows
// _declspec works in BC++ 5 and later, as well as VC++
-#if defined(__VISUALC__) || defined(__BORLANDC__) || defined(__GNU LesserC__)
+#if defined(__VISUALC__) || defined(__BORLANDC__) || defined(__GNU_LesserC__)
# ifdef XBMAKINGDLL
# define XBDLLEXPORT __declspec( dllexport )
# define XBDLLEXPORT_DATA(type) __declspec( dllexport ) type
diff -up xbase64-3.1.2/xbase64/xbcdx.h.lesserg xbase64-3.1.2/xbase64/xbcdx.h
--- xbase64-3.1.2/xbase64/xbcdx.h.lesserg 2012-01-05 15:32:17.398608985 -0500
+++ xbase64-3.1.2/xbase64/xbcdx.h 2012-01-05 15:32:43.051370614 -0500
@@ -50,7 +50,7 @@ struct CdxInnerNode: public CdxNode
{
char keys[500];
}
-#ifdef __GNU LesserC__
+#ifdef __GNU_LesserC__
__attribute__((packed))
#endif
;
@@ -67,7 +67,7 @@ struct CdxLeafNode: public CdxNode
char byteCount;
char keys[488];
}
-#ifdef __GNU LesserC__
+#ifdef __GNU_LesserC__
__attribute__((packed))
#endif
;
diff -up xbase64-3.1.2/xbase64/xbdate.cpp.lesserg xbase64-3.1.2/xbase64/xbdate.cpp
--- xbase64-3.1.2/xbase64/xbdate.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbdate.cpp 2012-01-05 15:31:01.719312213 -0500
@@ -40,7 +40,7 @@
*/
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma implementation "xbdate.h"
#endif
diff -up xbase64-3.1.2/xbase64/xbdate.h.lesserg xbase64-3.1.2/xbase64/xbdate.h
--- xbase64-3.1.2/xbase64/xbdate.h.lesserg 2006-07-17 12:54:50.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbdate.h 2012-01-05 15:31:01.721312195 -0500
@@ -45,7 +45,7 @@
#ifndef __XB_XBDATE_H__
#define __XB_XBDATE_H__
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma interface
#endif
diff -up xbase64-3.1.2/xbase64/xbdbf.cpp.lesserg xbase64-3.1.2/xbase64/xbdbf.cpp
--- xbase64-3.1.2/xbase64/xbdbf.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbdbf.cpp 2012-01-05 15:31:01.722312185 -0500
@@ -39,7 +39,7 @@
*/
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma implementation "xbdbf.h"
#endif
diff -up xbase64-3.1.2/xbase64/xbdbf.h.lesserg xbase64-3.1.2/xbase64/xbdbf.h
--- xbase64-3.1.2/xbase64/xbdbf.h.lesserg 2006-07-17 12:54:50.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbdbf.h 2012-01-05 15:31:01.723312175 -0500
@@ -41,7 +41,7 @@
#ifndef __XB_DBF_H__
#define __XB_DBF_H__
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma interface
#endif
diff -up xbase64-3.1.2/xbase64/xbexp.cpp.lesserg xbase64-3.1.2/xbase64/xbexp.cpp
--- xbase64-3.1.2/xbase64/xbexp.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbexp.cpp 2012-01-05 15:31:01.725312157 -0500
@@ -38,7 +38,7 @@
*/
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma implementation "xbexp.h"
#endif
diff -up xbase64-3.1.2/xbase64/xbexp.h.lesserg xbase64-3.1.2/xbase64/xbexp.h
--- xbase64-3.1.2/xbase64/xbexp.h.lesserg 2006-07-17 12:54:50.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbexp.h 2012-01-05 15:31:01.726312148 -0500
@@ -42,7 +42,7 @@
#ifndef __XB_EXP_H__
#define __XB_EXP_H__
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma interface
#endif
diff -up xbase64-3.1.2/xbase64/xbfile.cpp.lesserg xbase64-3.1.2/xbase64/xbfile.cpp
--- xbase64-3.1.2/xbase64/xbfile.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbfile.cpp 2012-01-05 15:31:01.727312139 -0500
@@ -39,7 +39,7 @@
*/
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma implementation "xbfile.h"
#endif
diff -up xbase64-3.1.2/xbase64/xbfile.h.lesserg xbase64-3.1.2/xbase64/xbfile.h
--- xbase64-3.1.2/xbase64/xbfile.h.lesserg 2006-07-17 12:54:50.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbfile.h 2012-01-05 15:31:01.728312130 -0500
@@ -45,7 +45,7 @@
#ifndef __XB_FILE_H__
#define __XB_FILE_H__
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma interface
#endif
diff -up xbase64-3.1.2/xbase64/xbfilter.cpp.lesserg xbase64-3.1.2/xbase64/xbfilter.cpp
--- xbase64-3.1.2/xbase64/xbfilter.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbfilter.cpp 2012-01-05 15:31:01.729312120 -0500
@@ -38,7 +38,7 @@
*/
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma implementation "xbfilter.h"
#endif
diff -up xbase64-3.1.2/xbase64/xbfilter.h.lesserg xbase64-3.1.2/xbase64/xbfilter.h
--- xbase64-3.1.2/xbase64/xbfilter.h.lesserg 2006-07-17 12:54:50.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbfilter.h 2012-01-05 15:31:01.731312101 -0500
@@ -44,7 +44,7 @@
#ifndef __XB_FILTER_H__
#define __XB_FILTER_H__
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma interface
#endif
diff -up xbase64-3.1.2/xbase64/xbindex.cpp.lesserg xbase64-3.1.2/xbase64/xbindex.cpp
--- xbase64-3.1.2/xbase64/xbindex.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbindex.cpp 2012-01-05 15:31:01.732312092 -0500
@@ -37,7 +37,7 @@
USA
*/
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma implementation "xbindex.h"
#endif
diff -up xbase64-3.1.2/xbase64/xbindex.h.lesserg xbase64-3.1.2/xbase64/xbindex.h
--- xbase64-3.1.2/xbase64/xbindex.h.lesserg 2006-07-17 12:54:50.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbindex.h 2012-01-05 15:31:01.733312083 -0500
@@ -43,7 +43,7 @@
#ifndef __XB_INDEX_H__
#define __XB_INDEX_H__
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma interface
#endif
diff -up xbase64-3.1.2/xbase64/xblock.cpp.lesserg xbase64-3.1.2/xbase64/xblock.cpp
--- xbase64-3.1.2/xbase64/xblock.cpp.lesserg 2012-01-05 15:31:01.696312427 -0500
+++ xbase64-3.1.2/xbase64/xblock.cpp 2012-01-05 15:31:01.734312074 -0500
@@ -42,7 +42,7 @@
USA
*/
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma implementation "xblock.h"
#endif
diff -up xbase64-3.1.2/xbase64/xblock.h.lesserg xbase64-3.1.2/xbase64/xblock.h
--- xbase64-3.1.2/xbase64/xblock.h.lesserg 2006-07-17 12:54:50.000000000 -0400
+++ xbase64-3.1.2/xbase64/xblock.h 2012-01-05 15:31:01.735312065 -0500
@@ -44,7 +44,7 @@
#ifndef __XB_XBLOCK_H__
#define __XB_XBLOCK_H__
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma interface
#endif
diff -up xbase64-3.1.2/xbase64/xbndx.cpp.lesserg xbase64-3.1.2/xbase64/xbndx.cpp
--- xbase64-3.1.2/xbase64/xbndx.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbndx.cpp 2012-01-05 15:31:01.737312045 -0500
@@ -36,7 +36,7 @@
*/
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma implementation "xbndx.h"
#endif
diff -up xbase64-3.1.2/xbase64/xbndx.h.lesserg xbase64-3.1.2/xbase64/xbndx.h
--- xbase64-3.1.2/xbase64/xbndx.h.lesserg 2006-07-17 12:54:50.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbndx.h 2012-01-05 15:31:01.738312036 -0500
@@ -41,7 +41,7 @@
#ifndef __XB_NDX_H__
#define __XB_NDX_H__
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma interface
#endif
diff -up xbase64-3.1.2/xbase64/xbntx.cpp.lesserg xbase64-3.1.2/xbase64/xbntx.cpp
--- xbase64-3.1.2/xbase64/xbntx.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbntx.cpp 2012-01-05 15:31:01.740312018 -0500
@@ -40,7 +40,7 @@
USA
*/
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma implementation "xbntx.h"
#endif
diff -up xbase64-3.1.2/xbase64/xbntx.h.lesserg xbase64-3.1.2/xbase64/xbntx.h
--- xbase64-3.1.2/xbase64/xbntx.h.lesserg 2006-07-17 12:54:50.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbntx.h 2012-01-05 15:31:01.741312009 -0500
@@ -42,7 +42,7 @@
#ifndef __XB_NTX_H__
#define __XB_NTX_H__
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma interface
#endif
diff -up xbase64-3.1.2/xbase64/xbstring.cpp.lesserg xbase64-3.1.2/xbase64/xbstring.cpp
--- xbase64-3.1.2/xbase64/xbstring.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbstring.cpp 2012-01-05 15:31:01.742312000 -0500
@@ -38,7 +38,7 @@
*/
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma implementation "xbstring.h"
#endif
diff -up xbase64-3.1.2/xbase64/xbstring.h.lesserg xbase64-3.1.2/xbase64/xbstring.h
--- xbase64-3.1.2/xbase64/xbstring.h.lesserg 2006-07-17 12:54:50.000000000 -0400
+++ xbase64-3.1.2/xbase64/xbstring.h 2012-01-05 15:31:01.743311990 -0500
@@ -41,7 +41,7 @@
#ifndef __XBSTRING_H__
#define __XBSTRING_H__
-#ifdef __GNU LesserG__
+#ifdef __GNU_LesserG__
#pragma interface
#endif

9
xbase-3.1.2-xbnode.patch Normal file
View File

@ -0,0 +1,9 @@
diff -up xbase64-3.1.2/xbase64/xbnode.cpp.BAD xbase64-3.1.2/xbase64/xbnode.cpp
--- xbase64-3.1.2/xbase64/xbnode.cpp.BAD 2009-08-19 23:10:38.444059289 -0400
+++ xbase64-3.1.2/xbase64/xbnode.cpp 2009-08-19 23:10:47.348202984 -0400
@@ -1,4 +1,4 @@
-#include "xbNode.h"
+#include "xbnode.h"
void xbNodeLink::AddNode(xbNodeLink* node)
{

137
xbase.spec Normal file
View File

@ -0,0 +1,137 @@
Name: xbase
Version: 3.1.2
Release: 1mamba
Summary: A C++ class library for manipulating Xbase type datafiles and indices
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://sourceforge.net/projects/xdb/
Source: https://sourceforge.net/projects/xdb/files/Source/%{version}/xbase64-%{version}.tar.gz
Patch0: xbase-3.1.2-fixconfig.patch
Patch1: xbase-3.1.2-gcc44.patch
Patch2: xbase-2.0.0-ppc.patch
Patch3: xbase-3.1.2-xbnode.patch
Patch4: xbase-3.1.2-lesserg.patch
Patch5: xbase-3.1.2-gcc47.patch
Patch6: xbase-3.1.2-gcc6.patch
Patch7: xbase-3.1.2-configure-gcc-version-fix.patch
Patch8: xbase-3.1.2-gcc7.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgcc
BuildRequires: libstdc++6-devel
## AUTOBUILDREQ-END
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: libxbase-tools
Obsoletes: libxbase-tools < 3.1.2
%description
Xbase is a collection of specifications, programs, utilities and a C++ class library for manipulating Xbase type datafiles and indices.
%package -n lib%{name}
Group: System/Libraries
Summary: A C++ class library for manipulating Xbase type datafiles and indices
%description -n lib%{name}
Xbase is a collection of specifications, programs, utilities and a C++ class library for manipulating Xbase type datafiles and indices.
%package -n lib%{name}-devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n lib%{name}-devel
Xbase is a collection of specifications, programs, utilities and a C++ class library for manipulating Xbase type datafiles and indices.
This package contains static libraries and header files needed for development.
%debug_package
%prep
%setup -q -n xbase64-%{version}
%patch 0 -p1
%patch 1 -p1 -b .gcc44
%patch 2 -p1
%patch 3 -p1
%patch 4 -p1 -b .lesserg
%patch 5 -p1 -b .gcc47
%patch 6 -p1 -b .gcc6
%patch 7 -p1 -b .verfix
%patch 8 -p1 -b .gcc7
%build
%configure \
--disable-static
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
ln -s libxbase64.so.1.0.0 %{buildroot}%{_libdir}/libxbase.so.1.0.0
ln -s libxbase64.so.1 %{buildroot}%{_libdir}/libxbase.so.1
ln -s libxbase64.so %{buildroot}%{_libdir}/libxbase.so
ln -s xbase64 %{buildroot}%{_includedir}/xbase
ln -s xbase64-config %{buildroot}%{_bindir}/xbase-config
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n lib%{name} -p /sbin/ldconfig
%postun -n lib%{name} -p /sbin/ldconfig
%pretrans -n lib%{name}-devel -p <lua>
-- Remove /usr/sbin early to avoid error due to package upgrade from owned dir to symlink
path = "%{_includedir}/xbase"
st = posix.stat(path)
if st and st.type == "directory" then
status = os.rename(path, path .. ".rpmmoved")
end
%posttrans -n lib%{name}-devel
[ -e %{_includedir}/xbase.rpmmoved ] && rm -rf %{_includedir}/xbase.rpmmoved
:
%files
%defattr(-,root,root)
%{_bindir}/checkndx
%{_bindir}/copydbf
%{_bindir}/dbfutil1
%{_bindir}/dbfxtrct
%{_bindir}/deletall
%{_bindir}/dumphdr
%{_bindir}/dumprecs
%{_bindir}/packdbf
%{_bindir}/reindex
%{_bindir}/undelall
%{_bindir}/zap
%files -n lib%{name}
%defattr(-,root,root)
%{_libdir}/libxbase.so.*
%{_libdir}/libxbase64.so.*
%doc copying
%files -n lib%{name}-devel
%defattr(-,root,root)
%{_bindir}/xbase64-config
%{_bindir}/xbase-config
%{_includedir}/xbase
%dir %{_includedir}/xbase64
%{_includedir}/xbase64/*.h
%{_libdir}/libxbase.so
%{_libdir}/libxbase64.so
#%doc ChangeLog NEWS README TODO
%changelog
* Sat Oct 21 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.2-1mamba
- update to 3.1.2
* Wed May 07 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.1-1mamba
- update to 2.1.1
* Fri Jan 28 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0-1mamba
- package created by autospec