update to 3.107 [release 3.107-1mamba;Thu Sep 01 2022]
This commit is contained in:
parent
68d936ae3a
commit
e73ae369d5
44
xawtv-3.107-glibc-2.36.patch
Normal file
44
xawtv-3.107-glibc-2.36.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
diff -Nru xawtv-3.107.orig/console/fbtools.c xawtv-3.107/console/fbtools.c
|
||||||
|
--- xawtv-3.107.orig/console/fbtools.c 2020-05-16 01:32:25.000000000 +0200
|
||||||
|
+++ xawtv-3.107/console/fbtools.c 2022-09-01 14:48:20.046709173 +0200
|
||||||
|
@@ -520,6 +520,6 @@
|
||||||
|
|
||||||
|
/* cleanup */
|
||||||
|
fb_cleanup();
|
||||||
|
- fprintf(stderr,"Oops: %s\n",sys_siglist[termsig]);
|
||||||
|
+ fprintf(stderr,"Oops: %s\n",strsignal(termsig));
|
||||||
|
exit(42);
|
||||||
|
}
|
||||||
|
diff -Nru xawtv-3.107.orig/console/record.c xawtv-3.107/console/record.c
|
||||||
|
--- xawtv-3.107.orig/console/record.c 2020-05-16 01:32:25.000000000 +0200
|
||||||
|
+++ xawtv-3.107/console/record.c 2022-09-01 14:48:20.040709235 +0200
|
||||||
|
@@ -429,7 +429,7 @@
|
||||||
|
{
|
||||||
|
if (verbose)
|
||||||
|
fprintf(stderr,"\n%s - exiting\n",
|
||||||
|
- sys_siglist[signal]);
|
||||||
|
+ strsignal(signal));
|
||||||
|
stop = 1;
|
||||||
|
}
|
||||||
|
|
||||||
|
diff -Nru xawtv-3.107.orig/x11/rootv.c xawtv-3.107/x11/rootv.c
|
||||||
|
--- xawtv-3.107.orig/x11/rootv.c 2020-05-16 01:32:25.000000000 +0200
|
||||||
|
+++ xawtv-3.107/x11/rootv.c 2022-09-01 14:48:13.618775381 +0200
|
||||||
|
@@ -133,7 +133,7 @@
|
||||||
|
termsig = signal;
|
||||||
|
if (verbose)
|
||||||
|
fprintf(stderr,"received signal %d [%s]\n",
|
||||||
|
- termsig,sys_siglist[termsig]);
|
||||||
|
+ termsig,strsignal(termsig));
|
||||||
|
}
|
||||||
|
|
||||||
|
static void usage(FILE *fp)
|
||||||
|
@@ -422,7 +422,7 @@
|
||||||
|
}
|
||||||
|
if (verbose && termsig)
|
||||||
|
fprintf(stderr,"exiting on signal %d [%s]\n",
|
||||||
|
- termsig,sys_siglist[termsig]);
|
||||||
|
+ termsig,strsignal(termsig));
|
||||||
|
if (do_mute && have_mute)
|
||||||
|
XvSetPortAttribute(dpy,port,XV_MUTE,1);
|
||||||
|
XvStopVideo(dpy,port,win);
|
53
xawtv.spec
53
xawtv.spec
@ -2,39 +2,21 @@
|
|||||||
%define pkgvertail %(echo %version | cut -d. -f 2)
|
%define pkgvertail %(echo %version | cut -d. -f 2)
|
||||||
Name: xawtv
|
Name: xawtv
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 3.103
|
Version: 3.107
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A small suite of software for TV and video controlling
|
Summary: A small suite of software for TV and video controlling
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://linux.bytesex.org/xawtv/
|
URL: https://www.kraxel.org/blog/linux/xawtv/
|
||||||
Source: http://linuxtv.org/downloads/xawtv/xawtv-%{version}.tar.bz2
|
Source: http://linuxtv.org/downloads/xawtv/xawtv-%{version}.tar.bz2
|
||||||
#Source: http://dl.bytesex.org/cvs-snapshots/xawtv-%{pkgverdate}-%{pkgvertail}.tar.gz
|
|
||||||
Patch0: xawtv-20081014.100645-quicktime.patch
|
Patch0: xawtv-20081014.100645-quicktime.patch
|
||||||
|
Patch1: xawtv-3.107-glibc-2.36.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libalsa-devel
|
|
||||||
BuildRequires: libarts-devel
|
|
||||||
BuildRequires: libatk-devel
|
|
||||||
BuildRequires: libcairo-devel
|
|
||||||
BuildRequires: libdv-devel
|
|
||||||
BuildRequires: libfontconfig-devel
|
|
||||||
BuildRequires: libfreetype-devel
|
|
||||||
BuildRequires: libGL-devel
|
|
||||||
BuildRequires: libglib1-devel
|
|
||||||
BuildRequires: libglib-devel
|
|
||||||
BuildRequires: libgtk-devel
|
|
||||||
BuildRequires: libICE-devel
|
BuildRequires: libICE-devel
|
||||||
BuildRequires: libjpeg-devel
|
|
||||||
BuildRequires: libmad-devel
|
|
||||||
BuildRequires: libncurses-devel
|
|
||||||
BuildRequires: libpango-devel
|
|
||||||
BuildRequires: libpng-devel
|
|
||||||
BuildRequires: libquicktime-devel
|
|
||||||
BuildRequires: libSM-devel
|
BuildRequires: libSM-devel
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
BuildRequires: libXaw-devel
|
BuildRequires: libXaw-devel
|
||||||
@ -43,12 +25,30 @@ BuildRequires: libXft-devel
|
|||||||
BuildRequires: libXinerama-devel
|
BuildRequires: libXinerama-devel
|
||||||
BuildRequires: libXmu-devel
|
BuildRequires: libXmu-devel
|
||||||
BuildRequires: libXpm-devel
|
BuildRequires: libXpm-devel
|
||||||
|
BuildRequires: libXrandr-devel
|
||||||
BuildRequires: libXrender-devel
|
BuildRequires: libXrender-devel
|
||||||
BuildRequires: libXt-devel
|
BuildRequires: libXt-devel
|
||||||
BuildRequires: libXv-devel
|
BuildRequires: libXv-devel
|
||||||
|
BuildRequires: libXxf86dga-devel
|
||||||
|
BuildRequires: libXxf86vm-devel
|
||||||
|
BuildRequires: libaa-devel
|
||||||
|
BuildRequires: libalsa-devel
|
||||||
|
BuildRequires: libdv-devel
|
||||||
|
BuildRequires: libfontconfig-devel
|
||||||
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libglvnd-devel
|
||||||
|
BuildRequires: libgpm-devel
|
||||||
|
BuildRequires: libjpeg-devel
|
||||||
|
BuildRequires: liblesstif-devel
|
||||||
|
BuildRequires: libncurses-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libquicktime-devel
|
||||||
|
BuildRequires: libslang-devel
|
||||||
|
BuildRequires: libv4l-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: libzvbi-devel
|
BuildRequires: libzvbi-devel
|
||||||
BuildRequires: mpeg2dec-devel
|
BuildRequires: lirc-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -60,12 +60,12 @@ In the future even more hardware will be supported, the current development snap
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
%patch1 -p1
|
||||||
#./autogen.sh
|
|
||||||
|
NOCONFIGURE=1 ./autogen.sh
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
--enable-arts \
|
|
||||||
--enable-zvbi
|
--enable-zvbi
|
||||||
|
|
||||||
%make
|
%make
|
||||||
@ -106,6 +106,9 @@ In the future even more hardware will be supported, the current development snap
|
|||||||
#%doc README.network README.recording README.translate README.xfree4 TODO
|
#%doc README.network README.recording README.translate README.xfree4 TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 01 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.107-1mamba
|
||||||
|
- update to 3.107
|
||||||
|
|
||||||
* Sun Apr 28 2013 Automatic Build System <autodist@mambasoft.it> 3.103-1mamba
|
* Sun Apr 28 2013 Automatic Build System <autodist@mambasoft.it> 3.103-1mamba
|
||||||
- update to 3.103
|
- update to 3.103
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user