update to 3.103 [release 3.103-1mamba;Sun Apr 28 2013]
This commit is contained in:
parent
2dcc589af8
commit
68d936ae3a
@ -1,2 +1,8 @@
|
|||||||
# xawtv
|
# xawtv
|
||||||
|
|
||||||
|
xawtv started as TV application for the bttv driver, because the Motif-based "xtvscreen" was the only TV application at this time. Alot has changed since:
|
||||||
|
The xawtv and bttv driver switched over to the video4linux interface.
|
||||||
|
Support for more interfaces was added: Xvideo Extention, the new video4linux2 interface and BSD Family video grabber driver (bktr).
|
||||||
|
xawtv isn't a single application any more, it is a small suite of video4linux related software, with video recording capabilities and serveral useful command line tools.
|
||||||
|
In the future even more hardware will be supported, the current development snapshots already have DVB support for example.
|
||||||
|
|
||||||
|
51
xawtv-20081014.100645-quicktime.patch
Normal file
51
xawtv-20081014.100645-quicktime.patch
Normal file
@ -0,0 +1,51 @@
|
|||||||
|
diff -ru xawtv/libng/plugins/read-mpeg.c xawtv.patched/libng/plugins/read-mpeg.c
|
||||||
|
--- xawtv/libng/plugins/read-mpeg.c 2005-10-08 16:13:11.000000000 +0200
|
||||||
|
+++ xawtv.patched/libng/plugins/read-mpeg.c 2008-12-02 03:33:46.000000000 +0100
|
||||||
|
@@ -768,7 +768,7 @@
|
||||||
|
size = h->ts.size-off;
|
||||||
|
if (buf->size + size > TS_AUDIO_BUF) {
|
||||||
|
fprintf(stderr,"ts: TS_AUDIO_BUF too small (%ld > %d)\n",
|
||||||
|
- buf->size + size, TS_AUDIO_BUF);
|
||||||
|
+ (long int) buf->size + size, TS_AUDIO_BUF);
|
||||||
|
exit(1);
|
||||||
|
}
|
||||||
|
memcpy(buf->data + buf->size, data, size);
|
||||||
|
diff -ru xawtv/libng/plugins/write-qt.c xawtv.patched/libng/plugins/write-qt.c
|
||||||
|
--- xawtv/libng/plugins/write-qt.c 2004-02-24 21:09:16.000000000 +0100
|
||||||
|
+++ xawtv.patched/libng/plugins/write-qt.c 2008-12-02 03:32:30.000000000 +0100
|
||||||
|
@@ -336,6 +336,7 @@
|
||||||
|
int i,j,k,skip,fmtid;
|
||||||
|
unsigned int cmodel;
|
||||||
|
struct qt_video_priv *vp;
|
||||||
|
+ int model=0;
|
||||||
|
|
||||||
|
/* handle video encoders */
|
||||||
|
video = malloc(sizeof(qt_vformats));
|
||||||
|
@@ -348,10 +349,12 @@
|
||||||
|
info[i]->name,info[i]->long_name);
|
||||||
|
for (j = 0; j < info[i]->num_fourccs; j++)
|
||||||
|
fprintf(stderr," fcc : %s\n",info[i]->fourccs[j]);
|
||||||
|
- for (j = 0; j < info[i]->num_encoding_colormodels; j++)
|
||||||
|
- fprintf(stderr," cmodel: %d [%s]\n",
|
||||||
|
- info[i]->encoding_colormodels[j],
|
||||||
|
- lqt_get_colormodel_string(info[i]->encoding_colormodels[j]));
|
||||||
|
+ for (j = 0; j < lqt_num_colormodels(); j++)
|
||||||
|
+ {
|
||||||
|
+ model=lqt_get_colormodel(j);
|
||||||
|
+ fprintf(stderr," cmodel: %d [%s]\n", model,
|
||||||
|
+ lqt_get_colormodel_string(model) );
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
|
||||||
|
/* sanity checks */
|
||||||
|
@@ -378,8 +381,8 @@
|
||||||
|
/* pick colormodel */
|
||||||
|
fmtid = VIDEO_NONE;
|
||||||
|
cmodel = 0;
|
||||||
|
- for (j = 0; j < info[i]->num_encoding_colormodels; j++) {
|
||||||
|
- cmodel = info[i]->encoding_colormodels[j];
|
||||||
|
+ for (j = 0; j < lqt_num_colormodels(); j++) {
|
||||||
|
+ cmodel = lqt_get_colormodel(j);
|
||||||
|
if (cmodel>= sizeof(cmodels)/sizeof(int))
|
||||||
|
continue;
|
||||||
|
if (!cmodels[cmodel])
|
116
xawtv.spec
Normal file
116
xawtv.spec
Normal file
@ -0,0 +1,116 @@
|
|||||||
|
%define pkgverdate %(echo %version | cut -d. -f 1)
|
||||||
|
%define pkgvertail %(echo %version | cut -d. -f 2)
|
||||||
|
Name: xawtv
|
||||||
|
Epoch: 1
|
||||||
|
Version: 3.103
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A small suite of software for TV and video controlling
|
||||||
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://linux.bytesex.org/xawtv/
|
||||||
|
Source: http://linuxtv.org/downloads/xawtv/xawtv-%{version}.tar.bz2
|
||||||
|
#Source: http://dl.bytesex.org/cvs-snapshots/xawtv-%{pkgverdate}-%{pkgvertail}.tar.gz
|
||||||
|
Patch0: xawtv-20081014.100645-quicktime.patch
|
||||||
|
License: GPL
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libalsa-devel
|
||||||
|
BuildRequires: libarts-devel
|
||||||
|
BuildRequires: libatk-devel
|
||||||
|
BuildRequires: libcairo-devel
|
||||||
|
BuildRequires: libdv-devel
|
||||||
|
BuildRequires: libfontconfig-devel
|
||||||
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libGL-devel
|
||||||
|
BuildRequires: libglib1-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libgtk-devel
|
||||||
|
BuildRequires: libICE-devel
|
||||||
|
BuildRequires: libjpeg-devel
|
||||||
|
BuildRequires: libmad-devel
|
||||||
|
BuildRequires: libncurses-devel
|
||||||
|
BuildRequires: libpango-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libquicktime-devel
|
||||||
|
BuildRequires: libSM-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXaw-devel
|
||||||
|
BuildRequires: libXext-devel
|
||||||
|
BuildRequires: libXft-devel
|
||||||
|
BuildRequires: libXinerama-devel
|
||||||
|
BuildRequires: libXmu-devel
|
||||||
|
BuildRequires: libXpm-devel
|
||||||
|
BuildRequires: libXrender-devel
|
||||||
|
BuildRequires: libXt-devel
|
||||||
|
BuildRequires: libXv-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
BuildRequires: libzvbi-devel
|
||||||
|
BuildRequires: mpeg2dec-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
|
||||||
|
%description
|
||||||
|
xawtv started as TV application for the bttv driver, because the Motif-based "xtvscreen" was the only TV application at this time. Alot has changed since:
|
||||||
|
The xawtv and bttv driver switched over to the video4linux interface.
|
||||||
|
Support for more interfaces was added: Xvideo Extention, the new video4linux2 interface and BSD Family video grabber driver (bktr).
|
||||||
|
xawtv isn't a single application any more, it is a small suite of video4linux related software, with video recording capabilities and serveral useful command line tools.
|
||||||
|
In the future even more hardware will be supported, the current development snapshots already have DVB support for example.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
#%patch0 -p1
|
||||||
|
#./autogen.sh
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure \
|
||||||
|
--enable-arts \
|
||||||
|
--enable-zvbi
|
||||||
|
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall SUID_ROOT=""
|
||||||
|
|
||||||
|
#%find_lang %{name}
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
#-f %{name}.lang
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_sysconfdir}/X11/app-defaults/MoTV
|
||||||
|
%{_sysconfdir}/X11/app-defaults/Xawtv
|
||||||
|
%{_sysconfdir}/X11/app-defaults/mtt
|
||||||
|
%{_sysconfdir}/X11/de_DE.UTF-8/app-defaults/MoTV
|
||||||
|
%{_sysconfdir}/X11/fr_FR.UTF-8/app-defaults/MoTV
|
||||||
|
%{_sysconfdir}/X11/it_IT.UTF-8/app-defaults/MoTV
|
||||||
|
%{_bindir}/*
|
||||||
|
%attr(4711,root,root) %{_bindir}/v4l-conf
|
||||||
|
%dir %{_datadir}/xawtv
|
||||||
|
%{_datadir}/xawtv/*
|
||||||
|
%dir %{_libdir}/xawtv
|
||||||
|
%{_libdir}/xawtv/*
|
||||||
|
%{_mandir}/man1/*
|
||||||
|
%{_mandir}/fr/man1/*
|
||||||
|
%{_mandir}/es/man1/*
|
||||||
|
%{_mandir}/es/man5/*
|
||||||
|
%{_mandir}/es/man8/*
|
||||||
|
%{_mandir}/man5/xawtvrc.5*
|
||||||
|
%{_mandir}/man8/v4l-conf.8*
|
||||||
|
%doc COPYING
|
||||||
|
#ChangeLog ChangeLog.bak README README.bttv README.dvb README.lirc
|
||||||
|
#%doc README.network README.recording README.translate README.xfree4 TODO
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Apr 28 2013 Automatic Build System <autodist@mambasoft.it> 3.103-1mamba
|
||||||
|
- update to 3.103
|
||||||
|
|
||||||
|
* Mon Nov 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 20081014.100645-1mamba
|
||||||
|
- update to 20081014.100645
|
||||||
|
|
||||||
|
* Wed Sep 20 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 102024-1qilnx
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user