138 lines
4.1 KiB
RPMSpec
138 lines
4.1 KiB
RPMSpec
%define pkgver %(echo %version | tr . _)
|
|
Name: xalan-j2
|
|
Version: 2.7.2
|
|
Release: 1mamba
|
|
Summary: Java XSLT processor
|
|
Group: Applications/Publishing
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://xml.apache.org/xalan-j/
|
|
Source0: https://archive.apache.org/dist/xalan/xalan-j/binaries/xalan-j_%{pkgver}-bin-2jars.zip
|
|
License: Apache Software License 1.1, Apache Software License 2.0, W3C
|
|
## AUTOBUILDREQ-BEGIN
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: javapackages
|
|
Requires: javapackages
|
|
Requires: xerces-j2
|
|
Obsoletes: xalan-j2-demo < 2.7.2
|
|
Obsoletes: xalan-j2-manual < 2.7.2
|
|
Obsoletes: xalan-j2-javadoc < 2.7.2
|
|
Obsoletes: xalan-j2-repolib < 2.7.2
|
|
|
|
%description
|
|
Xalan is an XSLT processor for transforming XML documents into HTML, text, or other XML document types. It implements the W3C Recommendations for XSL Transformations (XSLT) and the XML Path Language (XPath). It can be used from the command line, in an applet or a servlet, or as a module in other program.
|
|
|
|
%package xsltc
|
|
Group: Applications/Publishing
|
|
Summary: XSLT compiler
|
|
#Requires: jakarta-bcel
|
|
#%if "%{stage1}" != "1"
|
|
#Requires: jakarta-regexp
|
|
#Requires: java-lex
|
|
#%endif
|
|
Requires: java_cup
|
|
|
|
%description xsltc
|
|
The XSLT Compiler is a Java-based tool for compiling XSLT stylesheets into lightweight and portable Java byte codes called translets.
|
|
|
|
%prep
|
|
%setup -q -n xalan-j_%{pkgver}
|
|
|
|
%build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
mkdir -p %{buildroot}%{_javadir}
|
|
#install -p -m 644 xalan-interpretive.jar \
|
|
# %{buildroot}%{_javadir}/xalan-j2-interpretive-%{version}.jar
|
|
install -p -m 644 xsltc.jar \
|
|
%{buildroot}%{_javadir}/xsltc-%{version}.jar
|
|
install -p -m 644 serializer.jar \
|
|
%{buildroot}%{_javadir}/xalan-j2-serializer-%{version}.jar
|
|
install -p -m 644 xalan.jar \
|
|
%{buildroot}%{_javadir}/xalan-j2-%{version}.jar
|
|
|
|
#install -p -m 644 samples/xalansamples.jar \
|
|
# %{buildroot}%{_javadir}/xalan-j2-samples.jar
|
|
|
|
(
|
|
cd %{buildroot}%{_javadir}
|
|
for jar in *-%{version}*; do
|
|
ln -s ${jar} `echo $jar | sed "s|-%{version}||g"`
|
|
done
|
|
)
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post
|
|
update-alternatives --install %{_javadir}/jaxp_transform_impl.jar jaxp_transform_impl %{_javadir}/xalan-j2.jar 30
|
|
|
|
%preun
|
|
{
|
|
[ $1 = 0 ] || exit 0
|
|
update-alternatives --remove jaxp_transform_impl %{_javadir}/xalan-j2.jar
|
|
} >/dev/null 2>&1 || :
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_javadir}/xalan-j2-%{version}.jar
|
|
%{_javadir}/xalan-j2.jar
|
|
#%{_javadir}/xalan-j2-interpretive-%{version}.jar
|
|
#%{_javadir}/xalan-j2-interpretive.jar
|
|
%{_javadir}/xalan-j2-serializer-%{version}.jar
|
|
%{_javadir}/xalan-j2-serializer.jar
|
|
#%{_javadir}/xalan-j2-samples.jar
|
|
%ghost %{_javadir}/jaxp_transform_impl.jar
|
|
%doc LICENSE.txt
|
|
|
|
%files xsltc
|
|
%defattr(-,root,root)
|
|
%{_javadir}/xsltc-%{version}.jar
|
|
%{_javadir}/xsltc.jar
|
|
%doc LICENSE.txt
|
|
|
|
%changelog
|
|
* Tue Aug 16 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.7.2-1mamba
|
|
- update to 2.7.2
|
|
|
|
* Wed Mar 23 2011 gil <puntogil@libero.it> 2.7.1-6mamba
|
|
- rebuilt with java-openjdk support
|
|
|
|
* Tue Mar 09 2010 gil <puntogil@libero.it> 2.7.1-5mamba
|
|
- fix java.lang.OutOfMemoryError during javadocs task
|
|
|
|
* Tue Nov 24 2009 gil <puntogil@libero.it> 2.7.1-4mamba
|
|
- rebuilt
|
|
- added new sub package: repolib
|
|
|
|
* Fri Mar 13 2009 gil <puntogil@libero.it> 2.7.1-3mamba
|
|
- rebuilt with new xerces-j2
|
|
|
|
* Mon Mar 09 2009 gil <puntogil@libero.it> 2.7.1-2mamba
|
|
- added tomcat support
|
|
|
|
* Sat Mar 07 2009 gil <puntogil@libero.it> 2.7.1-1mamba
|
|
- update to 2.7.1
|
|
|
|
* Fri Feb 27 2009 gil <puntogil@libero.it> 2.7.0-6mamba
|
|
- rebuilt
|
|
|
|
* Thu Feb 26 2009 gil <puntogil@libero.it> 2.7.0-5mamba
|
|
- rebuilt with new xerces-j2
|
|
|
|
* Wed Feb 25 2009 gil <puntogil@libero.it> 2.7.0-4mamba
|
|
- fixed some errors
|
|
|
|
* Tue Feb 24 2009 gil <puntogil@libero.it> 2.7.0-3mamba
|
|
- rebuilt with system xerces-j2
|
|
- todo: tomcat support
|
|
|
|
* Tue Feb 24 2009 gil <puntogil@libero.it> 2.7.0-1mamba
|
|
- update to 2.7.0
|
|
|
|
* Mon Dec 22 2008 gil <puntogil@libero.it> 2.7.1-1mamba
|
|
- package created by autospec
|