rebuilt (added gcc 4.3 patch) [release 1.10.0-3mamba;Sat Apr 28 2012]

This commit is contained in:
Silvan Calarco 2024-01-05 19:32:02 +01:00
parent e31cbeaf92
commit 90c7dacc85
3 changed files with 174 additions and 0 deletions

View File

@ -1,2 +1,6 @@
# xalan-c # xalan-c
Xalan is an XSLT processor for transforming XML documents into HTML, text, or other XML document types.
Xalan-C++ is a robust implementation of the W3C Recommendations for XSL Transformations (XSLT) and the XML Path Language (XPath).

View File

@ -0,0 +1,65 @@
diff -ur xalan.old/c/src/xalanc/PlatformSupport/DirectoryEnumerator.hpp xalan-1.10/c/src/xalanc/PlatformSupport/DirectoryEnumerator.hpp
--- xalan.old/c/src/xalanc/PlatformSupport/DirectoryEnumerator.hpp 2005-05-05 00:32:04.000000000 +0000
+++ xalan-1.10/c/src/xalanc/PlatformSupport/DirectoryEnumerator.hpp 2007-12-29 18:36:08.000000000 +0000
@@ -16,8 +16,6 @@
#if !defined(DIRECTORY_ENUMERATOR_HEADER_GUARD_1357924680)
#define DIRECTORY_ENUMERATOR_HEADER_GUARD_1357924680
-
-
// Base header file. Must be first.
#include <xalanc/PlatformSupport/PlatformSupportDefinitions.hpp>
@@ -36,6 +34,7 @@
#include <functional>
#include <iterator>
+#include <cstring>
#include "xercesc/framework/MemoryManager.hpp"
diff -ur xalan.old/c/src/xalanc/XalanDOM/XalanDOMString.cpp xalan-1.10/c/src/xalanc/XalanDOM/XalanDOMString.cpp
--- xalan.old/c/src/xalanc/XalanDOM/XalanDOMString.cpp 2005-08-08 15:25:52.000000000 +0000
+++ xalan-1.10/c/src/xalanc/XalanDOM/XalanDOMString.cpp 2007-12-29 18:25:29.000000000 +0000
@@ -19,6 +19,7 @@
#include <cassert>
+#include <cstring>
diff -ur xalan.old/c/src/xalanc/XalanExe/XalanExe.cpp xalan-1.10/c/src/xalanc/XalanExe/XalanExe.cpp
--- xalan.old/c/src/xalanc/XalanExe/XalanExe.cpp 2005-04-29 21:39:46.000000000 +0000
+++ xalan-1.10/c/src/xalanc/XalanExe/XalanExe.cpp 2007-12-29 18:41:19.000000000 +0000
@@ -19,6 +19,7 @@
#include <cstdlib>
+#include <cstring>
#if defined(XALAN_CLASSIC_IOSTREAMS)
#include <iostream.h>
#else
diff -ur xalan.old/c/src/xalanc/XMLSupport/FormatterToHTML.cpp xalan-1.10/c/src/xalanc/XMLSupport/FormatterToHTML.cpp
--- xalan.old/c/src/xalanc/XMLSupport/FormatterToHTML.cpp 2005-06-30 21:52:35.000000000 +0000
+++ xalan-1.10/c/src/xalanc/XMLSupport/FormatterToHTML.cpp 2007-12-29 18:26:53.000000000 +0000
@@ -26,6 +26,7 @@
#include <cassert>
+#include <cstring>
diff -ur xalan.old/c/src/xalanc/XSLT/ElemNumber.cpp xalan-1.10/c/src/xalanc/XSLT/ElemNumber.cpp
--- xalan.old/c/src/xalanc/XSLT/ElemNumber.cpp 2005-07-26 20:09:17.000000000 +0000
+++ xalan-1.10/c/src/xalanc/XSLT/ElemNumber.cpp 2007-12-29 18:30:55.000000000 +0000
@@ -15,7 +15,7 @@
*/
#include "ElemNumber.hpp"
-
+#include <cstring>
#include <xercesc/sax/AttributeList.hpp>

105
xalan-c.spec Normal file
View File

@ -0,0 +1,105 @@
%define libname lib%{name}
%define pckver %(echo %version | tr '.' '_')
Name: xalan-c
Version: 1.10.0
Release: 3mamba
Summary: An XSLT processor in C++
Group: Development/Tools
Vendor: openmamba
Distribution: openmamba
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
URL: http://xml.apache.org/xalan-c
Source: http://www.apache.org/dist/xml/xalan-c/source/Xalan-C_%{pckver}-src.tar.gz
Patch0: %{name}-1.10.0-gcc-43.patch
License: Apache License 2.0
BuildRequires: libxerces-c-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Xalan is an XSLT processor for transforming XML documents into HTML, text, or other XML document types.
Xalan-C++ is a robust implementation of the W3C Recommendations for XSL Transformations (XSLT) and the XML Path Language (XPath).
%package -n %{libname}
Summary: Library for an XSLT processor in C++
Group: System/Libraries
%description -n %{libname}
Library for an XSLT processor in C++.
%package -n %{libname}-devel
Summary: Static libraries and headers for %{libname}
Group: Development/Libraries
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
%description -n %{libname}-devel
Library for an XSLT processor in C++.
This package contains static libraries and header files need for development.
%prep
%setup -q -n xml-xalan
%patch0 -p1
# use optflags in runConfigure
for runconf in $(find -name runConfigure); do
sed -i -e "s/-O2 \(-DNDEBUG\)/%{optflags} \1/g" $runconf
done
%build
export XERCESCROOT=%{_includedir}/xercesc
export XALANCROOT=$(pwd)/c
export ICUROOT=%{_prefix}
pushd c
autoreconf --install --force
./runConfigure \
-p linux \
-c %{_target_platform}-gcc \
-x %{_target_platform}-g++ \
-m inmem \
-t icu \
-r pthread \
-b 32 \
-P %{_prefix} \
-C --libdir="%{_libdir}"
%make -j1
popd
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
export XALANCROOT=$(pwd)/c
%makeinstall -C c
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n %{libname} -p /sbin/ldconfig
%postun -n %{libname} -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/*
%doc c/README c/LICENSE c/readme.html
%files -n %{libname}
%defattr(-, root, root)
%{_libdir}/*.so.*
%files -n %{libname}-devel
%defattr(-, root, root)
%{_includedir}/xalanc
%{_libdir}/*.so
%doc c/xdocs
%changelog
* Sat Apr 28 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.0-3mamba
- rebuilt (added gcc 4.3 patch)
* Thu Oct 18 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.0-2mamba
- rebuilt against libxerces-c 1.8.0
* Fri Jun 08 2007 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 1.10.0-1mamba
- package created by autospec