wxWidgets30/wxWidgets30-3.0.5.1-fix-locales-collision.patch
Silvan Calarco 1429cbe187 update to 3.0.5.1
add fix-locales-collision patch for i18n package to cohexist with 3.1 [release 3.0.5.1-1mamba;Tue May 19 2020]
2024-01-05 19:30:27 +01:00

37 lines
1.8 KiB
Diff

diff -Nru wxWidgets-3.0.5.1.orig/Makefile.in wxWidgets-3.0.5.1/Makefile.in
--- wxWidgets-3.0.5.1.orig/Makefile.in 2020-05-02 16:03:18.000000000 +0200
+++ wxWidgets-3.0.5.1/Makefile.in 2020-05-19 13:01:08.669000000 +0200
@@ -16185,7 +16185,7 @@
$(INSTALL_DIR) $(DESTDIR)$(datadir)/locale/$$l ; \
$(INSTALL_DIR) $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES ; \
if test -f $(srcdir)/locale/$$l.mo ; then \
- $(INSTALL_DATA) $(srcdir)/locale/$$l.mo $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES/wxstd.mo ; \
+ $(INSTALL_DATA) $(srcdir)/locale/$$l.mo $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES/wxstd${WX_RELEASE_NODOT}.mo ; \
fi ; \
done
diff -Nru wxWidgets-3.0.5.1.orig/build/bakefiles/wx.bkl wxWidgets-3.0.5.1/build/bakefiles/wx.bkl
--- wxWidgets-3.0.5.1.orig/build/bakefiles/wx.bkl 2020-05-02 16:03:18.000000000 +0200
+++ wxWidgets-3.0.5.1/build/bakefiles/wx.bkl 2020-05-19 13:01:51.516000000 +0200
@@ -137,7 +137,7 @@
<using module="gettext"/>
<gettext-catalogs id="locale">
<srcdir>$(SRCDIR)/locale</srcdir>
- <catalog-name>wxstd</catalog-name>
+ <catalog-name>wxstd${WX_RELEASE_NODOT}</catalog-name>
<linguas>
ca cs da de el es fi fr hu id it ja nl pl ru sl sv tr uk
zh zh_CN zh_TW
diff -Nru wxWidgets-3.0.5.1.orig/src/common/translation.cpp wxWidgets-3.0.5.1/src/common/translation.cpp
--- wxWidgets-3.0.5.1.orig/src/common/translation.cpp 2020-05-02 16:03:18.000000000 +0200
+++ wxWidgets-3.0.5.1/src/common/translation.cpp 2020-05-19 13:02:47.999000000 +0200
@@ -1471,7 +1471,7 @@
bool wxTranslations::AddStdCatalog()
{
- if ( !AddCatalog(wxS("wxstd")) )
+ if ( !AddCatalog(wxS("wxstd" wxSTRINGIZE(wxMAJOR_VERSION) wxSTRINGIZE(wxMINOR_VERSION))) )
return false;
// there may be a catalog with toolkit specific overrides, it is not