update to 3.0.5.1
add fix-locales-collision patch for i18n package to cohexist with 3.1 [release 3.0.5.1-1mamba;Tue May 19 2020]
This commit is contained in:
parent
419cb13f12
commit
1429cbe187
36
wxWidgets30-3.0.5.1-fix-locales-collision.patch
Normal file
36
wxWidgets30-3.0.5.1-fix-locales-collision.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
diff -Nru wxWidgets-3.0.5.1.orig/Makefile.in wxWidgets-3.0.5.1/Makefile.in
|
||||||
|
--- wxWidgets-3.0.5.1.orig/Makefile.in 2020-05-02 16:03:18.000000000 +0200
|
||||||
|
+++ wxWidgets-3.0.5.1/Makefile.in 2020-05-19 13:01:08.669000000 +0200
|
||||||
|
@@ -16185,7 +16185,7 @@
|
||||||
|
$(INSTALL_DIR) $(DESTDIR)$(datadir)/locale/$$l ; \
|
||||||
|
$(INSTALL_DIR) $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES ; \
|
||||||
|
if test -f $(srcdir)/locale/$$l.mo ; then \
|
||||||
|
- $(INSTALL_DATA) $(srcdir)/locale/$$l.mo $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES/wxstd.mo ; \
|
||||||
|
+ $(INSTALL_DATA) $(srcdir)/locale/$$l.mo $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES/wxstd${WX_RELEASE_NODOT}.mo ; \
|
||||||
|
fi ; \
|
||||||
|
done
|
||||||
|
|
||||||
|
diff -Nru wxWidgets-3.0.5.1.orig/build/bakefiles/wx.bkl wxWidgets-3.0.5.1/build/bakefiles/wx.bkl
|
||||||
|
--- wxWidgets-3.0.5.1.orig/build/bakefiles/wx.bkl 2020-05-02 16:03:18.000000000 +0200
|
||||||
|
+++ wxWidgets-3.0.5.1/build/bakefiles/wx.bkl 2020-05-19 13:01:51.516000000 +0200
|
||||||
|
@@ -137,7 +137,7 @@
|
||||||
|
<using module="gettext"/>
|
||||||
|
<gettext-catalogs id="locale">
|
||||||
|
<srcdir>$(SRCDIR)/locale</srcdir>
|
||||||
|
- <catalog-name>wxstd</catalog-name>
|
||||||
|
+ <catalog-name>wxstd${WX_RELEASE_NODOT}</catalog-name>
|
||||||
|
<linguas>
|
||||||
|
ca cs da de el es fi fr hu id it ja nl pl ru sl sv tr uk
|
||||||
|
zh zh_CN zh_TW
|
||||||
|
diff -Nru wxWidgets-3.0.5.1.orig/src/common/translation.cpp wxWidgets-3.0.5.1/src/common/translation.cpp
|
||||||
|
--- wxWidgets-3.0.5.1.orig/src/common/translation.cpp 2020-05-02 16:03:18.000000000 +0200
|
||||||
|
+++ wxWidgets-3.0.5.1/src/common/translation.cpp 2020-05-19 13:02:47.999000000 +0200
|
||||||
|
@@ -1471,7 +1471,7 @@
|
||||||
|
|
||||||
|
bool wxTranslations::AddStdCatalog()
|
||||||
|
{
|
||||||
|
- if ( !AddCatalog(wxS("wxstd")) )
|
||||||
|
+ if ( !AddCatalog(wxS("wxstd" wxSTRINGIZE(wxMAJOR_VERSION) wxSTRINGIZE(wxMINOR_VERSION))) )
|
||||||
|
return false;
|
||||||
|
|
||||||
|
// there may be a catalog with toolkit specific overrides, it is not
|
@ -5,8 +5,8 @@
|
|||||||
%define wxBaseu_name libwx_baseu30
|
%define wxBaseu_name libwx_baseu30
|
||||||
|
|
||||||
Name: wxWidgets30
|
Name: wxWidgets30
|
||||||
Version: 3.0.4
|
Version: 3.0.5.1
|
||||||
Release: 2mamba
|
Release: 1mamba
|
||||||
Summary: GTK+ port of the wxWidgets library
|
Summary: GTK+ port of the wxWidgets library
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -17,13 +17,15 @@ Source: https://github.com/wxWidgets/wxWidgets/releases/download/v%{versi
|
|||||||
#Source: http://downloads.sourceforge.net/wxwindows/wxWidgets-%{version}.tar.bz2
|
#Source: http://downloads.sourceforge.net/wxwindows/wxWidgets-%{version}.tar.bz2
|
||||||
Patch0: wxWidgets-3.0.2-gcc-6.1.0.patch
|
Patch0: wxWidgets-3.0.2-gcc-6.1.0.patch
|
||||||
Patch1: wxWidgets-3.0.2-make-abi-check-not-fatal.patch
|
Patch1: wxWidgets-3.0.2-make-abi-check-not-fatal.patch
|
||||||
|
Patch2: wxWidgets30-3.0.5.1-fix-locales-collision.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: GConf-devel
|
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: ldconfig
|
||||||
|
BuildRequires: libGConf-devel
|
||||||
BuildRequires: libGL-devel
|
BuildRequires: libGL-devel
|
||||||
BuildRequires: libGLU-devel
|
BuildRequires: libGLU-devel
|
||||||
BuildRequires: libSDL-devel
|
BuildRequires: libSDL2-devel
|
||||||
BuildRequires: libSM-devel
|
BuildRequires: libSM-devel
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
BuildRequires: libXxf86vm-devel
|
BuildRequires: libXxf86vm-devel
|
||||||
@ -34,9 +36,10 @@ BuildRequires: libgcc
|
|||||||
BuildRequires: libgdk-pixbuf-devel
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
BuildRequires: libgnome-vfs-devel
|
BuildRequires: libgnome-vfs-devel
|
||||||
BuildRequires: libgst-plugins-base010-devel
|
BuildRequires: libgst-plugins-base-devel
|
||||||
BuildRequires: libgstreamer010-devel
|
BuildRequires: libgstreamer-devel
|
||||||
BuildRequires: libgtk-devel
|
BuildRequires: libgtk-devel
|
||||||
|
BuildRequires: libharfbuzz-devel
|
||||||
BuildRequires: libjpeg-devel
|
BuildRequires: libjpeg-devel
|
||||||
BuildRequires: libmspack-devel
|
BuildRequires: libmspack-devel
|
||||||
BuildRequires: libnotify-devel
|
BuildRequires: libnotify-devel
|
||||||
@ -45,14 +48,11 @@ BuildRequires: libpng-devel
|
|||||||
BuildRequires: libsoup-devel
|
BuildRequires: libsoup-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libtiff-devel
|
BuildRequires: libtiff-devel
|
||||||
BuildRequires: libwebkit-gtk3-devel
|
BuildRequires: libwebkit2gtk-devel
|
||||||
BuildRequires: libxml2-devel
|
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libX11-devel
|
|
||||||
BuildRequires: xorg-proto-devel
|
BuildRequires: xorg-proto-devel
|
||||||
BuildRequires: libesound-devel
|
BuildRequires: libesound-devel
|
||||||
BuildRequires: libgnome-vfs-devel
|
|
||||||
BuildRequires: libgnomecanvas-devel
|
BuildRequires: libgnomecanvas-devel
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
@ -155,15 +155,19 @@ The translations files for the wxWidgets library.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n wxWidgets-%{version}
|
%setup -q -n wxWidgets-%{version}
|
||||||
|
#-D -T
|
||||||
|
#:<< _EOF
|
||||||
|
|
||||||
#%patch0 -p1
|
#%patch0 -p1
|
||||||
#%patch1 -p1
|
#%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
# FIXME: %{_datadir}/bakefile/presets generates a conflict between wx 2.6
|
# FIXME: %{_datadir}/bakefile/presets generates a conflict between wx 2.6
|
||||||
# and 2.8 devel packages
|
# and 2.8 devel packages
|
||||||
#sed -i "s,bakefile/presets,bakefile/presets-\$(WX_RELEASE),g" Makefile.in
|
#sed -i "s,bakefile/presets,bakefile/presets-\$(WX_RELEASE),g" Makefile.in
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
#:<< _EOF
|
||||||
# configure and build the UNICODE version
|
# configure and build the UNICODE version
|
||||||
%configure \
|
%configure \
|
||||||
--with-gtk=3 \
|
--with-gtk=3 \
|
||||||
@ -191,6 +195,7 @@ The translations files for the wxWidgets library.
|
|||||||
--enable-optimise \
|
--enable-optimise \
|
||||||
--without-debug_flag \
|
--without-debug_flag \
|
||||||
--without-debug_info
|
--without-debug_info
|
||||||
|
|
||||||
# --disable-compat26 \
|
# --disable-compat26 \
|
||||||
# --enable-accessibility
|
# --enable-accessibility
|
||||||
|
|
||||||
@ -222,9 +227,12 @@ mv %{buildroot}%{_datadir}/aclocal/wxwin.m4 %{buildroot}%{_datadir}/aclocal/wxwi
|
|||||||
install -d %{buildroot}%{_datadir}/wx/examples/src
|
install -d %{buildroot}%{_datadir}/wx/examples/src
|
||||||
cp -a demos samples %{buildroot}%{_datadir}/wx/examples
|
cp -a demos samples %{buildroot}%{_datadir}/wx/examples
|
||||||
|
|
||||||
%find_lang wxstd
|
%find_lang wxstd30
|
||||||
%find_lang wxmsw
|
|
||||||
cat wxstd.lang wxmsw.lang > %{wxMain}.lang
|
rm -f %{buildroot}%{_datadir}/locale/it/LC_MESSAGES/wxmsw.mo
|
||||||
|
|
||||||
|
#% find_lang wxmsw
|
||||||
|
#cat wxstd.lang wxmsw.lang > %{wxMain}.lang
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
@ -285,7 +293,7 @@ fi
|
|||||||
%{_includedir}/wx-%{majversion}/*
|
%{_includedir}/wx-%{majversion}/*
|
||||||
%{_datadir}/aclocal/wxwin30.m4
|
%{_datadir}/aclocal/wxwin30.m4
|
||||||
|
|
||||||
%files -n %{wxMain}-i18n -f %{wxMain}.lang
|
%files -n %{wxMain}-i18n -f wxstd30.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
|
|
||||||
%files -n %{wxMain}-examples
|
%files -n %{wxMain}-examples
|
||||||
@ -295,6 +303,10 @@ fi
|
|||||||
%{_datadir}/bakefile/presets/*
|
%{_datadir}/bakefile/presets/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 19 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.5.1-1mamba
|
||||||
|
- update to 3.0.5.1
|
||||||
|
- add fix-locales-collision patch for i18n package to cohexist with 3.1
|
||||||
|
|
||||||
* Sun Mar 01 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.4-2mamba
|
* Sun Mar 01 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.4-2mamba
|
||||||
- rebuilt with debug package
|
- rebuilt with debug package
|
||||||
|
|
||||||
@ -389,7 +401,7 @@ fi
|
|||||||
* Wed Jun 30 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.2-5qilnx
|
* Wed Jun 30 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.2-5qilnx
|
||||||
- added symlink /usb/bin/wx-config
|
- added symlink /usb/bin/wx-config
|
||||||
|
|
||||||
* Wed Apr 20 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.2-4qilnx
|
* Tue Apr 20 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.2-4qilnx
|
||||||
- fixed default permission for devel package (%defattr missing)
|
- fixed default permission for devel package (%defattr missing)
|
||||||
- *.so moved to main package
|
- *.so moved to main package
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user