rebuilt with --enable-graphics_ctx [release 2.8.12-9mamba;Sat Jul 30 2016]
This commit is contained in:
parent
f310a1d7f2
commit
277be8211b
15
wxGTK-2.8.12-make-abi-check-not-fatal.patch
Normal file
15
wxGTK-2.8.12-make-abi-check-not-fatal.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff -up wxGTK-2.8.12/src/common/appbase.cpp.abicheck wxGTK-2.8.12/src/common/appbase.cpp
|
||||||
|
--- wxGTK-2.8.12/src/common/appbase.cpp.abicheck 2015-03-12 17:15:18.000000000 +0100
|
||||||
|
+++ wxGTK-2.8.12/src/common/appbase.cpp 2015-03-12 17:15:57.000000000 +0100
|
||||||
|
@@ -424,10 +424,7 @@ bool wxAppConsole::CheckBuildOptions(con
|
||||||
|
msg.Printf(_T("Mismatch between the program and library build versions detected.\nThe library used %s,\nand %s used %s."),
|
||||||
|
lib.c_str(), progName.c_str(), prog.c_str());
|
||||||
|
|
||||||
|
- wxLogFatalError(msg.c_str());
|
||||||
|
-
|
||||||
|
- // normally wxLogFatalError doesn't return
|
||||||
|
- return false;
|
||||||
|
+ wxLogWarning(msg.c_str());
|
||||||
|
}
|
||||||
|
#undef wxCMP
|
||||||
|
|
18
wxGTK.spec
18
wxGTK.spec
@ -9,7 +9,7 @@
|
|||||||
|
|
||||||
Name: %{wxMain}
|
Name: %{wxMain}
|
||||||
Version: 2.8.12
|
Version: 2.8.12
|
||||||
Release: 8mamba
|
Release: 9mamba
|
||||||
Summary: GTK+ port of the wxWidgets library
|
Summary: GTK+ port of the wxWidgets library
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -19,6 +19,7 @@ URL: http://wxwindows.org/
|
|||||||
Source: http://downloads.sourceforge.net/wxwindows/%{pkgname}-%{version}.tar.bz2
|
Source: http://downloads.sourceforge.net/wxwindows/%{pkgname}-%{version}.tar.bz2
|
||||||
Patch0: %{name}-2.8.9-gvfs_syntax.patch
|
Patch0: %{name}-2.8.9-gvfs_syntax.patch
|
||||||
Patch1: wxGTK-2.8.12-locale-compat.patch
|
Patch1: wxGTK-2.8.12-locale-compat.patch
|
||||||
|
Patch2: wxGTK-2.8.12-make-abi-check-not-fatal.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: GConf-devel
|
BuildRequires: GConf-devel
|
||||||
@ -240,8 +241,10 @@ The translations files for the wxWidgets library.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n wxGTK-%{version} -a0
|
%setup -q -n wxGTK-%{version} -a0
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
cd wxGTK-%{version}
|
cd wxGTK-%{version}
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
cd ..
|
cd ..
|
||||||
|
|
||||||
# FIXME: %{_datadir}/bakefile/presets generates a conflict between wx 2.6
|
# FIXME: %{_datadir}/bakefile/presets generates a conflict between wx 2.6
|
||||||
@ -257,6 +260,7 @@ cd ..
|
|||||||
--enable-shared \
|
--enable-shared \
|
||||||
--enable-soname \
|
--enable-soname \
|
||||||
--enable-tabdialog \
|
--enable-tabdialog \
|
||||||
|
--enable-graphics_ctx \
|
||||||
--enable-mediactrl \
|
--enable-mediactrl \
|
||||||
--with-libpng=sys \
|
--with-libpng=sys \
|
||||||
--with-libjpeg=sys \
|
--with-libjpeg=sys \
|
||||||
@ -271,7 +275,9 @@ cd ..
|
|||||||
--with-gnomevfs \
|
--with-gnomevfs \
|
||||||
--enable-optimise \
|
--enable-optimise \
|
||||||
--without-debug_flag \
|
--without-debug_flag \
|
||||||
--without-debug_info
|
--without-debug_info \
|
||||||
|
CXXFLAGS="%{optflags} -Wno-narrowing"
|
||||||
|
|
||||||
# --disable-compat26 \
|
# --disable-compat26 \
|
||||||
# --enable-accessibility
|
# --enable-accessibility
|
||||||
|
|
||||||
@ -289,6 +295,7 @@ cd wxGTK-%{version}
|
|||||||
--enable-shared \
|
--enable-shared \
|
||||||
--enable-soname \
|
--enable-soname \
|
||||||
--enable-tabdialog \
|
--enable-tabdialog \
|
||||||
|
--enable-graphics_ctx \
|
||||||
--enable-mediactrl \
|
--enable-mediactrl \
|
||||||
--with-libpng=sys \
|
--with-libpng=sys \
|
||||||
--with-libjpeg=sys \
|
--with-libjpeg=sys \
|
||||||
@ -303,7 +310,9 @@ cd wxGTK-%{version}
|
|||||||
--with-gnomevfs \
|
--with-gnomevfs \
|
||||||
--enable-optimise \
|
--enable-optimise \
|
||||||
--without-debug_flag \
|
--without-debug_flag \
|
||||||
--without-debug_info
|
--without-debug_info \
|
||||||
|
CXXFLAGS="%{optflags} -Wno-narrowing"
|
||||||
|
|
||||||
# --disable-compat26 \
|
# --disable-compat26 \
|
||||||
# --enable-accessibility
|
# --enable-accessibility
|
||||||
|
|
||||||
@ -470,6 +479,9 @@ fi
|
|||||||
%{_datadir}/bakefile/presets/*
|
%{_datadir}/bakefile/presets/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jul 30 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.12-9mamba
|
||||||
|
- rebuilt with --enable-graphics_ctx
|
||||||
|
|
||||||
* Tue Feb 02 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.12-8mamba
|
* Tue Feb 02 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.12-8mamba
|
||||||
- move presets to a -presets package to avoid confict with wxWidgets 3
|
- move presets to a -presets package to avoid confict with wxWidgets 3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user