update to 3.1 [release 3.1-1mamba;Sun Dec 12 2021]

This commit is contained in:
Silvan Calarco 2024-01-05 19:28:55 +01:00
parent 5aaa83641b
commit a4e07c514e
3 changed files with 90 additions and 55 deletions

View File

@ -1,11 +1,5 @@
# wordnet # wordnet
WordNet is a large lexical database of English, developed under the direction WordNet is a large lexical database of English, developed under the direction of George A. Miller. Nouns, verbs, adjectives and adverbs are grouped into sets of cognitive synonyms (synsets), each expressing a distinct concept. Synsets are interlinked by means of conceptual-semantic and lexical relations. The resulting network of meaningfully related words and concepts can be navigated with the browser. WordNet is also freely and publicly available for download.
of George A. Miller. Nouns, verbs, adjectives and adverbs are grouped into sets WordNet's structure makes it a useful tool for computational linguistics and natural language processing.
of cognitive synonyms (synsets), each expressing a distinct concept. Synsets
are interlinked by means of conceptual-semantic and lexical relations. The
resulting network of meaningfully related words and concepts can be navigated
with the browser. WordNet is also freely and publicly available for download.
WordNet's structure makes it a useful tool for computational linguistics and
natural language processing.

View File

@ -0,0 +1,10 @@
--- WordNet-3.0/src/stubs.c.orig 2021-12-12 15:32:32.165968570 +0000
+++ WordNet-3.0/src/stubs.c 2021-12-12 15:32:51.665783930 +0000
@@ -10,6 +10,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
+#define USE_INTERP_RESULT 1
#include <tcl.h>
#include <tk.h>
#include <wn.h>

View File

@ -1,13 +1,15 @@
%define srcver 3.0
Name: wordnet Name: wordnet
Version: 3.0 Version: 3.1
Release: 2mamba Release: 1mamba
Summary: A lexical database for the English language Summary: A lexical database for the English language
Group: Applications/Text Group: Applications/Text
Vendor: openmamba Vendor: openmamba
Distribution: openmamba Distribution: openmamba
Packager: gil <puntogil@libero.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://wordnet.princeton.edu/ URL: https://wordnet.princeton.edu/
Source: http://wordnetcode.princeton.edu/%{version}/WordNet-%{version}.tar.bz2 Source: https://wordnetcode.princeton.edu/%{srcver}/WordNet-%{srcver}.tar.bz2
Source1: https://wordnetcode.princeton.edu/wn%{version}.dict.tar.gz
Patch0: wordnet-3.0-CVE-2008-2149.patch Patch0: wordnet-3.0-CVE-2008-2149.patch
Patch1: wordnet-3.0-CVE-2008-3908.patch Patch1: wordnet-3.0-CVE-2008-3908.patch
Patch2: wordnet-3.0-fix_man.patch Patch2: wordnet-3.0-fix_man.patch
@ -17,39 +19,38 @@ Patch5: wordnet-3.0-wishwn_manpage.patch
Patch6: wordnet-3.0-use_system_tk_headers.patch Patch6: wordnet-3.0-use_system_tk_headers.patch
Patch7: wordnet-3.0-libtool.patch Patch7: wordnet-3.0-libtool.patch
Patch8: wordnet-3.0-error_message.patch Patch8: wordnet-3.0-error_message.patch
Patch9: wordnet-3.1-tcl-8.6.12.patch
License: GPL, MIT License: GPL, MIT
BuildRequires: automake
BuildRequires: libtool
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
BuildRequires: libexpat-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libpthread-stubs-devel
BuildRequires: libtcl-devel
BuildRequires: libtk-devel
BuildRequires: libX11-devel BuildRequires: libX11-devel
BuildRequires: libXScrnSaver-devel
BuildRequires: libXau-devel BuildRequires: libXau-devel
BuildRequires: libxcb-devel
BuildRequires: libXdmcp-devel BuildRequires: libXdmcp-devel
BuildRequires: libXext-devel BuildRequires: libXext-devel
BuildRequires: libXft-devel BuildRequires: libXft-devel
BuildRequires: libXrender-devel BuildRequires: libXrender-devel
BuildRequires: libXScrnSaver-devel BuildRequires: libbrotli-devel
BuildRequires: libbzip2-devel
BuildRequires: libexpat-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libglib-devel
BuildRequires: libgraphite2-devel
BuildRequires: libharfbuzz-devel
BuildRequires: libpng-devel
BuildRequires: libtcl-devel
BuildRequires: libtk-devel
BuildRequires: libxcb-devel
BuildRequires: libz-devel BuildRequires: libz-devel
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
BuildRequires: automake
BuildRequires: libtool
Requires: libwordnet = %{?epoch:%epoch:}%{version}-%{release} Requires: libwordnet = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description %description
WordNet is a large lexical database of English, developed under the direction WordNet is a large lexical database of English, developed under the direction of George A. Miller. Nouns, verbs, adjectives and adverbs are grouped into sets of cognitive synonyms (synsets), each expressing a distinct concept. Synsets are interlinked by means of conceptual-semantic and lexical relations. The resulting network of meaningfully related words and concepts can be navigated with the browser. WordNet is also freely and publicly available for download.
of George A. Miller. Nouns, verbs, adjectives and adverbs are grouped into sets WordNet's structure makes it a useful tool for computational linguistics and natural language processing.
of cognitive synonyms (synsets), each expressing a distinct concept. Synsets
are interlinked by means of conceptual-semantic and lexical relations. The
resulting network of meaningfully related words and concepts can be navigated
with the browser. WordNet is also freely and publicly available for download.
WordNet's structure makes it a useful tool for computational linguistics and
natural language processing.
%package -n libwordnet %package -n libwordnet
Summary: WordNet libraries Summary: WordNet libraries
@ -57,7 +58,6 @@ Group: System/Libraries
%description -n libwordnet %description -n libwordnet
A lexical database for the English language. A lexical database for the English language.
This package contains the WordNet libraries. This package contains the WordNet libraries.
%package -n libwordnet-devel %package -n libwordnet-devel
@ -67,65 +67,91 @@ Requires: libwordnet = %{?epoch:%epoch:}%{version}-%{release}
%description -n libwordnet-devel %description -n libwordnet-devel
A lexical database for the English language. A lexical database for the English language.
This package contains static libraries and header files needed for development.
This package contains static libraries and header files need for development. %debug_package
%prep %prep
%setup -q -n WordNet-%{version} %setup -q -c -a0 -a1
cd WordNet-%{srcver}
%patch0 -p1 -b .cve-2008-2149 %patch0 -p1 -b .cve-2008-2149
%patch1 -p1 -b .cve-2008-3908 %patch1 -p1 -b .cve-2008-3908
%patch2 -p1 -b .fix_man %patch2 -p1 -b .fix_man
%patch3 -p1 -b .fix_resourcedir_path #%patch3 -p1 -b .fix_resourcedir_path
%patch4 -p1 -b .src_stubs_c %patch4 -p1 -b .src_stubs_c
%patch5 -p1 -b .wishwn_manpage %patch5 -p1 -b .wishwn_manpage
sed -e '/man_MANS/ s/$/ wishwn.1/' -i doc/man/Makefile.am sed -e '/man_MANS/ s/$/ wishwn.1/' -i doc/man/Makefile.am
%patch6 -p1 -b .use_system_tk_headers %patch6 -p1 -b .use_system_tk_headers
%patch7 -p1 -b .libtool %patch7 -p1 -b .libtool
%patch8 -p1 -b .error_message %patch8 -p1 -b .error_message
%patch9 -p1 -b .tcl_8.6.12
sed 's:"/usr/local/WordNet-3.0/lib/wnres":"/usr/share/wordnet/wnres":' -i src/wnb
rm -rf include/tk rm -rf include/tk
%build
libtoolize && aclocal libtoolize && aclocal
autoupdate autoupdate
autoreconf -i autoreconf -i
%build
cd WordNet-%{srcver}
%configure \ %configure \
--prefix=%{_datadir}/wordnet \
--enable-static=no \ --enable-static=no \
--prefix=%{_datadir}/wordnet-%{version}/ --with-tcl=%{_prefix}/lib/tcl8.6
sed 's:#define DEFAULTPATH "/usr/dict":#define DEFAULTPATH "/usr/share/wordnet/dict":' -i config.h
%make %make
%install %install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}" [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall %makeinstall -C WordNet-%{srcver}
rm -f %{buildroot}%{_libdir}/libWN.la rm -f %{buildroot}%{_libdir}/libWN.la
rm -rf %{buildroot}%{_datadir}/%{name}-%{version}/doc rm -rf %{buildroot}%{_datadir}/%{name}-%{version}/doc
rm -rf doc/{html,ps,pdf}/Makefile* rm -rf doc/{html,ps,pdf}/Makefile*
# Replace dictionary files
rm -fr %{buildroot}%{_datadir}/wordnet/dict
cp -a dict %{buildroot}%{_datadir}/wordnet/dict
chmod -R u=rwX,go=rX %{buildroot}%{_datadir}/wordnet/dict
%clean %clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}" [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n libwordnet -p /sbin/ldconfig
%postun -n libwordnet -p /sbin/ldconfig
%files %files
%defattr(-,root,root) %defattr(-,root,root)
%{_bindir}/wishwn %{_bindir}/wishwn
%{_bindir}/wn %{_bindir}/wn
%{_bindir}/wnb %{_bindir}/wnb
%dir %{_datadir}/wordnet-%{version} %dir %{_datadir}/wordnet
%dir %{_datadir}/wordnet-%{version}/dict %dir %{_datadir}/wordnet/dict
%dir %{_datadir}/wordnet-%{version}/dict/* %{_datadir}/wordnet/dict/*
%dir %{_datadir}/wordnet-%{version}/lib %dir %{_datadir}/wordnet/lib
%dir %{_datadir}/wordnet-%{version}/lib/wnres %dir %{_datadir}/wordnet/lib/wnres
%dir %{_datadir}/wordnet-%{version}/lib/wnres/* %{_datadir}/wordnet/lib/wnres/*
%{_mandir}/man1/*.1.gz %dir %{_datadir}/wordnet/doc
%{_mandir}/man5/*.5.gz %dir %{_datadir}/wordnet/doc/html
%{_mandir}/man7/*.7.gz %{_datadir}/wordnet/doc/html/*
%doc AUTHORS COPYING ChangeLog INSTALL %dir %{_datadir}/wordnet/doc/pdf
%doc LICENSE README doc/{html,ps,pdf} %{_datadir}/wordnet/doc/pdf/*
%dir %{_datadir}/wordnet/doc/ps
%post -n libwordnet -p /sbin/ldconfig %{_datadir}/wordnet/doc/ps/*
%{_mandir}/man1/grind.1*
%postun -n libwordnet -p /sbin/ldconfig %{_mandir}/man1/wishwn.1*
%{_mandir}/man1/wn*.1*
%{_mandir}/man5/cntlist.5*
%{_mandir}/man5/lexnames.5*
%{_mandir}/man5/senseidx.5*
%{_mandir}/man5/wn*.5*
%{_mandir}/man7/morphy.7*
%{_mandir}/man7/uniqbeg.7*
%{_mandir}/man7/wn*.7*
%doc WordNet-%{srcver}/AUTHORS WordNet-%{srcver}/COPYING WordNet-%{srcver}/LICENSE
%files -n libwordnet %files -n libwordnet
%defattr(-,root,root) %defattr(-,root,root)
@ -135,9 +161,14 @@ rm -rf doc/{html,ps,pdf}/Makefile*
%defattr(-,root,root) %defattr(-,root,root)
%{_includedir}/wn.h %{_includedir}/wn.h
%{_libdir}/libWN.so %{_libdir}/libWN.so
%{_mandir}/man3/*.3.gz %{_mandir}/man3/binsrch.3*
%{_mandir}/man3/morph.3*
%{_mandir}/man3/wn*.3*
%changelog %changelog
* Sun Dec 12 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1-1mamba
- update to 3.1
* Sun Apr 10 2011 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 3.0-2mamba * Sun Apr 10 2011 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 3.0-2mamba
- rebuilt - rebuilt
* Sat Jan 22 2011 gil <puntogil@libero.it> 3.0-1mamba * Sat Jan 22 2011 gil <puntogil@libero.it> 3.0-1mamba