package created using the webbuild interface [release 1.0.11-1mamba;Sun Dec 22 2013]
This commit is contained in:
parent
5e57b041f2
commit
49196620a0
@ -1,2 +1,4 @@
|
||||
# winusb
|
||||
|
||||
winusb - A program to create Windows USB stick installer from a real Windows DVD or an image.
|
||||
|
||||
|
19
winusb-1.0.11-wxGTK-3.0.patch
Normal file
19
winusb-1.0.11-wxGTK-3.0.patch
Normal file
@ -0,0 +1,19 @@
|
||||
--- winusb-1.0.11/src/findFile.cpp.orig 2014-01-21 15:11:07.698652278 +0100
|
||||
+++ winusb-1.0.11/src/findFile.cpp 2014-01-21 15:11:29.388444590 +0100
|
||||
@@ -37,14 +37,14 @@
|
||||
}
|
||||
|
||||
#if defined(__UNIX__)
|
||||
- testPath = wxString(wxStandardPaths().GetInstallPrefix() + _T("/share/") + _T(PACKAGE) + _T("/") + str);
|
||||
+ testPath = wxString(wxStandardPaths::Get().GetInstallPrefix() + _T("/share/") + _T(PACKAGE) + _T("/") + str);
|
||||
if(wxFileExists(testPath) || wxDirExists(testPath)) // Si c'est dans le dossier /usr/.../share/nomprog
|
||||
{
|
||||
return testPath;
|
||||
}
|
||||
#endif // defined(__UNIX__)
|
||||
|
||||
- testPath = wxString(wxStandardPaths().GetDataDir() + _T("/") + str);
|
||||
+ testPath = wxString(wxStandardPaths::Get().GetDataDir() + _T("/") + str);
|
||||
if(wxFileExists(testPath) || wxDirExists(testPath)) // Si c'est dans le dossier /usr/.../share/nomPaquet
|
||||
{
|
||||
return testPath;
|
63
winusb.spec
Normal file
63
winusb.spec
Normal file
@ -0,0 +1,63 @@
|
||||
Name: winusb
|
||||
Version: 1.0.11
|
||||
Release: 1mamba
|
||||
Summary: A program to create Windows USB stick installer from a real Windows DVD or an image
|
||||
Group: Graphical Desktop/Applications/Utilities
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://en.congelli.eu/prog_info_winusb.html
|
||||
Source: http://en.congelli.eu/download/winusb/winusb-%{version}.tar.gz
|
||||
Patch0: winusb-1.0.11-wxGTK-3.0.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libwxBase-unicode-devel
|
||||
BuildRequires: libwxGTK-unicode-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: gksu
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
winusb - A program to create Windows USB stick installer from a real Windows DVD or an image.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/winusb
|
||||
%{_bindir}/winusbgui
|
||||
%{_datadir}/applications/winusbgui.desktop
|
||||
%{_datadir}/pixmaps/winusbgui-icon.png
|
||||
%dir %{_datadir}/winusb
|
||||
%dir %{_datadir}/winusb/data
|
||||
%{_datadir}/winusb/data/*
|
||||
%dir %{_datadir}/winusb/locale
|
||||
%dir %{_datadir}/winusb/locale/fr
|
||||
%dir %{_datadir}/winusb/locale/fr/LC_MESSAGES
|
||||
%{_datadir}/winusb/locale/fr/LC_MESSAGES/trad.mo
|
||||
%{_datadir}/winusb/locale/fr/LC_MESSAGES/wxstd.mo
|
||||
%{_mandir}/man1/winusb.1*
|
||||
%{_mandir}/man1/winusbgui.1*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%changelog
|
||||
* Sun Dec 22 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.11-1mamba
|
||||
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user