update to 2.0 [release 2.0-1mamba;Sun Mar 12 2017]

This commit is contained in:
Davide Madrisan 2024-01-05 19:26:59 +01:00
parent 00aff1b44d
commit d441d9f28a
3 changed files with 15 additions and 85 deletions

View File

@ -1,12 +0,0 @@
--- wine-1.1.42/dlls/ntdll/cdrom.c.orig 2010-04-12 22:15:41.000000000 +0200
+++ wine-1.1.42/dlls/ntdll/cdrom.c 2010-04-12 22:18:09.000000000 +0200
@@ -2675,6 +2675,9 @@
static NTSTATUS GetInquiryData(int fd, PSCSI_ADAPTER_BUS_INFO BufferOut, DWORD OutBufferSize)
{
#ifdef HAVE_SG_IO_HDR_T_INTERFACE_ID
+# ifndef INQUIRY
+# define INQUIRY 0x12
+# endif
PSCSI_INQUIRY_DATA pInquiryData = NULL;
UCHAR sense_buffer[32];
int iochk, version;

View File

@ -1,45 +0,0 @@
commit ce4b6451aabbe83809c7483c748cfa009cc090d6
Author: Alexandre Julliard <julliard@winehq.org>
Date: Fri May 10 22:01:44 2013 +0200
configure: Add explicit install targets in libs/wine for make_makefiles.
diff --git a/configure b/configure
index d4c1f8e..ef38bfd 100755
--- a/configure
+++ b/configure
@@ -16379,7 +16379,7 @@ wine_fn_config_makefile documentation enable_documentation
wine_fn_config_makefile fonts enable_fonts install-lib
wine_fn_config_makefile include enable_include install-dev
wine_fn_config_makefile libs/port enable_libs_port
-wine_fn_config_makefile libs/wine enable_libs_wine
+wine_fn_config_makefile libs/wine enable_libs_wine install-dev,install-lib
wine_fn_config_makefile libs/wpp enable_libs_wpp
wine_fn_config_makefile loader enable_loader install-lib,manpage
wine_fn_config_program aspnet_regiis enable_aspnet_regiis install
diff --git a/configure.ac b/configure.ac
index 6dd2348..b44673e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3173,7 +3173,7 @@ WINE_CONFIG_MAKEFILE([documentation])
WINE_CONFIG_MAKEFILE([fonts],,[install-lib])
WINE_CONFIG_MAKEFILE([include],,[install-dev])
WINE_CONFIG_MAKEFILE([libs/port])
-WINE_CONFIG_MAKEFILE([libs/wine])
+WINE_CONFIG_MAKEFILE([libs/wine],,[install-dev,install-lib])
WINE_CONFIG_MAKEFILE([libs/wpp])
WINE_CONFIG_MAKEFILE([loader],,[install-lib,manpage])
WINE_CONFIG_PROGRAM(aspnet_regiis,,[install])
diff --git a/libs/wine/Makefile.in b/libs/wine/Makefile.in
index b8dc385..7de7799 100644
--- a/libs/wine/Makefile.in
+++ b/libs/wine/Makefile.in
@@ -111,4 +111,8 @@ version.c: dummy
$(RELPATH):
@cd $(TOOLSDIR)/tools && $(MAKE) relpath$(TOOLSEXT)
+# Make sure that make_makefiles sees the install rules
+install install-lib::
+install install-dev::
+
@LIBWINE_RULES@

View File

@ -1,10 +1,13 @@
%define _use_internal_dependency_generator 1 %define _use_internal_dependency_generator 1
%define wine_gecko_ver 2.40
%define wine_mono_ver 4.6.2 %define wine_gecko_ver 2.40
%define WINE_GECKO_CHECKED_FOR_VERSION 1.8.3 %define wine_mono_ver 4.6.4
%define wine_staging_ver %{version} %define wine_staging_ver %{version}
%define WINE_GECKO_CHECKED_FOR_VERSION 2.0
Name: wine Name: wine
Version: 1.8.3 Version: 2.0
Release: 1mamba Release: 1mamba
Epoch: 3 Epoch: 3
Summary: An open source implementation of the Windows API on top of X and Unix Summary: An open source implementation of the Windows API on top of X and Unix
@ -13,8 +16,7 @@ Vendor: openmamba
Distribution: openmamba Distribution: openmamba
Packager: Davide Madrisan <davide.madrisan@gmail.com> Packager: Davide Madrisan <davide.madrisan@gmail.com>
URL: http://www.winehq.org URL: http://www.winehq.org
Source0: http://ibiblio.org/pub/linux/system/emulators/wine/wine-%{version}.tar.bz2 Source0: http://dl.winehq.org/wine/source/%{version}/wine-%{version}.tar.bz2
Source100: https://github.com/wine-compholio/wine-staging.git/v%{wine_staging_ver}-unofficial/wine-staging-%{version}.tar.bz2
Source1: wine-systemd-32 Source1: wine-systemd-32
Source2: wine-systemd-64 Source2: wine-systemd-64
Source3: wine_hidden_kde-desktop Source3: wine_hidden_kde-desktop
@ -33,18 +35,13 @@ Source16: wine-iexplore.desktop
Source20: wine-ldconfig-32 Source20: wine-ldconfig-32
Source21: wine-ldconfig-64 Source21: wine-ldconfig-64
# see: http://wiki.winehq.org/Gecko # see: http://wiki.winehq.org/Gecko
Source30: http://downloads.sourceforge.net/project/wine/Wine%20Gecko/%{wine_gecko_ver}/wine_gecko-%{wine_gecko_ver}-x86.msi Source30: http://dl.winehq.org/wine/wine-gecko/%{wine_gecko_ver}/wine_gecko-%{wine_gecko_ver}-x86.msi
Source31: http://downloads.sourceforge.net/project/wine/Wine%20Gecko/%{wine_gecko_ver}/wine_gecko-%{wine_gecko_ver}-x86_64.msi Source31: http://dl.winehq.org/wine/wine-gecko/%{wine_gecko_ver}/wine_gecko-%{wine_gecko_ver}-x86_64.msi
# see: http://wiki.winehq.org/Mono # see: http://wiki.winehq.org/Mono
Source40: http://dl.winehq.org/wine/wine-mono/%{wine_mono_ver}/wine-mono-%{wine_mono_ver}.msi Source40: http://dl.winehq.org/wine/wine-mono/%{wine_mono_ver}/wine-mono-%{wine_mono_ver}.msi
#Source40: http://downloads.sourceforge.net/project/wine/Wine%20Mono/%{wine_mono_ver}/wine-mono-%{wine_mono_ver}.tar.gz
# pipelight patchset, see http://fds-team.de/cms/pipelight-compile-wine.html
#Source41: http://fds-team.de/mirror/wine-patches-minimal-%{version}.tar.gz
Source42: wine-autoupdate Source42: wine-autoupdate
Patch2: %{name}-1.1.42-INQUIRY_undeclared.patch # Staging repository for Wine
Patch3: %{name}-1.5.30-restore-shared-lib.patch Source100: https://github.com/wine-compholio/wine-staging/archive/v%{wine_staging_ver}.tar.gz
#Patch4: ftp://ftp.etersoft.ru/pub/people/amorozov/usb/%{version}/0001-Add-support-of-native-Windows-drivers-for-USB-tokens.txt
#Patch5: ftp://ftp.etersoft.ru/pub/people/amorozov/usb/%{version}/0002-Re-generate-some-files.txt
License: LGPL License: LGPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: desktop-file-utils BuildRequires: desktop-file-utils
@ -182,25 +179,16 @@ Header, include files and library definition files for developing applications w
%prep %prep
%setup -q -n %{name}-%{version} %setup -q -n %{name}-%{version}
#-D -T
#:<< _EOF
#-a41
%if "%{version}" != "%{WINE_GECKO_CHECKED_FOR_VERSION}" %if "%{version}" != "%{WINE_GECKO_CHECKED_FOR_VERSION}"
echo "ERROR: please check if Wine Gecko is latest available at" echo "ERROR: please check if Wine Gecko is latest available at"
echo "http://sourceforge.net/projects/wine/files/Wine%20Gecko/" echo "http://sourceforge.net/projects/wine/files/Wine%20Gecko/"
exit 1 exit 1
%endif %endif
#%patch2 -p1
tar xvf %{SOURCE100} --strip-components 1 tar xvf %{SOURCE100} --strip-components 1
./patches/patchinstall.sh DESTDIR="$(pwd)" --all ./patches/patchinstall.sh DESTDIR="$(pwd)" --all
#%ifarch %{ix86}
#cat patches/*.patch | patch -p1
#%endif
%build %build
#:<< _EOF
%configure \ %configure \
--libdir=%{_libdir} \ --libdir=%{_libdir} \
--sysconfdir=%{_sysconfdir}/wine \ --sysconfdir=%{_sysconfdir}/wine \
@ -405,7 +393,6 @@ exit 0
%{_bindir}/winepath %{_bindir}/winepath
%{_bindir}/wineserver %{_bindir}/wineserver
%dir %{_datadir}/wine/fonts %dir %{_datadir}/wine/fonts
#%{_datadir}/wine/generic.ppd
%{_datadir}/wine/l_intl.nls %{_datadir}/wine/l_intl.nls
%{_datadir}/wine/wine.inf %{_datadir}/wine/wine.inf
%dir %{_datadir}/wine/gecko %dir %{_datadir}/wine/gecko
@ -495,8 +482,8 @@ exit 0
%doc documentation/README.* %doc documentation/README.*
%changelog %changelog
* Sun Jul 31 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.3-1mamba * Sun Mar 12 2017 Davide Madrisan <davide.madrisan@gmail.com> 2.0-1mamba
- update to 1.8.3 - update to 2.0
* Thu Apr 07 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.1-1mamba * Thu Apr 07 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.1-1mamba
- update to 1.8.1 - update to 1.8.1