update to 6.0.2 [release 6.0.2-1mamba;Sat Nov 27 2021]
This commit is contained in:
parent
2e27698ab0
commit
11cbe65989
50
wine-6.0.2-fix-conflict-ldap_contact.patch
Normal file
50
wine-6.0.2-fix-conflict-ldap_contact.patch
Normal file
@ -0,0 +1,50 @@
|
||||
From 69b2494e526246aab5f32c7b233594a393988a51 Mon Sep 17 00:00:00 2001
|
||||
From: yuiiio <atbjyk@protonmail.com>
|
||||
Date: Fri, 26 Nov 2021 22:23:32 +0900
|
||||
Subject: [PATCH] fix conflict ldap_connect
|
||||
|
||||
---
|
||||
dlls/wldap32/init.c | 2 +-
|
||||
dlls/wldap32/winldap_private.h | 2 +-
|
||||
dlls/wldap32/wldap32.spec | 2 +-
|
||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/dlls/wldap32/init.c b/dlls/wldap32/init.c
|
||||
index afaef3b52f2..d3409d1465b 100644
|
||||
--- a/dlls/wldap32/init.c
|
||||
+++ b/dlls/wldap32/init.c
|
||||
@@ -322,7 +322,7 @@ WLDAP32_LDAP * CDECL cldap_openW( PWCHAR hostname, ULONG portnumber )
|
||||
* The timeout parameter may be NULL in which case a default timeout
|
||||
* value will be used.
|
||||
*/
|
||||
-ULONG CDECL ldap_connect( WLDAP32_LDAP *ld, struct l_timeval *timeout )
|
||||
+ULONG CDECL WLDAP32_ldap_connect( WLDAP32_LDAP *ld, struct l_timeval *timeout )
|
||||
{
|
||||
TRACE( "(%p, %p)\n", ld, timeout );
|
||||
|
||||
diff --git a/dlls/wldap32/winldap_private.h b/dlls/wldap32/winldap_private.h
|
||||
index 69035050961..a6cddabf559 100644
|
||||
--- a/dlls/wldap32/winldap_private.h
|
||||
+++ b/dlls/wldap32/winldap_private.h
|
||||
@@ -320,7 +320,7 @@ ULONG CDECL ldap_compare_ext_sA(WLDAP32_LDAP*,PCHAR,PCHAR,PCHAR,struct WLDAP32_b
|
||||
ULONG CDECL ldap_compare_ext_sW(WLDAP32_LDAP*,PWCHAR,PWCHAR,PWCHAR,struct WLDAP32_berval*,PLDAPControlW*,PLDAPControlW*);
|
||||
ULONG CDECL ldap_compare_sA(WLDAP32_LDAP*,PCHAR,PCHAR,PCHAR);
|
||||
ULONG CDECL ldap_compare_sW(WLDAP32_LDAP*,PWCHAR,PWCHAR,PWCHAR);
|
||||
-ULONG CDECL ldap_connect(WLDAP32_LDAP*,LDAP_TIMEVAL*);
|
||||
+ULONG CDECL WLDAP32_ldap_connect(WLDAP32_LDAP*,LDAP_TIMEVAL*);
|
||||
WLDAP32_LDAP * CDECL ldap_conn_from_msg(WLDAP32_LDAP*,WLDAP32_LDAPMessage*);
|
||||
ULONG CDECL ldap_control_freeA(LDAPControlA*);
|
||||
ULONG CDECL ldap_control_freeW(LDAPControlW*);
|
||||
diff --git a/dlls/wldap32/wldap32.spec b/dlls/wldap32/wldap32.spec
|
||||
index 8a8e29fc198..33e630dea87 100644
|
||||
--- a/dlls/wldap32/wldap32.spec
|
||||
+++ b/dlls/wldap32/wldap32.spec
|
||||
@@ -75,7 +75,7 @@
|
||||
85 cdecl ldap_compare_ext_sW(ptr wstr wstr wstr ptr ptr ptr)
|
||||
86 cdecl ldap_compare_sA(ptr str str str)
|
||||
87 cdecl ldap_compare_sW(ptr wstr wstr wstr)
|
||||
- 88 cdecl ldap_connect(ptr ptr)
|
||||
+ 88 cdecl ldap_connect(ptr ptr) WLDAP32_ldap_connect
|
||||
89 cdecl ldap_control_free(ptr) ldap_control_freeA
|
||||
90 cdecl ldap_control_freeA(ptr)
|
||||
91 cdecl ldap_control_freeW(ptr)
|
53
wine.spec
53
wine.spec
@ -6,20 +6,20 @@
|
||||
%define wine_gecko_ver 2.47.2
|
||||
# see: http://wiki.winehq.org/Mono
|
||||
%define wine_mono_ver 5.1.1
|
||||
%define wine_staging_ver %{version}
|
||||
%define wine_staging_ver %(echo %version | cut -d. -f1-2)
|
||||
|
||||
%define WINE_GECKO_CHECKED_FOR_VERSION 6.0
|
||||
%define WINE_GECKO_CHECKED_FOR_VERSION 6.0.2
|
||||
|
||||
Name: wine
|
||||
Version: 6.0
|
||||
Version: 6.0.2
|
||||
Release: 1mamba
|
||||
Epoch: 3
|
||||
Summary: An open source implementation of the Windows API on top of X and Unix
|
||||
Group: Applications/Emulators
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||
URL: http://www.winehq.org
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.winehq.org/
|
||||
Source0: http://dl.winehq.org/wine/source/%{MAJver}.0/wine-%{version}.tar.xz
|
||||
Source1: wine-systemd-32
|
||||
Source2: wine-systemd-64
|
||||
@ -44,29 +44,28 @@ Source40: http://dl.winehq.org/wine/wine-mono/%{wine_mono_ver}/wine-mono-%{
|
||||
Source42: wine-autoupdate
|
||||
# Staging repository for Wine
|
||||
Source100: https://github.com/wine-staging/wine-staging.git/v%{wine_staging_ver}/wine-staging-%{version}.tar.bz2
|
||||
Patch0: wine-6.0.2-fix-conflict-ldap_contact.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libGLUT-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libaudio-devel
|
||||
BuildRequires: libesound-devel
|
||||
BuildRequires: libgphoto-devel
|
||||
BuildRequires: liblcms-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgphoto2-devel
|
||||
BuildRequires: libgst-plugins-base-devel
|
||||
BuildRequires: libgstreamer-devel
|
||||
BuildRequires: liblcms2-devel
|
||||
BuildRequires: libmpg123-devel
|
||||
BuildRequires: libopenal-devel
|
||||
BuildRequires: libopenldap-devel
|
||||
BuildRequires: libpcap-devel
|
||||
BuildRequires: libperl
|
||||
BuildRequires: libpulseaudio-devel
|
||||
BuildRequires: libudev-devel
|
||||
BuildRequires: libunwind-devel
|
||||
BuildRequires: libusb-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: mpg123-devel
|
||||
BuildRequires: ocl-icd-devel
|
||||
BuildRequires: perl-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libgphoto2-devel >= 1:2.5.19-1mamba
|
||||
@ -195,13 +194,16 @@ Header, include files and library definition files for developing applications w
|
||||
#-D -T
|
||||
#:<< __EOF
|
||||
%if "%{version}" != "%{WINE_GECKO_CHECKED_FOR_VERSION}"
|
||||
echo "ERROR: please check if Wine Gecko is latest available at"
|
||||
echo "http://sourceforge.net/projects/wine/files/Wine%20Gecko/"
|
||||
echo "ERROR: please check for needed Wine Gecko version at"
|
||||
echo "https://wiki.winehq.org/Gecko"
|
||||
exit 1
|
||||
%endif
|
||||
|
||||
tar xvf %{SOURCE100} --strip-components 1
|
||||
./patches/patchinstall.sh DESTDIR="$(pwd)" --all
|
||||
%patch0 -p1 -b .fix-conflict-ldap_contact
|
||||
|
||||
# 6.0.2: wine-staging patches do not apply, temporary disabled
|
||||
#tar xvf %{SOURCE100} --strip-components 1
|
||||
#./patches/patchinstall.sh DESTDIR="$(pwd)" --all
|
||||
|
||||
%build
|
||||
#:<< __EOF
|
||||
@ -501,6 +503,9 @@ exit 0
|
||||
%doc documentation/README.*
|
||||
|
||||
%changelog
|
||||
* Sat Nov 27 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 6.0.2-1mamba
|
||||
- update to 6.0.2
|
||||
|
||||
* Fri Jan 22 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 6.0-1mamba
|
||||
- update to 6.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user