automatic version update by autodist [release 18-1mamba;Sat Mar 01 2014]
This commit is contained in:
parent
2ea4231404
commit
375510480f
@ -1,2 +1,4 @@
|
||||
# widelands
|
||||
|
||||
In Widelands, you are the regent of a small tribe. You start out with nothing but your headquarters, a kind of castle in which all your resources are stored. Every member of your tribe will do his or her part to produce more resources - wood, food, iron, gold and more - to further this growth. But you are not alone in the world, and you will meet other tribes sooner or later. Some of them may be friendly and trade with you. However, if you want to rule the world, you will have to train soldiers and fight.. :°
|
||||
|
||||
|
10
widelands-17-gcc-4.7.patch
Normal file
10
widelands-17-gcc-4.7.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- widelands-build17-src/src/main.cc.orig 2013-07-15 13:22:34.201117347 +0200
|
||||
+++ widelands-build17-src/src/main.cc 2013-07-15 13:22:48.369970197 +0200
|
||||
@@ -28,6 +28,7 @@
|
||||
#include <iostream>
|
||||
#include <stdexcept>
|
||||
#include <typeinfo>
|
||||
+#include <unistd.h>
|
||||
|
||||
#include <SDL_main.h>
|
||||
|
48
widelands.flagfix.patch
Normal file
48
widelands.flagfix.patch
Normal file
@ -0,0 +1,48 @@
|
||||
diff -up ./build/scons-tools/scons_configure.py.flagfix ./build/scons-tools/scons_configure.py
|
||||
--- ./build/scons-tools/scons_configure.py.flagfix 2008-04-06 20:39:50.000000000 +0200
|
||||
+++ ./build/scons-tools/scons_configure.py 2008-04-06 20:40:32.000000000 +0200
|
||||
@@ -440,35 +440,7 @@ def do_configure_compiler_warnings(confi
|
||||
#conf.CheckCompilerFlag('-Werror', env)
|
||||
|
||||
def do_configure_compiler_features(config_h_file, conf, env):
|
||||
- conf.CheckCompilerFlag('-fstack-protector-all', env)
|
||||
- conf.CheckCompilerFlag('-fbounds-check', env)
|
||||
- conf.CheckCompilerFlag('-pipe', env)
|
||||
-
|
||||
- if env.optimize:
|
||||
- # !!!! -fomit-frame-pointer breaks execeptions !!!!
|
||||
- conf.CheckCompilerFlag('-fexpensive-optimizations', env)
|
||||
- conf.CheckCompilerFlag('-finline-functions', env)
|
||||
- conf.CheckCompilerFlag('-ffast-math', env)
|
||||
- conf.CheckCompilerFlag('-funroll-loops', env)
|
||||
- conf.CheckCompilerFlag('-O3', env)
|
||||
- else:
|
||||
- conf.CheckCompilerFlag('-O0', env)
|
||||
-
|
||||
- if env.profile:
|
||||
- conf.CheckCompilerFlag('-pg', env)
|
||||
- conf.CheckCompilerFlag('-fprofile-arcs', env)
|
||||
-
|
||||
- if env.debug:
|
||||
- conf.CheckCompilerFlag('-g', env)
|
||||
- conf.CheckCompilerFlag('-fmessage-length=0', env)
|
||||
-
|
||||
-def do_configure_linker_features(config_h_file, conf, env):
|
||||
- if env.profile:
|
||||
- conf.CheckLinkerFlag('-pg', env)
|
||||
- conf.CheckLinkerFlag('-fprofile-arcs', env)
|
||||
-
|
||||
- if env.strip:
|
||||
- conf.CheckLinkerFlag('-s', env)
|
||||
+ conf.CheckCompilerFlag('flagi', env)
|
||||
|
||||
def do_configure(conf, env):
|
||||
config_h_file=write_configh_header()
|
||||
@@ -480,7 +452,6 @@ def do_configure(conf, env):
|
||||
|
||||
do_configure_compiler_warnings(config_h_file, conf, env)
|
||||
do_configure_compiler_features(config_h_file, conf, env)
|
||||
- do_configure_linker_features(config_h_file, conf, env)
|
||||
|
||||
write_configh(config_h_file, env)
|
||||
write_configh_footer(config_h_file)
|
196
widelands.spec
Normal file
196
widelands.spec
Normal file
@ -0,0 +1,196 @@
|
||||
Name: widelands
|
||||
Version: 18
|
||||
Release: 1mamba
|
||||
Summary: A game like Settlers II
|
||||
Group: Graphical Desktop/Applications/Games
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://widelands.sourceforge.net/
|
||||
#Source0: http://downloads.sourceforge.net/widelands/widelands-build-%{version}-source.tar.bz2
|
||||
#Source: http://downloads.sourceforge.net/widelands/widelands-build-%{version}-linuxi386.tar.bz2
|
||||
Source: https://launchpad.net/widelands/build%{version}/build-%{version}/+download/widelands-build%{version}-src.tar.bz2
|
||||
#Source: http://launchpad.net/widelands/build16/build16/+download/widelands-build%{version}-src.tar.bz2
|
||||
Patch0: widelands.flagfix.patch
|
||||
Patch1: widelands-17-gcc-4.7.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libglew-devel
|
||||
BuildRequires: liblua-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libSDL_gfx-devel
|
||||
BuildRequires: libSDL_image-devel
|
||||
BuildRequires: libSDL_mixer-devel
|
||||
BuildRequires: libSDL_net-devel
|
||||
BuildRequires: libSDL_ttf-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libglew-devel >= 1.9.0
|
||||
BuildRequires: ctags
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: scons
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: gettext
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: make
|
||||
#BuildRequires: libggz-devel, libggz-client-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
In Widelands, you are the regent of a small tribe. You start out with nothing but your headquarters, a kind of castle in which all your resources are stored. Every member of your tribe will do his or her part to produce more resources - wood, food, iron, gold and more - to further this growth. But you are not alone in the world, and you will meet other tribes sooner or later. Some of them may be friendly and trade with you. However, if you want to rule the world, you will have to train soldiers and fight.. :°
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-build%{version}-src
|
||||
#-D -T
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%cmake -d build ../ \
|
||||
-DLUA_LIBRARY=%{_libdir}/liblua.so.5.1 \
|
||||
-DLUA_INCLUDE_DIR=`pkg-config --variable=includedir lua5.1`
|
||||
|
||||
%make
|
||||
# scons build=release \
|
||||
# build_id=%{version} \
|
||||
# install_prefix=%{_datadir}/games/%{name} \
|
||||
# bindir=%{_bindir} \
|
||||
# datadir=%{_datadir}/games/%{name} \
|
||||
# localedir=%{_datadir}/games/%{name} \
|
||||
# build_id=build-%{version}
|
||||
|
||||
## enable_ggz=1
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
#scons datadir=%{buildroot}%{_datadir}/games/%{name} \
|
||||
# bindir=%{buildroot}%{_bindir} \
|
||||
# localedir=%{buildroot}%{_datadir}/games/%{name} \
|
||||
# build_id=build-%{version} \
|
||||
# install
|
||||
|
||||
install -d -m0755 %{buildroot}%{_bindir}
|
||||
ln -s ../games/widelands %{buildroot}%{_bindir}/widelands
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/applications
|
||||
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/16x16/apps
|
||||
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/32x32/apps
|
||||
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/48x48/apps
|
||||
|
||||
install -m0644 pics/wl-ico-16.png %{buildroot}%{_datadir}/icons/hicolor/16x16/apps/%{name}.png
|
||||
install -m0644 pics/wl-ico-32.png %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/%{name}.png
|
||||
install -m0644 pics/wl-ico-48.png %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/%{name}.png
|
||||
|
||||
cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
|
||||
[Desktop Entry]
|
||||
Name=Widelands
|
||||
Comment=Open source realtime-strategy game
|
||||
Exec=/usr/bin/widelands
|
||||
Icon=/usr/share/icons/hicolor/48x48/apps/widelands.png
|
||||
Terminal=false
|
||||
Type=Application
|
||||
StartupNotify=false
|
||||
Categories=Game;StrategyGame;
|
||||
EOF
|
||||
|
||||
#cd %{buildroot}
|
||||
#find usr/share/games/widelands/locale/ -maxdepth 1 -type d -name \*_\* | sed -n 's#\(usr/share/games/widelands/locale/\(.*\)_.*\)#%lang(\2) /\1#p' > %{_builddir}/%{name}/%{name}.files
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
# For the next release
|
||||
#%pre
|
||||
# preparing system before update
|
||||
#cat << EOF | while read name; do rm -rf "%{_datadir}/widelands/maps/${name}.wmf"; done
|
||||
#Checkmate
|
||||
#Dry Riverbed
|
||||
#Elven Forests
|
||||
#Enemy in sight
|
||||
#Finlakes
|
||||
#Firegames
|
||||
#Four Castles
|
||||
#Glacier Lake
|
||||
#Golden Peninsula
|
||||
#Lake of tranquility
|
||||
#Plateau
|
||||
#Riverlands
|
||||
#The Oasis Triangle
|
||||
#The big lake
|
||||
#The long way
|
||||
#Two frontiers
|
||||
#War of the Valleys
|
||||
#EOF
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/widelands
|
||||
%{_prefix}/games/widelands
|
||||
%{_datadir}/applications/%{name}.desktop
|
||||
%{_datadir}/icons/hicolor/*x*/apps/%{name}.png
|
||||
%dir %{_datadir}/games/widelands
|
||||
%{_datadir}/games/widelands/COPYING
|
||||
%{_datadir}/games/widelands/CREDITS
|
||||
%{_datadir}/games/widelands/ChangeLog
|
||||
%{_datadir}/games/widelands/VERSION
|
||||
%dir %{_datadir}/games/widelands/campaigns
|
||||
%{_datadir}/games/widelands/campaigns/cconfig
|
||||
%{_datadir}/games/widelands/campaigns/*.wmf
|
||||
#%dir %{_datadir}/games/widelands/doc
|
||||
%dir %{_datadir}/games/widelands/fonts
|
||||
%{_datadir}/games/widelands/fonts/*.ttf
|
||||
%{_datadir}/games/widelands/fonts/README.DejaVu
|
||||
%dir %{_datadir}/games/widelands/fonts/Widelands
|
||||
%{_datadir}/games/widelands/fonts/Widelands/FONTLOG
|
||||
%{_datadir}/games/widelands/fonts/Widelands/LICENSE
|
||||
%{_datadir}/games/widelands/fonts/Widelands/Widelands.ttf
|
||||
%dir %{_datadir}/games/widelands/locale
|
||||
%{_datadir}/games/widelands/locale/*
|
||||
%dir %{_datadir}/games/widelands/global
|
||||
%{_datadir}/games/widelands/global/*
|
||||
%dir %{_datadir}/games/widelands/maps
|
||||
%{_datadir}/games/widelands/maps/*.wmf
|
||||
%{_datadir}/games/widelands/maps/*/*.wmf/*
|
||||
%dir %{_datadir}/games/widelands/music
|
||||
%{_datadir}/games/widelands/music/*.ogg
|
||||
%dir %{_datadir}/games/widelands/pics
|
||||
%{_datadir}/games/widelands/pics/*
|
||||
%dir %{_datadir}/games/widelands/scripting
|
||||
%{_datadir}/games/widelands/scripting/*
|
||||
%dir %{_datadir}/games/widelands/sound
|
||||
%{_datadir}/games/widelands/sound/*
|
||||
%dir %{_datadir}/games/widelands/txts
|
||||
%{_datadir}/games/widelands/txts/*
|
||||
%dir %{_datadir}/games/widelands/tribes
|
||||
%{_datadir}/games/widelands/tribes/atlanteans
|
||||
%{_datadir}/games/widelands/tribes/barbarians
|
||||
%{_datadir}/games/widelands/tribes/empire
|
||||
%dir %{_datadir}/games/widelands/worlds
|
||||
%{_datadir}/games/widelands/worlds/blackland
|
||||
%{_datadir}/games/widelands/worlds/desert
|
||||
%{_datadir}/games/widelands/worlds/greenland
|
||||
%{_datadir}/games/widelands/worlds/winterland
|
||||
%doc COPYING CREDITS
|
||||
#ChangeLog
|
||||
|
||||
%changelog
|
||||
* Sat Mar 01 2014 Automatic Build System <autodist@mambasoft.it> 18-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jul 15 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 17-2mamba
|
||||
- rebuilt with libSDL_gfx 2.0.24
|
||||
|
||||
* Sat Apr 28 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 17-1mamba
|
||||
- update to 17
|
||||
|
||||
* Fri Dec 16 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 16-1mamba
|
||||
- update to 16
|
||||
|
||||
* Fri Sep 19 2008 gil <puntogil@libero.it> 12-1mamba
|
||||
- added desktop file
|
Loading…
Reference in New Issue
Block a user