automatic version update by autodist [release 1.15-1mamba;Sun Jan 19 2014]

This commit is contained in:
Automatic Build System 2024-01-05 19:14:28 +01:00
parent 50b89a506a
commit 0d96881bb2
10 changed files with 523 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# wget
GNU Wget is a file retrieval utility which can use either the HTTP or FTP protocols.
Wget features include the ability to work in the background while you're logged out, recursive retrieval of directories, file name wildcard matching, remote file timestamp storage and comparison, use of Rest with FTP servers and Range with HTTP servers to retrieve files over slow or unstable connections, support for Proxy servers, and configurability.

104
wget-1.10-ctype.patch Normal file
View File

@ -0,0 +1,104 @@
OpenSSL 0.9.7 now includes ctype.h, and because OpenSSL's headers are included
after safe-ctype.h, compilation bombs out. We include ctype.h to force the
double-inclusion checks in ctype.h to be triggered when we include OpenSSL's
headers, avoiding the whole mess.
--- wget-1.8.2/src/ftp.c 2002-12-13 20:27:59.000000000 -0500
+++ wget-1.8.2/src/ftp.c 2002-12-13 20:27:54.000000000 -0500
@@ -30,6 +30,8 @@
#include <config.h>
+#include <ctype.h>
+
#include <stdio.h>
#include <stdlib.h>
#ifdef HAVE_STRING_H
--- wget-1.8.2/src/ftp-basic.c 2002-12-13 20:28:18.000000000 -0500
+++ wget-1.8.2/src/ftp-basic.c 2002-12-13 20:28:12.000000000 -0500
@@ -29,6 +29,8 @@
#include <config.h>
+#include <ctype.h>
+
#include <assert.h>
#include <stdio.h>
#include <stdlib.h>
--- wget-1.8.2/src/ftp-ls.c 2002-12-13 20:28:36.000000000 -0500
+++ wget-1.8.2/src/ftp-ls.c 2002-12-13 20:28:31.000000000 -0500
@@ -30,6 +30,8 @@
#include <config.h>
+#include <ctype.h>
+
#include <stdio.h>
#include <stdlib.h>
#ifdef HAVE_STRING_H
--- wget-1.8.2/src/http.c 2002-12-13 20:29:07.000000000 -0500
+++ wget-1.8.2/src/http.c 2002-12-13 20:29:13.000000000 -0500
@@ -30,6 +30,8 @@
#include <config.h>
+#include <ctype.h>
+
#include <stdio.h>
#include <stdlib.h>
#include <sys/types.h>
--- wget-1.8.2/src/retr.c 2002-12-13 20:29:49.000000000 -0500
+++ wget-1.8.2/src/retr.c 2002-12-13 20:29:55.000000000 -0500
@@ -29,6 +29,8 @@
#include <config.h>
+#include <ctype.h>
+
#include <stdio.h>
#include <stdlib.h>
#include <sys/types.h>
--- wget-1.8.2/src/main.c 2002-12-13 20:30:14.000000000 -0500
+++ wget-1.8.2/src/main.c 2002-12-13 20:30:17.000000000 -0500
@@ -30,6 +30,8 @@
#include <config.h>
+#include <ctype.h>
+
#include <stdio.h>
#include <stdlib.h>
#ifdef HAVE_UNISTD_H
--- wget-1.8.2/src/progress.c 2002-12-13 20:30:07.000000000 -0500
+++ wget-1.8.2/src/progress.c 2002-12-13 20:30:03.000000000 -0500
@@ -29,6 +29,8 @@
#include <config.h>
+#include <ctype.h>
+
#include <stdio.h>
#include <stdlib.h>
#ifdef HAVE_STRING_H
--- wget-1.8.2/src/recur.c 2002-12-13 20:30:46.000000000 -0500
+++ wget-1.8.2/src/recur.c 2002-12-13 20:30:43.000000000 -0500
@@ -29,6 +29,8 @@
#include <config.h>
+#include <ctype.h>
+
#include <stdio.h>
#include <stdlib.h>
#ifdef HAVE_STRING_H
--- wget-1.8.2/src/res.c 2002-12-13 20:31:02.000000000 -0500
+++ wget-1.8.2/src/res.c 2002-12-13 20:30:59.000000000 -0500
@@ -71,6 +71,8 @@
# include <config.h>
#endif
+#include <ctype.h>
+
#include <stdio.h>
#include <stdlib.h>
#ifdef HAVE_STRING_H

View File

@ -0,0 +1,15 @@
Fixes NULL pointer dereference (CVE-2006-6719) (bz #221483)
--- wget-1.10.2/src/ftp-basic.c.orig 2007-01-04 19:30:31.000000000 +0100
+++ wget-1.10.2/src/ftp-basic.c 2007-01-04 19:31:48.000000000 +0100
@@ -1038,7 +1038,9 @@ ftp_syst (int csock, enum stype *server_
first word of the server response)? */
request = strtok (NULL, " ");
- if (!strcasecmp (request, "VMS"))
+ if (request == NULL)
+ *server_type = ST_OTHER;
+ else if (!strcasecmp (request, "VMS"))
*server_type = ST_VMS;
else if (!strcasecmp (request, "UNIX"))
*server_type = ST_UNIX;

View File

@ -0,0 +1,27 @@
diff -Nru wget-1.11.4.orig/src/log.c wget-1.11.4/src/log.c
--- wget-1.11.4.orig/src/log.c 2008-04-27 06:48:23.000000000 +0200
+++ wget-1.11.4/src/log.c 2008-09-08 02:44:19.000000000 +0200
@@ -516,12 +516,19 @@
{
if (file)
{
- logfp = fopen (file, appendp ? "a" : "w");
- if (!logfp)
+ if (strcmp(file, "-"))
{
- fprintf (stderr, "%s: %s: %s\n", exec_name, file, strerror (errno));
- exit (1);
+ logfp = fopen (file, appendp ? "a" : "w");
+ if (!logfp)
+ {
+ fprintf (stderr, "%s: %s: %s\n", exec_name, file, strerror (errno));
+ exit (1);
+ }
}
+ else
+ {
+ logfp = stdout;
+ }
}
else
{

View File

@ -0,0 +1,11 @@
diff -Nru wget-1.11.4.orig/doc/sample.wgetrc wget-1.11.4/doc/sample.wgetrc
--- wget-1.11.4.orig/doc/sample.wgetrc 2008-09-08 02:36:16.000000000 +0200
+++ wget-1.11.4/doc/sample.wgetrc 2008-09-08 02:37:05.000000000 +0200
@@ -43,6 +43,7 @@
# problems supporting passive transfer. If you are in such
# environment, use "passive_ftp = off" to revert to active FTP.
#passive_ftp = off
+passive_ftp = on
# The "wait" command below makes Wget wait between every connection.
# If, instead, you want Wget to wait only between retries of failed

40
wget-1.13-etc.patch Normal file
View File

@ -0,0 +1,40 @@
diff -Nru wget-1.13.orig/doc/wget.texi wget-1.13/doc/wget.texi
--- wget-1.13.orig/doc/wget.texi 2011-08-06 12:22:58.000000000 +0200
+++ wget-1.13/doc/wget.texi 2011-08-12 11:42:02.549749776 +0200
@@ -190,14 +190,14 @@
Most of the features are fully configurable, either through command line
options, or via the initialization file @file{.wgetrc} (@pxref{Startup
File}). Wget allows you to define @dfn{global} startup files
-(@file{/usr/local/etc/wgetrc} by default) for site settings. You can also
+(@file{/etc/wgetrc} by default) for site settings. You can also
specify the location of a startup file with the --config option.
@ignore
@c man begin FILES
@table @samp
-@item /usr/local/etc/wgetrc
+@item /etc/wgetrc
Default location of the @dfn{global} startup file.
@item .wgetrc
@@ -2696,8 +2696,8 @@
@cindex location of wgetrc
When initializing, Wget will look for a @dfn{global} startup file,
-@file{/usr/local/etc/wgetrc} by default (or some prefix other than
-@file{/usr/local}, if Wget was not installed there) and read commands
+@file{/etc/wgetrc} by default (or some prefix other than
+@file{/etc}, if Wget was not installed there) and read commands
from there, if it exists.
Then it will look for the user's file. If the environmental variable
@@ -2708,7 +2708,7 @@
The fact that user's settings are loaded after the system-wide ones
means that in case of collision user's wgetrc @emph{overrides} the
-system-wide wgetrc (in @file{/usr/local/etc/wgetrc} by default).
+system-wide wgetrc (in @file{/etc/wgetrc} by default).
Fascist admins, away!
@node Wgetrc Syntax, Wgetrc Commands, Wgetrc Location, Startup File

96
wget-1.14-libproxy.patch Normal file
View File

@ -0,0 +1,96 @@
Index: configure.ac
===================================================================
--- configure.ac.orig
+++ configure.ac
@@ -338,6 +338,22 @@ else
fi
fi
+dnl
+dnl libproxy support
+dnl
+AC_ARG_ENABLE(libproxy,
+ [ --enable-libproxy libproxy support for system wide proxy configuration])
+if test "${enable_libproxy}" != "no"
+then
+ PKG_CHECK_MODULES([libproxy], [libproxy-1.0], [enable_libproxy=yes], [enable_libproxy=no])
+fi
+if test "${enable_libproxy}" = "yes"
+then
+ AC_SUBST(libproxy_CFLAGS)
+ AC_SUBST(libproxy_LIBS)
+ AC_DEFINE([HAVE_LIBPROXY], 1, [Define when using libproxy])
+fi
+
dnl **********************************************************************
dnl Checks for IPv6
dnl **********************************************************************
Index: src/Makefile.am
===================================================================
--- src/Makefile.am.orig
+++ src/Makefile.am
@@ -37,7 +37,7 @@ endif
# The following line is losing on some versions of make!
DEFS = @DEFS@ -DSYSTEM_WGETRC=\"$(sysconfdir)/wgetrc\" -DLOCALEDIR=\"$(localedir)\"
-LIBS = @LIBICONV@ @LIBINTL@ @LIBS@ $(LIB_CLOCK_GETTIME)
+LIBS = @LIBICONV@ @LIBINTL@ @libproxy_LIBS@ @LIBS@ $(LIB_CLOCK_GETTIME)
EXTRA_DIST = css.l css.c css_.c build_info.c.in
Index: src/retr.c
===================================================================
--- src/retr.c.orig
+++ src/retr.c
@@ -54,6 +54,10 @@ as that of the covered work. */
#include "html-url.h"
#include "iri.h"
+#ifdef HAVE_LIBPROXY
+#include "proxy.h"
+#endif
+
/* Total size of downloaded files. Used to enforce quota. */
SUM_SIZE_INT total_downloaded_bytes;
@@ -1182,7 +1186,40 @@ getproxy (struct url *u)
break;
}
if (!proxy || !*proxy)
+#ifdef HAVE_LIBPROXY
+ {
+ pxProxyFactory *pf = px_proxy_factory_new();
+ if (!pf)
+ {
+ logprintf (LOG_VERBOSE, _("Allocating memory for libproxy failed"));
+ return NULL;
+ }
+ int i;
+ char direct[] = "direct://";
+
+ logprintf (LOG_VERBOSE, _("asking libproxy about url '%s'\n"), u->url);
+ char **proxies = px_proxy_factory_get_proxies(pf, u->url);
+ if (proxies[0])
+ {
+ char *check = NULL;
+ asprintf(&check , "%s", proxies[0]);
+ logprintf (LOG_VERBOSE, _("libproxy suggest to use '%s'\n"), check);
+ if(strcmp(check ,direct) != 0)
+ {
+ asprintf(&proxy , "%s", proxies[0]);
+ logprintf (LOG_VERBOSE, _("case 2: libproxy setting to use '%s'\n"), proxy);
+ }
+ }
+ for(i=0;proxies[i];i++) free(proxies[i]);
+ free(proxies);
+ free(pf);
+
+ if (!proxy || !*proxy)
+ return NULL;
+ }
+#else
return NULL;
+#endif
/* Handle shorthands. `rewritten_storage' is a kludge to allow
getproxy() to return static storage. */

14
wget-1.8.2-msec.patch Normal file
View File

@ -0,0 +1,14 @@
--- wget-1.9.1/src/retr.c 2003-10-11 15:57:11.000000000 +0200
+++ wget-1.9.1/src/retr.c.patched 2004-03-01 17:19:23.000000000 +0100
@@ -288,7 +288,10 @@
{
double dlrate;
- assert (msecs >= 0);
+ /* fix msec for machines with non ordinal clock */
+ if (msecs < 0)
+ msecs = 0;
+
assert (bytes >= 0);
if (msecs == 0)

View File

@ -0,0 +1,45 @@
--- wget-1.9.1/src/http.c
+++ wget-1.9.1/src/http.c
@@ -1479,6 +1479,7 @@
/* Open the local file. */
if (!opt.dfp)
{
+ sanitize_path(*hs->local_file);
mkalldirs (*hs->local_file);
if (opt.backups)
rotate_backups (*hs->local_file);
--- wget-1.9.1/src/utils.c
+++ wget-1.9.1/src/utils.c
@@ -554,6 +554,22 @@
#endif
}
+
+char *
+sanitize_path(char *path)
+{
+ char *str = NULL;
+
+ /* evilhost/.bashrc and evilhost/.. */
+ while ((str = strstr(path, "/.")) != NULL)
+ str[1] = '_';
+ /* .bashrc */
+ if (*path == '.')
+ *path = '_';
+ return path;
+}
+
+
/* Returns 0 if PATH is a directory, 1 otherwise (any kind of file).
Returns 0 on error. */
int
--- wget-1.9.1/src/utils.h
+++ wget-1.9.1/src/utils.h
@@ -75,6 +75,7 @@
int make_directory PARAMS ((const char *));
char *unique_name PARAMS ((const char *, int));
char *file_merge PARAMS ((const char *, const char *));
+char *sanitize_path PARAMS ((char *));
int acceptable PARAMS ((const char *));
int accdir PARAMS ((const char *s, enum accd));

168
wget.spec Normal file
View File

@ -0,0 +1,168 @@
%define with_ssl 1
Name: wget
Version: 1.15
Release: 1mamba
Epoch: 1
Summary: A utility for retrieving files using the HTTP or FTP protocols
Group: Applications/Networking
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://ftp.gnu.org/gnu/wget
Source: http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.gz
Patch0: %{name}-1.8.2-msec.patch
Patch1: %{name}-1.11.4-passive_ftp.patch
Patch2: %{name}-1.13-etc.patch
Patch3: %{name}-1.11.4-logstdout.patch
Patch4: %{name}-1.9.1-can-2004-1487_1488.patch
Patch5: %{name}-1.10-ctype.patch
Patch6: %{name}-1.10.2-CVE-2006-6719.patch
Patch7: wget-1.14-libproxy.patch
License: GPL
Requires(post): %{__install_info}
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgcrypt-devel
BuildRequires: libgmp-devel
BuildRequires: libgnutls-devel
BuildRequires: libgpg-error-devel
BuildRequires: libidn-devel
BuildRequires: libnettle-devel
BuildRequires: libpcre-devel
BuildRequires: libproxy-devel
BuildRequires: libtasn1-devel
BuildRequires: libuuid-devel
BuildRequires: libz-devel
BuildRequires: p11-kit-devel
## AUTOBUILDREQ-END
BuildRequires: gettext-devel
Requires(post):%{__install_info}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
GNU Wget is a file retrieval utility which can use either the HTTP or FTP protocols.
Wget features include the ability to work in the background while you're logged out, recursive retrieval of directories, file name wildcard matching, remote file timestamp storage and comparison, use of Rest with FTP servers and Range with HTTP servers to retrieve files over slow or unstable connections, support for Proxy servers, and configurability.
%prep
%setup -q
#%patch0 -p1 -b .msec
%patch1 -p1 -b .passive_ftp.patch
#%patch2 -p1 -b .etc
%patch3 -p1 -b .logstdout
#%patch4 -p1 -b .can-2004-1487_1488
#%patch5 -p1 -b .ctype
#%patch6 -p1 -b .cve-2006-6719
%patch7 -p0
%build
autoreconf
%if %with_ssl
%configure --with-ssl
%else
%configure
%endif
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
#install -m755 util/rmold.pl %{buildroot}%{_bindir}/rmold
%find_lang %{name}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post
%install_info %{name}.info
%preun
%uninstall_info %{name}.info
exit 0
%files -f %{name}.lang
%defattr(-,root,root)
%{_bindir}/wget
#%{_bindir}/rmold
%config(noreplace) %{_sysconfdir}/wgetrc
%{_mandir}/man1/*
%{_infodir}/%{name}.info.*
%doc AUTHORS COPYING src/ChangeLog MAILING-LIST NEWS README
%changelog
* Sun Jan 19 2014 Automatic Build System <autodist@mambasoft.it> 1.15-1mamba
- automatic version update by autodist
* Sat Nov 10 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.14-2mamba
- added libproxy support patch (from opensuse)
* Mon Aug 06 2012 Automatic Build System <autodist@mambasoft.it> 1.14-1mamba
- automatic version update by autodist
* Sun Sep 18 2011 Automatic Build System <autodist@mambasoft.it> 1.13.4-1mamba
- automatic version update by autodist
* Wed Aug 31 2011 Automatic Build System <autodist@mambasoft.it> 1.13.3-1mamba
- automatic version update by autodist
* Wed Aug 17 2011 Automatic Build System <autodist@mambasoft.it> 1.13.1-1mamba
- automatic version update by autodist
* Fri Aug 12 2011 Automatic Build System <autodist@mambasoft.it> 1.13-1mamba
- automatic version update by autodist
* Thu Nov 11 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12-2mamba
- rebuilt with openssl 1.0.0
* Mon Oct 12 2009 Automatic Build System <autodist@mambasoft.it> 1.12-1mamba
- automatic update to 1.12 by autodist
* Fri Sep 19 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.11.4-1mamba
- automatic update to 1.11.4 by autodist
* Tue Nov 13 2007 Aleph0 <aleph0@openmamba.org> 1.10.2-4mamba
- rebuilt
* Thu Mar 22 2007 Davide Madrisan <davide.madrisan@qilinux.it> 1.10.2-3qilnx
- always exit successfully from the %%preun script
* Tue Mar 20 2007 Davide Madrisan <davide.madrisan@qilinux.it> 1.10.2-2qilnx
- security fix against CVE-2006-6719
* Mon Oct 17 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.10.2-1qilnx
- update to version 1.10.2 by autospec
- also fixes the security issue QSA-2005-120 (CAN-2005-3185)
* Thu Oct 06 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.10.1-2qilnx
- removed rmold.pl script
* Mon Aug 22 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.10.1-1qilnx
- update to version 1.10.1 by autospec
- also fixes the security issue CAN-2004-2014
- patches updated
* Fri Jun 10 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.9.1-2qilnx
- security fix against CAN-2004-1487 and CAN-2004-1488
- large file support (LFS patch)
- fixed package group
- install/uninstall info files
* Mon Mar 01 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.9.1-1qilnx
- new version rebuilt
* Thu Jul 17 2003 Silvan Calarco <silvan.calarco@qinet.it> 1.8.2-5qilnx
- added msec patch to allow program continuation when system clock is not monotone
* Tue May 27 2003 Alessandro Ramazzina <alessandro.ramazzina@qinet.it> 1.82-4qilnx
- modified wgetrc file, ftp passive is on now
* Mon May 26 2003 Alessandro Ramazzina <alessandro.ramazzina@qinet.it> 1.82-3qilnx
- added sysconfdir and infodir parameters
* Tue Apr 29 2003 Luca Tinelli <luca.tinelli@qinet.it> 1.82-2qilnx
- changed .bz extension for compress files
* Tue Apr 08 2003 Luca Tinelli <luca.tinelli@qinet.it> 1.82-1qilnx
- first build