automatic version update by autodist [release 1.680-1mamba;Thu Mar 13 2014]
This commit is contained in:
parent
2d782f04b1
commit
c13c39e8b8
@ -1,2 +1,4 @@
|
|||||||
# webmin
|
# webmin
|
||||||
|
|
||||||
|
Webmin is a web-based interface for system administration for Unix. Using any modern web browser, you can setup user accounts, Apache, DNS, file sharing and much more. Webmin removes the need to manually edit Unix configuration files like /etc/passwd, and lets you manage a system from the console or remotely.
|
||||||
|
|
||||||
|
14
webmin-1.510-openmamba.patch
Normal file
14
webmin-1.510-openmamba.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -Nru webmin-1.510.orig//apache/config-openmamba-linux webmin-1.510/apache/config-openmamba-linux
|
||||||
|
--- webmin-1.510.orig//apache/config-openmamba-linux 2010-03-05 02:22:24.000000000 +0100
|
||||||
|
+++ webmin-1.510/apache/config-openmamba-linux 2010-04-09 17:56:53.686300739 +0200
|
||||||
|
@@ -1,6 +1,9 @@
|
||||||
|
show_list=0
|
||||||
|
-httpd_dir=/etc/httpd
|
||||||
|
+httpd_dir=/var/www/html
|
||||||
|
+httpd_conf=/etc/httpd/httpd.conf
|
||||||
|
httpd_path=/usr/sbin/httpd
|
||||||
|
+srm_conf=/etc/httpd/srm.conf
|
||||||
|
+access_conf=/etc/httpd/access.conf
|
||||||
|
mime_types=/etc/httpd/mime.types
|
||||||
|
start_cmd=/etc/rc.d/init.d/httpd start
|
||||||
|
stop_cmd=/etc/rc.d/init.d/httpd stop
|
80
webmin-1.640-install_noroot.patch
Normal file
80
webmin-1.640-install_noroot.patch
Normal file
@ -0,0 +1,80 @@
|
|||||||
|
diff -Nru webmin-1.420.orig/setup.sh webmin-1.420/setup.sh
|
||||||
|
--- webmin-1.420.orig/setup.sh 2008-06-04 15:08:13.000000000 +0200
|
||||||
|
+++ webmin-1.420/setup.sh 2008-06-04 15:11:17.000000000 +0200
|
||||||
|
@@ -33,17 +33,6 @@
|
||||||
|
echo "systems and common Unix services to be easily administered."
|
||||||
|
echo ""
|
||||||
|
|
||||||
|
-# Only root can run this
|
||||||
|
-id | grep "uid=0(" >/dev/null
|
||||||
|
-if [ $? != "0" ]; then
|
||||||
|
- uname -a | grep -i CYGWIN >/dev/null
|
||||||
|
- if [ $? != "0" ]; then
|
||||||
|
- echo "ERROR: The Webmin install script must be run as root";
|
||||||
|
- echo "";
|
||||||
|
- exit 1;
|
||||||
|
- fi
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
# Use the supplied destination directory, if any
|
||||||
|
if [ "$1" != "" ]; then
|
||||||
|
wadir=$1
|
||||||
|
@@ -364,12 +353,6 @@
|
||||||
|
echo ""
|
||||||
|
exit 12
|
||||||
|
fi
|
||||||
|
- $perl -e 'use Socket; socket(FOO, PF_INET, SOCK_STREAM, getprotobyname("tcp")); setsockopt(FOO, SOL_SOCKET, SO_REUSEADDR, pack("l", 1)); bind(FOO, pack_sockaddr_in($ARGV[0], INADDR_ANY)) || exit(1); exit(0);' $port
|
||||||
|
- if [ $? != "0" ]; then
|
||||||
|
- echo "ERROR: TCP port $port is already in use by another program"
|
||||||
|
- echo ""
|
||||||
|
- exit 13
|
||||||
|
- fi
|
||||||
|
printf "Login name (default admin): "
|
||||||
|
if [ "$login" = "" ]; then
|
||||||
|
read login
|
||||||
|
@@ -740,45 +740,6 @@
|
||||||
|
echo ""
|
||||||
|
fi
|
||||||
|
|
||||||
|
-echo "Changing ownership and permissions .."
|
||||||
|
-# Make all config dirs non-world-readable
|
||||||
|
-for m in $newmods; do
|
||||||
|
- chown -R root $config_dir/$m
|
||||||
|
- chgrp -R bin $config_dir/$m
|
||||||
|
- chmod -R og-rw $config_dir/$m
|
||||||
|
-done
|
||||||
|
-# Make miniserv config files non-world-readable
|
||||||
|
-for f in miniserv.conf miniserv.pem miniserv.users; do
|
||||||
|
- chown -R root $config_dir/$f
|
||||||
|
- chgrp -R bin $config_dir/$f
|
||||||
|
- chmod -R og-rw $config_dir/$f
|
||||||
|
-done
|
||||||
|
-chmod +r $config_dir/version
|
||||||
|
-if [ "$nochown" = "" ]; then
|
||||||
|
- # Make program directory non-world-writable, but executable
|
||||||
|
- chown -R root "$wadir"
|
||||||
|
- chgrp -R bin "$wadir"
|
||||||
|
- chmod -R og-w "$wadir"
|
||||||
|
- chmod -R a+rx "$wadir"
|
||||||
|
-fi
|
||||||
|
-if [ $var_dir != "/var" -a "$upgrading" != 1 ]; then
|
||||||
|
- # Make log directory non-world-readable or writable
|
||||||
|
- chown -R root $var_dir
|
||||||
|
- chgrp -R bin $var_dir
|
||||||
|
- chmod -R og-rwx $var_dir
|
||||||
|
-fi
|
||||||
|
-# Fix up bad permissions from some older installs
|
||||||
|
-for m in ldap-client ldap-server ldap-useradmin mailboxes mysql postgresql servers virtual-server; do
|
||||||
|
- if [ -d "$config_dir/$m" ]; then
|
||||||
|
- chown root $config_dir/$m
|
||||||
|
- chgrp bin $config_dir/$m
|
||||||
|
- chmod og-rw $config_dir/$m
|
||||||
|
- chmod og-rw $config_dir/$m/config 2>/dev/null
|
||||||
|
- fi
|
||||||
|
-done
|
||||||
|
-echo "..done"
|
||||||
|
-echo ""
|
||||||
|
-
|
||||||
|
# Save target directory if one was specified
|
||||||
|
if [ "$wadir" != "$srcdir" ]; then
|
||||||
|
echo $wadir >$config_dir/install-dir
|
13
webmin-desktop
Normal file
13
webmin-desktop
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
[Desktop Entry]
|
||||||
|
Version=1.0
|
||||||
|
Encoding=UTF-8
|
||||||
|
Name=Webmin
|
||||||
|
GenericName=Web based system administration tool
|
||||||
|
GenericName[it]=Interfaccia web di amministrazione del sistema
|
||||||
|
Comment=Configure the system via Webmin Web interface
|
||||||
|
Comment[it]=Configura il sistema con l'interfaccia Web Webmin
|
||||||
|
Exec=konqueror https://localhost:10000
|
||||||
|
Type=Application
|
||||||
|
Icon=kcontrol
|
||||||
|
Terminal=false
|
||||||
|
Categories=Application;System;
|
51
webmin-initscript
Normal file
51
webmin-initscript
Normal file
@ -0,0 +1,51 @@
|
|||||||
|
#! /bin/bash
|
||||||
|
#
|
||||||
|
# webmin Start/Stop the webmin service
|
||||||
|
# Copyright (c) 2007 by Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
#
|
||||||
|
# chkconfig: 2345 90 60
|
||||||
|
# description: a web-based interface for system administration for Unix
|
||||||
|
#
|
||||||
|
# Source function library.
|
||||||
|
. /etc/init.d/functions
|
||||||
|
|
||||||
|
WEBMIN_CONFIG=/etc/webmin
|
||||||
|
RETVAL=0
|
||||||
|
|
||||||
|
prog="webmin"
|
||||||
|
|
||||||
|
start() {
|
||||||
|
echo -n $"Starting $prog: "
|
||||||
|
$WEBMIN_CONFIG/start
|
||||||
|
evaluate_retval
|
||||||
|
echo
|
||||||
|
}
|
||||||
|
|
||||||
|
stop() {
|
||||||
|
echo -n $"Stopping $prog: "
|
||||||
|
$WEBMIN_CONFIG/stop
|
||||||
|
evaluate_retval
|
||||||
|
echo
|
||||||
|
}
|
||||||
|
|
||||||
|
restart() {
|
||||||
|
stop
|
||||||
|
start
|
||||||
|
}
|
||||||
|
|
||||||
|
case "$1" in
|
||||||
|
start)
|
||||||
|
start
|
||||||
|
;;
|
||||||
|
stop)
|
||||||
|
stop
|
||||||
|
;;
|
||||||
|
restart)
|
||||||
|
restart
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
echo $"Usage: $0 {start|stop|restart}"
|
||||||
|
exit 1
|
||||||
|
esac
|
||||||
|
|
||||||
|
exit $?
|
231
webmin.spec
Normal file
231
webmin.spec
Normal file
@ -0,0 +1,231 @@
|
|||||||
|
Name: webmin
|
||||||
|
Version: 1.680
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A web-based interface for system administration for Unix
|
||||||
|
Group: Applications/Web
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.webmin.com/index.html
|
||||||
|
Source: http://prdownloads.sourceforge.net/webadmin/webmin-%{version}.tar.gz
|
||||||
|
Source1: webmin-initscript
|
||||||
|
Source2: webmin-desktop
|
||||||
|
Patch0: %{name}-1.640-install_noroot.patch
|
||||||
|
Patch1: %{name}-1.510-openmamba.patch
|
||||||
|
License: GPL
|
||||||
|
BuildRequires: perl-Net-SSLeay >= 1.25
|
||||||
|
Requires: perl(CGI)
|
||||||
|
Requires: perl(Config)
|
||||||
|
Requires: perl(DBI)
|
||||||
|
Requires: perl(Data::Dumper)
|
||||||
|
Requires: perl(DynaLoader)
|
||||||
|
Requires: perl(Encode::HanConvert)
|
||||||
|
Requires: perl(English)
|
||||||
|
Requires: perl(Exporter)
|
||||||
|
Requires: perl(Fcntl)
|
||||||
|
Requires: perl(File::Basename)
|
||||||
|
Requires: perl(Getopt::Long)
|
||||||
|
Requires: perl(Getopt::Std)
|
||||||
|
Requires: perl(IPC::Open2)
|
||||||
|
Requires: perl(Mon::Client)
|
||||||
|
Requires: perl(Net::SSLeay)
|
||||||
|
Requires: perl(POSIX)
|
||||||
|
Requires: perl(Socket)
|
||||||
|
Requires: perl(Text::Wrap)
|
||||||
|
Requires: perl(Time::Local)
|
||||||
|
Requires: perl(ctime.pl)
|
||||||
|
Requires: perl(strict)
|
||||||
|
Requires: perl(timelocal.pl)
|
||||||
|
Requires: perl(vars)
|
||||||
|
Requires: perl(warnings)
|
||||||
|
Requires(post):expect
|
||||||
|
#Requires: shorewall
|
||||||
|
AutoReqProv: off
|
||||||
|
BuildArch: noarch
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Webmin is a web-based interface for system administration for Unix. Using any modern web browser, you can setup user accounts, Apache, DNS, file sharing and much more. Webmin removes the need to manually edit Unix configuration files like /etc/passwd, and lets you manage a system from the console or remotely.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
#%patch1 -p1
|
||||||
|
rm acl/Authen-SolarisRBAC-0.1/blib/arch/auto/Authen/SolarisRBAC/SolarisRBAC.so
|
||||||
|
mkdir tmp
|
||||||
|
|
||||||
|
%build
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
install -d %{buildroot}{%{_sysconfdir}/webmin,%{_prefix},/var/log/webmin,/opt/webmin}
|
||||||
|
|
||||||
|
export tempdir=%{_builddir}/%{name}-%{version}/tmp
|
||||||
|
|
||||||
|
config_dir=%{buildroot}%{_sysconfdir}/webmin \
|
||||||
|
var_dir=%{buildroot}/var/log/webmin \
|
||||||
|
perl=%{_bindir}/perl \
|
||||||
|
port=10000 \
|
||||||
|
login=admin \
|
||||||
|
password=tmppass \
|
||||||
|
ssl=1 \
|
||||||
|
atboot=0 \
|
||||||
|
nostart=1 \
|
||||||
|
./setup.sh %{buildroot}/opt/webmin
|
||||||
|
|
||||||
|
rm -f %{buildroot}%{_sysconfdir}/webmin/uninstall.sh
|
||||||
|
|
||||||
|
# strip buildroot from configuration files
|
||||||
|
find %{buildroot}%{_sysconfdir}/webmin -type f -exec sed -i 's|%{buildroot}||g' {} \;
|
||||||
|
|
||||||
|
# install initscript
|
||||||
|
install -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/webmin
|
||||||
|
|
||||||
|
# install desktop link
|
||||||
|
install -D -m 0644 %{SOURCE2} %{buildroot}%{_datadir}/applications/webmin.desktop
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}/var/log/webmin
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post
|
||||||
|
# new install
|
||||||
|
if [ $1 -eq 1 ]; then
|
||||||
|
|
||||||
|
RANDOM_PASSWD=`/usr/bin/mkpasswd -l 10 -s 0`
|
||||||
|
perl -e 'print "$ARGV[0]:",crypt($ARGV[1], "\$1\$XXXXXXXX"),":0\n"' "admin" "$RANDOM_PASSWD" \
|
||||||
|
> %{_sysconfdir}/webmin/miniserv.users
|
||||||
|
echo "# autogenerated admin password: $RANDOM_PASSWD" \
|
||||||
|
> %{_sysconfdir}/webmin/ADMIN_PASSWORD
|
||||||
|
chmod 600 %{_sysconfdir}/webmin/ADMIN_PASSWORD
|
||||||
|
echo "info: see webmin randomly generated password for admin in /etc/webmin/ADMIN_PASSWORD"
|
||||||
|
/sbin/chkconfig --add webmin
|
||||||
|
service webmin start
|
||||||
|
fi
|
||||||
|
if [ $1 -gt 1 ]; then
|
||||||
|
# upgrade
|
||||||
|
service webmin restart
|
||||||
|
fi
|
||||||
|
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
%preun
|
||||||
|
#erase
|
||||||
|
if [ $1 -eq 0 ]; then
|
||||||
|
service webmin stop 2>/dev/null
|
||||||
|
/sbin/chkconfig --del webmin
|
||||||
|
fi
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,bin)
|
||||||
|
%{_initrddir}/webmin
|
||||||
|
%dir %{_sysconfdir}/webmin
|
||||||
|
%config(noreplace) %{_sysconfdir}/webmin/*
|
||||||
|
%{_datadir}/applications/webmin.desktop
|
||||||
|
%dir /opt/webmin
|
||||||
|
/opt/webmin/*
|
||||||
|
%dir /var/log/webmin
|
||||||
|
%doc LICENCE README
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Mar 13 2014 Automatic Build System <autodist@mambasoft.it> 1.680-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Jan 14 2014 Automatic Build System <autodist@mambasoft.it> 1.670-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Oct 15 2013 Automatic Build System <autodist@mambasoft.it> 1.660-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Aug 18 2013 Automatic Build System <autodist@mambasoft.it> 1.650-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Aug 13 2013 Automatic Build System <autodist@mambasoft.it> 1.640-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed May 15 2013 Automatic Build System <autodist@mambasoft.it> 1.630-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Feb 04 2013 Automatic Build System <autodist@mambasoft.it> 1.620-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Nov 16 2012 Automatic Build System <autodist@mambasoft.it> 1.610-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Sep 21 2012 Automatic Build System <autodist@mambasoft.it> 1.600-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Jun 30 2012 Automatic Build System <autodist@mambasoft.it> 1.590-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Jan 22 2012 Automatic Build System <autodist@mambasoft.it> 1.580-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Oct 03 2011 Automatic Build System <autodist@mambasoft.it> 1.570-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Aug 05 2011 Automatic Build System <autodist@mambasoft.it> 1.560-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Apr 27 2011 Automatic Build System <autodist@mambasoft.it> 1.550-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Apr 01 2011 Automatic Build System <autodist@mambasoft.it> 1.540-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sun Dec 19 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.530-1mamba
|
||||||
|
- update to 1.530
|
||||||
|
|
||||||
|
* Wed Sep 08 2010 Automatic Build System <autodist@mambasoft.it> 1.520-1mamba
|
||||||
|
- automatic update to 1.520 by autodist
|
||||||
|
|
||||||
|
* Fri Apr 09 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.510-2mamba
|
||||||
|
- added openmamba patch for apache
|
||||||
|
|
||||||
|
* Fri Apr 09 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.510-1mamba
|
||||||
|
- update to 1.510
|
||||||
|
|
||||||
|
* Sun Dec 06 2009 Automatic Build System <autodist@mambasoft.it> 1.500-1mamba
|
||||||
|
- automatic update to 1.500 by autodist
|
||||||
|
|
||||||
|
* Thu Sep 17 2009 Automatic Build System <autodist@mambasoft.it> 1.490-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Mon Jun 15 2009 Automatic Build System <autodist@mambasoft.it> 1.480-1mamba
|
||||||
|
- automatic update to 1.480 by autodist
|
||||||
|
|
||||||
|
* Wed Mar 18 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.470-1mamba
|
||||||
|
- automatic update to 1.470 by autodist
|
||||||
|
|
||||||
|
* Thu Mar 12 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.460-1mamba
|
||||||
|
- automatic update to 1.460 by autodist
|
||||||
|
|
||||||
|
* Mon Jan 26 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.450-1mamba
|
||||||
|
- automatic update to 1.450 by autodist
|
||||||
|
|
||||||
|
* Tue Oct 28 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.441-1mamba
|
||||||
|
- automatic update to 1.441 by autodist
|
||||||
|
|
||||||
|
* Sat Oct 25 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.440-1mamba
|
||||||
|
- automatic update to 1.440 by autodist
|
||||||
|
|
||||||
|
* Sun Aug 31 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.430-1mamba
|
||||||
|
- update to 1.430
|
||||||
|
|
||||||
|
* Wed Jun 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.420-1mamba
|
||||||
|
- update to 1.420
|
||||||
|
|
||||||
|
* Thu Feb 14 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.400-1mamba
|
||||||
|
- update to 1.400
|
||||||
|
|
||||||
|
* Thu Aug 09 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.360-1mamba
|
||||||
|
- update to 1.360
|
||||||
|
- dropped openmamba patch (merged upstream)
|
||||||
|
|
||||||
|
* Tue Jul 03 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.350-2mamba
|
||||||
|
- enabled some missing modules with the new patch
|
||||||
|
|
||||||
|
* Fri Jun 29 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.350-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user