update to 2.30.2 [release 2.30.2-1mamba;Sat Nov 14 2020]
This commit is contained in:
parent
302b80663d
commit
1df1dd2256
16
webkitgtk-2.30.2-x86-arm-jit-build-workaround.patch
Normal file
16
webkitgtk-2.30.2-x86-arm-jit-build-workaround.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
--- webkitgtk-2.30.2/Source/JavaScriptCore/runtime/ExecutableBase.h.orig 2020-11-15 13:38:05.728335800 +0100
|
||||||
|
+++ webkitgtk-2.30.2/Source/JavaScriptCore/runtime/ExecutableBase.h 2020-11-15 13:39:39.097033310 +0100
|
||||||
|
@@ -179,10 +179,11 @@
|
||||||
|
|
||||||
|
bool hasJITCodeFor(CodeSpecializationKind kind) const
|
||||||
|
{
|
||||||
|
- if (kind == CodeForCall)
|
||||||
|
+ return false;
|
||||||
|
+/* if (kind == CodeForCall)
|
||||||
|
return hasJITCodeForCall();
|
||||||
|
ASSERT(kind == CodeForConstruct);
|
||||||
|
- return hasJITCodeForConstruct();
|
||||||
|
+ return hasJITCodeForConstruct();*/
|
||||||
|
}
|
||||||
|
|
||||||
|
// Intrinsics are only for calls, currently.
|
@ -20,7 +20,7 @@
|
|||||||
%define libname libwebkit2gtk
|
%define libname libwebkit2gtk
|
||||||
|
|
||||||
Name: webkitgtk
|
Name: webkitgtk
|
||||||
Version: 2.28.4
|
Version: 2.30.2
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Port of WebKit embeddable web component to GTK+
|
Summary: Port of WebKit embeddable web component to GTK+
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
@ -31,6 +31,7 @@ URL: http://www.webkitgtk.org/
|
|||||||
Source0: http://www.webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
|
Source0: http://www.webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
|
||||||
Patch0: libwebkit-gtk-1.3.10-nspluginwrapper.patch
|
Patch0: libwebkit-gtk-1.3.10-nspluginwrapper.patch
|
||||||
Patch1: webkitgtk-2.16.6-arm-sync_add_and_fetch_8_duplicate.patch
|
Patch1: webkitgtk-2.16.6-arm-sync_add_and_fetch_8_duplicate.patch
|
||||||
|
Patch2: webkitgtk-2.30.2-x86-arm-jit-build-workaround.patch
|
||||||
License: BSD, LGPL
|
License: BSD, LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -142,17 +143,19 @@ This package contains the documentation for %{name},
|
|||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q -D -T
|
||||||
#-D -T
|
:<< _EOF
|
||||||
|
%ifarch arm %{ix86}
|
||||||
|
%patch2 -p1
|
||||||
|
%endif
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#:<< _EOF
|
#%ifnarch x86_64
|
||||||
%ifnarch x86_64
|
## To workaround ar 4GB file limit see also:
|
||||||
# To workaround ar 4GB file limit see also:
|
## https://build.opensuse.org/package/view_file/openSUSE:Factory/webkit2gtk3/webkit2gtk3.spec
|
||||||
# https://build.opensuse.org/package/view_file/openSUSE:Factory/webkit2gtk3/webkit2gtk3.spec
|
#EXTRA_CFLAGS="-g0 -Wl,--no-keep-memory -Wl,--no-map-whole-files"
|
||||||
EXTRA_CFLAGS="-g0 -Wl,--no-keep-memory -fuse-ld=gold -Wl,--no-map-whole-files -Wl,--no-keep-files-mapped"
|
#EXTRA_CXXFLAGS="-g0 -Wl,--no-keep-memory -Wl,--no-map-whole-files"
|
||||||
EXTRA_CXXFLAGS="-g0 -Wl,--no-keep-memory -fuse-ld=gold -Wl,--no-map-whole-files -Wl,--no-keep-files-mapped"
|
#%endif
|
||||||
%endif
|
|
||||||
|
|
||||||
%cmake -d build \
|
%cmake -d build \
|
||||||
\
|
\
|
||||||
@ -174,10 +177,11 @@ EXTRA_CXXFLAGS="-g0 -Wl,--no-keep-memory -fuse-ld=gold -Wl,--no-map-whole-files
|
|||||||
-DCMAKE_MODULE_LINKER_FLAGS="-Wl,--as-needed -Wl,-z,now -pthread" \
|
-DCMAKE_MODULE_LINKER_FLAGS="-Wl,--as-needed -Wl,-z,now -pthread" \
|
||||||
-DCMAKE_SHARED_LINKER_FLAGS="-Wl,--as-needed -Wl,-z,now -pthread" \
|
-DCMAKE_SHARED_LINKER_FLAGS="-Wl,--as-needed -Wl,-z,now -pthread" \
|
||||||
%ifarch arm
|
%ifarch arm
|
||||||
-DENABLE_JIT=OFF \
|
|
||||||
-DENABLE_SPELLCHECK=0
|
-DENABLE_SPELLCHECK=0
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
# -DENABLE_JIT=OFF \
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -236,6 +240,12 @@ EXTRA_CXXFLAGS="-g0 -Wl,--no-keep-memory -fuse-ld=gold -Wl,--no-map-whole-files
|
|||||||
%{_datadir}/gtk-doc/html/webkitdomgtk-%{apiver}/*
|
%{_datadir}/gtk-doc/html/webkitdomgtk-%{apiver}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Nov 14 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.30.2-1mamba
|
||||||
|
- update to 2.30.2
|
||||||
|
|
||||||
|
* Sat Sep 26 2020 Automatic Build System <autodist@mambasoft.it> 2.30.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Thu Jul 30 2020 Automatic Build System <autodist@mambasoft.it> 2.28.4-1mamba
|
* Thu Jul 30 2020 Automatic Build System <autodist@mambasoft.it> 2.28.4-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user