automatic version update by autodist [release 2.44.1-1mamba;Tue Apr 09 2024]
This commit is contained in:
parent
f9fa769611
commit
197bf839c6
@ -1,22 +0,0 @@
|
|||||||
--- webkitgtk-2.42.2/Source/WebCore/xml/XSLTProcessor.h.orig 2023-11-25 15:40:55.964477218 +0100
|
|
||||||
+++ webkitgtk-2.42.2/Source/WebCore/xml/XSLTProcessor.h 2023-11-25 15:41:00.126507392 +0100
|
|
||||||
@@ -61,7 +61,7 @@
|
|
||||||
|
|
||||||
void reset();
|
|
||||||
|
|
||||||
- static void parseErrorFunc(void* userData, xmlError*);
|
|
||||||
+ static void parseErrorFunc(void* userData, const xmlError*);
|
|
||||||
static void genericErrorFunc(void* userData, const char* msg, ...);
|
|
||||||
|
|
||||||
// Only for libXSLT callbacks
|
|
||||||
--- webkitgtk-2.42.2/Source/WebCore/xml/XSLTProcessorLibxslt.cpp.orig 2023-11-25 15:54:11.058051011 +0100
|
|
||||||
+++ webkitgtk-2.42.2/Source/WebCore/xml/XSLTProcessorLibxslt.cpp 2023-11-25 15:54:18.276056735 +0100
|
|
||||||
@@ -59,7 +59,7 @@
|
|
||||||
// It would be nice to do something with this error message.
|
|
||||||
}
|
|
||||||
|
|
||||||
-void XSLTProcessor::parseErrorFunc(void* userData, xmlError* error)
|
|
||||||
+void XSLTProcessor::parseErrorFunc(void* userData, const xmlError* error)
|
|
||||||
{
|
|
||||||
PageConsoleClient* console = static_cast<PageConsoleClient*>(userData);
|
|
||||||
if (!console)
|
|
@ -12,7 +12,7 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: webkitgtk
|
Name: webkitgtk
|
||||||
Version: 2.42.5
|
Version: 2.44.1
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Port of WebKit embeddable web component to GTK+
|
Summary: Port of WebKit embeddable web component to GTK+
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
@ -22,20 +22,16 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|||||||
URL: https://www.webkitgtk.org/
|
URL: https://www.webkitgtk.org/
|
||||||
Source0: http://www.webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
|
Source0: http://www.webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
|
||||||
Patch2: webkitgtk-2.30.2-x86-arm-jit-build-workaround.patch
|
Patch2: webkitgtk-2.30.2-x86-arm-jit-build-workaround.patch
|
||||||
Patch3: webkitgtk-2.42.2-libxml2-2.12.1.patch
|
|
||||||
Patch4: webkitgtk-2.42.5-x86-build-fix.patch
|
Patch4: webkitgtk-2.42.5-x86-build-fix.patch
|
||||||
License: BSD, LGPL
|
License: BSD, LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: gst-plugins-bad-devel
|
BuildRequires: gst-plugins-bad-devel
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
BuildRequires: libXcomposite-devel
|
|
||||||
BuildRequires: libXdamage-devel
|
|
||||||
BuildRequires: libXrender-devel
|
|
||||||
BuildRequires: libXt-devel
|
|
||||||
BuildRequires: libat-spi2-core-devel
|
BuildRequires: libat-spi2-core-devel
|
||||||
BuildRequires: libatomic-devel
|
BuildRequires: libatomic-devel
|
||||||
BuildRequires: libavif-devel
|
BuildRequires: libavif-devel
|
||||||
|
BuildRequires: libbacktrace-devel
|
||||||
BuildRequires: libcairo-devel
|
BuildRequires: libcairo-devel
|
||||||
BuildRequires: libdrm-devel
|
BuildRequires: libdrm-devel
|
||||||
BuildRequires: libenchant-devel
|
BuildRequires: libenchant-devel
|
||||||
@ -46,7 +42,6 @@ BuildRequires: libgcc
|
|||||||
BuildRequires: libgcrypt-devel
|
BuildRequires: libgcrypt-devel
|
||||||
BuildRequires: libgdk-pixbuf-devel
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
BuildRequires: libgpg-error-devel
|
|
||||||
BuildRequires: libgst-plugins-base-devel
|
BuildRequires: libgst-plugins-base-devel
|
||||||
BuildRequires: libgstreamer-devel
|
BuildRequires: libgstreamer-devel
|
||||||
BuildRequires: libgtk3-devel
|
BuildRequires: libgtk3-devel
|
||||||
@ -58,7 +53,6 @@ BuildRequires: libjxl-devel
|
|||||||
BuildRequires: liblcms2-devel
|
BuildRequires: liblcms2-devel
|
||||||
BuildRequires: libmanette-devel
|
BuildRequires: libmanette-devel
|
||||||
BuildRequires: libmesa-devel
|
BuildRequires: libmesa-devel
|
||||||
BuildRequires: libopenjpeg-devel
|
|
||||||
BuildRequires: libpango-devel
|
BuildRequires: libpango-devel
|
||||||
BuildRequires: libpng-devel
|
BuildRequires: libpng-devel
|
||||||
BuildRequires: libseccomp-devel
|
BuildRequires: libseccomp-devel
|
||||||
@ -69,15 +63,13 @@ BuildRequires: libstdc++6-devel
|
|||||||
BuildRequires: libsystemd-devel
|
BuildRequires: libsystemd-devel
|
||||||
BuildRequires: libtasn1-devel
|
BuildRequires: libtasn1-devel
|
||||||
BuildRequires: libwayland-devel
|
BuildRequires: libwayland-devel
|
||||||
BuildRequires: libwayland-egl-devel
|
|
||||||
BuildRequires: libwebp-devel
|
BuildRequires: libwebp-devel
|
||||||
BuildRequires: libwoff2-devel
|
BuildRequires: libwoff2-devel
|
||||||
BuildRequires: libwpe-devel
|
|
||||||
BuildRequires: libwpebackend-fdo-devel
|
|
||||||
BuildRequires: libxml2-devel
|
BuildRequires: libxml2-devel
|
||||||
BuildRequires: libxslt-devel
|
BuildRequires: libxslt-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libbacktrace-devel
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
BuildRequires: bubblewrap
|
BuildRequires: bubblewrap
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
@ -115,15 +107,6 @@ Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
|
WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
|
||||||
This package contains libraries and header files needed for development.
|
This package contains libraries and header files needed for development.
|
||||||
|
|
||||||
#%package jsc
|
|
||||||
#Group: Applications/Networking
|
|
||||||
#Summary: JavaScriptCore shell for WebKit GTK+
|
|
||||||
#Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
|
||||||
#
|
|
||||||
#%description jsc
|
|
||||||
#WebKit/GTK+ is the new GTK+ port of the WebKit, an open-source web content engine that powers numerous applications such as web browsers, email clients, feed readers, web and text editors, and a whole lot more.
|
|
||||||
#This package contains WebKit's JavaScript engine. It allows you to interact with the JavaScript engine directly.
|
|
||||||
|
|
||||||
%package webinspector
|
%package webinspector
|
||||||
Group: Applications/Networking
|
Group: Applications/Networking
|
||||||
Summary: Data files for WebKit GTK+'s Web Inspector
|
Summary: Data files for WebKit GTK+'s Web Inspector
|
||||||
@ -150,15 +133,14 @@ This package contains the documentation for %{name},
|
|||||||
%setup -q
|
%setup -q
|
||||||
#-D -T
|
#-D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
%ifarch arm %{ix86}
|
#%ifarch arm %{ix86}
|
||||||
%patch 2 -p1
|
#%patch 2 -p1
|
||||||
%patch 4 -p1
|
#%patch 4 -p1
|
||||||
%endif
|
#%endif
|
||||||
%ifarch arm
|
#%ifarch arm
|
||||||
#sed -i "s|ARM64|ARMv7|" Source/JavaScriptCore/CMakeLists.txt
|
##sed -i "s|ARM64|ARMv7|" Source/JavaScriptCore/CMakeLists.txt
|
||||||
sed -i "s|WTF_CPU_ARM64|WTF_CPU_ARM|" CMakeLists.txt
|
#sed -i "s|WTF_CPU_ARM64|WTF_CPU_ARM|" CMakeLists.txt
|
||||||
%endif
|
#%endif
|
||||||
#%patch 3 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
@ -198,9 +180,11 @@ EXTRA_CXXFLAGS="-g1"
|
|||||||
-DENABLE_GTKDOC=ON \
|
-DENABLE_GTKDOC=ON \
|
||||||
%endif
|
%endif
|
||||||
%if "%?with_apiver" == ""
|
%if "%?with_apiver" == ""
|
||||||
|
-DUSE_GTK4=OFF \
|
||||||
-DUSE_SOUP2=ON \
|
-DUSE_SOUP2=ON \
|
||||||
%endif
|
%endif
|
||||||
%if "%?with_apiver" == "4.1"
|
%if "%?with_apiver" == "4.1"
|
||||||
|
-DUSE_GTK4=OFF \
|
||||||
-DUSE_SOUP2=OFF \
|
-DUSE_SOUP2=OFF \
|
||||||
%endif
|
%endif
|
||||||
%if "%?with_apiver" == "5.0"
|
%if "%?with_apiver" == "5.0"
|
||||||
@ -212,24 +196,6 @@ EXTRA_CXXFLAGS="-g1"
|
|||||||
%endif
|
%endif
|
||||||
-DENABLE_MINIBROWSER=ON
|
-DENABLE_MINIBROWSER=ON
|
||||||
|
|
||||||
#%ifnarch x86_64
|
|
||||||
# -DCMAKE_C_FLAGS="$EXTRA_CFLAGS" \
|
|
||||||
# -DCMAKE_CXX_FLAGS="$EXTRA_CXXFLAGS" \
|
|
||||||
# -DCMAKE_C_FLAGS_RELWITHDEBINFO="-O2 -g1" \
|
|
||||||
# -DCMAKE_CXX_FLAGS_RELWITHDEBINFO="-O2 -g1" \
|
|
||||||
#%else
|
|
||||||
# -DCMAKE_C_FLAGS_RELWITHDEBINFO="-O2 -g1" \
|
|
||||||
# -DCMAKE_CXX_FLAGS_RELWITHDEBINFO="-O2 -g1" \
|
|
||||||
#%endif
|
|
||||||
# -DCMAKE_EXE_LINKER_FLAGS="-Wl,--as-needed -Wl,-z,now -pthread" \
|
|
||||||
# -DCMAKE_MODULE_LINKER_FLAGS="-Wl,--as-needed -Wl,-z,now -pthread" \
|
|
||||||
# -DCMAKE_SHARED_LINKER_FLAGS="-Wl,--as-needed -Wl,-z,now -pthread" \
|
|
||||||
|
|
||||||
# -DENABLE_JIT=OFF \
|
|
||||||
|
|
||||||
# Note: seen on arm ,2.30.4: in case of failure due to missing JavaScriptCore-4.gir:
|
|
||||||
# make JavaScriptCore-4-gir
|
|
||||||
|
|
||||||
%make -j2
|
%make -j2
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -280,12 +246,20 @@ rm -f %{buildroot}%{_bindir}/WebKitWebDriver
|
|||||||
|
|
||||||
%files -n %{libname}-doc
|
%files -n %{libname}-doc
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{_datadir}/gtk-doc/html/javascriptcoregtk-%{apiver}
|
%dir %{_docdir}/javascriptcoregtk-%{apiver}
|
||||||
%{_datadir}/gtk-doc/html/javascriptcoregtk-%{apiver}/*
|
%{_docdir}/javascriptcoregtk-%{apiver}/*
|
||||||
%dir %{_datadir}/gtk-doc/html/webkit*-%{apiver}
|
%dir %{_docdir}/webkit*gtk-%{apiver}
|
||||||
%{_datadir}/gtk-doc/html/webkit*-%{apiver}/*
|
%{_docdir}/webkit*gtk-%{apiver}/*
|
||||||
|
%dir %{_docdir}/webkit*gtk-web*-extension-%{apiver}
|
||||||
|
%{_docdir}/webkit*gtk-web*-extension-%{apiver}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 09 2024 Automatic Build System <autodist@openmamba.org> 2.44.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Apr 05 2024 Automatic Build System <autodist@openmamba.org> 2.44.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Fri Feb 09 2024 Automatic Build System <autodist@openmamba.org> 2.42.5-1mamba
|
* Fri Feb 09 2024 Automatic Build System <autodist@openmamba.org> 2.42.5-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user