fix for missing third party libraries by passing BUILD_SHARED_LIBS=OFF [release 3.4.1-2mamba;Wed Mar 24 2021]
This commit is contained in:
parent
e7f75c3600
commit
7acf87cd6a
11
warzone2100-3.4.1-link_libz.patch
Normal file
11
warzone2100-3.4.1-link_libz.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- warzone2100/src/CMakeLists.txt.orig 2021-03-01 00:36:07.480997337 +0100
|
||||||
|
+++ warzone2100/src/CMakeLists.txt 2021-03-01 00:34:37.993463912 +0100
|
||||||
|
@@ -185,7 +185,7 @@
|
||||||
|
target_link_libraries(warzone2100 ${QT5ALL_LIBRARIES} ${QT5ALL_LDFLAGS_OTHER})
|
||||||
|
target_link_libraries(warzone2100 version Qt5::QWindowsIntegrationPlugin Qt5ThemeSupport Qt5FontDatabaseSupport Qt5EventDispatcherSupport)
|
||||||
|
else()
|
||||||
|
- set_target_properties(warzone2100 PROPERTIES LINK_FLAGS "-Wl,--start-group")
|
||||||
|
+ set_target_properties(warzone2100 PROPERTIES LINK_FLAGS "-Wl,--start-group /usr/lib64/libz.a")
|
||||||
|
endif()
|
||||||
|
endif()
|
||||||
|
|
@ -1,37 +1,40 @@
|
|||||||
Name: warzone2100
|
Name: warzone2100
|
||||||
Version: 3.2.3
|
Version: 3.4.1
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: 3D real time strategy game
|
Summary: 3D real time strategy game
|
||||||
Group: Applications/Games
|
Group: Applications/Games
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://wz2100.net/
|
URL: https://wz2100.net/
|
||||||
Source: http://downloads.sourceforge.net/project/%{name}/releases/%{version}/%{name}-%{version}.tar.xz
|
# Note: source manually renamed to add version
|
||||||
#Source: http://downloads.sourceforge.net/project/%{name}/%{name}/Warzone%202100%20%{version}/%{name}-%{version}.tar.gz
|
Source: https://sourceforge.net/projects/warzone2100/files/releases/%{version}/warzone2100-%{version}.tar.xz
|
||||||
|
Patch0: warzone2100-3.4.1-link_libz.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libgcc
|
|
||||||
BuildRequires: libGL-devel
|
BuildRequires: libGL-devel
|
||||||
BuildRequires: libGLU-devel
|
BuildRequires: libGLU-devel
|
||||||
|
BuildRequires: libSDL2-devel
|
||||||
|
BuildRequires: libcurl-devel
|
||||||
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libglew-devel
|
||||||
|
BuildRequires: libharfbuzz-devel
|
||||||
|
BuildRequires: libminiupnpc-devel
|
||||||
BuildRequires: libogg-devel
|
BuildRequires: libogg-devel
|
||||||
BuildRequires: libopenal-devel
|
BuildRequires: libopenal-devel
|
||||||
BuildRequires: libphysfs-devel
|
BuildRequires: libphysfs-devel
|
||||||
BuildRequires: libpng-devel
|
BuildRequires: libpng-devel
|
||||||
BuildRequires: libpopt-devel
|
BuildRequires: libqt5-devel
|
||||||
BuildRequires: libSDL-devel
|
BuildRequires: libsodium-devel
|
||||||
BuildRequires: libSDL_net-devel
|
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libtheora-devel
|
BuildRequires: libtheora-devel
|
||||||
BuildRequires: libvorbis-devel
|
BuildRequires: libvorbis-devel
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: quesoglc-devel
|
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Warzone 2100 is a 3D realtime strategy game on a future Earth.
|
Warzone 2100 is a 3D realtime strategy game on a future Earth.
|
||||||
Warzone 2100 Resurrection is an effort to continue maintainence and publishing of Warzone 2100. Warzone 2100 was one of the first 3D RTS games ever. It was released commercially by Pumpkin Studies in 1999, and released in 2004 under the GPL.
|
Warzone 2100 Resurrection is an effort to continue maintainence and publishing of Warzone 2100. Warzone 2100 was one of the first 3D RTS games ever. It was released commercially by Pumpkin Studies in 1999, and released in 2004 under the GPL.
|
||||||
@ -53,17 +56,21 @@ Featuring:
|
|||||||
* Cross-Platform internet/intranet multiplayer with up to 8 players
|
* Cross-Platform internet/intranet multiplayer with up to 8 players
|
||||||
* Challenging Computer-AI
|
* Challenging Computer-AI
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q -n warzone2100
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export LDFLAGS='-L %{_libdir}'
|
%cmake -d build \
|
||||||
%configure
|
-DBUILD_SHARED_LIBS=OFF \
|
||||||
|
-DWZ_DISTRIBUTOR="openmamba"
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall DESTDIR=%{buildroot}
|
%makeinstall -C build
|
||||||
|
|
||||||
%find_lang %{name}
|
%find_lang %{name}
|
||||||
|
|
||||||
@ -77,6 +84,10 @@ export LDFLAGS='-L %{_libdir}'
|
|||||||
%{_datadir}/metainfo/warzone2100.appdata.xml
|
%{_datadir}/metainfo/warzone2100.appdata.xml
|
||||||
%{_datadir}/icons/warzone2100.png
|
%{_datadir}/icons/warzone2100.png
|
||||||
%dir %{_datadir}/warzone2100
|
%dir %{_datadir}/warzone2100
|
||||||
|
%dir %{_datadir}/warzone2100/fonts
|
||||||
|
%{_datadir}/warzone2100/fonts/DejaVu.LICENSE.txt
|
||||||
|
%{_datadir}/warzone2100/fonts/DejaVuSans-Bold.ttf
|
||||||
|
%{_datadir}/warzone2100/fonts/DejaVuSans.ttf
|
||||||
#%dir %{_datadir}/warzone2100/mods
|
#%dir %{_datadir}/warzone2100/mods
|
||||||
%dir %{_datadir}/warzone2100/music
|
%dir %{_datadir}/warzone2100/music
|
||||||
%{_datadir}/warzone2100/*.wz
|
%{_datadir}/warzone2100/*.wz
|
||||||
@ -89,6 +100,12 @@ export LDFLAGS='-L %{_libdir}'
|
|||||||
%doc AUTHORS COPYING ChangeLog
|
%doc AUTHORS COPYING ChangeLog
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 24 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.1-2mamba
|
||||||
|
- fix for missing third party libraries by passing BUILD_SHARED_LIBS=OFF
|
||||||
|
|
||||||
|
* Mon Feb 01 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.1-1mamba
|
||||||
|
- update to 3.4.1
|
||||||
|
|
||||||
* Mon Aug 14 2017 Automatic Build System <autodist@mambasoft.it> 3.2.3-1mamba
|
* Mon Aug 14 2017 Automatic Build System <autodist@mambasoft.it> 3.2.3-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user