59 lines
1.7 KiB
RPMSpec
59 lines
1.7 KiB
RPMSpec
Name: wakeonlan
|
|
Version: 0.42
|
|
Release: 1mamba
|
|
Summary: A command that sends 'magic packets' to wake-on-LAN enabled ethernet adapters and motherboards
|
|
Group: Applications/Networking
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://github.com/jpoliv/wakeonlan
|
|
Source: https://github.com/jpoliv/wakeonlan.git/v%{version}/wakeonlan-%{version}.tar.bz2
|
|
License: Artistic
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libperl
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl-Test-Perl-Critic
|
|
Requires: perl >= %perl_major_ver
|
|
|
|
%description
|
|
Wakeonlan is a Perl script that sends 'magic packets' to wake-on-LAN enabled ethernet adapters and motherboards, in order to switch on remote computers.
|
|
|
|
#% debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%{__perl} Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
|
|
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist |\
|
|
sed "s,%{buildroot},,g;s,.*/man/.*,&.gz,g" |\
|
|
sort -u > .packlist && rm -f $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Sun Mar 20 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 0.42-1mamba
|
|
- update to 0.42
|
|
|
|
* Mon May 12 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.41-1mamba
|
|
- package created using the webbuild interface
|