fix build for x86_64 architecture [release 0.1-2mamba;Thu Jan 09 2014]
This commit is contained in:
parent
a152bdb18b
commit
b7cf55ee94
@ -1,2 +1,5 @@
|
||||
# vteplugin
|
||||
|
||||
vteplugin implements a terminal emulator in a browser plugins.
|
||||
That means you can use command line in a terminal inside a browser tab.
|
||||
|
||||
|
25
vteplugin-0.1-html.patch
Normal file
25
vteplugin-0.1-html.patch
Normal file
@ -0,0 +1,25 @@
|
||||
--- vteplugin-0.1/vteplugin.html.orig 2010-04-15 14:03:15.000000000 +0200
|
||||
+++ vteplugin-0.1/vteplugin.html 2010-04-15 14:06:37.000000000 +0200
|
||||
@@ -1,10 +1,14 @@
|
||||
-<style>
|
||||
-body {
|
||||
- margin: 0px;
|
||||
- padding: 0px;
|
||||
-}
|
||||
-</style>
|
||||
+<html>
|
||||
+<head>
|
||||
+ <title>Terminal</title>
|
||||
+ <style>
|
||||
+ body {
|
||||
+ margin: 0px;
|
||||
+ padding: 0px;
|
||||
+ }
|
||||
+ </style>
|
||||
+</head>
|
||||
<body>
|
||||
-<embed type="application/vte" width="100%" height="100%" bgcolor="black" fgcolor="white" font="">
|
||||
-</embed>
|
||||
+ <embed type="application/vte" width="100%" height="100%" bgcolor="black" fgcolor="white" font=""></embed>
|
||||
</body>
|
||||
+</html>
|
70
vteplugin.spec
Normal file
70
vteplugin.spec
Normal file
@ -0,0 +1,70 @@
|
||||
Name: vteplugin
|
||||
Version: 0.1
|
||||
Release: 2mamba
|
||||
Summary: A plugin to run a terminal inside a webbrowser tab
|
||||
Group: Applications/Web
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
|
||||
URL: http://github.com/arenevier/vteplugin
|
||||
Source: http://blog.renevier.net/public/vteplugin-%{version}.tar.bz2
|
||||
Patch: vteplugin-0.1-html.patch
|
||||
License: WTFPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libvte0-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: python
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
vteplugin implements a terminal emulator in a browser plugins.
|
||||
That means you can use command line in a terminal inside a browser tab.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch -p1
|
||||
|
||||
sed -i "s,\(install_path=\"\)/usr/lib,\1%{buildroot}%{_libdir},;s,\['-O2'\, '-Wall'\],'%optflags'.split()," wscript
|
||||
|
||||
%build
|
||||
export CFLAGS="${CFLAGS:-%optflags}"
|
||||
export CXXFLAGS="${CXXFLAGS:-%optflags}"
|
||||
%{__python} waf configure
|
||||
%{__python} waf build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%{__python} waf install
|
||||
|
||||
install -D -m0644 vteplugin.html \
|
||||
%{buildroot}%{_datadir}/vteplugin/vteplugin.html
|
||||
|
||||
# fixup strange shared library permissions
|
||||
chmod 755 %{buildroot}%{_libdir}/mozilla/plugins/*.so
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/mozilla/plugins/*.so
|
||||
%{_datadir}/vteplugin
|
||||
%doc COPYING.TXT README.TXT
|
||||
|
||||
%changelog
|
||||
* Thu Jan 09 2014 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.1-2mamba
|
||||
- fix build for x86_64 architecture
|
||||
|
||||
* Thu Apr 15 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.1-1mamba
|
||||
- package created by autospec
|
Reference in New Issue
Block a user