package created by autospec [release 4.1.3-1mamba;Wed May 14 2014]
This commit is contained in:
parent
15d0d4449b
commit
234eef30e3
@ -1,2 +1,4 @@
|
||||
# vnc
|
||||
|
||||
VNC allows you to access and control your desktop applications wherever you are in the world, whenever you need to. VNC has a widespread user base, from individuals to the world's largest multi-national companies, utilizing the technology for a range of applications.
|
||||
|
||||
|
33
vnc-4.1.3-glibc-2.19.patch
Normal file
33
vnc-4.1.3-glibc-2.19.patch
Normal file
@ -0,0 +1,33 @@
|
||||
diff -ru vnc-4_1_3-unixsrc/common/network/TcpSocket.cxx vnc-4_1_3-unixsrc.good/common/network/TcpSocket.cxx
|
||||
--- vnc-4_1_3-unixsrc/common/network/TcpSocket.cxx 2008-10-16 15:16:20.000000000 +0000
|
||||
+++ vnc-4_1_3-unixsrc.good/common/network/TcpSocket.cxx 2014-05-14 14:29:24.133633291 +0000
|
||||
@@ -37,6 +37,7 @@
|
||||
#include <fcntl.h>
|
||||
#endif
|
||||
|
||||
+#include <stdlib.h>
|
||||
#include <network/TcpSocket.h>
|
||||
#include <rfb/util.h>
|
||||
#include <rfb/LogWriter.h>
|
||||
diff -ru vnc-4_1_3-unixsrc/unix/tx/TXImage.cxx vnc-4_1_3-unixsrc.good/unix/tx/TXImage.cxx
|
||||
--- vnc-4_1_3-unixsrc/unix/tx/TXImage.cxx 2008-10-16 15:16:21.000000000 +0000
|
||||
+++ vnc-4_1_3-unixsrc.good/unix/tx/TXImage.cxx 2014-05-14 14:35:16.897477801 +0000
|
||||
@@ -21,6 +21,7 @@
|
||||
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <strings.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/ipc.h>
|
||||
diff -ru vnc-4_1_3-unixsrc/unix/x0vncserver/Image.cxx vnc-4_1_3-unixsrc.good/unix/x0vncserver/Image.cxx
|
||||
--- vnc-4_1_3-unixsrc/unix/x0vncserver/Image.cxx 2008-10-16 15:16:21.000000000 +0000
|
||||
+++ vnc-4_1_3-unixsrc.good/unix/x0vncserver/Image.cxx 2014-05-14 14:35:49.209008812 +0000
|
||||
@@ -21,6 +21,7 @@
|
||||
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/ipc.h>
|
||||
#include <sys/shm.h>
|
71
vnc.spec
Normal file
71
vnc.spec
Normal file
@ -0,0 +1,71 @@
|
||||
%define pkgver %(echo %version | tr . _)
|
||||
Name: vnc
|
||||
Version: 4.1.3
|
||||
Release: 1mamba
|
||||
Summary: VNC 4 remote access software for desktop and mobile platforms
|
||||
Group: Applications/Networking
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.realvnc.com/
|
||||
# WARNING: needs to be downloaded from site
|
||||
Source: http://www.realvnc.com/download/binary/785/vnc-%{pkgver}-unixsrc.tar.gz
|
||||
Patch0: vnc-4.1.3-glibc-2.19.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXtst-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
VNC allows you to access and control your desktop applications wherever you are in the world, whenever you need to. VNC has a widespread user base, from individuals to the world's largest multi-national companies, utilizing the technology for a range of applications.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{pkgver}-unixsrc
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
cd unix
|
||||
%configure
|
||||
%make -j1
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
cd unix
|
||||
install -d %{buildroot}{%{_bindir},%{_mandir}/man1}
|
||||
install -m0755 vncconfig/vncconfig %{buildroot}%{_bindir}/vnc4config
|
||||
install -m0644 vncconfig/vncconfig.man %{buildroot}%{_mandir}/man1/vnc4config.1
|
||||
install -m0755 vncviewer/vncviewer %{buildroot}%{_bindir}/vnc4viewer
|
||||
install -m0644 vncviewer/vncviewer.man %{buildroot}%{_mandir}/man1/vnc4viewer.1
|
||||
install -m0755 vncpasswd/vncpasswd %{buildroot}%{_bindir}/vnc4passwd
|
||||
install -m0644 vncpasswd/vncpasswd.man %{buildroot}%{_mandir}/man1/vnc4passwd.1
|
||||
install -m0755 x0vncserver/x0vncserver %{buildroot}%{_bindir}/vnc4server
|
||||
install -m0644 x0vncserver/x0vncserver.man %{buildroot}%{_mandir}/man1/vnc4server.1
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/vnc4config
|
||||
%{_bindir}/vnc4passwd
|
||||
%{_bindir}/vnc4server
|
||||
%{_bindir}/vnc4viewer
|
||||
%{_mandir}/man1/vnc4config.1*
|
||||
%{_mandir}/man1/vnc4passwd.1*
|
||||
%{_mandir}/man1/vnc4server.1*
|
||||
%{_mandir}/man1/vnc4viewer.1*
|
||||
%doc LICENCE.txt
|
||||
|
||||
%changelog
|
||||
* Wed May 14 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.1.3-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user